Retropie CRT Edition - Raspberry pi 2B/3B/3B+ - TV 15Khz (vga666 / pi2scart / rgb-pi)

-krahs- escribió:
ugrash escribió:@-krahs-
I tried EVO version, it's really better, thank you very much !

New version of EVO is comming up... with a lot of improvements:
More code optimization, last retroarch, emulationstation and... new experimental tool dedicated for RGB cable changing, now pi2jamma and jamma rgb-pi ready... Also on first boot will ask you which cable you have...

:)


Ostia pues buenísima noticia,me esperaré entonces al update de la EVO.
mil gracias !
salu2!
I would like to have Intellivision games in RetroPie CRT. Can I help to do something ? What has to be done to add another system ?
-krahs- escribió:Imagen


MARAVILLA ver que la vas a adaptar al Pi2Jamma! [tadoramo]
-krahs- escribió:
ugrash escribió:@-krahs-
I tried EVO version, it's really better, thank you very much !

New version of EVO is comming up... with a lot of improvements:
More code optimization, last retroarch, emulationstation and... new experimental tool dedicated for RGB cable changing, now pi2jamma and jamma rgb-pi ready... Also on first boot will ask you which cable you have...

:)

No paras!
Una petición,podrías incluir en algún update,la típica pantalla cuadriculada de linealidad,en el screen utility?.Desde software no se podrá ajustar nada,pero será una referencia de ajuste,para el modo servivio de la tv.
mcfly escribió:
-krahs- escribió:
ugrash escribió:@-krahs-
I tried EVO version, it's really better, thank you very much !

New version of EVO is comming up... with a lot of improvements:
More code optimization, last retroarch, emulationstation and... new experimental tool dedicated for RGB cable changing, now pi2jamma and jamma rgb-pi ready... Also on first boot will ask you which cable you have...

:)

No paras!
Una petición,podrías incluir en algún update,la típica pantalla cuadriculada de linealidad,en el screen utility?.Desde software no se podrá ajustar nada,pero será una referencia de ajuste,para el modo servivio de la tv.

Echale un ojo a las herramientas de 240p Test Suite que ya hay... están en la sección de configuración de video, aparte de tener los patrones que necesitas tiene otras muchas cosas... :) Esto complementa la herramienta de centrado propia.
Buenos días a todos, por fin pude meterle ayer mano a la imagen del Retropie CRT que tenía grabada desde hace meses, se trata de la legacy, en mi RPi2.

Os comento por si alguien lo sabe, tuve los siguientes problemas:
  • No consigo echar a andar el SegaCD. Copio la bios donde dice, en la ruta /bios, uso una imagen válida y me devuelve al listado de juegos. Los pasos son exactamente los mismos que uso en el Retropie normal donde si juego al SegaCD sin problemas.
  • Mismo problema con PC Engine CD, con los mismos pasos de el Retropie normal aquí no me va.
  • No puedo configurar el Amiberry, la pantalla me sale absolutamente minúscula e ilegible. Si intento cambiar la resolución a la que se ejecuta (pulsando A durante el arranque) me sale pantalla de error tal que "Invalid resolution, don't let retroarch to modify my values" o algo así.

Si alguien me echa una mano lo agradezco [beer]
AxelStone escribió:Buenos días a todos, por fin pude meterle ayer mano a la imagen del Retropie CRT que tenía grabada desde hace meses, se trata de la legacy, en mi RPi2.

Os comento por si alguien lo sabe, tuve los siguientes problemas:
  • No consigo echar a andar el SegaCD. Copio la bios donde dice, en la ruta /bios, uso una imagen válida y me devuelve al listado de juegos. Los pasos son exactamente los mismos que uso en el Retropie normal donde si juego al SegaCD sin problemas.
  • Mismo problema con PC Engine CD, con los mismos pasos de el Retropie normal aquí no me va.
  • No puedo configurar el Amiberry, la pantalla me sale absolutamente minúscula e ilegible. Si intento cambiar la resolución a la que se ejecuta (pulsando A durante el arranque) me sale pantalla de error tal que "Invalid resolution, don't let retroarch to modify my values" o algo así.

Si alguien me echa una mano lo agradezco [beer]

Hola.
Por favor, prueba la EVO, que es la última.
Los juegos deben ir en las carpetas segacd y pcenginecd dentro de la capeta de roms, estos sistemas funcionan perfectamente, pero insisto, descárgate la última versión y lo pruebas de nuevo.
En cuanto al amiberry, ese problema si no recuerdo mal está corregido en la ultima y solo pasaba lanzando directamente amiberry.

Las resoluciones del sistema NO se pueden cambiar en esta distribución a través de 'runcommand' (pulsando A durante el arranque) ya que está pensado para CRT y están controladas.
@-krahs- Buenas, tranquilo el tema de las carpetas está bien. Como digo lo uso en Retropie normal, misma ISO misma Bios, todo ubicado en las mismas carpetas. Se me lista bien el SegaCD, se me lista bien el juego, doy a cargar...y vuelta a la lista. Es lo mismo que me ocurría en el Retropie normal antes de meter la Bios, por eso tengo la duda de si aquí se ubicaba en otra ruta.

Habrá que probar la nueva versión, gracias :)
Muy buenas a todos. Alguien me podría por favor indicar si tengo snaps y vídeos de los juegos en que carpetas y con qué resoluciones tengo que ponerlos para que me funcionen. Lo pregunto porque las he copiado de la imagen de plata o roms pero no sé ni si valen ni donde pegarlas.
Muchas gracias.
larry74 escribió:Muy buenas a todos. Alguien me podría por favor indicar si tengo snaps y vídeos de los juegos en que carpetas y con qué resoluciones tengo que ponerlos para que me funcionen. Lo pregunto porque las he copiado de la imagen de plata o roms pero no sé ni si valen ni donde pegarlas.
Muchas gracias.


Si te valen,solo pon las carpetas(snap videos y boxart imágenes) dentro del sistema que corresponda y asegurate de que el gamelist de dicho sistema esté bien configurado;si no hazlo de nuevo en el sistema que necesites y lo puedes hacer con Gengal por ejemplo.

salu2!
@-krahs- Ya he pillado el último Retropie EVO, la verdad es que mejora una barbaridad, la interfaz es absolutamente preciosa. Además está optimizado, el Afterburner 32X me daba algunos tirones en mi RPi2 con el legacy y ahora me va totalmente fino , ¡currazo!

Sin embargo el sega CD sigue sin andar, lo raro es que no llega a la pantalla de la Bios. Cargo por ejemplo el juego, el mismo que pongo en el retropie normal, y no llego a ver la pantalla de la bios del sega cd. Tampoco me escupe al menu, de hecho puedo desplegar la pantalla de ajustes del retroarch, ¿es posible que mi TV no soporte el modo de imagen? Me resulta extraño, ya que la MD va perfectamente.

Gracias!
buenas amigos una pregunta tonta se puede istalar la nueva version encima de otra, mas que nada es para no configurar todo de nuevo y no perder las partidas guardadas que me daria un mal xD [angelito] [angelito] [angelito] [angelito] [bye] [bye]
Muy buenas, me gustaría probar la nueva beta que ha colgado el autor del programa en su GitHub pero recuerdo vagamente que algo tuve que editar en un archivo de configuración para que me reconociera los dos manos de mi recreativa, alguno tiene una ligera idea de que archivo podía ser por si se ha visto en la misma situación? Mas que nada para usar la misma tarjeta o comprar otra tarjeta y no arriesgarme a perder toda la configuración.

Un saludo.
cholo_3314 escribió:buenas amigos una pregunta tonta se puede istalar la nueva version encima de otra, mas que nada es para no configurar todo de nuevo y no perder las partidas guardadas que me daria un mal xD [angelito] [angelito] [angelito] [angelito] [bye] [bye]


Nooo,tienes que hacer una instalación nueva con la imagen que quieras grabar.

jdeacon escribió:Muy buenas, me gustaría probar la nueva beta que ha colgado el autor del programa en su GitHub pero recuerdo vagamente que algo tuve que editar en un archivo de configuración para que me reconociera los dos manos de mi recreativa, alguno tiene una ligera idea de que archivo podía ser por si se ha visto en la misma situación? Mas que nada para usar la misma tarjeta o comprar otra tarjeta y no arriesgarme a perder toda la configuración.

Un saludo.


No tengo ni idea de nueva beta...aquí tenemos EVO que es la evolución de Retropie CRT Edition y los enlaces están perfectamente.
Lo de cambiar archivo ni idea:nunca e tenido que hacer eso,será por tus controladoras de mandos¿?
salu2
Si, de esa EVO hablo, en el enlace de la primera pagina esta la 2.1 que es la que quiero probar. Si, era algo de mi controlador de mando, pero no doy con el archivo, voy a ver si en el historial de alguna pregunta que hiciera yo en su momento tengo la respuesta para después no encontrarme que no funciona.

Localizado el fichero que me hacia falta, e instalada la nueva Beta ahora a trastear.

Dudas:
-Como puedo editar el fichero de emulationstation para que reconozca los *.hdf del sistema de Commodore Amiga? Solo reconoce los lha, ni siquiera los comprimidos en *.7z
-Como puedo entrar por FileZilla? Lo intento pero no hay manera, sin embargo por samba si puedo entrar en las carpetas pero no puedo ver donde esta el es_system.cfg para cambiar las extensiones que reconoce Amiga por ejemplo.
Gracias.
jdeacon escribió:Dudas:
-Como puedo editar el fichero de emulationstation para que reconozca los *.hdf del sistema de Commodore Amiga? Solo reconoce los lha, ni siquiera los comprimidos en *.7z
-Como puedo entrar por FileZilla? Lo intento pero no hay manera, sin embargo por samba si puedo entrar en las carpetas pero no puedo ver donde esta el es_system.cfg para cambiar las extensiones que reconoce Amiga por ejemplo.
Gracias.


Es el ,es_systems y si, por samba me parece que no se ve,añade esa extensión en el sistema en concreto.
Ruta /opt/retropie/configs/all/emulationstation/
Imagen
usa mejor FlashXp filezilla...bueno va bien...pero yo lo usé una vez y en la vida lo he vuelto a usar jeje ¬_¬ (si quieres te lo paso por privado ;)
salu2!
Mil gracias, voy a ver si tiene version para mac y lo pruebo.

Me queda ver cosas que ya hice anteriormente con la version que tenia en verano, como que los juegos de arcade verticales me salen en horizontal y ese tipo de cosas que creo que había que ponerlo en otro directorio aparte los horizontales y los verticales. Eso y que no tengo configurado lo de los créditos y demás, que supongo que sera entrando con un teclado al principio y configurar los coin, start y demás. Si me olvido de algo mas coméntamelo, mil gracias.

Edito: Ya veo que no tiene opción para mac el flashxp. Como lo configuras tu? Sftp, con la ip, que puerto? Usuario y contraseña?
jdeacon escribió:Mil gracias, voy a ver si tiene version para mac y lo pruebo.

Me queda ver cosas que ya hice anteriormente con la version que tenia en verano, como que los juegos de arcade verticales me salen en horizontal y ese tipo de cosas que creo que había que ponerlo en otro directorio aparte los horizontales y los verticales. Eso y que no tengo configurado lo de los créditos y demás, que supongo que sera entrando con un teclado al principio y configurar los coin, start y demás. Si me olvido de algo mas coméntamelo, mil gracias.

Edito: Ya veo que no tiene opción para mac el flashxp. Como lo configuras tu? Sftp, con la ip, que puerto? Usuario y contraseña?


Los juegos verticales los e metido junto con los horizontales y cada vez que pongo uno salta el filtro bilinear y eso:todo bien vamos...en las últimas versiones no había que activarlo ya :-? (activalo tu en el menú crt si no te saltara por si solo)

Igual que en el programa hago con el navegador de carpetas,abro una carpeta cualquiera y arriba pongo la ip del dispositivo,como tengo 2 macas conectadas casi siempre le pongo la ip de cada una cuando quiero acceder.
Imagen

siempre \\ delante.
usuario pi
contraseña raspberri
Si solo tienes una ip/dispositivo pues puedes poner retropie y listo
Imagen

El flashxp lo mismo pero FTP/SFTP(los dos a la vez) puerto 22(el que pone por defecto casi siempre...) y user pi y contraseña raspberri

salu2
Perfecto, así si puedo entrar ya por FileZilla, lo que no me queda claro es lo que me dices al principio de que tienes los juegos horizontales y verticales en el mismo directorio, que tendría que activar para que no salieran girados los verticales?

Verse se ve de lujo, en mi maquina con Hantarex, he probado el street fighter 3 alpha de psx y me quedo alucinado de como se ve eso, voy a terminar poniendo en uno de los puertos de la raspberry un mando de la play y jugar a un resident evil a la antigua usanza.

Los juegos de amiga al fin me funcionan que con la anterior version que tenia no me funcionaban, eso si, los cargo con amiberry porque con la opción por defecto siempre me salta el escritorio de workbench de amiga diciéndome que introduzca el disco adf, por amiberry sin problema aunque me recorta la imagen por la parte de arriba y por debajo deja mucho espacio en negro, no se si con puae habría que configurar algo mas que no he hecho para que termine funcionando.

Mañana seguire con las pruebas.

Gracias por la ayuda.
jdeacon escribió:Perfecto, así si puedo entrar ya por FileZilla, lo que no me queda claro es lo que me dices al principio de que tienes los juegos horizontales y verticales en el mismo directorio, que tendría que activar para que no salieran girados los verticales?

Verse se ve de lujo, en mi maquina con Hantarex, he probado el street fighter 3 alpha de psx y me quedo alucinado de como se ve eso, voy a terminar poniendo en uno de los puertos de la raspberry un mando de la play y jugar a un resident evil a la antigua usanza.

Los juegos de amiga al fin me funcionan que con la anterior version que tenia no me funcionaban, eso si, los cargo con amiberry porque con la opción por defecto siempre me salta el escritorio de workbench de amiga diciéndome que introduzca el disco adf, por amiberry sin problema aunque me recorta la imagen por la parte de arriba y por debajo deja mucho espacio en negro, no se si con puae habría que configurar algo mas que no he hecho para que termine funcionando.

Mañana seguire con las pruebas.

Gracias por la ayuda.



Menú CRT está todo:
Imagen
Imagen
Imagen

salu2
Ok gracias, mañana lo pruebo, le pongo ese valor de giro -90º

Ya lo tengo casi perfecto, como puedo modificar los controles en final burn por juego?? Por ejemplo para cambiar el orden de los botones en el REnegade?? En mame normal es pulsando en el teclado el tabulador, pero en final burn ese método no funciona.

Gracias.
Configuralo con Retroarch:

https://arcadegamer.es/configurar-boton ... -retropie/


Yo tengo un problema con el propio menu de retroarch, aparece tan aplastado... es ilegible, sale deformado horizontalmente... como puedo solucionar eso? me es imposible configurar los controles.
WIZZY escribió:Configuralo con Retroarch:

https://arcadegamer.es/configurar-boton ... -retropie/


Yo tengo un problema con el propio menu de retroarch, aparece tan aplastado... es ilegible, sale deformado horizontalmente... como puedo solucionar eso? me es imposible configurar los controles.



Lo intentare, gracias por la solución, no lo había pensado y evidentemente es la solución.
WIZZY escribió:Configuralo con Retroarch:

https://arcadegamer.es/configurar-boton ... -retropie/


Yo tengo un problema con el propio menu de retroarch, aparece tan aplastado... es ilegible, sale deformado horizontalmente... como puedo solucionar eso? me es imposible configurar los controles.

Hola WIZZY.
Estás usando la distribución EVO que aparece en la primera página? Entiendo que no has modificado nada por lo que, puedes describir mejor donde te pasa lo de los menús aplastados? Es emulando un sistema Nes, megadrive, arcade? Si es arcade desde carpeta estás lanzando las roms?
queria probar el retropie en un pc y no me sale, se queda cargando en pantalla negra... lo que yo nose cual sera el problema si esque hay un retropie para el raspberry especializado y otro para pc, o sera que use mi microSD por USB con un adaptador que va lento en leer la informacion, porque lo que es pasar archivos con ese adaptador va mas lento que con un adaptador de ranuras de SD.

me pille un pack de 16gb que era una imagen que instale con el win32diskimager, desconozco si hay un programa mejor que ese, ya que tuve que usarlo en windows 7 porque en xp no me dejaba.
-krahs- escribió:
WIZZY escribió:Configuralo con Retroarch:

https://arcadegamer.es/configurar-boton ... -retropie/


Yo tengo un problema con el propio menu de retroarch, aparece tan aplastado... es ilegible, sale deformado horizontalmente... como puedo solucionar eso? me es imposible configurar los controles.

Hola WIZZY.
Estás usando la distribución EVO que aparece en la primera página? Entiendo que no has modificado nada por lo que, puedes describir mejor donde te pasa lo de los menús aplastados? Es emulando un sistema Nes, megadrive, arcade? Si es arcade desde carpeta estás lanzando las roms?


Ocurría en todos.
Finalmente he optado por actualizar a la nueva versión y ya funciona todo correcto. Ya funciona el retroarch, los sticks en mame, incluso el sonido que creia que era problema de los altavoces ahora funciona perfecto. Estoy muy contento dada la faena que me estaba dando y las soluciones que me ha dado simplemente actualizando.

Ahora tengo otro problema y espero el último:
Tengo una interfaz xin mo de 2 players que uso para un solo player, y otra dragon que uso para el segundo player. El caso es que probando mil configuraciones distintas, conectando, desconectando... solo consigo que funcione el P1 y el P2 no, el P1 en el P2 y en el P1 nada, incluso P1 y P2 intercambiados, pero NUNCA, P1 y P2 en su sitio. Llevo días con eso y me estoy volviendo loco. En la anterior version logré hacerlo funcionar pero ahora es imposible!

Por favor tenéis la solución?

Gracias.
Esta disponible la nueva versión Retropie CRT Edition EVO (Beta 2.3), la principal novedad es el soporte de manera experimental a pi2jamma (gracias @pacocas) y RGB-Pi JAMMA. El cambio de cable se realiza mediante un modulo dedicado que podéis encontrar bajo el menu de CRT (RGB Cable Selector). Del mismo modo en el primer arranque preguntará por el cable que se tiene instalado para configurarlo automáticamente. Como siempre es posible cambiarlo en cualquier momento.

En el caso de PI2JAMMA decir que, dado que se comporta como un teclado, ha sido necesario preconfigurar todo el sistema para que funcione.
Los que ya tienen un pi2jamma ya están familiarizados con esto, pero dejo las combinaciones de teclas aquí:

EMULATIONSTATION y Menus de retroarch:
Button 'b': Player1Button1
Button 'a': Player1Button2

MENUS MODO TEXTO DE RETROPIE Y RASPBIAN:
Seleccionar: Player1Button3

ACCESOS ESPECIALES:
Salir de emuladores: Player1Start + Player1Button1 (emula tecla ESC)
Menu Retroarch: Player1Start + Player1Button2 (emula tecla F1)
Menu MAME: Player1Start + Player1Button4 (emula tecla TAB)

INSERTAR CREDITOS:
Si no dispones de botones para moneda puedes usar las siguientes combinaciones:
COIN Player1: Player1Start + Player1UP (emula tecla 5)
COIN Player2: Player2Start + Player1UP (emula tecla 6)
ó
COIN Player2: Player2Start + Player2UP (emula tecla 6)


En otro orden de cosas, es posible activar desde el Configuration Utility el Aspect Ratio Correction de SCUMMVM (desactivado, manual o por defecto). Esto permite ver muchos juegos a pantalla completa eliminando las franjas negras horizontales pero ojo, aunque el juego completará la pantalla perderemos el pixel perfect. NO funciona con todos los juegos, la compatibilidad depende de SCUMMVM.
En relación tambien a SCUMMVM, ahora los menus del emulador son más grandes y legibles.

Hay otro monton de cosas que han cambiado y que podeis revisar en el changelog. Mi intención es seguir trabajando en más pero no sacaré release nueva a corto plazo salvo que se detecte algún problema que lo requiera. En mi opinión funciona lo suficientemente bien como para dejarla un tiempo y que nadie se vea obligado a seguir actualizando versiones, por lo que no significa necesariamente que sea la ultima.

WIZZY escribió:
-krahs- escribió:
WIZZY escribió:Configuralo con Retroarch:

https://arcadegamer.es/configurar-boton ... -retropie/


Yo tengo un problema con el propio menu de retroarch, aparece tan aplastado... es ilegible, sale deformado horizontalmente... como puedo solucionar eso? me es imposible configurar los controles.

Hola WIZZY.
Estás usando la distribución EVO que aparece en la primera página? Entiendo que no has modificado nada por lo que, puedes describir mejor donde te pasa lo de los menús aplastados? Es emulando un sistema Nes, megadrive, arcade? Si es arcade desde carpeta estás lanzando las roms?


Ocurría en todos.
Finalmente he optado por actualizar a la nueva versión y ya funciona todo correcto. Ya funciona el retroarch, los sticks en mame, incluso el sonido que creia que era problema de los altavoces ahora funciona perfecto. Estoy muy contento dada la faena que me estaba dando y las soluciones que me ha dado simplemente actualizando.

Ahora tengo otro problema y espero el último:
Tengo una interfaz xin mo de 2 players que uso para un solo player, y otra dragon que uso para el segundo player. El caso es que probando mil configuraciones distintas, conectando, desconectando... solo consigo que funcione el P1 y el P2 no, el P1 en el P2 y en el P1 nada, incluso P1 y P2 intercambiados, pero NUNCA, P1 y P2 en su sitio. Llevo días con eso y me estoy volviendo loco. En la anterior version logré hacerlo funcionar pero ahora es imposible!

Por favor tenéis la solución?

Gracias.


@WIZZY tu configuración es muy particular y sospecho que tu problema viene porque el controlador XIN MO es para dos player y debido a que en este retropie está correctamente configurado, el sistema siempre detectará dos joystick para el XIN MO por lo que el dragon siempre será el tercero.

Como workaround puedes eliminar manualmente la configuración del XIN MO para que solo detecte un joystick y el dragon sea el segundo pero ten en cuenta que si abres la herramienta de RGB Cable Selector corregirá tu cambio y lo dejará como debe ser.

Para hacerlo, conecta la SD en un PC, accede al fichero cmdline.txt en la carpeta /boot y elimina esto:
usbhid.quirks=0x16c0:0x05e1:0x040


Graba el fichero y vuelve a montar la SD en la Raspberry, ahora el XIN MO solo debería identificarse como un solo joystick.
@-krahs- fantástico! A mediodia te digo si ha funcionado o no.
Para el Xin mo hay un video en arcadexpress para hacerlo funcionar en retropie sin problema modificando un fichero, Echale un ojo que con esa solución a mi me funciono el interfaz para dos jugadores.
Grande y mas grande,gracias @-krahs- noticias fantásticas.
En cuanto llegue a casa pruebo la nueva versión si o si [beer]
salu2!!!
Solucionado, simplemente detectaba el Xin mo Como jugador dos.

Simplemente he cambiado Las placas de sitio y ya está. Ahora detecta el Dragon como Player uno en la posición Player uno, y el Xin mo como Player dos en posicion player. 2.

La solucion de borrar el comando del txt no habia funcionado.
Y porque no usas el Xin mo para controlar los dos jugadores?
@jdeacon porque en su momento retropie crt creo recordar no era compatible hasta esta ultima versión EVO. Preferí comprar una segunda interfaz. Y ahora por comodidad no queria volver a liarme y basicamente he cambiado las interfaces de sitio. 5 minutos apenas.
Ya vuelve a estar disponible la imagen para bajar...
Se ha tenido que actualizar ya que en el ultimo update SCUMMVM no iniciaba.

Siento el cambio de ultima hora, ahora Beta 2.4...
@WIZZY desde el primer día,yo he utilizado xin mo(1 player),sin ningún problema.Por eso,me quedé un poco parado,al ver que se había incluído su soporte,hace muy poco.
mcfly escribió:@WIZZY desde el primer día,yo he utilizado xin mo(1 player),sin ningún problema.Por eso,me quedé un poco parado,al ver que se había incluído su soporte,hace muy poco.

Buenas.
Xin Mo funcionaba bien, el problema que hay con este dispositivo es que si no se configura debidamente emulation estation sólo detecta un joystick cuando lo correcto es que se identifiquen dos.
En la wiki de retropie tenéis más info al respecto...
Al Final la solución dentro de mis capacidades ha sido la os he comentado. Muchísimas gracias a todos por la ayuda.

Edito: acabo de recordar que compre la segunda interfaz porque usaba recalbox.
Version para raspberry 4 se espera? O ya funciona con esta?
Buenas como se realizaría overclock en este sistema? supongo que en el config.txt habla que meter las lineas; pero no se muy bien en que parte. [+risas]
un saludo
buenas tardes, en primer lugar gracias por el maravilloso proyecto, es el único digno de ellos montado en raspberry: ¡simple y efectivo!

Tendría un par de preguntas / solicitudes:

en la última versión, la opción de fuerza en arcade ya no funciona, déjame explicarte:

si inicio rtype, funcionó en pantalla completa y se centró con la opción force.

en la última versión (2.4) la pantalla es completamente negra, incluso si el juego funciona sin problemas.

Noté que la opción forzar / recortar se produce después de la pantalla de carga, mientras que antes de que sucediera ... antes.
¿También hay una opción para agregar esta opción a otros juegos de arcade?

finalmente, ¿es posible dar compatibilidad al Daphne y, aunque no se vuelva perfecto, al Saturno?

Gracias de nuevo, y lo siento si he creado preguntas que ya han sido respondidas

saludos
xam925 escribió:buenas tardes, en primer lugar gracias por el maravilloso proyecto, es el único digno de ellos montado en raspberry: ¡simple y efectivo!

Tendría un par de preguntas / solicitudes:

en la última versión, la opción de fuerza en arcade ya no funciona, déjame explicarte:

si inicio rtype, funcionó en pantalla completa y se centró con la opción force.

en la última versión (2.4) la pantalla es completamente negra, incluso si el juego funciona sin problemas.

Noté que la opción forzar / recortar se produce después de la pantalla de carga, mientras que antes de que sucediera ... antes.
¿También hay una opción para agregar esta opción a otros juegos de arcade?

finalmente, ¿es posible dar compatibilidad al Daphne y, aunque no se vuelva perfecto, al Saturno?

Gracias de nuevo, y lo siento si he creado preguntas que ya han sido respondidas

saludos


Hola.
Efectivamente el selector para ajustar los juegos con resoluciones especiales (arcade encapsulator) no funciona bien. Se debe a un cambio aplicado en la última beta al modulo arcade. Ya está solucionado y se incorporará en la siguiente versión.
Este 'arcade encapsulator' solo es necesario para determinados juegos, no es necesario para todos los demás.

En cuanto a daphne, el problema es la resolución ya que originalmente eran juegos laserdisc con resolución de 480 lineas. Teniendo en cuenta que eran videos, tal vez se pueda apañar para que sean jugables aunque perderiamos bastante... Habría que verlo...

Muchisimas gracias por el reporte :)
Hello Krahs, just suscribe to pushes you some feedbacks about this last build 2.4 (the first I try, fantastic job !)

First , I use the Retrotink Ultimate RGB solution with Component output. At the boot, I have black screen. I have add these lines on pi config boot to have ES display :

dtoverlay=dpi24
dpi_output_format=519


So, am I supposed to select "RGB -pi" on choice cable , or my device is it currently non suitable ?

I have the display on ES, all menus seems work. But , when I launch a game :
  • display choice "forced" or "cropped" is asked. If I choose, I got a black screen, for the both choice (I suppose I meet again a pb of wrong display config).
  • If I don't choose, the game is launching auto at the end of few seconds, but while we think that a choice was made by default to launch the title, the screen game actually covers the display choice. Thus, in game, if I launch Retroarch menu, while I navigate accross the retroarch parameters, I navigate also on the first display choice stayed active rear( listening the sound of navigation)! and if I select a parameter, I validate too the display choice (so black screen in my case).
  • And, at this point, if I exit the game, I come back to ES in a very wrong resolution state, with no visibility of vertical navigation (no updated screen in vertical, i see only when I change system ) and no possibility to reboot or restart ES).

Will be extra cool if you add Retrotink choice solution on the future build (caution, it have two output mode possible, vga and component) ! thanks :)

Independantly, I have note you have been constrained to compensate the wrong aspect ratio inducted by the 270p hdmi timing by stretched graphics ressource for good display in theme (all the 270p theme). I have meet the same pb and I have ask on the Retropie forum if there would be a possibility to have a parameter to cheat the intern aspect ratio (for fonts, and all the elements which must have a perfect ratio like md_marquee, logos etc), when we have no choice to get a wrong ratio by special hdmi_timing, to avoid apply faked ratio on graphics ressources. But I think a request of you would have very more luck of success and weight :)

thanks and successful continuation !
Scanlinator escribió:Hello Krahs, just suscribe to pushes you some feedbacks about this last build 2.4 (the first I try, fantastic job !)

First , I use the Retrotink Ultimate RGB solution with Component output. At the boot, I have black screen. I have add these lines on pi config boot to have ES display :

dtoverlay=dpi24
dpi_output_format=519


So, am I supposed to select "RGB -pi" on choice cable , or my device is it currently non suitable ?

I have the display on ES, all menus seems work. But , when I launch a game :
  • display choice "forced" or "cropped" is asked. If I choose, I got a black screen, for the both choice (I suppose I meet again a pb of wrong display config).
  • If I don't choose, the game is launching auto at the end of few seconds, but while we think that a choice was made by default to launch the title, the screen game actually covers the display choice. Thus, in game, if I launch Retroarch menu, while I navigate accross the retroarch parameters, I navigate also on the first display choice stayed active rear( listening the sound of navigation)! and if I select a parameter, I validate too the display choice (so black screen in my case).
  • And, at this point, if I exit the game, I come back to ES in a very wrong resolution state, with no visibility of vertical navigation (no updated screen in vertical, i see only when I change system ) and no possibility to reboot or restart ES).

Will be extra cool if you add Retrotink choice solution on the future build (caution, it have two output mode possible, vga and component) ! thanks :)

Independantly, I have note you have been constrained to compensate the wrong aspect ratio inducted by the 270p hdmi timing by stretched graphics ressource for good display in theme (all the 270p theme). I have meet the same pb and I have ask on the Retropie forum if there would be a possibility to have a parameter to cheat the intern aspect ratio (for fonts, and all the elements which must have a perfect ratio like md_marquee, logos etc), when we have no choice to get a wrong ratio by special hdmi_timing, to avoid apply faked ratio on graphics ressources. But I think a request of you would have very more luck of success and weight :)

thanks and successful continuation !


Thanks a lot for your feedback @Scanlinator :)
The issue with arcade encapsulator (forced/cropped) was already reported and solved, the fix will be present on next release....
In regard of retrotink, probably you can use it perfectly with those changes but keep in mind that it’s not a supported device so as soon as you launch “RGB Cable Selector” this will try to fix any configuration to fit to any of the profiles.
Unfortunately I can’t have or better said, I can’t buy all possible devices to test and give support to and, retrotink is an example.
Maybe in the future I can get one...

On the other hand, you are right, 270p themes implies a big effort to make them visible in the right aspect ratio... hope even with limitations with retrotink, you are enjoying the distribution...

I’ll wait for other problems if not, new release will be available soon with encapsulator fix.

Thanks again
He instalado la nueva versión EVO para Pi2Jamma y va de lujo!

Lo único que quiero meter las roms, pero no soy capaz de conectarme por FileZilla. Intento con "root" "root" o "pi" "raspberry", pero nada. Tengo la Wifi configurada, meto la IP pero no hay manera.

Alguna idea?
VaNiL escribió:He instalado la nueva versión EVO para Pi2Jamma y va de lujo!

Lo único que quiero meter las roms, pero no soy capaz de conectarme por FileZilla. Intento con "root" "root" o "pi" "raspberry", pero nada. Tengo la Wifi configurada, meto la IP pero no hay manera.

Alguna idea?


deberías poder conectar con user/pass pi/raspberry puerto 22. Haz un ping a la ip a ver si resuelve. Bueno, primero de todo, te has metido en raspi-config y has habilitado ssh en interfacing options?
VaNiL escribió:He instalado la nueva versión EVO para Pi2Jamma y va de lujo!

Lo único que quiero meter las roms, pero no soy capaz de conectarme por FileZilla. Intento con "root" "root" o "pi" "raspberry", pero nada. Tengo la Wifi configurada, meto la IP pero no hay manera.

Alguna idea?

Tambien tienes la opción de usar un USB... formatea un USB que tengas disponible en exFAT y crea una carpeta llamada roms en el raiz.
Insertala en la PI y activa el USB Automount, el solo te generará toda la estructura de carpetas necesaria.
Expulsa el USB y copia las roms que quieras desde un PC, tan pronto como lo vuelvas a pinchar en la PI, emulationstation se reiniciará solo y lo montará automáticamente.
@VaNiL también puedes,desde el pc que tengas conectado al mismo router que la rpi,escribes en "ejecutar"
//retropie
Y tendrás acceso a las carpeta roms o bios,por ejemplo.Desde ahí,ya puedes hacer copy/paste.Si te pide usuario/contraseña, son pi/raspberry.
-krahs- escribió:
VaNiL escribió:He instalado la nueva versión EVO para Pi2Jamma y va de lujo!

Lo único que quiero meter las roms, pero no soy capaz de conectarme por FileZilla. Intento con "root" "root" o "pi" "raspberry", pero nada. Tengo la Wifi configurada, meto la IP pero no hay manera.

Alguna idea?

Tambien tienes la opción de usar un USB... formatea un USB que tengas disponible en exFAT y crea una carpeta llamada roms en el raiz.
Insertala en la PI y activa el USB Automount, el solo te generará toda la estructura de carpetas necesaria.
Expulsa el USB y copia las roms que quieras desde un PC, tan pronto como lo vuelvas a pinchar en la PI, emulationstation se reiniciará solo y lo montará automáticamente.


Wow! Gracias! Perfecto!

Gracias a todos por vuestras respuestas!! Ya funciona, jo, qué maravilla [amor] [amor] [amor]
959 respuestas