[Hilo oficial] EZ-Flash Junior

1, 2, 3, 4, 5, 6, 7
@Ippo Makunouchi nada, me alegro vaya todo bien, ahora a disfrutar [looco]
esta flash card tiene ya power sarving?
yuragalo escribió:@luffyelx ???



Si tiene para salvar la partida donde quieras?
luffyelx escribió:
yuragalo escribió:@luffyelx ???



Si tiene para salvar la partida donde quieras?

Si te refieres a savestates, como diga que sí le pegó fuego a mi EDGB mientras voy encargando una.
@luffyelx @Thundertwin72 no tiene soporte de save states, tampoco sé si entra en el roadmap del flashcart.
PD: encontré la incompatibilidad que comentaba antes de mod de pantalla y no era de la Color [tomaaa] , era de DMG, en concreto la que sustituye también la placa delantera.
Estaba en los comentarios del cartucho en la web oficial.
Vayapordios... Acabo de pedir ese mod [facepalm]

Pues nada, seguiré tirando de mi EDGB chinorro.
@Thundertwin72 vaya, ya lo siento, no encontraba na dichosa conversación [snif]
Hablan de éste Kit en concreto:
https://www.ebay.co.uk/itm/Game-Boy-Backlit-Screen-LCD-IPS-Color-Kit-Speaker-DMG-Original-V2/254556087461?pageci=e20e10cf-0d6a-4c60-b37a-00dc013ec45f
En mi caso si hubiera tenido EDGB no hubiera dado el salto a éste (hace muy bien el apaño), pero bueno es una valoración personal.
no he dicho nada pues. Lo que si me hecha para atras es que en los mods no vaya bien ni en la pocket.
yuragalo escribió:@Thundertwin72 vaya, ya lo siento, no encontraba na dichosa conversación [snif]
Hablan de éste Kit en concreto:
https://www.ebay.co.uk/itm/Game-Boy-Backlit-Screen-LCD-IPS-Color-Kit-Speaker-DMG-Original-V2/254556087461?pageci=e20e10cf-0d6a-4c60-b37a-00dc013ec45f
En mi caso si hubiera tenido EDGB no hubiera dado el salto a éste (hace muy bien el apaño), pero bueno es una valoración personal.

He pedido éste y, aunque el kit que enlazas ya incorpora el altavoz y una pieza donde alojar la pcb pequeña, diría que es el mismo.

Y voy a dejarlo ya, porque no veo muy adecuado hablar de esto en este hilo.
Hola, he encontrado un problema en mi EZ Flash Junior y quería preguntar si a alguien más le ocurre lo mismo o es un problema puntual de mi cartucho. En cualquier juego de Pokemon que utilice RTC (He probado varias versiones de roms y hasta en varios idiomas de GOLD, SILVER y CRYSTAL) el RTC dentro del juego si funciona, pero cada como 40 segundos o 1 minuto, se cambia la hora a un desfase como de 8 hrs y del día se mueve 5 días (ejmp. de Martes 10 AM cambia a Domingo 6 PM), después pasan 15-20 segundos en esa hora y regresa a la hr correcta. Y así se repite en bucle el cambio horario.

-En el menú de la EZ Flash JR la hora siempre está correcta y si se queda guardada.
-La batería de la EZ Flash JR se encuentra nueva 3.04 V en el Multimetro-Voltimetro-Tester
-Probado con Roms en Español e Inglés
-Versión FW4 K1.04e

Gracias por su atención. Saludos.
@RetroKarl pues no he notado nada de ese estilo, tendré que probar mas tiempo la 2a gen. a ver si se da ese bug que comentas, gracias por avisar compi y bienvenido al foro ;)

PD: veo que has reportado en el hilo TestFlight de GBATemp y era un error conocido (en mi caso no noté nada :-? ), han sacado un update que aparentemente le han corregido, actualizo y pruebo a ver. Mil gracias compi.
Ippo Makunouchi está baneado por "Troll"
Por mi parte en todo este tiempo he encontrado un juego que no carga, el Adventures of Lolo.

A parte de ese detalle contentísimo con el cartucho.
Ippo Makunouchi escribió:Por mi parte en todo este tiempo he encontrado un juego que no carga, el Adventures of Lolo.

A parte de ese detalle contentísimo con el cartucho.

A mi me carga perfectamente, imagino que dices el de la game boy clasica, desconozco si hay otro.
Ippo Makunouchi está baneado por "Troll"
@kerobscure Asi es, el de la GB clasica. En ese caso quizas sea mi rom, voy a probar con otra.
yuragalo escribió:@RetroKarl pues no he notado nada de ese estilo, tendré que probar mas tiempo la 2a gen. a ver si se da ese bug que comentas, gracias por avisar compi y bienvenido al foro ;)

PD: veo que has reportado en el hilo TestFlight de GBATemp y era un error conocido (en mi caso no noté nada :-? ), han sacado un update que aparentemente le han corregido, actualizo y pruebo a ver. Mil gracias compi.


Hola Yuragalo, gracias por la bienvenida :)

Así es, reporté el bug, al parecer ya era conocido e hicieron un update, cambiaron unas cosas, pero sigue sin arreglarse. Ya actualicé con la información de mis Tests con el nuevo Firmware y Kernel, espero se solucione pronto. Lo que no me ha quedado claro es en que porcentaje de tarjetas se presenta esto. Gracias por tu respuesta y tu atención. Saludos.

Ippo Makunouchi escribió:@kerobscure Asi es, el de la GB clasica. En ese caso quizas sea mi rom, voy a probar con otra.


Hola Ippo, confirmado, "Adventures of Lolo" si me funciona también a mi correctamente. Probablemente sea cosa de tu Rom, Siempre procura usar Roms limpias que no hayan pasado por ningún emulador ni Flashcart, porque suelen parcharse y si ese Rom parchado lo llevas a otro emulador o Flashcart, suelen dar problemas. Saludos.
@Ippo Makunouchi a mi me carga bien también el Lolo.
@RetroKarl de momento no he notado nada (también te digo que antes tampoco, lo que no quiere decir que no esté presente el problema [carcajad] ), eso sí, recomiendan comenzar una partida de cero con el nuevo kernel para asegurarse de que no se vuelva a reproducir el bug, al menos eso comentaba Ezflash2.
yuragalo escribió:@Ippo Makunouchi a mi le carga bien también el Lolo.
@RetroKarl de momento no he notado nada (también te digo que antes tampoco, lo que no quiere decir que no esté presente el problema [carcajad] ), eso sí, recomiendan comenzar una partida de cero con el nuevo kernel para asegurarse de que no se vuelva a reproducir el bug, al menos eso comentaba Ezflash2.


Si, todas fueron con partidas nuevas, y de inicio si, así juegues por horas, se comporta correctamente todo, pero tras unos cuantos guardados continuos (reseteando para guardar el Backup Save), el RTC se vuelve loco en el juego.
@RetroKarl ok, bueno saberlo, sigue el bug entonces.

PD: llevo de momento al Cristal 3 medallas y varias horas divididas en varios días (a día por gimnasio) y de momento no me ha hecho nada raro la hora ni el día :-? (Lo que no quiere decir que no termine reproduciéndose mas adelante).
PD2: pues por 1a vez se me ha reproducido el bug adelantándose varias horas hasta marcar las 2 am [carcajad]
Ippo Makunouchi está baneado por "Troll"
@RetroKarl Muchas gracias por el conaejo, lo tendre en cuenta [beer]
yuragalo escribió:@RetroKarl ok, bueno saberlo, sigue el bug entonces.

PD: llevo de momento al Cristal 3 medallas y varias horas divididas en varios días (a día por gimnasio) y de momento no me ha hecho nada raro la hora ni el día :-? (Lo que no quiere decir que no termine reproduciéndose mas adelante).
PD2: pues por 1a vez se me ha reproducido el bug adelantándose varias horas hasta marcar las 2 am [carcajad]


Hola Yuragalo, si, el Crystal es la versión que aparentemente funcionaba mejor, pero igual pasa después de varios guardados :s

Al parecer el developer quiere forzosamente meter los datos del RTC en el archivo .sav, pero no estoy muy seguro que sea lo mejor, varios emuladores que considero de los mejores de GB-GBC para android y consolas portátiles crean mejor un archivo .rtc aparte solamente para controlar bien el "Tiempo Real" con excepción del GameYob para DS, pero tampoco estaría muy seguro de que guarda esos datos en el .sav o en otro archivo de config.

Puede que este problema este altamente relacionado con los problemas del Pokemon Prism que nada más no cosigue hacer funcionar bien con el RTC el developer.

Por curiosidad, que idioma estás usando del Pokemon Crystal? y que version de Firmware-Kernel? si es el fw5 kernel 1.05 que build?

Gracias por tu tiempo para corroborar el problema y tu respuesta. Saludos.
@RetroKarl tengo la última actualización test 5-27, estoy usando edición cristal española parcheada con un hack que desbloquea el evento Celebi.
Como dices ha aguantado varios guardados antes del bug, esta madrugada retomé la partida y volvió a la normalidad de nuevo.

PD: eso de incrustar datos en el save tampoco me convence, puede haber problemas de poder reutilizarlo en otros soportes.
@yuragalo Ya veo, gracias por la info. Y pues ojalá se solucione pronto. O a ultimas, la versión de FW4 Kernel 1.04 que me cambiaba de hora cada 30 segs y después regresaba a la correcta, tiene sus ventajas, bayas infinitas XD y capturar a cualquier pkmn a cualquier hora pues vas rotando día y noche en cuestión de segundos XD
@RetroKarl esta tarde se descojonó la hora otra vez sin haberle dado uso previo ni guardado hoy; y se me ha vuelto a corregir justo ahora, pasadas las 12, parece ser que se corrige el conteo de hora al pasar de día.
Eso sí el origen del fallo/descontrol a saber.
En cuanto me pase la Cristal que ya me he puesto, empezaré con la Oro/Plata que terminará igual supongo y por lo que comentas.
Pensaba que el bug era solo con Prism pero parece ser también con las ediciones oficiales.

PD: lo que no me ha pasado por el momento es congelación de hora o reinicio y tener que reintroducir la misma in-game.
En el menú del cartucho va perfectamente tanto hora como fecha.
@yuragalo Ya veo, cuando pide introducir de nuevo hr-fecha, lo mejor suele ser no guardar ni cargar, sino salir del juego, cuando prendas la consola y te diga de respaldar el backup save, le das en descartar-cancelar. Vuelves a cargar el juego y si tienes suerte en unos 1-3 intentos solito te carga de nuevo la hr-fecha correcta. Porque la mayor parte de las veces, cuando re introduzco la hr-fecha, ahí si se vuelve medio loco los próximos guardados, cambia sola la hr-fecha aleatoriamente, se congela la hr o entra en bucle de pedirte siempre la hr-fecha al iniciar.

(Ignora lo anterior XD, leí mal, pensé que ya te había pasado)

Para los problemas que me da a mi la test 5-27, casi que puedo asegurar que me iba mejor la FW4 Kernel 1.04e, aunque me pasara 30 segs en la hr-fecha correcta y 30 segs en las incorrectas en bucle,por lo menos nunca olvidó la fecha correcta el game save por más veces que guardara. Siempre recordaba la correcta y la incorrecta alternandolas, pero la correcta nunca se desfasaba ni un segundo, nunca me pidió introducir de nuevo etc.

Si, te digo, he probado en puras versiones oficiales, y como te mencionaba, seguramente los problemas de Prism ocurran por estos pequeños bugs en las oficiales, después de todo Prism no deja de ser una versión parchada de Crystal. Gracias por tu tiempo y atención.
@RetroKarl sí, con la 5-27 también hace bucle pero de horas (no se exactamente cuando se descojona, no llevo el conteo), pero al pasar de día (a patir 12 noche) se corrige como comentaba antes.
Tengo que probar a forzar el RTC en menú, quizá forzando desde ahí se pueda regular bruscamente de momento, hasta que arreglen el tema.

Al final me tocará hacerme cuenta en GBATemp y reportar por allí también [carcajad] .
De todas formas no creo sea cartucho defectuoso porque en menú el RTC siempre está correcto, al menos en mi caso de momento, supongo será de software.

PD: pues mira acabo de cargar y hoy no se ha descontrolado, esta perfecto, ayer llegué hasta en conflicto Rocket en Radio ciudad Trigal.
@Slycuper el bug en Pkmn Prism se sabe de hace bastante, pero no caímos en la cuenta que podía pasar en ediciones oficiales, en mi caso probé con partidas que tenía ya completas y no detecté nada, posiblemente porque no probé lo suficiente parece ser.
Testear las 3 ediciones de 2a gen a conciencia como comprenderás conlleva echarle bastante tiempo, con todo el catalogazo que tiene GB/GBC [amor] [babas]
@Slycuper lo entiendo compi, a mí me gustan mucho pero no todo es Pkmn, de hecho hay mejores títulos para mí por lo menos, auténticas joyazas en esta plataforma.
También volver a decir que nos que tenemos el cartucho somos como los conejillos de indias [carcajad] y que en mi caso solo lo he recomendado siempre que el salto sea notable como en mi caso (y dependiendo del precio que tenga que no es el mismo en todos los sitios), pasar de un EMS GB USB Smart Card (gran fladhcart pero con sus años y consecuentes limitaciones) a éste Ezjr; teniendo cartuchos del estilo como EDGB, EL Cheapo... Pues el salto no es tan grande y hay que pensárselo muy mucho.
De hecho vuelvo a comentar si hubiera tenido uno de esos seguramente no hubiera dado el salto al Ezjr, pero vamos que aún con todo esto yo estoy muy contento con el Ezjr y sobretodo al precio que me salió XD

PD: @RetroKarl creo que acabo de encontrar un patrón +- claro en mi caso (se me ha dado 2 días seguidos, seguiré mañana al tanto), se descontrola la hora en el juego aproximadamente entre las 18:00 horas hasta las 0:00 del día siguiente donde se "reinicia"/corrige (en Cristal Española de No-Intro), vamos que haría ese bucle como comentábamos antes, guarde o no la partida. Recién comprobado hace un ratito, estoy haciendo varias pruebas y luego comento resultados.
@yuragalo Pues si llegas a ubicar a la perfección tu problema, seguramente sería de gran ayuda para el dev, Igual ya te mencioné un par de veces en GBATemp. Si ehh, tampoco estoy tan seguro de que sea que estén defectuosas, lo que si podría ser es que unos cartuchos tengan una marca de chips y otros otra, puede ser por mil cosas, como falta de stock por el problema actual sanitario u alguna otra razón muy distinta y que por eso se presente más en unos cartuchos que en otros. Quedo al pendiente de tus pruebas.

Pues sabes que? podría tener sentido las horas que mencionas, porque son las horas que por lo general pruebo las cosas :S

Si concuerdo contigo de la Ezjr, fuera de estos bugs en los Pkmn, cualquier otro juego va como cartucho original, cero problemas, carga super rápida, cero errores.

@Slycuper Si, también me sorprendió demasiado que no hubiera reportes de ello, y que solo hubiera quejas del Pkmn Prism en lugar de los oficiales. Pero también considera eso, que hay miles de fanáticos del GB-GBC que nunca en su vida han jugado Pkmn ni piensan hacerlo, cada quien tiene sus gustos. Y como menciona @yuragalo, probar todo esto si implica bastante tiempo. Saludos.
@RetroKarl sí, sigo parte del foro GBATemp y el hilo del testflight, os leo y estoy al tanto, gracias por ello ;) , solo que no tengo user [carcajad]
Paso a comentar pruebas realizadas en una AGS-101 (la que uso siempre pal vicio XD ), uSD Kingston 1GB en FAT - 32KB tamaño cluster y FW/Kernel 5-27; quedaría probar en otras tarjetas de 4GB para arriba con formato soportado oficialmente (FAT32 - 32KB cluster).

>>A partir de las 18:xx ó 19:xx aproximadamente, pasa a las 2:xx y al día Viernes (no recuerdo si fue hora/fecha que creé la partida...), además el tiempo no avanza a no ser que estés in-game, si guardas partida ya volvería a correr fuera del juego durante dicha franja.
>>Si fuerzo cambio de día del RTC en el Kernel no se rectifica la hora en el juego pero el día cambia perfectamente.
>>Si fuerzo cambio de hora en el Kernel al borde de cambio de día (23:59 por ejemplo), al dejarle pasar a las 0:00 horas y día siguiente se corrige y funciona bien de nuevo en el juego.
Pero si solo adelanto o retraso el tiempo dentro del mismo día, no se corrige, simplemente adelanta/retrasa dentro de ese desfase y vuelve a contar un game.
>>El RTC (fecha y hora) en el kernel me funciona siempre bien, no he detectado nada raro.
EDITO: Novedad: se me ha reiniciado el RTC en Kernel al cabo de cargar varias veces la Cristal pero sin guardar (tiempo congelado) y al volver a configurar he estado un buen rato echándole un ojo, a veces hacia tics (cambios ultrarrapidos) en algunos parámetros y enseguida se han corregido de nuevo (a veces día, a veces mes, año o segundero...), pero es cuestión de milisegundos ese "tic"/cambio.
A si que sí, supongo hay algún bug del RTC en firm/kernel... O lo provoca el cargar el juego... A saber (Espero no sea hard).

PD: Confirmado el patrón en principio, el bug de descontrol se da en esa franja a partir de las 18:xx ó 19:xx aprox. (Cambia a las 2:xx y día Viernes) hasta las 0:00 donde pasa al día siguiente y se corrige de nuevo, todo ello en mi caso particular.
Por cierto perdona por el tochazo, los edit y consecuentes menciones [ayay]
@yuragalo Ya veo, Leí todo lo que has escrito hasta ahora, y por lo que veo, ya se te han presentado prácticamente todos los problemas que a mi me han pasado e incluso unos nuevos que seguramente me pasaron pero no noté.

En un rato haré unas pruebas para corroborar las hrs que me mencionas de fallos, porque como te decía, es muy probable que se me presentaran más los fallos porque esas son las horas a las que solía probar.Y pues tomaré en cuenta toda esta info que dejaste para observar el comportamiento. Lo que me sorprende es que ya hasta el reinicio de la hr de la EZJr te haya pasado. Espero que siendo así, sean mucho más rastreables los bugs en el FW/Kernel en cualquier EZJr.

Jaja no te preocupes, así con los edits está bien, sino terminas escribiendo mil mensajes como yo XD
@RetroKarl OK gracias compi, también decir que el reinicio del RTC en Kernel, CREO ha sido debido a que he visto que en ocasiones si cargo el juego pero no la partida (quedo en el cuadro de continuar partida, hora y día...) y reseteo el cartucho con el botón (sin cargar partida), al cargar el OS se queda colgado en "Loading" y toca apagar consola y encender de nuevo, no sirve con resetear más veces con botón, se cuelga igual (y la 1a vez me pasó he reseteado varias veces con el botón antes de apagar la consola).
He provocado otras 2 veces ese cuelgue (ya que solo se da alguna vez, no es algo fijo) pero no se ha vuelto a resetear el RTC.
Por cierto, decir también que la carga del juego la estoy haciendo con el Start (carga rápida).
A ver si a otros compis de aquí o de allí se les da el tema del RTC, que entiendo debería pasar igual.
Esta claro que ambos coincidimos en problema y patrón +-
@yuragalo Completamente así!!! pantalla de Loading trabada en varias ocasiones cuando me pasó lo del reseteo de la hr de la EZJr, pero yo eso lo asocié con las baterías bajas (muy bajas), las pantallas de Loading trabadas, porque al cambiar de baterías se quitó por completo. No recuerdas si tardaste mucho en tener que cargar la consola desde ese momento?

Si, hay que ver si a mas personas les pasa, porque sería demasiada coincidencia que solo a ti y a mi nos pase. Espero sobre todo que el developer logre reproducir el problema para poder solucionarlo de primera mano y no solo en base a lo que un tercero le cuenta.

Probaré esto, sacaré unas conclusiones y después yo creo tocara armar un "procedimiento" para reproducir los bugs y hacerle saber al developer.
@RetroKarl prácticamente recién cargada la consola en mi caso (de hecho teniendo batería en rojo y usando el cartucho no he tenido problemas). No puedo reproducirlo de fijo, por el momento me parece "aleatorio" dentro de esa premisa de no haber cargado la partida y resetear con el boton desde el menu in-game mencionado, además durante el periodo de descontrol del RTC.
Por cierto, como cabía esperar pasadas las 12 noche, corregido día y hora de nuevo, el patrón se afianza.
Seguiré probando mañana con tarjeta 4GB+ FAT32 y 32KB cluster.
Por cierto, que uSD y en que formato y tamaño cluster usas?
@yuragalo Pues ya he probado, primero con la Silver USA, después con la Crystal USA y al final como tú, con la Cristal SPA para que fuera correcta la comparación con los factores externos reducidos lo más posible.

Silver USA, un descontrol total, mucho pedirme poner de nuevo la hora y empeora todo si usas el botón reset, no respeta lo de las 18:00-2:00 del descontrol, le pasa a todas horas. Se mejora algo usando el interruptor de encendido en lugar del botón de reset.

Crystal USA, fue más parecido a tu caso, pero aún así no fue idéntico, opera un poco distinto el RTC al parecer en cada juego e idioma, al menos en la EZJr. Y a mitad de las pruebas, forzando el RTC, tuve reset de la hora de la EZJr, seguido de loadings trabados, por lo que creo que podemos deducir que el forzar el RTC varias veces provoca que se resetee el RTC de la EZJr y sospecho que esas pantallas trabadas son el resultado de estar operando en el día 0 y mes 0 (valores seguramente no validos para el RTC del juego) del año 2000. Después por "X" o "Y" razón entrará.

Cristal SPA, bastante parecido a lo que me decías, aunque no idéntico, si, parece ser que las 18:00 hacen que salga todo de control. Aunque ya desde las 17:00 pasaban unas cosas, 2 de cada 3 cargas (todas sin guardado) mostraban una hora -10 mins trabado, y 1 de 3 mostraba la hr correcta. Luego ya estaba todo paranoico yo cargando en minuto par y minuto non jaja, y luego más paranoico cargando pasada la mitad de el minuto XX:YY = igual o mayor a 30 segundos. Y cargaban bien siempre XD. Ocasionalmente alcance las 18:00 y pues si, todo se aloco, después intenté forzar el cambio de día, pero creo lo hice medio mal, porque todo fue a peor y hasta la hr se me fue a la que tenia en la Silver USA XD (seguramente fue coincidencia).

Sobre tu pregunta, ahora las que más uso son:

-microSD Sandisk 8Gb Fat32 32Kb de cluster (también de 1Gb y de 2Gb pero solo las usé un par de veces por lo del cluster, me lo dejaba en 16 el SD Crad Formatter y en FAT, aunque te diré, iban bien con todos los juegos, a la perfección)
-microSD AData 16Gb clase 10 Fat32 32Kb de cluster

Probado ese formato de ambas con el formateador de Windows 10 y con el SD Card Formatter, sin aparente cambio entre ambos métodos.
@RetroKarl perfecto gracias, sí cuando se me ha reseteado RTC ya quedado en esos parámetros 2000/0/0 00:00:00.
Antes usaba una Samsung 8GB Clase6 en formato oficial compatible (FAT32 32KB).
Entonces se podría descartar problema de tarjeta o formato de la misma (como vi que ya funcionaba bien en FAT y 32KB con las de 1GB y 2GB, pues le puse una de esas, que entra todo el catalogo de sobra, sin repetir regiones y demás), aún así probaré con lo soportadas oficialmente.
Sí, por lo que comentas el fallo es muy parecido en Cristal (me falta probar Oro y Plata).
Está claro que algún conflicto hay con el RTC y juegos o implementacion del MBC3 + timer + save de títulos comentados...
Gracias compi por la info, seguiremos probando y recopilando info [oki]
PD: vale al final el descontrol es a partir de las 19:00 horas hasta las 00:00 del día siguiente donde se corrige.
Y decir también que se me ha vuelto a resetear el RTC en Kernel al trastear (una sola vez), cargando y reseteando como decía ayer, pero sin cuelgues.
Entonces por mi parte en la 5/27 veo y confirmo en Cristal española Nointro de finales del '13 hace ése patrón.
Empezaré con oro y Plata, además buscaré otras Rom fuera del romset que tengo para probar.
Ou mama, estamos quemando el hilo a tochazos, nos van a mandar los demás compis a la mierda [carcajad]
Mil disculpas [angelito]
@yuragalo Vale, entonces, cambia de nuevo la hipótesis, con esto que comentas, creo que los resets o ciclos de apagado-encendido continuos son lo que resetea el RTC de la tarjeta.

Yo ya la verdad estoy muy confundido XD me pasan taaanto, y son tantos los problemas con la Silver que así como que ubicar patrones, lo veo medio complicado jaja.

Y al parecer si, la Crystal USA y Cristal SPA es la más estable, ahí creo que puedo intuir que esto se debe a que los últimos cambios para corregir los fallos con Pkmn Prism indirectamente acaban ayudando a esa versión, pues no deja de ser un HackRom de la versión Crystal.

Ya veo, quedo al pendiente de que pasa. He estado haciendo tiempo a ver si contestan en GbaTemp, pero aun nada, como siga así, ya con la nueva info voy a intentar explicar mejor todos los problemas (editando mi último comentario), que no son pocos por desgracia.

Hahaha, quemando el hilo aquí y en GbaTemp también, he estado spameando como si no hubiera un mañana XD
@RetroKarl pues a mí el patrón de descontrol al menos en Cristal es fijo, lo que pasa es que he encontrado la hora exacta cuando empieza (a partir de las 19:00, creo que esto varía según la hora al comenzar partida).
Lo del Reseteo del RTC no me parece algo fijo, puede que ocurra o no, es algo mas aleatorio, al menos no he encontrado patrón o causante, pero desde luego entra la posibilidad si se trastea con la ediciones gen 2. A ver si veo algún tipo de patrón o coincidencia.

También he empezado nuevas partidas, otra edición Cristal española y oro/plata todas nointro, cuando vea algo comento.

Lo mismo me vuelvo también a la 1.04/fw4 si compensa más, ya veremos.
Esperar toca a ver si arreglan definitivamente el tema.
Otro por aquí que se lo ha pillado y de momento encantado de la vida. Lo he estrenado con el Mario Land 2 DX [amor]
@RetroKarl probado otro Cristal española nointro, además de sendas Oro y Plata españolas nointro, desfase del timer en todas.
La 1a no se corrige a partir de lad 0:00 del día siguiente pero se corrige en algún momento del día.
Las otras dos (Oro/plata) se me comportan similar a la cristal que he estado usando esto días atrás (la del parche Celebi), el desfase se corrige al las 0:00 del día siguiente, aunque empiece el descontrol a y con hora/dia diferentes.
Por ello me hace pensar que influye la hora introducida al crear partida nueva y de ahí esa diferencia.
Me falta empezar partidas de cero en tarjeta 4gb+ en FAT32 - 32KB.
Aunque viendo que te pasa igual y creo ya hemos hecho suficientes pruebas, como hemos comentado antes que el timer o su implementación/comunicacion junto con el MBC de la gen2 por la razón que sea [360º] , o bug o a saber.
Seguiré probando otras Roms por si van por ahí los tiros.
Solo queda comprobar si a otros compis les pasa igual o similar y esperar nuevas updates.
@yuragalo Pues aún sin respuesta de GbaTemp, pero igual, tomé Roms de otro lado, igual No-Intro, versiones en inglés sobre todo, y luego españolas, trasteé un poco entre versión 4 y 5 de FW con sus respectivos Kernels, así como de pruebas tomé una Sandisk Ultra de 32gb.

(Ah y pedí otra EZJr aprovechando el envío de DHL junto con un par de omegas para unos colegas)

Y pues nada, igual, el FW4 Kernel 1.04e solido como roca y super estable TODO, no importa cuando o cuanto resetees o apagues el sistema, nunca pasa el error de Roms trabados cargando u Hora-Fecha de la EZJr reiniciada al 2000/00/00 00:00:00. Solamente el fallo ya explicado con el RTC en las versiones oficiales.

Mientras tanto 5-27 Test, lo mismo, un descontrol, haciendo pruebas RTC de la EZJr se ha reiniciado solo (unas 3 veces). Por desgracia mis pruebas fueron de 17:00 a 20:00 hrs, por lo que no se si influyó en que esté mas loca la cosa.

Puede de hecho observar lo que me habías dicho, el RTC de la EZJr saltando mili segundos a otros meses, días, horas, minutos etc, muy peculiar, pero eso apoya la teoría del que el RTC del FW4 Kernel 1.04e era más estable que este.

Otra cosa peculiar, un bucle de tiempo congelado en el RTC de la EZJr cada que reiniciaba para guardar el juego o para descartar el save. me movía hacia la pestaña de la hr y todo detenido, sin embargo si seguía avanzando al parecer, pues varias ocasiones con apagar y encender la consola, la hr estaba correcta.

Y sobre lo que llevas mencionando la importancia de la hr a la que creas la partida, pues tiene bastante sentido, ya que aparte de lo que mencionas, en una de mis partidas, conseguí hacer trabajar correctamente al 100% Pkmn Silver USA (el más problematico) sin importar la hr cargando el juego cuando el reloj del RTC de la EZJr fuera en XX:XX:28-30 segs, te va a sonar paranoico jaja, pero cargando con XX:XX:05-15 segs me daba una hr erronea y congelada dentro del juego, y cargando por los XX:XX:40-50 segs, me pedía introducir la hr de nuevo el juego. Esto lo habré probado como 10 veces para cada situación de error de las 2 distintas y 20 veces cargando en la situación que cargaba bien y a parte acompañaba de guardados recurrentes.

Terminé toda esa prueba pensando que tenía una solución a medias mientras arreglan eso, pero borré todo y comencé otra partida con exactamente las mismas condiciones en TODO, y no sirvió, me parece que se movió entonces debido a la hr de creación de la partida. Algo está muy mal en el RTC de la 5-27 Test para causar todos esos problemas :s

@Leonsito Pues si, quitando el problema del RTC que hemos encontrado, es una tarjeta muy sólida para el catalogo de GB-GBC, todos los demás juegos que he probado (que no son pocos) han corrido a la perfección. Hahaha, que bien, quien se imaginaría hace años que podríamos correr Hack-roms en hardware original :)
@RetroKarl Gracias por la info compi, pues nada me vuelvo a fw4/kernel 1.04de momento, que también coincido iba mejor, de hecho ni me enteré del tema estando en esa versión.
Paciencia que ya sacaran actualización, a ver si hacen como con el Omega que me pareció leer en algún hilo de GBATemp, el source de su soft estaba liberado.
Hola,me acaba de llegar mi ez flash jr de ali y tengo un problema con el.

Tengo dos GBA una con el mod de la pantalla y otra sin el, en la del mod se me crashea constantemente,y en la que no la tiene no ,en cambio el ez flash omega va perfecto en las dos, alguno sabe porque puede ser? gracias
@Cassie
Si es la pantalla IPS, puede ser por el consumo, ya que es muy elevado.
el_ssbb_boy escribió:@Cassie
Si es la pantalla IPS, puede ser por el consumo, ya que es muy elevado.



no,es la ags 101 ,puede ser también por el consumo? tiene arreglo?
@Cassie
Pues creo que es problema de la GBA, prueba con juegos originales de GB y GBC. Con una SP que compré en este foro también me pasa, me di cuenta cuando empecé a comprar juegos de GB-GBC.
@yuragalo Vale, podrías probar el Pkmn USA Silver (que en realidad me pasa en todos los USA y SPA)? para tener la confirmación de que cada 20-40 segs se cambia la hr en el pokegear (algunas veces ocurre hasta la 3 carga del juego). Gracias de antemano :)

Ahora que dices de "paciencia", siento que esto es un DejaVu XD , con la consola New Bittboy y su SO de fabrica y luego también con el CFW, había un error de apagado muy gordo, que hacía que entraras en bucles de que prendía con la pantalla en negro 4 de cada 5 veces. Alerté por todos lados en los foros de Dingoonity (donde estaba el Dev), hasta me pelee con el vendedor de Aliexpress XD . Yo todo paranoico, porque parecía que era el único con el problema (en 3 consolas). Según a nadie le pasaba. Y de la noche a la mañana según ahora si, a todos les pasaba, el Dev lo vio y lo solucionó. Pero si llevó tiempo :/ pese a que fue una solución relativamente sencilla.

Ya apareció en GBATemp otro chico con otro problema de RTC en otro juego, por eso me acordé.

@Cassie (Aww, Cassie de Skins? que recuerdos jaja [amor] ) Quizás actualizando al "FW-Kernel 5-27" test quieran correr bien. Ha habido varios problemas como esos por lo que he leído, que la EZFJr no corra en GBC con mod de pantalla, en GBA con mod de pantalla, en GBP stock, en ciertos modelos de GBC y en la consola clónica GB BOY Colour. Supuestamente se ha ido mejorando la compatibilidad, entonces podría ser.

Y hablando de consumo, sería un poco raro, digo, tengo entendido que la EZF Omega es casi casi la tarjeta que más consume de todo el mercado (Y esa corre bien), entonces la EZFJr sinceramente no creo que consumiera más o.O, como menciona @el_ssbb_boy, deberías probar con juegos de GB-GBC para ver que pasa. Para descartar que el chip individual que reproduce los juegos de GB-GBC tenga un problema por "X" o "Y" razón.
@RetroKarl oki, voy regresando el fw/kernel e iré probando, que ahora ando afinando el OC en el PC y toy entretenido [carcajad]

Edito: creé y empecé partidas ayer de Cristal/Oro/Plata españolas en FW4/kernel1.04 y de momento bien, ni un sólo fallo de ningún tipo, lo único que desde el principio introduje la hora sale con 3 minutos menos respecto al RTC, algo que la verdad me parece una nimiedad respecto a los problemas con las versiones test.
También decir que no he avanzado en las partidas, pero vamos en las ultimas pruebas con la 5/27 igual y aparecieron.
Si surge algo raro comento, por eso al principio de todo esto no encontré nada raro, en versión 1.04 incluso 1.03 no vi problemas que es cuando probé las gen2, actualice a las últimas 1.05 y no había vuelto a jugarlas [carcajad] .
Todavía tengo pendiente las versiones Usa/Eur.

Edito2: pues eso, pasado el día de nuevo y sigue la fecha/hora bien en las 3, ningun tipo de fallo o problema salvo esos 3 minutos menos respecto al RTC, en FW4/Kernel 1.04.
Avanzare y guardaré regularmente las partidas a ver. Y después las Usa Eur.
303 respuestas
1, 2, 3, 4, 5, 6, 7