Retropie CRT Edition - Raspberry pi 2B/3B/3B+ - TV 15Khz (vga666 / pi2scart / rgb-pi)

must be also the RIGHT bios "neogeo.zip" there are 2-3 sets differnts arround the net...only one work good with those neogeo/mame roms.
I'm trying to use the latest Amiga MegaAGS HDF collection with lr-puae, but I'm stumped. Any help appreciated ...
Hi, can you tell us how you tried to use AmigaAGS collection with lr-puae. This emulator comes pre-installed but of course you need all the BIOS, kickstart files etc. You can find a link to the an archive with all the BIOS files for all systems supported by CRT Evo in the CRT EVO guide I wrote a few months ago. These BIOS file work, trust me, I have a huge amiga rom set I cooked, that works perfectly, with games for all models, demos etc.
The guide (look for "bios") : CRT EVO GUIDE

Also, if you PM me I can share my amiga romset. You ca see a demo of how the amiga presentation looks like here
Hola, alguien podría probar el Dungeon Magic y decirme si le funciona bien al 100%.
A mí me parece que va bien, pero el sonido se nota que va muy justo y más adelante, cuando hay niveles con niebla o con muchos enemigos, empieza a ralentizarse demasiado. Que decepción....

Si a alguno os va bien, que emu y habéis tocado algún parámetro???

Gracias!

Hello everyone! Someone can test Dungeon Magic arcade rom to check if it works at 100%?
To me looks like it works ok except for the sound, it don't work fully well. The problem comes in higher levels when the game use fog or there are a lot of enemies, the game slow down.

If someone have the game working at full speed even in higher levels, what emu are you using and are you setting up something special?

Thanks
I have two nes roms for dungeon magic that work (Dungeon Magic - Sword of the Elements (USA) and Dungeon & Magic - Swords of Element (Japan))....pm me so that I can send them to you....
However : I just played for 30s and everything looked ok, you're saying that problems arise in higher levels.... well, I can't test that... but I can send you my roms and you'll try....
toto2000 escribió:I have two nes roms for dungeon magic that work (Dungeon Magic - Sword of the Elements (USA) and Dungeon & Magic - Swords of Element (Japan))....pm me so that I can send them to you....
However : I just played for 30s and everything looked ok, you're saying that problems arise in higher levels.... well, I can't test that... but I can send you my roms and you'll try....

Thank you for the answere but i'm talking about an Arcade game: https://en.m.wikipedia.org/wiki/Dungeon_Magic
Caps here: https://www.arcade-history.com/?n=dunge ... ail&id=718
Ahora mismo no tengo la Raspberry conectada para comprobarlo. Pregunta:

Alguno está usando el modo run-ahead en Retroarch con la 3B o 3B+? y si es así, qué resultados le está dando con los cores de FBNeo y MAME2010? Se consiguen mejoras en el input lag o afecta demasiado al rendimiento?

-----------

I don't have my Raspberry assembled right now to check it, but I have a question:

Does anyone use run-ahead mode with Retroarch on the 3B or 3B+? If that's the case, wich results are you getting with the FBNeo and MAME2010 cores? Does it help with the input lag or does it get in the way of performance?
Que cable me recomendáis fabricarme para esta distro ?
virusxd escribió:Que cable me recomendáis fabricarme para esta distro ?


http://retrocables.es/tienda/index.php? ... &id_lang=4

[bye]
Buenas a todos,

Quería hacer una pregunta sobre esta versión de Retropie, solo funciona a 15Hz o también con monitores de 31 Hz? Tengo la Sega Naomi original.

Muchas gracias de antemano.
Hi,

I have sound problem with some games R-type arcade for example.

Running it with fbneo emulator.

I have update retropie (4.7.2) and main core package. Any idea to solve this ?

Many thnaks
@RuralGalaxy Hola, la distribución funciona a 15 KHz así que con el monitor de una Naomi no te funcionaría (a no ser que seas de los afortunados con un monitor trifrecuencia de los que incorporaban los últimos modelos). Probablemente haya algún truco para doblar la frecuencia de refresco o la resolución (vía software o hardware) y sacar imagen a 31 KHz, pero desconozco cómo se podría hacer.

---------------------------------------

@ryosanisback Hi, have you tried to run it using MAME? Depending on the game, using a different emulator can provide better results.
---------------------------------------

@ryosanisback Hi, have you tried to run it using MAME? Depending on the game, using a different emulator can provide better results.


yes try few emulators, I think it's not good to update the emulator core and the retropie system.

Any advises on this ?

I'm back to the original version and it's ok :)
Hi,

I have problems launching x68000 games.

I have 2 bios files in my BIOS folder :

iplrom.dat and cgrom.dat

I try to launch Mad Stalker for example, I have 2 files in my x68000 roms folder :

Mad Stalker Full Metal Worth (1994)(Family Soft)(Disk 1 of 2)(Disk A).dim
Mad Stalker Full Metal Worth (1994)(Family Soft)(Disk 2 of 2)(Disk B).dim

But the game not launched [mamaaaaa]

Any help would be so appreciated [beer]
ryosanisback escribió:Hi,

I have problems launching x68000 games.

I have 2 bios files in my BIOS folder :

iplrom.dat and cgrom.dat

I try to launch Mad Stalker for example, I have 2 files in my x68000 roms folder :

Mad Stalker Full Metal Worth (1994)(Family Soft)(Disk 1 of 2)(Disk A).dim
Mad Stalker Full Metal Worth (1994)(Family Soft)(Disk 2 of 2)(Disk B).dim

But the game not launched [mamaaaaa]

Any help would be so appreciated [beer]




On BIOS dir you must have a another dir named : keropi

inside "keropi" put your 2 bios x68000 files...

must work =)
Hola. Estoy usando la version 3.3 Muchas gracias por el trabajo es una pasada y mucho menos engorroso que hacerse un pc arcade. Estaba intentado meterle la rom de mame pero por el tema de las versiones de romset estoy muy perdido con eso. Que romset viene incluido en mame? No se si esa es la pregunta correcta jaja
DeathWalk escribió:
toto2000 escribió:I have two nes roms for dungeon magic that work (Dungeon Magic - Sword of the Elements (USA) and Dungeon & Magic - Swords of Element (Japan))....pm me so that I can send them to you....
However : I just played for 30s and everything looked ok, you're saying that problems arise in higher levels.... well, I can't test that... but I can send you my roms and you'll try....

Thank you for the answere but i'm talking about an Arcade game: https://en.m.wikipedia.org/wiki/Dungeon_Magic
Caps here: https://www.arcade-history.com/?n=dunge ... ail&id=718

Finally I fixed the problem, I started from scratch and using Advmame and overclocking to 1300 my B3 it's almost perfect, perfectly playable.
No estoy seguro si debo preguntarlo aquí o no. La cuestión es que busco una imagen de Raspberry Pi que detecte el mando pro por bluetooth de Nintendo Switch sin que se queden todas las luces led parpadeando, es decir, que se quede fija encendida. Sabéis alguna que haga eso? gracias.
Esto creo que suele ser un problema algo habitual, pero no he encontrado solución. El caso es que he probado sin tocar configs, varias roms de snes, nes, neo geo, y todo bien, pero al probar las de megadrive se queda la pantalla en negro. He probado a cambiar de emulador al pico y nada. Alguien sabe que puede ser?


EDIT: Solucionado. Es el romset, por lo visto funciona en RGB PI OS y en Retropie se queda la pantalla en negro, al cambiarlo si ha funcionado correctamente.
HELP DAPHNE INPUT problem with crt 3.3 !!!

does anyone have problems with the DAPHNE controls and its games (Dlair, Spacece etc ...) ??
any key ply1 / pl2 have the same PAUSE function ....!!!
only one (x) exits the game and returns to the menu ...
I tried to check the config.input of daphne well and look for a solution to the problem ... but the problem is not there, rather in the input driver that under the daphne no longer works correctly.
my JAmma / crt card has it as a chip mcp23017
it works great with all emulators ... except the daphne. but that's not all because it seems that this problem is in crt 3.3 while in 2.x it works even if in a strange way ... that is, it only works the second time you re-enter the game .... while the first has the usual problem " PAUSE".... but a second time you launch game, work....THIS NOT HAPPENS' on EVO 3.3....
I have verified that with the keyboard it works well ...
discovering that the joy direction also work .... they are the buttons that are not recognized or have a bug (under daphne or crt 3.3)
I have done all the checks and tests on the "joy" codes ... but it does not make any difference on any key, including select / coin.
@jimiz did you remap the controls in the crt cfg menu ? I think that a remaping menu is displayed the first time you run a daphne game... I have a jamma cabinet and we just installed crt evo 3.3 on it with a pi2jamma board. I'll check this on our setup and will let you know.
Hi
yes this was for default, but nothing work....
I try to disactivate , and change the configs/Daphne/dapinput.ini
the 3' number Js0 of buttons (direction works!!!)
but nothing change...also select and coin...all sind PAUSE...when pressed.
I try to read with the retropie command , ( jstest /dev/input/js0) the numbers alre showed of my pl1 buttons... and all work correctly...I try to insert on ini file this valours...but nothins change...

Buttons works only by keyboards (usb)!

My friend have the crt evo 2....so with old retropie installed...
I give my same daphne dir. what' happen?
the first laucher same problem o me.. exit, and again launched and work perfect !

so , something not work anymore on crtevo 3.3 for daphne input...for sure on jammapi (mcp23017 controller)!!!


dapinput.ini :

[KEYBOARD]
KEY_UP = 273 114 0
KEY_DOWN = 274 102 0
KEY_LEFT = 276 100 0
KEY_RIGHT = 275 103 0
KEY_BUTTON1 = 306 97 2
KEY_BUTTON2 = 308 115 1
KEY_BUTTON3 = 32 113 5
KEY_START1 = 49 0 12
KEY_START2 = 50 0 12
KEY_COIN1 = 53 0 11
KEY_COIN2 = 54 0 0
KEY_SKILL1 = 304 119 0
KEY_SKILL2 = 122 105 0
KEY_SKILL3 = 120 107 0
KEY_SERVICE = 57 0 0
KEY_TEST = 283 0 0
KEY_RESET = 284 0 0
KEY_SCREENSHOT = 293 0 0
KEY_QUIT = 27 113 4
END
Buenas a todos, ayer me pasó algo extraño: el core genesis plus gx dejó de funcionar. Desde hace un par de días la resolución vertical me aparece cambiada (224px en vez de 240px). La pongo bien, guardo ajustes pero no queda bien guardado, cuando cargo otro juego vuelve a poner 224px. De repente y sin venir a cuento dejó de funcionar, me saca al escritorio cuando cargo un juego. Algo debe haber quedado mal configurado, ¿alguna idea de qué ficheros mirar?

Gracias.

--------------------------------------------------------------------------------

Good everybody, yesterday something strange happened to me: the core genesis plus gx stopped working. Since a couple of days ago the vertical resolution has changed (224px instead of 240px). I set it right, I save the settings but it doesn't stay saved, when I load another game it goes back to 224px. Suddenly and unexpectedly it stopped working, it takes me to the desktop when I load a game. Something must have been misconfigured, any idea what files to look at?

Thanks.
Hello,
i use RGBPI cable with RGBPI OS with no problem. I tried this distro but i see some noises in the video signal , who's using this distro with this cable ? The signal is clean ?

thanks
@cybermat Hi, the video output for this distro is configured by default for VGA666/Pi2Scart, which use a different pinout than RGB-Pi (resulting in noise and incorrect colours).
During the first boot, a menu appears where you can select a different output type (you should select the 'RGB-Pi/piCRT' option) and also within the CRT config menu you also have this option.

Hope that helps. Regards!
I selected the right cable during first boot, i see the image but there are noises in background. Anyway is not a problem, because i needed to test scraping from gamedb and screenscraper for testing purposes.
No tengo ni idea de si este es el sitio correcto para preguntar.

Para un uso exclusivo de juegos retro, que tipo de raspberry me haría falta? Con la 3b+ es suficiente, no? O debería mirar algo más nuevo? Solo sería para meter emuladores y juegos retro.

Un saludo.
@-Karhonte- Hola buenas, depende de lo que estés buscando. Si tu intención es emular los juegos y verlos en una TV CRT lo mejor sería una Raspberry 3B o 3B+, ya que la 4 a día de hoy no está soportada, pero si lo que quieres es verlos en una pantalla LCD moderna lo mejor sería una Raspberry Pi 4 al ser la más potente.

Un saludo.
@Botvinnik Sería para verlo en una pantalla de monitor o televisión de hoy en día. He montado hace poco para mi algo parecido a una pandora box usando una raspberry 3b+ y un amigo me dijo si podría jugar a los mismos juegos y emuladores usando únicamente una raspberry. Yo imaginaba que si, lo que no sabía era recomendarle cual de todas ellas.

Imagino que con la raspberry 4 de 2 GB de ram (la más baja que hay creo) va más que sobrado, no?

A la que he montado yo me recomendaron poner un disipador, en esta de 4 sería igual? Mismo disipador o se calienta más?
@-Karhonte- En ese caso yo creo que la mejor opción sería la Rpi4 como te decía, al ser la más potente a día de hoy y además ya tiene soporte para todas las distros destinadas a emulación (Recalbox, Retropie, Batocera, Lakka, etc.).

Como bien dices, con el modelo de 2GB de RAM te llega de sobra para cualquier emulador, y además te funcionaría mejor que una Pandora, que de potencia suelen andar justitas. Para que te hagas una idea, con una Rpi 4 puedes llegar a emular Dreamcast y bastantes juegos de N64 (logicamente, de ahí para abajo todo iría bien también).
En cuanto al tema de la disipación, la Rpi 4 se calienta un poco más que la 3, así que siempre es buena idea meterle un disipador o incluso un ventilador pequeño. No es que se vaya a echar a arder, pero por escasamente 1€ no está de más.
@Botvinnik perfecto! Muchas gracias. Donde soles comprar vosotros las raspberry? Hay algún sitio oficial que tenga un precio fijo o valen en cualquier lado? En mi caso, seguí las indicaciones de un señor de YouTube para montar todo y seguí los links de compra que puso. En Amazon se pueden comprar? Hay tienda oficial? O tiro por Aliexpress y tiendas variadas?
@-Karhonte- Yo las últimas las he comprado en tiendatec.es o en kubii.es que son los distribuidores oficiales en España (Kubii está en Francia pero envían a España sin problema), pero también se pueden encontrar en Aliexpress o Amazon así que puedes mirar donde más te convenga en función de los precios.
jimiz escribió:Hi
yes this was for default, but nothing work....
I try to disactivate , and change the configs/Daphne/dapinput.ini
the 3' number Js0 of buttons (direction works!!!)
but nothing change...also select and coin...all sind PAUSE...when pressed.
I try to read with the retropie command , ( jstest /dev/input/js0) the numbers alre showed of my pl1 buttons... and all work correctly...I try to insert on ini file this valours...but nothins change...

Buttons works only by keyboards (usb)!

My friend have the crt evo 2....so with old retropie installed...
I give my same daphne dir. what' happen?
the first laucher same problem o me.. exit, and again launched and work perfect !

so , something not work anymore on crtevo 3.3 for daphne input...for sure on jammapi (mcp23017 controller)!!!


dapinput.ini :

[KEYBOARD]
KEY_UP = 273 114 0
KEY_DOWN = 274 102 0
KEY_LEFT = 276 100 0
KEY_RIGHT = 275 103 0
KEY_BUTTON1 = 306 97 2
KEY_BUTTON2 = 308 115 1
KEY_BUTTON3 = 32 113 5
KEY_START1 = 49 0 12
KEY_START2 = 50 0 12
KEY_COIN1 = 53 0 11
KEY_COIN2 = 54 0 0
KEY_SKILL1 = 304 119 0
KEY_SKILL2 = 122 105 0
KEY_SKILL3 = 120 107 0
KEY_SERVICE = 57 0 0
KEY_TEST = 283 0 0
KEY_RESET = 284 0 0
KEY_SCREENSHOT = 293 0 0
KEY_QUIT = 27 113 4
END


any News about? to me also no way , for jamma keys working on Daphne , only usb pad/keyboard.
@claudiazan
yes , resolved.
CRTEVO have a bug (not only one...) on mk-arcade controller (driver).
I Install a new one perfect for my jamma card. and more fast also (0 delay)...
now work perfect also with Daphne, ofcourse you must reconfig. ply1 and 2 keys with emulationstation menu.
unfortunately a lot could still be corrected and added to this crt evo, but as you can see from the site it seems dead (and for months ...) and zero concrete support, so everyone goes for themselves ...
1433 respuestas
125, 26, 27, 28, 29