Retropie CRT Edition - Raspberry pi 2B/3B/3B+ - TV 15Khz (vga666 / pi2scart / rgb-pi)

huronisx escribió:@jcortes
¿Has logrado jugar con netplay?
Yo tengo el mismo problema. El host aparece n la lista de host de retroarch cuando lo buscas, pero el cliente no se conecta. El juego del host aparece sin sonido.
No sé si es un tema de esta distribución o es general de retropie, si es así pido disculpas por ensuciar el hilo.


Hola.
Gracias a @jcortes hemos encontrado el problema. [beer]
Se estan haciendo varias pruebas y la idea es sacar pronto una nueva versión que corrija esto y otras pequeñas modificaciones que han surgido.
hope next release to see add few emu crt new supported...like vic20 , psp....
Hi everyone,

First of all, a big thank you to all those who have worked hard and contributed to an amazing project. I hope it will always continue to be supported.

Now, to my question..
I am happy with the functionality of the default theme (Uniflyered Color I believe), but I would like to change a few colours, images etc.
If I want to do this, is it a simple case of replacing the images found in the Menu Art folder with my own? Of course, making sure they are the same resolution, contain the same windows etc.
Or is it more complex than this? Must I completely redesign my own theme from the beginning?

Thank you all once again for your great work and assistance!
Con la nueva salida de RetroPie 4.7 - Sera que tendremos nuestro RetroPie CRT Edition para Raspberry Pi 4 [360º]
Hola a todos y disculpad si esto ha sido respondido porque he hecho una búsqueda y no he encontrado nada. Acabo de comprar un cable RGB-Pi (RPi 3 B) y he montado el SO en la SD, hasta ahí todo correcto. Me fastidia perder toda la config del Retropie que usaba por HDMi, pero estoy montando un cabinet con una TV de tubo para darle ese tufillo retro.
Mis problemas son los siguientes, a ver si me podéis echar un cable:

1.- El tema es que no consigo configurar los controles en MAME, no me guarda la config de EMULATIONSTATION en muchas ROMS y dentro del juego no hay forma de abrir menú para configurarlo

2.- Al salir de muchas de las ROMS, la pantalla se queda en negro y no vuelve a EMULATIONSTATION con lo que tengo que reiniciar la RasPi

3.-Hay un Theme que me encantaba anteriormente que es el ComicBook, ahora no aparece en la galería y no sé si es por un tema de incompatibilidad. Si es así ¿Hay alguna manera de hacerlo compatible?

Muchas gracias y siento el chorreo!!
@Scheidgen Si tienes un cable RGB-PI nada mejor que su propio sistema operativo, entra en su discord y te ayudarán.
Joe Musashi escribió:@Scheidgen Si tienes un cable RGB-PI nada mejor que su propio sistema operativo, entra en su discord y te ayudarán.


Tengo un cable RGB-Pi, pero soy fiel a Retropie, su propio OS funciona estupendamente pero no me gusta el interfaz y tampoco le tengo mucho aprecio al modo Kiosk que tiene. El mueble lo he colocado en un lugar semi/público (en la oficina) y no quiero que nadie le meta mano a nada de la config.
@Scheidgen Tú mismo, pero estás muy equivocado, el modo kiosco va de lujo
Joe Musashi escribió:@Scheidgen Tú mismo, pero estás muy equivocado, el modo kiosco va de lujo


No digo que vaya mal, digo que no me gusta o para ser más correctos, me gusta menos que en RetroPie. Por otro lado, estoy en el hilo del RetroPie, con lo que tiene sentido que pregunte por él más que por el RGB-Pi OS
Scheidgen escribió:Hola a todos y disculpad si esto ha sido respondido porque he hecho una búsqueda y no he encontrado nada. Acabo de comprar un cable RGB-Pi (RPi 3 B) y he montado el SO en la SD, hasta ahí todo correcto. Me fastidia perder toda la config del Retropie que usaba por HDMi, pero estoy montando un cabinet con una TV de tubo para darle ese tufillo retro.
Mis problemas son los siguientes, a ver si me podéis echar un cable:

1.- El tema es que no consigo configurar los controles en MAME, no me guarda la config de EMULATIONSTATION en muchas ROMS y dentro del juego no hay forma de abrir menú para configurarlo

2.- Al salir de muchas de las ROMS, la pantalla se queda en negro y no vuelve a EMULATIONSTATION con lo que tengo que reiniciar la RasPi

3.-Hay un Theme que me encantaba anteriormente que es el ComicBook, ahora no aparece en la galería y no sé si es por un tema de incompatibilidad. Si es así ¿Hay alguna manera de hacerlo compatible?

Muchas gracias y siento el chorreo!!


Hola.
Esta versión de Retropie está pensada para CRTs, y deberás acomodarte ella en ese sentido configurándola como necesites, al menos la primera vez, luego puedes hacerte una imagen de la SD. Por lo demás es basicamente lo mismo que Retropie normal con la salvedad de que se limitan ciertos emuladores y modificaciones, aquellos que no se pueden reproducir a 15khz.

Para los controles, tan pronto como los configures bajo emulationstation (el frontend) todos los emuladores quedarán listos para usar a excepción de advance mame, el cual deberás configurar manualmente con la ayuda de un teclado cuando lo lances la primera vez.
A parte es posible hacer un remap de los controles por juego o sistema que basandose en la configuración de controles inicial cambia los botones como quieras. Esto está documentado en retropie y aquí funciona igual.

Que interface de controles usas en tu recreativa? Es un ipac, un interface joystick tipo zero delay, un adaptador jamma, rgb-pi jamma...?

En cuanto a los temas, al menos esta distribución nunca ha tenido el ComicBook como parte del listado. Ajustar un tema de ES a 4:3 y 320x240 tiene trabajo, y no es uno que se haya incorporado nunca. Los temas que puedas encontrar disponibles para retropie normal pueden ser instalados como uno más en CRT edition, pero no vas a tener un resultado de tu agrado, ya te lo adelanto. :) Es posible que anterioremente hayas usado otra distribución distinta para CRT que esta, la que puedes encontrar al principio del hilo.

En cuanto a la pantalla en negro al salir de las roms no es algo que me haya ocurrido (tampoco niego que te pase).
Asegurate que cuando grabas la imagen balena etcher termina correctametne la comprobación y muestra una bolita en color verde. Podría ser que tus problemas vengan por problemas de acceso a la SD... No sabría decírtelo.

Que versión estas usando?
-krahs- escribió:En cuanto a la pantalla en negro al salir de las roms no es algo que me haya ocurrido (tampoco niego que te pase).
Asegurate que cuando grabas la imagen balena etcher termina correctametne la comprobación y muestra una bolita en color verde. Podría ser que tus problemas vengan por problemas de acceso a la SD... No sabría decírtelo.

Que versión estas usando?


No quoteo el resto porque todas las contestaciones son satisfactorias XD. Antes usaba una distro estándar de Retropie en un monitor por HDMI, así que en general estoy bastante familiarizado con interfaz y configuraciones.

En cuanto al párrafo del quote, estoy usando la EVOv3, quemada con Balena y todo correcto. El OS funciona tras pasar las primeras pantallas de configuración y su reinicio, el problema empieza cuando cargo ROMs, todo lo hago por red directamente a la SD así que no parece que la SD tenga ningún otro problema. Acabo de descubrir que lo que pasa es que la pantalla en negro es porque al salir de esas ROMs no vuele a EMULATIONSTATION y tampoco se ve en el monitor (TV CRT) la consola de Linux aunque está ahí. Lo sé porque aún sin ver nada me dí cuenta de que la Raspi no estaba colgada porque podía acceder por Putty y probé a escribir a ciegas: "emulationstation + intro" y efectivamente lo cargó de nuevo.


@-krahs- Aprovecho con otra duda ya que no lo he testeado. Con Retropie CRT ¿Sigue siendo funcional conectar la Pi por HDMI?

Gracias!
Scheidgen escribió:
-krahs- escribió:En cuanto a la pantalla en negro al salir de las roms no es algo que me haya ocurrido (tampoco niego que te pase).
Asegurate que cuando grabas la imagen balena etcher termina correctametne la comprobación y muestra una bolita en color verde. Podría ser que tus problemas vengan por problemas de acceso a la SD... No sabría decírtelo.

Que versión estas usando?


No quoteo el resto porque todas las contestaciones son satisfactorias XD. Antes usaba una distro estándar de Retropie en un monitor por HDMI, así que en general estoy bastante familiarizado con interfaz y configuraciones.

En cuanto al párrafo del quote, estoy usando la EVOv3, quemada con Balena y todo correcto. El OS funciona tras pasar las primeras pantallas de configuración y su reinicio, el problema empieza cuando cargo ROMs, todo lo hago por red directamente a la SD así que no parece que la SD tenga ningún otro problema. Acabo de descubrir que lo que pasa es que la pantalla en negro es porque al salir de esas ROMs no vuele a EMULATIONSTATION y tampoco se ve en el monitor (TV CRT) la consola de Linux aunque está ahí. Lo sé porque aún sin ver nada me dí cuenta de que la Raspi no estaba colgada porque podía acceder por Putty y probé a escribir a ciegas: "emulationstation + intro" y efectivamente lo cargó de nuevo.


@-krahs- Aprovecho con otra duda ya que no lo he testeado. Con Retropie CRT ¿Sigue siendo funcional conectar la Pi por HDMI?

Gracias!


No, solo podrás usar la salida de video del GPIO (en tu caso RGB-Pi si no me confundo).
Que juegos son los que te falla al salir? Puedo intentar reproducir el problema...

Otra pregunta, estas aplicando overclock?
-krahs- escribió:
No, solo podrás usar la salida de video del GPIO (en tu caso RGB-Pi si no me confundo).
Que juegos son los que te falla al salir? Puedo intentar reproducir el problema...

Otra pregunta, estas aplicando overclock?


Todos, pero en ARCADE. He eliminado todas las ROMS que vienen por defecto ya que no voy a utilizar prácticamente ningún otro sistema (quizás solo Daphne y C64). En cuanto al overclock, de momento nada. Primero quiero estabilidad y todo lo que he puesto es 2D, iba a probar el Tekken y creo que igual ahí si que necesitaría un poquito de OC, aunque no lo sé.
Hola de nuevo,

Escribí el siguiente post hace una semana, pero en inglés. Lo siento.
Ahora lo intentaré de nuevo en mi mal español. [360º] Espero que sea más comprensible para algunos de ustedes.

Hola a todos,

En primer lugar, un gran agradecimiento a todos los que han trabajado duro y contribuido a un proyecto increíble. Espero que siempre siga siendo apoyado.

Ahora, a mi pregunta...
Estoy contento con la funcionalidad del tema por defecto (Uniflyered Color, creo), pero me gustaría cambiar algunos colores, imágenes, etc.
Si quiero hacer esto, ¿es un simple caso de reemplazar las imágenes que se encuentran en la carpeta de Menu Art por las mías? Por supuesto, asegurándose de que tienen la misma resolución, y asegurándose de que contienen las mismas ventanas en las posiciones correctas, etc.
¿O es más complejo que esto? ¿Debo aprender a rediseñar completamente mi propio tema desde el principio?

Gracias a todos una vez más por su gran trabajo y asistencia!
DJMoss escribió:Hola de nuevo,

Escribí el siguiente post hace una semana, pero en inglés. Lo siento.
Ahora lo intentaré de nuevo en mi mal español. [360º] Espero que sea más comprensible para algunos de ustedes.

Hola a todos,

En primer lugar, un gran agradecimiento a todos los que han trabajado duro y contribuido a un proyecto increíble. Espero que siempre siga siendo apoyado.

Ahora, a mi pregunta...
Estoy contento con la funcionalidad del tema por defecto (Uniflyered Color, creo), pero me gustaría cambiar algunos colores, imágenes, etc.
Si quiero hacer esto, ¿es un simple caso de reemplazar las imágenes que se encuentran en la carpeta de Menu Art por las mías? Por supuesto, asegurándose de que tienen la misma resolución, y asegurándose de que contienen las mismas ventanas en las posiciones correctas, etc.
¿O es más complejo que esto? ¿Debo aprender a rediseñar completamente mi propio tema desde el principio?

Gracias a todos una vez más por su gran trabajo y asistencia!


Hola.
Los temas son y se realizan del mismo modo que en retropie normal, por lo que puedes reemplazar las imagenes o modificar el tema según la documentación disponible en retropie.
Otra cosa es que te cueste más o menos conseguir el resultado que buscas.
-krahs- escribió:
DJMoss escribió:Hola de nuevo,

Escribí el siguiente post hace una semana, pero en inglés. Lo siento.
Ahora lo intentaré de nuevo en mi mal español. [360º] Espero que sea más comprensible para algunos de ustedes.

Hola a todos,

En primer lugar, un gran agradecimiento a todos los que han trabajado duro y contribuido a un proyecto increíble. Espero que siempre siga siendo apoyado.

Ahora, a mi pregunta...
Estoy contento con la funcionalidad del tema por defecto (Uniflyered Color, creo), pero me gustaría cambiar algunos colores, imágenes, etc.
Si quiero hacer esto, ¿es un simple caso de reemplazar las imágenes que se encuentran en la carpeta de Menu Art por las mías? Por supuesto, asegurándose de que tienen la misma resolución, y asegurándose de que contienen las mismas ventanas en las posiciones correctas, etc.
¿O es más complejo que esto? ¿Debo aprender a rediseñar completamente mi propio tema desde el principio?

Gracias a todos una vez más por su gran trabajo y asistencia!


Hola.
Los temas son y se realizan del mismo modo que en retropie normal, por lo que puedes reemplazar las imagenes o modificar el tema según la documentación disponible en retropie.
Otra cosa es que te cueste más o menos conseguir el resultado que buscas.


Muchas gracias por su ayuda :)
Buenas,
hay alguna forma de mapear la tecla F2 en mame2003+ para que no tenga que usar un teclado para entrar en service mode del arcade de turno? He estado mirando y parece casi imposible mapear al mando esa tecla, no?
-krahs- escribió:
huronisx escribió:@jcortes
¿Has logrado jugar con netplay?
Yo tengo el mismo problema. El host aparece n la lista de host de retroarch cuando lo buscas, pero el cliente no se conecta. El juego del host aparece sin sonido.
No sé si es un tema de esta distribución o es general de retropie, si es así pido disculpas por ensuciar el hilo.


Hola.
Gracias a @jcortes hemos encontrado el problema. [beer]
Se estan haciendo varias pruebas y la idea es sacar pronto una nueva versión que corrija esto y otras pequeñas modificaciones que han surgido.


Si no es mucho pedir, repasad el emu de C64 (vice), que por algún motivo el botón de del joystick no se mapea (curiosamente los botones de dirección sí).
Gracias!!
Hola a todos ! Muy buen trabajo ! Tengo un problema con una JVC que me han dado sin mando , he mirado en el manual y ese modelo tiene RGB , pero no consigo que entre la imagen sale en negro pero se escucha , utilizo el DPI VGA 666 y un cable VGA scart de retrocables que ya trae un step Up conectado al pin 16 para activar el modo rgb , aparte le he puesto otro para alimentar 12 v al pin 8 para que salte automáticamente al canal Av , siempre me a funcionado pero en esta TV no , ni conectando un supergun jamma hace lo mismo , voy a intentar conseguir el mando por qué tienes que pulsar 3 veces el Av. Para ponerlo en modo rgb e igual tiene que ser voltaje específico para activarlo , mi pregunta es si a alguien le ha pasado algo parecido ,gracias
Hi, I've just updated from EVO 2.0 to EVO 3.3, I use an external HDD for roms, when I updated to EVO 3.3 out of 29 of my systems only 15 show in EVO 3.3 when all 29 worked with EVO2.0, is there any major changes to the rom folder structure between versions?
Hoy he instalado la 3.3 y he probado desde disco duro externo varios sistemas. a ver si alguien me puede indicar.
Todos me han funcionado menos MSX que se volvía al menu, y en arcade el X-arcade no respondia a las pulsaciones.

Una de las cosas que hice que no se si esta bien hecha es meter en BIOS todo el paquete de bios 1 gb que hay aparte en el canal, y entre ellas estan las BIOS parece de MSX por lo que no se que me pasa, justo es de los sistemas que mas me interesan a ver si alguiien sabe.
hi!

is there a way to add good old 270p resolution into the new v3.3 image? don't know why but my pvm struggles with 240p front-end resolution despite having zero issues with 240p resolution in games. changing config.txt is easy but there must be a script to tell the system to go back to the designated 240p resolution after retroarch closed. i don't know maybe this image uses a python file instead of a text-based script command. any idea? how can i add 270p?

i also wonder how can i use a usb soundcard instead of integrated audio. back then all i need to do was creating a file named alsa-base.conf and changing the priorities of sound devices with that but that also doesn't work with new v3.3 os.
Un saludo a todos. Llevo tiempo disfrutando de una arcade, en la que tengo puesta una raspberry con esta edición de Retropie y tengo un par de preguntas que quizás sean de novato. Una es para el tema de actualizar la versión del EVO, ¿cuáles son las formas de hacerlo?. Y la segunda cuestión es que tengo el theme de Supersweet puesto, y el previo lo tengo en modo vídeo. Cada vez que paso de un juego a otro, primero me muestra imagen fija, y luego el vídeo. Si no tiene imagen fija, se muestra unos segundos en negro, y luego el vídeo. ¿Hay alguna forma de que solo muestre vídeos, sin que cargue primero la imagen del juego fija, para que sea más rápido? Gracias de antemano.
Hola!
Me encanta esta distribucion,
Igualmente vengo de fpgas y maquinas reales y no me convence la suavidad en el scroll x ejemplo en neogeo.
Hy alguna forma de exprimir la pi3 para q se vea lo mas suave posible?

Se recomienda actualizar por wifi retroarch y los emuladores?

Hay algun grupon de telegra para esta distro?

Como hago para poder separar y tener los juegos Tate de un romset?

Gracias!
hola
Even if you set the volumes to the minimum .... of system music (background), then with games at low volume ...
when on the waiting menu, the screensaver (random video) with audio starts ... the volume is very loud .... and there is no way to lower it! BUG or can I manually intervene on some system file to set it (video player) ???
HI @- krahs - (or anyone else who knows and can help :-? )

I have an image that I can't start since it's set to the wrong RGB cable, is there a way to change a parameter in the files in the boot partition so that you can choose RGB Cable just like on initial startup or set it to the correct cable?

I am running it with the piCRT connector, and it's an old image v1.X so it needs to be set to RGB-PI, currently it set too one of the JAMMA options..

Cheers!
claudiazan escribió:* CRT EVO DEVS.... meaby good news for PI4 CRT Users ??

http://mydedibox.fr/rpi4-custom-modes-o ... euhlub84Qg



Hay una version de recallbox para probar el crt en la pi4 [amor]
krux77 escribió:HI @- krahs - (or anyone else who knows and can help :-? )

I have an image that I can't start since it's set to the wrong RGB cable, is there a way to change a parameter in the files in the boot partition so that you can choose RGB Cable just like on initial startup or set it to the correct cable?

I am running it with the piCRT connector, and it's an old image v1.X so it needs to be set to RGB-PI, currently it set too one of the JAMMA options..

Cheers!



In config.txt for crtpi 1.1 final if this is the one you have. Copy and replace everything.

hdmi_timings=320 1 10 30 40 240 1 6 5 12 0 0 0 60 0 6400000 1

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# force all optional hardware interfaces off
dtparam=i2c_arm=off
dtparam=i2s=off
dtparam=spi=off
enable_uart=0

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Memory configuration
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
#Set disable_audio_dither to 1 and uncomment line if you experience issues with white noise on the audio jack.
#disable_audio_dither=1
#Set audio_pwm_mode to 0/2/3/; 2 enables the sigma-delta oversampled PWM with ~16-bit resolution
audio_pwm_mode=3

# 15Khz using GPIO
overscan_scale=1
framebuffer_depth=32
enable_dpi_lcd=1
display_default_lcd=1
dpi_group=2
dpi_mode=87

# RGB-Pi
#dtoverlay=pwm-2chan,pin=18,func=2,pin2=19,func2=2
#dpi_output_format=6

# JAMMA RGB-PI
#dtparam=i2c_vc=on
#dtoverlay=i2c-gpio,i2c_gpio_sda=10,i2c_gpio_scl=11

#Set dtoverlay to vga666 or rgb-pi; vga666 for generic adapters and pi2scart
dtoverlay=vga666

# CRT Video Recovery MODES; 0=disabled; 1=enabled
crt_recovery_enabled=0
# MODE to apply: DEFAULT/MODE1/MODE2/MODE3 (modes.cfg)
crt_recovery_mode=DEFAULT

# CRT DAEMON; 0=disabled; 1=enabled
crt_daemon_enabled=1
# Set if you have a jamma cable; 0=none; 1=pi2jamma; 2=jamma-rgb-pi
jamma_cable=0
Buenas, acabo de instalar la img y de conectar la pi al la recre, da alguna interferencia, pero he hecho el cable algo rápido, solo con las masas de los colores, va mediante vga666 al RGB de la recreativa, RGB+G+Sincronismos Unidos, los controles por interfaz usb doble Xin Mo, el fix que trae estupendo, todo cableado a través de un extensor de jamma, para no tocar el cableado original.

Pero buena, esa no es la cuestión, me ha gustado mucho ver retropie en la recreativa, antes tenía un pc, pero murió el disco duro y la daba problemas además la fuente, y el cambio a esta opción me parece muy agradable la verdad, con menos cosas que configurar pero a la vez, todo muy bien preparado.

Dar las gracias por este trabajazo y sobre todo, el detalle de los jueguillos que trae la img, muy de la scene.

Me recomendais alimentar la Raspberry vía los 5 vol de la fuente de la recreativa, que tiene mas amperios y así no tendré problemas de voltaje, o por su "cargador", que es de 5 vol y 3 amperios, pero chinorris, venía con el pack de la raspberry.

ME falta ponerle un ampli de sonido al invento, que ya tengo pedido...

Bueno, lo dicho, gracias por el trabajazo que se está haciendo, un placer quitar el pandora y poder manipular otra vez roms etc como con el PC.


Un saludo
Hola chicos, me disculpo por el idioma pero no soy español. He estado usando Retropie CRT Edition, desde el principio con gran entusiasmo. Ayer actualicé a la versión 3.3, y con pesar noto que se ha eliminado la función para rotar juegos en modo tate. Rotar la parte delantera cada vez es demasiado laborioso, ¿hay alguna manera de resolver el problema? No me gustaría volver a la versión 1.1. Gracias por las respuestas.

https://i.ibb.co/0VJnQKm/gamerotation.png

https://i.ibb.co/Khq7PWk/1.jpg

https://i.ibb.co/SnCbZXg/2.jpg
1280 respuestas
122, 23, 24, 25, 26