[HO] Red Dead Redemption 2 - Problemas, Rendimiento, Config y Dudas Técnicas

Hola gente. Para los que esteis teniendo problemas con el launcher y los crasheos os cuento como lo he solucionado.

En cuanto al launcher, he tenido que descargar los drivers mas actuales de tarjeta gráfica. Es muy sencillo de hacer, eso si fijaros en las especificaciones de vuestra tarjeta grafica para aseguraros que os descargais el driver correcto.

Una vez instalado el driver pude acceder al juego pero entonces empece a tener problemas de crasheos. Estos cuelgues me devolvian al escritorio y siempre se producian durante el video introductorio, justamente despues de la primera pantalla de carga. Este problema lo he solucionado desactivando el antivirus. En mi caso el Avast.

Espero que mi experiencia sirva de ayuda a aquellos que esteis teniendo los mismos problemas que tuve yo. Por cierto el juego me va de fabula con una gtx 1070.

Saludos!
kai_dranzer20 está baneado por "Game Over"
lleva Denuvo ?
a mi al final tambien me ha funcionado desactivando todo lo del antivirus, en mi caso el bitdefender
acaban de actualizar el launcher a ver q se han jicao ahora....
kai_dranzer20 escribió:lleva Denuvo ?


No. Lleva una protección que suele usar Rockstar (Arxan o algo así se llama, me suena) + el DRM de la tienda en sí
Yo tengo el antivirus del windows... he desactivado firewall, la proteccion y nada, se actualizo el launcher y nada tampoco... No lo entiendo -.-
Por mi parte no he tenido problemas con el launcher pero el rendimiento no es para tirar cohetes. Vale que no tengo un equipo top (i7-4770K, 16GB de RAM y GTX1070 para monitor 1440p), pero en todos los juegos de los últimos años he sido capaz de hacerlos correr a más de 60 fps estables tocando cosas (hasta el Monster Hunter World que es otro prodigio de la optimización). Sin embargo aquí hay partes entre 40 y 50fps (estoy en la nieve todavía). Lo poco que he jugado pinta chulo, pero esta sensación de dejadez en optimización toca la gaita.

Saludos.
Yo si he podido entrar al juego añadiendolo a excepciones en el avast. Ahora estoy configurando, y con un equipo bajito (I5 6400 y 1050 ti) tengo 30 fps estables con una configuración media y alguna cosita en alta. Entre algunas cosas que toque y mejoras de rendimiento en futuras actualizaciones, espero jugar entre 45 y 50 fps y me daría con un canto en los dientes la verdad.

Después del susto inicial parece que esto va arrancando, probad lo del antivirus quien no lo haya hecho.

Por cierto, recomendáis vulkan antes que direct x?
Alfe escribió:Yo tengo el antivirus del windows... he desactivado firewall, la proteccion y nada, se actualizo el launcher y nada tampoco... No lo entiendo -.-


Estoy igual y ni se dignan a sacar algo rápido para al menos solucionar el problema del launcher, ya ni hablo del rendimiento...lamentable [facepalm]
han actualizdo el launcher y ahora me va como el culo.

resulta que si mantengo MAYUS pulsado para correr me va a tirones y antes no...

No obstante, con una GTX960, que se supone que esta por encima de los recomendados... me da 30fps no constantes con TODO en calidad BAJA :(

jugable pero con unos graficos de play 2 [buuuaaaa] [mamaaaaa]
Añadimos otro problema al asunto :
Los que jugais con mando, tenéis el puntero del mouse en medio de la pantalla? Es bastante incómodo

@Metalyard aún no has podido entrar? Intenta borrar la carpeta de mis documentos del Red dead.

Salu2
Habiendo seguido los dos hilos desde la hora de lanzamiento, da la impresión de que es un Mafia 3 en cuanto a lanzamiento y optimización: "desbloqueamos los fps y a correr; que se busquen la vida" [facepalm] Qué poca vergüenza.
@bromutu mmmmm, raro....
Vale que el rendimiento y optimización son pésimos, pero yo tengo una procesador de recomendados, y una GTX 980m (entre la tuya y una 970), y lo estoy jugando con TODO en medio (incluyendo "gráficos avanzados") a 38/40fps y alguna bajada a 35 (aunque lo juego limitado a 30fps).

Lo estás ejecutando con Vulkan? Has probado a quitar el Vsync?
Dume escribió:
Imagen

Imagen

Imagen


Según esta tabla mi 2060 super rendiría más que una 1080ti en este juego?
P3KaX escribió:Habiendo seguido los dos hilos desde la hora de lanzamiento, da la impresión de que es un Mafia 3 en cuanto a lanzamiento y optimización: "desbloqueamos los fps y a correr; que se busquen la vida" [facepalm] Qué poca vergüenza.

A mí me recuerda al Batman Arkham Knight. Tuvieron que retirarlo y todo a los pocos días de su lanzamiento por su optimización
Yo el problema que tengo que es ni se me descarga el juego XD Se queda pillado en 700 o 800 megas y de ahí no pasa. ¿Alguien más tiene este problema?
delirious escribió:
P3KaX escribió:Habiendo seguido los dos hilos desde la hora de lanzamiento, da la impresión de que es un Mafia 3 en cuanto a lanzamiento y optimización: "desbloqueamos los fps y a correr; que se busquen la vida" [facepalm] Qué poca vergüenza.

A mí me recuerda al Batman Arkham Knight. Tuvieron que retirarlo y todo a los pocos días de su lanzamiento por su optimización


Uuuhmmm no creo que sea para tanto [carcajad] Además, lo del Batman (tremendo juegazo, por cierto. Lo jugué cuando lo "arreglaron"), fue porque le encargaron la versión de PC a un estudio que solo tenía experiencia en juegos 2D. Fue un error de decisión... el caso del RDR2 es vagancia pura y dura, tiene pinta.

Aún así, como hoy en día cogen al consumidor como un betatester y teniendo en cuenta que es día de lanzamiento, vamos a darles un margen de tiempo a ver si arreglan este desastre.

[beer]
Metalyard escribió:
Alfe escribió:Yo tengo el antivirus del windows... he desactivado firewall, la proteccion y nada, se actualizo el launcher y nada tampoco... No lo entiendo -.-


Estoy igual y ni se dignan a sacar algo rápido para al menos solucionar el problema del launcher, ya ni hablo del rendimiento...lamentable [facepalm]


Pues si tio, ya podrian hacer algo... compro un juego y no puedo jugar, vaya asco.. un cabreoo... Y a ver si mañana lo arreglan, que igual no
Aquí uno con una Rtx 2080Ti.

Mi problema es que si activo el HDR en el juego los gráficos se ven muy oscuros (digamos que los grises se los pasa por el forro). Toqueteando las opciones de "Calibrar HDR” dentro del propio juego no soluciona el problema. Si lo desactivo se ve bien. Con otros juegos no pasa.

¿Está roto el HDR en la versión de PC también?

Por cierto, lo tengo a 3860 x 2160 y en el panel de control de Nvidia uso el perfil YUV422 de 10 bits.
Yo con una 1070m el juego me va perfecto, el prologo entre 40-50 fps con casi todo en alto, y super fluido mucho mejor que en consola
el agua esta rotisima,probar a poner el nivel del detalle del agua en bajo,vaya cambio de fps.

saludos :)
krullbantha escribió:el agua esta rotisima,probar a poner el nivel del detalle del agua en bajo,vaya cambio de fps.

saludos :)

Me lo imaginaba.
[beer]



Asi es el dejar todo lo que sea referido al AGUA en bajo, con la pc de mi firma, tengo 60 fps estables en Valentine.


[beer] [amor]


JUEGAZO.
eso venia a decir yo , los que tengais una 1080 ti con solo bajar un punto la barra de la fisica del agua se mantiene a 60fps estables con practicamente todo en ultra menos sombras en alto , reflejos en alto , resolución volumetrica de cerca y lejos en alto , alta resolución de la oclusión ambiental desactivada y la barra de distancia de dibujado bajar dos puntos , eso si a 1080P.. pero una gozada jugar así , se ve de escandalo y la iluminación uff alucinante

juegazo de 10

y a currar sin dormir jajjaj
javsp escribió:Aquí uno con una Rtx 2080Ti.

Mi problema es que si activo el HDR en el juego los gráficos se ven muy oscuros (digamos que los grises se los pasa por el forro). Toqueteando las opciones de "Calibrar HDR” dentro del propio juego no soluciona el problema. Si lo desactivo se ve bien. Con otros juegos no pasa.

¿Está roto el HDR en la versión de PC también?

Por cierto, lo tengo a 3860 x 2160 y en el panel de control de Nvidia uso el perfil YUV422 de 10 bits.


Tengo puesto el hdr en juego (veras que hay dos, el cinematografico y el juego) y se ve de lujo.
Otro mas por aquí al que le crashea el launcher.

MSI GTX 1660 Gaming X 6GB
16GB RAM
AMD Ryzen 5 2600 3.9GHz
Drivers actualizados hace unas horas.
Avast desactivado.

El PC tiene tres semanas, ni de coña voy a actualizar la BIOS por los inútiles de R*.
Titán_Salvaje_ escribió:eso venia a decir yo , los que tengais una 1080 ti con solo bajar un punto la barra de la fisica del agua se mantiene a 60fps estables con practicamente todo en ultra menos sombras en alto , reflejos en alto , resolución volumetrica de cerca y lejos en alto , alta resolución de la oclusión ambiental desactivada y la barra de distancia de dibujado bajar dos puntos , eso si a 1080P.. pero una gozada jugar así , se ve de escandalo y la iluminación uff alucinante

juegazo de 10

y a currar sin dormir jajjaj

La opción esa de agua al tope se come 30fps.. ya te dije que iba a ser muchísimo más exigente que el GTA V xD
Hola, a mi también me crashea el launcher, es que no he podido ver ni la primera pantalla del juego.
A ver si lo arreglan pronto, por que sino ya solo me queda formatear y no me apetece mucho.
Saludos.
Creo que lo suyo es ir poniendo obviedades para que el hilo no sea ciclico. Hasta ahora parece que las dos cosas que se repiten constantemente son:
- Mejor Vulcan que dx12
- Bajar parámetros del agua para ganar fps a cascoporro
- Alguna otra opcion fps killer?

Ayer me fui con muy mal sabor de boca, pero hoy espero perder tiempo en toquitear y dejarlo guay a 60 fps que es mi objetivo..
Branmark escribió:Hola, a mi también me crashea el launcher, es que no he podido ver ni la primera pantalla del juego.
A ver si lo arreglan pronto, por que sino ya solo me queda formatear y no me apetece mucho.
Saludos.


Ni formatees ni actualices la BIOS. No es culpa de tu PC y seguramente formateando lo único que hagas es perder el tiempo esperando a que vuelva a descargar para que te siga crasheando. Yo formateé hace dos días y me crashea el launcher.

Que Rockstar trata a los usuarios de PC como basura no es novedad, y esta vez no iba a ser menos.
Alguien ha probado si hay diferencia entre hdd y ssd en cuanto a fps? En cuanto a tiempos de carga ya entiendo que si la habra..
MI problema es que me ha empezado a hacer una cosa rara al ir a los menus....
Es como se va comiendo la pantalla de menu y va apareciendo poco a pòco por debajo la del juego y ya no ves los menus y no puedes cambiar nada..... ni encuentro la tecla pra salir.
Ayer lei en el foro algo parecido, alguna idea ?
Creo que voy a postear un nuevo error.

A mi me iba relativamente bien hasta que actualizaron el launcher y ahora me va relativamente mal. Aun poniendo la configuración gráfica máximo me esta cargando las texturas LOW, se ve todo como el ojete, los arboles dan vergüenza ajena y las caras de los protagonistas son una risa. Probare esta tarde a poner los parámetros por defecto (ya que me paso poco antes de irme a la cama) y si no lo soluciono así, pues desinstalaré y volveré a instalar...
Acabo de desinstalar y empezar de nuevo....
Lupoalb escribió:Acabo de desinstalar y empezar de nuevo....


Si desinstalas y vuelves a instalar no te guarda las partidas? Debería guardarlas en la nube y mantener saves.
Ark0 escribió:
Branmark escribió:Hola, a mi también me crashea el launcher, es que no he podido ver ni la primera pantalla del juego.
A ver si lo arreglan pronto, por que sino ya solo me queda formatear y no me apetece mucho.
Saludos.


Ni formatees ni actualices la BIOS. No es culpa de tu PC y seguramente formateando lo único que hagas es perder el tiempo esperando a que vuelva a descargar para que te siga crasheando. Yo formateé hace dos días y me crashea el launcher.

Que Rockstar trata a los usuarios de PC como basura no es novedad, y esta vez no iba a ser menos.


Ok, me voy a esperar a que lo arreglen, pero es una faena, casi 150 gb para nada, toda la hype se va transformando en otra cosa... [sati] [sati]
Saludos.
kabone escribió:
KoX escribió:¿Como se puede hacer algoa si de mal?

Estoy al principio y se para el juego cuando el viene en gana, pensaba que seria algo puntual pero no.

No se si hacer devolucion...


A mi me pasa lo mismo se queda parado como si bajara a 1 fps durante 1 o 2 segundos y vuelve y pues es muy molesto... conforme he avanzado ha pasado en menos ocasiones pero no deja de pasar... Al hacer las pruebas de rendimiento es donde veo que me marca:

Min: 1 fps
Media: 58 fps
Max: 60 fps

Pienso que me esta pasando por la memoria ram pero deberia haber algun preset donde funcione bien y aunque baje a 1080p la config y en configuraciones bajas sigue pasando entonces ya no se que mas puede ser... Por lo demas va bien muy fluido como dice la media 58 fps ... Espero pasar la parte de la nieve y mejore la cosa.


Yo lo corregí desactivando nucleos del procesador... prueba a ver
https://www.reddit.com/r/PCRedDead/comm ... dium=web2x
A mi el juego no me detecta bien la vram de la gráfica. Tengo 11 gigas y se muestran 9.

Por no hablar de que la barrita esa que debiera servirte para hacerte una idea está echa mierda y no funciona.
casin escribió:Buenas! Me pasa algo raro en el juego, al jugar con mando xbox one se me pone el icono del raton en el centro de la pantalla, y por mucho que mueva el ratón hacia un lado se vuelve a poner en el centro. A alguien más le pasa?

Por cierto a mi con la rtx 2060 me va a 60 fps clavados sin tocar nada, tan como viene por defecto en medio/alto y algunas cosas como texturas en ultra y en 1080p ultrawide (creo que es 2556x1080p), aun no he probado a subir cosas.

Saludos!

Me cito de nuevo, a nadie más le pasa lo del raton en el centro al jugar con mando?
casin escribió:
casin escribió:Buenas! Me pasa algo raro en el juego, al jugar con mando xbox one se me pone el icono del raton en el centro de la pantalla, y por mucho que mueva el ratón hacia un lado se vuelve a poner en el centro. A alguien más le pasa?

Por cierto a mi con la rtx 2060 me va a 60 fps clavados sin tocar nada, tan como viene por defecto en medio/alto y algunas cosas como texturas en ultra y en 1080p ultrawide (creo que es 2556x1080p), aun no he probado a subir cosas.

Saludos!

Me cito de nuevo, a nadie más le pasa lo del raton en el centro al jugar con mando?



A mi no me pasa, pero creo que habia una opcion para el puntero del raton en las opciones, quizas en pantalla no recuerdo exactamente
Kalakatita escribió:Creo que lo suyo es ir poniendo obviedades para que el hilo no sea ciclico. Hasta ahora parece que las dos cosas que se repiten constantemente son:
- Mejor Vulcan que dx12
- Bajar parámetros del agua para ganar fps a cascoporro
- Alguna otra opcion fps killer?

Ayer me fui con muy mal sabor de boca, pero hoy espero perder tiempo en toquitear y dejarlo guay a 60 fps que es mi objetivo..


Copio tu lista y añado varios puntos:

- Mejor Vulcan que dx12
- Bajar parámetros del agua para ganar fps a cascoporro
- Todas las opciones de sombras son caras, se recomienda bajarlas segun potencia del equipo/resolución...
- El MSAA (anti-aliasing) es brutalmente costoso. Se recomienda usar el TAA, que es el que usa los RDR2 de consola...
- La alta resolución de oclusión ambiental también es muy costosa, podemos subir la oclusión ambiental y bajar o quitar esta opción.


Por ahora es lo que puedo aportar. Debo seguir haciendo pruebas, además de con los settings, con las siguientes configs de Nvidia:

- Probar a ejecutar las fisicas en CPU en vez de GPU (ya que voy sobrado de procesador, veremos si descargar a la gráfica de estos cálculos aporta beneficio...).
- Probar si el modo low latency mejora o no el rendimiento del juego...
Titán_Salvaje_ escribió:eso venia a decir yo , los que tengais una 1080 ti con solo bajar un punto la barra de la fisica del agua se mantiene a 60fps estables con practicamente todo en ultra menos sombras en alto , reflejos en alto , resolución volumetrica de cerca y lejos en alto , alta resolución de la oclusión ambiental desactivada y la barra de distancia de dibujado bajar dos puntos , eso si a 1080P.. pero una gozada jugar así , se ve de escandalo y la iluminación uff alucinante

juegazo de 10

y a currar sin dormir jajjaj

Pues con tu equipo me parece un rendimiento más acorde a 2k que a 1080p. No se, espero que mejoren con el tiempo el rendimiento porque me parece una pasada. Yo lo pillaré más adelante cuando baje un poco de precio.
ErLaLe escribió:Creo que voy a postear un nuevo error.

A mi me iba relativamente bien hasta que actualizaron el launcher y ahora me va relativamente mal. Aun poniendo la configuración gráfica máximo me esta cargando las texturas LOW, se ve todo como el ojete, los arboles dan vergüenza ajena y las caras de los protagonistas son una risa. Probare esta tarde a poner los parámetros por defecto (ya que me paso poco antes de irme a la cama) y si no lo soluciono así, pues desinstalaré y volveré a instalar...


Creo que me pasa algo parecido, estaba jugando el prologo en las montañas y saltaba a la vista las texturas de las rocas y del caballo que eran pixeles, se veían fatal y tenia las texturas en alto. Tengo una 970 que sé que no va a poder tirar mucho pero es que ni poniéndolo todo en medio mejora mucho la cosa.
Kalakatita escribió:Creo que lo suyo es ir poniendo obviedades para que el hilo no sea ciclico. Hasta ahora parece que las dos cosas que se repiten constantemente son:
- Mejor Vulcan que dx12
- Bajar parámetros del agua para ganar fps a cascoporro
- Alguna otra opcion fps killer?

Ayer me fui con muy mal sabor de boca, pero hoy espero perder tiempo en toquitear y dejarlo guay a 60 fps que es mi objetivo..

Se supone que lo del agua es solo cuando sale agua, no? :)

Os recuerdo tambien que si se os ve algo borroso por culpa del TAA o por usar una resolucion no nativa, si teneis Nvidia, podeis usar en el panel de control la opción image sharpening para compensar esa borrosidad.
Pero que mierda...

He puesto el juego hace un momento, he cambiado lo del agua que dicen por aquí por probar y poner lo de 30fps, me pedia reinicar asi que he reiniciado y ahora no inicia... [enfado1] [enfado1] [enfado1] [enfado1]

Lo peor es que se ha quedado en segundo plano como en ejecución y me ha contado el tiempo y ha pasado de los 120 minutos [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1]
RaulKO escribió:
Kalakatita escribió:Creo que lo suyo es ir poniendo obviedades para que el hilo no sea ciclico. Hasta ahora parece que las dos cosas que se repiten constantemente son:
- Mejor Vulcan que dx12
- Bajar parámetros del agua para ganar fps a cascoporro
- Alguna otra opcion fps killer?

Ayer me fui con muy mal sabor de boca, pero hoy espero perder tiempo en toquitear y dejarlo guay a 60 fps que es mi objetivo..


Copio tu lista y añado varios puntos:

- Mejor Vulcan que dx12
- Bajar parámetros del agua para ganar fps a cascoporro
- Todas las opciones de sombras son caras, se recomienda bajarlas segun potencia del equipo/resolución...
- El MSAA (anti-aliasing) es brutalmente costoso. Se recomienda usar el TAA, que es el que usa los RDR2 de consola...
- La alta resolución de oclusión ambiental también es muy costosa, podemos subir la oclusión ambiental y bajar o quitar esta opción.


Por ahora es lo que puedo aportar. Debo seguir haciendo pruebas, además de con los settings, con las siguientes configs de Nvidia:

- Probar a ejecutar las fisicas en CPU en vez de GPU (ya que voy sobrado de procesador, veremos si descargar a la gráfica de estos cálculos aporta beneficio...).
- Probar si el modo low latency mejora o no el rendimiento del juego...


Tengo entendido que lo de calcular las físicas por cpu o gpu es solo para physx, cosa que no usa este juego. A parte la cpu es muy poco eficiente comparado a la gpu en cálculo de físicas.

Yo he probado a activar vsync en el panel de nvidia pero en vulkan se ve que no funciona.
Al final ayer pude ponerlo en marcha desactivando el bitdefender. Manda cojones que tengamos que hacer eso para que funcione. Muy mal R*

¿Alguien jugándolo con una RX580? Lo pregunto para compartir impresiones y configuraciones.

No lo empecé, únicamente estuve haciendo probaturas con las configuración gráfica.
En opciones avanzadas (que estaban bloqueadas) no toqué nada pero vi que me activaba por defecto Vulkan que según parece va mejor que Directx.
Las opciones gráficas restantes estaban todas en ultra, salvo algunas en alto y al hacer el test me daba de media 55fps. Puse todas en ultra y prácticamente daba lo mismo.

Esta noche miraré lo que decís, desactivar lo del agua, quitar MSAA y activar TAA y FXAA para el antialiasing.
¿Alguna cosa que se me quede en el tintero?

Se han cubierto de gloria.
MaxPowerGR escribió:Tengo una 970 y un i54690 y el juego se queda pillao de vez en cuando unos 5 o 6 segundos...es super frustrante.
He visto por ahí que a alguien más le pasa.¿a qué se puede deber?
Gracias



Bájate esta aplicación http://mion.faireal.net/BES/ y limita el proceso de RDR2 a -5% (Que seria que nunca gaste mas del 95%)

Yo tengo un i5 6500 y me pasaba lo mismo. En reddit hay muchas mas gente con este problema
KoX escribió:Pero que mierda...

He puesto el juego hace un momento, he cambiado lo del agua que dicen por aquí por probar y poner lo de 30fps, me pedia reinicar asi que he reiniciado y ahora no inicia... [enfado1] [enfado1] [enfado1] [enfado1]

Lo peor es que se ha quedado en segundo plano como en ejecución y me ha contado el tiempo y ha pasado de los 120 minutos [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1]

Yo saque toda la oclusion ambiental en el juego, y cuando vuelvo a entrar, me tira error y se me cierra, asi que fui ajustes y lo volvi activar en medio, y ahora puedo seguir jugando.

Esto ya es problema de Rockstar y su launcher, no de nuestras pcs.
Antes de comprarlo, quiero preguntaros... Con mi PC lo compro o me olvido de que vaya a funcionar?

GTX 1060 3GB
i5 7500k
16 GB RAM

Gracias compis.
javitoto escribió:
KoX escribió:Pero que mierda...

He puesto el juego hace un momento, he cambiado lo del agua que dicen por aquí por probar y poner lo de 30fps, me pedia reinicar asi que he reiniciado y ahora no inicia... [enfado1] [enfado1] [enfado1] [enfado1]

Lo peor es que se ha quedado en segundo plano como en ejecución y me ha contado el tiempo y ha pasado de los 120 minutos [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1] [enfado1]

Yo saque toda la oclusion ambiental en el juego, y cuando vuelvo a entrar, me tira error y se me cierra, asi que fui ajustes y lo volvi activar en medio, y ahora puedo seguir jugando.

Esto ya es problema de Rockstar y su launcher, no de nuestras pcs.


Y ¿donde fuiste para los ajustes si el juego se te cierra? porque en su carpeta no lo veo.
Yo estoy verificando archivos por si acaso yo que se...pero cuando termine probaré esto de la web de R*:

Run RDR2.exe as an administrator

Open the Rockstar Games Launcher
Select Settings
Select Red Dead Redemption 2 under My installed games
Select Open under View Installation Folder
Right-Click on RDR2
Select Properties
Under the Compatibility Tab
Select Run this Program as an Administrator and Disable Full Screen Optimization
Click OK
Return to the Games Menu in the Rockstar Games Launcher
Launch the game

https://support.rockstargames.com/artic ... expectedly
3498 respuestas
14, 5, 6, 7, 870