[HO] Bricks en 3DS

Esto debería salír en primera portada de eol para que la ggente se empapara bien.
egarrote escribió:Se pone la cosa calentita:

Crediar ha añadido esta linea al primer post:
Crediar escribió: Normmatt's region free patch is NOT causing any bricks since he patches the brick code!

Que no tiene sentido, ya que en EOL si hay un caso de brick on el launcher de Normmat!


Crediar ha modificado el post, ahora dice que el parche de Normmatt tampoco es seguro: "Normmatt's region free patch is not safe either!" Y se supone que estos sabían de la existencia como dicen de ese código...esto tampoco habla nada bien de ellos.
yo me pregunto que pasaría si no comprabas el GATEWAY y solo lo usabas para juegos originales, y solamente usabas el EMUNAND para poder irte a jugar online, podría darse el caso que también llegará a brickearte la consola x esto?
cora666 escribió:yo me pregunto que pasaría si no comprabas el GATEWAY y solo usabas juegos originales, y solamente usabas el EMUNAND para poder irte a jugar online, podría darse el caso que también llegará a brickearte la consola x esto?


Sí, tb. El problema no está en la propia tarjeta o en la carga de ROMS. Lo está en la ejecución del código que permite todo eso.
egarrote escribió:Hay una cosa que no me cuadra, por que Normmatt o Mathieulh como dicen sabían que ese código malicioso existía, repito, por que cojones no avisaron antes de que se produjeran los bricks, eh?

Alguien me lo explica?
Algo no cuadra...

Salu2!


Pero si sabían ese código, y como lo muestran con ese extracto de código, es que tienen desencriptado el launcher entero supuestamente ¿¿no??

Entonces:
1º Porque tienen que esperar a que los de Gateway saquen actualizaciones si ellos ya han visto todo el código y saben como va el tinglado.
2º Si saben como va el tinglado porque no sacan ellos las respectivas mejoras para sus flash y no que no sacan nada hasta después de que Gateway saque algo.

No se pero eso de que saquen ahora ese extracto de código a mi me parece demasiado sospechoso.

y pienso lo mismo que egarrote si sabían que ese código existía porque coño sacan los clones esa versión, con que hubieran quitado esas lineas se solucionaba todo el problema, pero aqui hay algo que no cuadra, o los clones intentan echar la mierda para otro lado para evitar la responsabilidad o nos intentan echar la milonga de que existe ese supuesto código para desprestigiar a Gateway [+furioso]
takuma-kun escribió:Esto debería salír en primera portada de eol para que la ggente se empapara bien.


bueno, aún es considerado un "rumor"...supongo que con el tiempo pasará a ser un hecho.
Y no es nada nuevo que se implementen este tipo de DRMs, solo espero que Gateway desaparezca, dejen de pagarles a los sceners para que se queden de brazos cruzados (porque a mi me late que si Normmatt o Mathieulh se quedaron callados, fue porque fueron obligados) y empiece una verdadera scene gratuita...que utopía, no? [+risas]
Esto respondera a tu pregunta. Cuando reporte que se me habia brickeado la consola en GBAtemp y luego postee la idea de que podia ser algo intensional por parte de Gateway, Nemoid respondio "Los piratas tienen lo que se merecen"....

http://gbatemp.net/threads/help-with-bl ... st-4882840

http://gbatemp.net/threads/help-with-bl ... st-4882858
NanakiXIII escribió:
cora666 escribió:yo me pregunto que pasaría si no comprabas el GATEWAY y solo usabas juegos originales, y solamente usabas el EMUNAND para poder irte a jugar online, podría darse el caso que también llegará a brickearte la consola x esto?


Sí, tb. El problema no está en la propia tarjeta o en la carga de ROMS. Lo está en la ejecución del código que permite todo eso.


no he comprado el GATEWAY, solamente uso el EMUNAND para jugar a mí MARIO KART ORIGINAL, pero con esto estoy pensando si deba volver a la beta 2.0b1 o me olvido del online.
Moquedami escribió:Esto respondera a tu pregunta. Cuando reporte que se me habia brickeado la consola en GBAtemp y luego postee la idea de que podia ser algo intensional por parte de Gateway, Nemoid respondio "Los piratas tienen lo que se merecen"....

http://gbatemp.net/threads/help-with-bl ... st-4882840

http://gbatemp.net/threads/help-with-bl ... st-4882858


Y como sabes que ese user es verdaderamente neimod ^^U
Porque se registro el 4 de enero del 2013 y tiene solo 9 mensajes muy raro me parece yo diría que es un Troll con su nick.[qmparto]
cora666 escribió:no he comprado el GATEWAY, solamente uso el EMUNAND para jugar a mí MARIO KART ORIGINAL, pero con esto estoy pensando si deba volver a la beta 2.0b1 o me olvido del online.


Mientras uses la beta 2, existe la posibilidad de brick.
Sea o no es el mismo usuario que reporto las lineas de codigo que detonan el brick, fijate entre sus mensajes.
cora666 escribió:
NanakiXIII escribió:
cora666 escribió:yo me pregunto que pasaría si no comprabas el GATEWAY y solo usabas juegos originales, y solamente usabas el EMUNAND para poder irte a jugar online, podría darse el caso que también llegará a brickearte la consola x esto?


Sí, tb. El problema no está en la propia tarjeta o en la carga de ROMS. Lo está en la ejecución del código que permite todo eso.


no he comprado el GATEWAY, solamente uso el EMUNAND para jugar a mí MARIO KART ORIGINAL, pero con esto estoy pensando si deba volver a la beta 2.0b1 o me olvido del online.


Pues por eso te lo digo, que el problema no está en si en la flashcard, sino en el launcher que lo hace funcionar. Así que te puede afectar.

Vuelve a la versión anterior. No necesitas el último firmware para jugar online, solo el parche 1.1 que sacó nintendo en la eshop. Si ya lo tienes, deberías poder seguir jugando online aunque no estés en 7.1.
NanakiXIII escribió:
Pues por eso te lo digo, que el problema no está en si en la flashcard, sino en el launcher que lo hace funcionar. Así que te puede afectar.

Vuelve a la versión anterior. No necesitas el último firmware para jugar online, solo el parche 1.1 que sacó nintendo en la eshop. Si ya lo tienes, deberías poder seguir jugando online aunque no estés en 7.1.


dentro de un rato veré si lo pruebo con la beta b1.
Los que tenéis brick (leon69s) en vuestra consola con Gateway, podéis confirmar el hash del launcher.dat de 2.0b2?

Yo tengo:
CRC32: 58F46229
MDA5: 6361C5D4935AF6D888FFC0646548F5DD
SHA-1: 3508A54DD3B1FF903FBF18ECF97B075205B67D0C


Salu2!
Hola a todos, tengo una duda. Si solamente uso el cartucho azul para backups de juegos de ds y homebrew, ¿tendre algun problema de brickeo?.
masterzero escribió:jajajaj lo que me faltaba por leer, en el foro de maxconsole un tio dice que no lo han hecho los de gateway y si lo han hecho lo han hecho sin querer.


Colega, piensa que eso lo ha podido escribir un niño de 12 o 13 años desde la inocencia absoluta porque no es algo lógico, no te alarmes tanto.

Por mi parte según leo cosas por aquí (yo paso de gbatemp o indagar más, porque no me interesa demasiado) me quedaré a ver si se acaba por confirmar la veracidad de esto, porque es algo muy raro que un team pegue la bomba de esta manera.. los sceners lo sepan y lo digan más tarde, tengan el codigo de gateway desencriptado (y no hay homebrew aún?) ya veremos en que queda esto..

Yo por mi parte vuelvo a algún launcher anterior, pero no descarto que sea un error de código de gateway que faltara por corregir en alguna parte y y los clones dejaran más errores al cambiar lo que cambiaran ellos..

Lo que si, es muy raro que tengamos la 2.02b desde el 23 de diciembre, y aparezcan bricks justo después de que los clones sacaran su "versión" propia.

Hola a todos, tengo una duda. Si solamente uso el cartucho azul para backups de juegos de ds y homebrew, ¿tendre algun problema de brickeo?.


No, la bomba está en el launcher.dat de la consola :) usa uno antiguo si lo tienes por ahí que ahora no esta en la web de gateway.
egarrote escribió:Los que tenéis brick (leon69s) en vuestra consola con Gateway, podéis confirmar el hash del launcher.dat de 2.0b2?

Yo tengo:
CRC32: 58F46229
MDA5: 6361C5D4935AF6D888FFC0646548F5DD
SHA-1: 3508A54DD3B1FF903FBF18ECF97B075205B67D0C


Salu2!


acabo de quedar con leons69s en persona y bueno , aclarar unos puntos su GW es diferente a la mía tanto azul y roja , comento las pegatinas de su GW tiene un color un poco mas flojo al de la mía , el chip de la tarjeta roja tiene un verde diferente a la mía , la azul ami me pone x-b en letras blancas a el no le pone nada , la caja donde a el le a venido es de cartón la mía de plástico y asta parece un pelin mas gruesa que la mia XD , primer clon que usa el mismo launcher de GW y que trata de clonar hardware? no lo se pero si me a parecio raro de cojones , aclaro que el la comprado en cymods y cymos no es un reseller oficial XD
Joder... vaya mala pinta tiene esto... poniendo 2.0b1 te libras? (Aunque 7.1 no funcione bien)

chekcoca escribió:
egarrote escribió:Los que tenéis brick (leon69s) en vuestra consola con Gateway, podéis confirmar el hash del launcher.dat de 2.0b2?

Yo tengo:
CRC32: 58F46229
MDA5: 6361C5D4935AF6D888FFC0646548F5DD
SHA-1: 3508A54DD3B1FF903FBF18ECF97B075205B67D0C


Salu2!


acabo de quedar con leons69s en persona y bueno , aclarar unos puntos su GW es diferente a la mía tanto azul y roja , comento las pegatinas de su GW tiene un color un poco mas flojo al de la mía , el chip de la tarjeta roja tiene un verde diferente a la mía , la azul ami me pone x-b en letras blancas a el no le pone nada , la caja donde a el le a venido es de cartón la mía de plástico y asta parece un pelin mas gruesa que la mia XD , primer clon que usa el mismo launcher de GW y que trata de clonar hardware? no lo se pero si me a parecio raro de cojones , aclaro que el la comprado en cymods y cymos no es un reseller oficial XD


El problema no es el hardware, es el código que está en el launcher.dat
pudiste flashear checko?
no digo lo contrario , digo que su brick con la GW puede que sea por otro clon hasta ahora desconocido

pd: estaba apunto de desmontarla cuando vimos que los bricks no se podían solucionar flasheando como aun esta en garantía no he probado a flashear
He cambiado el launcher de la 2.0b2 que tenía a la 1.1 y ahora cuando inicio el bravely default no me encuentra la partida que tenía en 2.0b2 (formateé la sd de la 3dsxl pero guardé el save en el ordenador y lo he vuelto a meter en la sd de la consola).

Significa eso que tengo que volver a empezar de nuevo el juego o que la partida solo funciona con el launcher del 2.0b1 o 2.0b2?. Es que no quiero estar en la 2.0 por todo lo que estoy leyendo en el hilo del boot error pero claro tampoco quiero perder las 36h que llevaba en el bravely }:/
kpik0 escribió:
El problema no es el hardware, es el código que está en el launcher.dat


Es el launcher.dat cuando es modificado o ejecutado en un flashcard no gateway (ya que no usan las mismas direcciones de memoria) así que es una teoría interesante que se confirmara.
chekcoca escribió:no digo lo contrario , digo que su brick con la GW puede que sea por otro clon hasta ahora desconocido

pd: estaba apunto de desmontarla cuando vimos que los bricks no se podían solucionar flasheando como aun esta en garantía no he probado a flashear


El propio team GateWay ya confirmó hace algún tiempo que había lanzado revisiones nuevas de su cartucho y de la caja en la que vienen, pero que siguen siendo el mismo cartucho con los mismos componentes.

Un saludo
chekcoca escribió:
egarrote escribió:Los que tenéis brick (leon69s) en vuestra consola con Gateway, podéis confirmar el hash del launcher.dat de 2.0b2?

Yo tengo:
CRC32: 58F46229
MDA5: 6361C5D4935AF6D888FFC0646548F5DD
SHA-1: 3508A54DD3B1FF903FBF18ECF97B075205B67D0C


Salu2!


acabo de quedar con leons69s en persona y bueno , aclarar unos puntos su GW es diferente a la mía tanto azul y roja , comento las pegatinas de su GW tiene un color un poco mas flojo al de la mía , el chip de la tarjeta roja tiene un verde diferente a la mía , la azul ami me pone x-b en letras blancas a el no le pone nada , la caja donde a el le a venido es de cartón la mía de plástico y asta parece un pelin mas gruesa que la mia XD , primer clon que usa el mismo launcher de GW y que trata de clonar hardware? no lo se pero si me a parecio raro de cojones , aclaro que el la comprado en cymods y cymos no es un reseller oficial XD

Es otra "versión de hardware" del Gateway pero es original, no puedo buscarte el link ahora pero te aseguro que es oficial. Si rebuscas entre mis post lo encontraras.

Salu2!
ok entonces tema aclarado , simplemente me quede mosca al verla
egarrote escribió:Si veis algún caso mas de brick, por favor dejad el link por aquí para recopilarlos todos en la primera página. [ginyo]

c0d3m4st4 escribió:mal rollito sí... está claro que va a ser la emunand

El caso de leon69s no se debe a la emuNAND, ¡ni siquiera llego a hacerla!

skunk df escribió:Si alguien de madrid se ofrece a soldar yo tengo 3ds con copia del nand en 4.5 pero ni idea de soldar.

Si hay algún alma caritativa que me mande mp

Puedes copiar y pegar la plantilla de la primera página para ver como se produjo tu brick?
Gracias!

Salu2!


No, en mi caso no ha provocado brick. Simplemente actualice pero la co sola funciona no tiene brick. Siento sí se ha entendido mal, lo siento.
genaut escribió:
kpik0 escribió:
El problema no es el hardware, es el código que está en el launcher.dat


Es el launcher.dat cuando es modificado o ejecutado en un flashcard no gateway (ya que no usan las mismas direcciones de memoria) así que es una teoría interesante que se confirmara.


Si esa teoría se confirmase entonces significa que han conseguido hacer copias casi idénticas al GateWay, con lo que significa que no podríamos fiarnos de cualquier reseller chino.
Pero lo interesante de esto es que si cambiamos la fecha a, que se yo, 2011, hipotéticamente podríamos usar el 3.0 y siguientes sin peligro de brick. No?
Esto quiere decir que los usuarios de Gateway estan expuestos a un brick en la ultima beta de gateway [mad] ?
me regreso a la 1.2 antes de que mi 3DS quede en este fuego cruzado de gateway y los clones
(mensaje borrado)
Kirameki escribió:Pero lo interesante de esto es que si cambiamos la fecha a, que se yo, 2011, hipotéticamente podríamos usar el 3.0 y siguientes sin peligro de brick. No?

parece ser que tiene que ver con la fecha en que se copia/crea el launch.dat y no con la de la consola

lo mejor es volver todos a las versiones sin emunand que a priori parecen seguras
Pues mañana me llega a mi la Gateway que he comprado jajaja. No entiendo la mitad de las cosas de las que habláis, que si NAND, que si betas....a lo mejor lo más sensato es dejar la tarjeta guardada en un cajón hasta que haya algo de luz sobre este tema.
ya Neimod confirmo en GbaTemp, que efectivamente el Team Gateway puso codigo malicioso en su launcher.

Edito : Aqui la cita de Neimod

Gateway put a code in their launcher.dat which roughly works like this:

Code:
if(<low 4bits u32 output from random-number-generator are zero> && <checksum over arm9 code is invalid>)
brick();
The random-number-generator uses the console date for initialization. That's why all the bricks occured after a certain date. The second part checks whether the launcher.dat file itself is legit. Any modification makes the checksum fail and therefore bricks the console.
por favor que alguien me explique yo tengo la gateway card y con la ultima beta puede haber un Brick por culpa de la SD CORUPTA que significa eso de la SD
Huuuuuuy!!!, que mal, lastima!!!!.

Esperemos y al menos sea mentira el otro rumor el cual dice que el regalito de los gateway daña la nand evitando revivir las consolas.

Por que de ser asi, estaremos jodidos!!!

Yo a lo mejor intento revivir hoy la XL, si es asi, reportare resultados.

Salu2
elmonton9 escribió:por favor que alguien me explique yo tengo la gateway card y con la ultima beta puede haber un Brick por culpa de la SD CORUPTA que significa eso de la SD


Si, es posible. Vuelve a la beta 1 de la 2.0 o a la versión 1.2.

La SD corrupta significa que, si al leer el archivo launcher.dat y hacer un checksum, si en vez de decir "AAAA" dice "AAA#" entonces Gateway te brickea la consola. Y puede que tu hash en realidad debió devolver "AAAA", pero porque la SD se corrupteó o hubo un error y leyó otra cosa, ya te brickearon.
Lordpsycho escribió:
elmonton9 escribió:por favor que alguien me explique yo tengo la gateway card y con la ultima beta puede haber un Brick por culpa de la SD CORUPTA que significa eso de la SD


Si, es posible. Vuelve a la beta 1 de la 2.0 o a la versión 1.2.

La SD corrupta significa que, si al leer el archivo launcher.dat y hacer un checksum, si en vez de decir "AAAA" dice "AAA#" entonces Gateway te brickea la consola. Y puede que tu hash en realidad debió devolver "AAAA", pero porque la SD se corrupteó o hubo un error y leyó otra cosa, ya te brickearon.


Lo que no entiendo es porque los saves de los juegos no funcionan cuando bajas a un firmware inferior.

Estaba en 2.0b2 y ahora estoy en 1.1 y la partida guardada de bravely default no me va :-?
takuma-kun escribió:Lo que no entiendo es porque los saves de los juegos no funcionan cuando bajas a un firmware inferior.

Estaba en 2.0b2 y ahora estoy en 1.1 y la partida guardada de bravely default no me va :-?


Probablemente los de GW cambiaron la forma de guardado, punteros a memoria, formato del save, o algo en su v2. Recuerda que en la 1.x mucha gente se quejaba de que si tenía que presionar Home+X y que a veces no se guardaba y se había perdido toda la partida y que con la v2 las cosas mejoraron.
En Maxconsole un usuario con brick producido por la Gateway ha publicado su checksum:

File: Launcher.dat.md5
CRC-32: c4cc5550
MD4: 5800e35e4c81f9bb8c4106df3923a8f1
MD5: 15d8b5d6d17bba7684c8a07cae29633d
SHA-1: ebbc2554978bb1f88e0209d6b97bae826da47676
A la larga, lo dulce amarga.
En resumen que ha sido confirmado no ?

Entonces la beta 1 no lo tiene no ???
Es segura?
Lordjontan escribió:En Maxconsole un usuario con brick producido por la Gateway ha publicado su checksum:

File: Launcher.dat.md5
CRC-32: c4cc5550
MD4: 5800e35e4c81f9bb8c4106df3923a8f1
MD5: 15d8b5d6d17bba7684c8a07cae29633d
SHA-1: ebbc2554978bb1f88e0209d6b97bae826da47676


Con esto se confirma que si hay corrupcion de datos en la SD, aun con FC Gateway uno esta propenso a sufrir un brick.

La corrupcion se puede dar por:

memorias SD de mala calidad.
no expulsar de forma segura la memoria de la computadora
o virus en la computadora.

Esto se esta poniendo feo!!!

Salu2
Será posible, que voy a tener que esconder las 3ds , por que estos cabrones del Gateway hayan metido esa mierda de codigo en el launcher. Ahora ya no me fio ni de los anteriores firmwares de la Gateway, la madre que los pario... [+furioso]
kalon escribió:Será posible, que voy a tener que esconder las 3ds , por que estos cabrones del Gateway hayan metido esa mierda de codigo en el launcher. Ahora ya no me fio ni de los anteriores firmwares de la Gateway, la madre que los pario... [+furioso]


Colega, esta "medida de seguridad" solo esta en el 2.0b2
PedroDJavier escribió:
kalon escribió:Será posible, que voy a tener que esconder las 3ds , por que estos cabrones del Gateway hayan metido esa mierda de codigo en el launcher. Ahora ya no me fio ni de los anteriores firmwares de la Gateway, la madre que los pario... [+furioso]


Colega, esta "medida de seguridad" solo esta en el 2.0b2

que sepamos nosotros [+risas]
Según mathieulh, incluso aunque el launcher no esté modificado ni haya corrupción en la SD, el brick puede seguir ocurriendo, ya que lo comprueba son las partes del código que se cargan en memoria, y estas pueden fallar ya que estamos cargando ese código a través de un exploit que ni mucho menos es entorno seguro y estable.
Y pensar que hace poco que estaba con lo del tutorial de Lina varias veces dentro de la emunand extraje la SD por error [+risas] supongo que corrí el riesgo de brick, la verdad estoy de acuerdo en que el team gateway trate de impedir que copien su trabajo PERO exponiendo a posibles bricks a sus usuarios legítimos? :-? Muy mal de su parte a ver que explicación dan.
Master_100 escribió:Según mathieulh, incluso aunque el launcher no esté modificado ni haya corrupción en la SD, el brick puede seguir ocurriendo, ya que lo comprueba son las partes del código que se cargan en memoria, y estas pueden fallar ya que estamos cargando ese código a través de un exploit que ni mucho menos es entorno seguro y estable.


Y esto sigue y sigue....

Mejor voy a ver si ya puso la marrana. Ojala y cuando regrese haya buenas noticias...

Salu2
Bueno acabo de regresar al launcher 1.2 con 4.5 no tengo Emunand pero el nuevo Zelda ya
no me corre [buuuaaaa] ha esperar la 2.0 oficial en vez de tener un posible brick dentro de la 3ds [mad]
Master_100 escribió:Según mathieulh, incluso aunque el launcher no esté modificado ni haya corrupción en la SD, el brick puede seguir ocurriendo, ya que lo comprueba son las partes del código que se cargan en memoria, y estas pueden fallar ya que estamos cargando ese código a través de un exploit que ni mucho menos es entorno seguro y estable.


Estamos escribiendo directamente sobre la memoria, da igual que sea un exploit,es igual de seguro que cargar un juego, el brick se pensaba que era por una corrupción en parte de la memoria nand, ahora dicen que le es asignado un tamaño de 0. Poco importa que sea un entorno "poco seguro y estable", el procesador lee lo que le lo que le damos, no hace magia xD
elmonton9 escribió:Bueno acabo de regresar al launcher 1.2 con 4.5 no tengo Emunand pero el nuevo Zelda ya
no me corre [buuuaaaa] ha esperar la 2.0 oficial en vez de tener un posible brick dentro de la 3ds [mad]


O eso o te pones la 2.0b1 si eres valiente.
2265 respuestas
15, 6, 7, 8, 946