pFBA: final burn alpha

1, 2, 3, 4, 516
Imagen


Ya que a los que estamos en 5.xx no tenemos las bondades ( o no) de retroarch, tenemos este pequeño substituto.
Reconoce sin problemas ( lo he testeado con casi todo el romset) :
Capcom CPS-1
Capcom CPS-2
Capcom CPS-3
Konami
Neo-Geo
Sega System 1, System 16 (y similar)
coleco
msx
pce
tg16
sgx

Github de pFBA

Listado de juegos que soporta oficialmente

Cosas a tener en cuenta:

-Para jugar desde el Dock, entrar al juego en modo portatil, quitar los mandos e insertar en el dock.

-Si tenéis problemas con las Bios de los juegos de MAME, seguir este tuto de @Ágata : https://www.elotrolado.net/viewtopic.php?p=1746080809

-Solo funciona el Romset especifico para FBA. El ultimo soportado es el FBA 0.2.97.43. ( google es vuestro amigo)

-Controles de la 1.5.7

You can enable or disable single joycon support from the pFBA main menu (+). When enabled, all detected joycons (not docked) will be handled as a single controller/player.

NINTENDO SWITCH CONTROLS (UI)
(L/R) : SWITCH FROM TITLE TO PREVIEW IMAGE
(+) : GENERAL OPTIONS + DEFAULT ROMS OPTIONS
(-) : PER ROM OPTIONS
(A) : RUN ROM

NINTENDO SWITCH CONTROLS (IN-GAME)
(+) : START
(-) : COINS
(+/-) + (A) : START
(+/-) + (B) : COINS
(+/-) + (X) : SERVICE SWITCH
(+/-) + (Y) : 1P + 2P START
(+/-) + (L/R) : PFBA MENU
(+) + (-) : UNIBIOS MENU (NEOGEO ONLY)


Habilitar los dos joycons para 2 player

En el menú de juegos pulsamos el botón + del joycon derecho y en "single Joycons" le ponemos ON


Guardar/cargar partida

Pulsando L y botón - , como R y botón + ( a la vez) accedemos a un menú donde dentro de States podemos salvar nuestra partida. Para cargar la partida haremos el mismo proceso y una vez pinchemos ese slot nos aparecerá un mensaje donde nos dice LOAD
Que tal funciona?
Solo funciona con 5.xx?
A mi me gusta más este que retroarch. Más facilito de manejar.

No los he probado en suich, pero si en vita.

Lo que no sé es si el homebrew de switch sigue teniendo q ir por linux, cosa q me da perecísima.
@anpeasolana por lo que se ve va en todas las versiones ( incluida 5xx) y va fino fino, falla alguna rom pero parece ser cosa del romset.

@Pichake va directamente por HBC
En 4.1.0 funciona perfectamente... no solo arcades, si no consolas segas y msx, coleco no he conseguido arrancar, me da error de driver
@jevilon mira en el hilo oficial, puede ser cosa de bios.
etolini escribió:@jevilon mira en el hilo oficial, puede ser cosa de bios.


Estoy seguro de ello, pero no se exactamente donde ponerla (de todas formas estoy con pfba 1.54 y he visto que hay 1.55) quizas esa forma de ordenar las roms sea mas facil para saber donde poner la bios
Pues a mí me va fatal. Todas las roms en rojo excepto una y las bios que también salen en verde. ¿Cuantas bios existen? Yo tengo seis metidas y nada.
Se Villano escribió:Pues a mí me va fatal. Todas las roms en rojo excepto una y las bios que también salen en verde. ¿Cuantas bios existen? Yo tengo seis metidas y nada.

Asegurate que las roms coinciden con la revision de fba que usa (la ultima verion es fba .0.2.97.43), eso es muy importante
Simplemente guapisimo, y el dobles ya lo rompe, hoy mismo he estado jugando un cadillac&dinosaur con los crios y nos lo hemos pasao pipa.
Desde luego yo actualice a 3.0.0 y para mi es lo mejor que podia hacer, y eso que tengo el zelda( grande tambien), pero es que el pfba muy conseguio.
jevilon escribió:
etolini escribió:@jevilon mira en el hilo oficial, puede ser cosa de bios.


Estoy seguro de ello, pero no se exactamente donde ponerla (de todas formas estoy con pfba 1.54 y he visto que hay 1.55) quizas esa forma de ordenar las roms sea mas facil para saber donde poner la bios

pues en la nueva versión tienes que poner, dentro de la carpeta de pFBA la carpeta del sistema que quieres poner y allí las roms y bios. Ya no hace falta renombrar los archivos.
En tu caso : pfba/coleco

Se Villano escribió:Pues a mí me va fatal. Todas las roms en rojo excepto una y las bios que también salen en verde. ¿Cuantas bios existen? Yo tengo seis metidas y nada.


no te puedo pasar enlace pero mira de buscar unibios ( google te ayuda)
Funciona perfectamente en 5.0.0. Entiendo que el tema del sonido de momento no se ha podido arreglar, verdad? El sonido no funciona, es problema de mi configuración o es que aún no está funcional?

Por cierto hago aquí una consulta, cuando uso el Homebrew no se puede usar el modo suspensión ya que la consola se bloquea. Hay algún modo de poder usarlo? Da bastante palo tener que hacer todo el proceso de cero casa vez que tienes que apagar la pantalla aunque solo sea por unos minutos.

Gracias y saludos.
En pfba que hay para el homebrew de la 3.0.0, si que va el sonido.
@Rodimus en 5.xx el sonido va perfecto. Prueba la versión 1.55.

En cuanto a la suspensión, es un tema de hbl no del emulador ( que lo puedes dejar en pausa)
Rodimus escribió:Funciona perfectamente en 5.0.0. Entiendo que el tema del sonido de momento no se ha podido arreglar, verdad? El sonido no funciona, es problema de mi configuración o es que aún no está funcional?

Por cierto hago aquí una consulta, cuando uso el Homebrew no se puede usar el modo suspensión ya que la consola se bloquea. Hay algún modo de poder usarlo? Da bastante palo tener que hacer todo el proceso de cero casa vez que tienes que apagar la pantalla aunque solo sea por unos minutos.

Gracias y saludos.

Yo lo he probado en 5.0.2 y el sonido sí que funciona, prueba apretar el + en el menu y activar sonido. No recuerdo si era apretando + únicamente o + y - al mismo tiempo, pero al hacerlo te sale un menú en el cual puedes activar el sonido.

Respecto a jugar a jugar a dobles, cada uno con un joycon, os comento lo que me funciona: Una vez cargas el juego, apretas - para dar almenos un crédito, en ese momento ya puedes sacar los joycons y debes apretar primero el boton del analógigo del joycon izquierdo para que lo detecte, Luego ya puedes apretar el del derecho para que te lo detecte también y, a disfrutar en compañía. XD
Se Villano escribió:Pues a mí me va fatal. Todas las roms en rojo excepto una y las bios que también salen en verde. ¿Cuantas bios existen? Yo tengo seis metidas y nada.

como comenta @jevilon mira que romset utilizas.

yo voy con uno un poco antiguo, de 2016, el v0.2.97.39 y la verdad me va muy bien todo.
Con la ultima actualización reconoce hasta 0.2.97.43.
probando la ultima version y todo OK, arranca coleco y arranca todo con sonido, con velocidad, solo que roms de megadrive europeas... van a toda caña (conviene usar usa o world)
Uliga escribió:
Rodimus escribió:Funciona perfectamente en 5.0.0. Entiendo que el tema del sonido de momento no se ha podido arreglar, verdad? El sonido no funciona, es problema de mi configuración o es que aún no está funcional?

Por cierto hago aquí una consulta, cuando uso el Homebrew no se puede usar el modo suspensión ya que la consola se bloquea. Hay algún modo de poder usarlo? Da bastante palo tener que hacer todo el proceso de cero casa vez que tienes que apagar la pantalla aunque solo sea por unos minutos.

Gracias y saludos.

Yo lo he probado en 5.0.2 y el sonido sí que funciona, prueba apretar el + en el menu y activar sonido. No recuerdo si era apretando + únicamente o + y - al mismo tiempo, pero al hacerlo te sale un menú en el cual puedes activar el sonido.

Respecto a jugar a jugar a dobles, cada uno con un joycon, os comento lo que me funciona: Una vez cargas el juego, apretas - para dar almenos un crédito, en ese momento ya puedes sacar los joycons y debes apretar primero el boton del analógigo del joycon izquierdo para que lo detecte, Luego ya puedes apretar el del derecho para que te lo detecte también y, a disfrutar en compañía. XD


Ya he conseguido que funcione el sonido, efectivamente había que activarlo en un menú del programa. Sin embargo lo de los joycons no consigo que los detecte como dos mandos independientes. ¿podrias explicar un poco mejor como lo has logrado?

Gracias y saludos.
Tiene problemas con la bateria igual que linux?

Gracias!
@Rodimus creo que en la ultima versión han capado el soporte para dos, pero todo es mirar y mapear los botones. Seguramente en la próxima versión lo implementaran de nuevo.

@[Lande] por lo que he trasteado no, no he visto un drenaje exagerado ni que se descalibre.
Rodimus escribió:
Uliga escribió:
Rodimus escribió:Funciona perfectamente en 5.0.0. Entiendo que el tema del sonido de momento no se ha podido arreglar, verdad? El sonido no funciona, es problema de mi configuración o es que aún no está funcional?

Por cierto hago aquí una consulta, cuando uso el Homebrew no se puede usar el modo suspensión ya que la consola se bloquea. Hay algún modo de poder usarlo? Da bastante palo tener que hacer todo el proceso de cero casa vez que tienes que apagar la pantalla aunque solo sea por unos minutos.

Gracias y saludos.

Yo lo he probado en 5.0.2 y el sonido sí que funciona, prueba apretar el + en el menu y activar sonido. No recuerdo si era apretando + únicamente o + y - al mismo tiempo, pero al hacerlo te sale un menú en el cual puedes activar el sonido.

Respecto a jugar a jugar a dobles, cada uno con un joycon, os comento lo que me funciona: Una vez cargas el juego, apretas - para dar almenos un crédito, en ese momento ya puedes sacar los joycons y debes apretar primero el boton del analógigo del joycon izquierdo para que lo detecte, Luego ya puedes apretar el del derecho para que te lo detecte también y, a disfrutar en compañía. XD


Ya he conseguido que funcione el sonido, efectivamente había que activarlo en un menú del programa. Sin embargo lo de los joycons no consigo que los detecte como dos mandos independientes. ¿podrias explicar un poco mejor como lo has logrado?

Gracias y saludos.

Jeje, espero explicarlo mejor. Con los dos joycons puestos, primero cargas el juego, luego apretas el boton "-" (joycon izquierdo) para poner creditos, una vez tengas creditos, sacas los dos joycons y apretas el boton del analogico del joycon izquierdo, en ese momento te lo detecta como player 1. Puede que empiece la partida pero si apretas el boton "+" (joycon derecho) te lo detectará como player 2 y aparecerá en el juego. Espero te sirva.
[Lande] escribió:Tiene problemas con la bateria igual que linux?

Gracias!


El problema de la bateria no es de linux sino de usar un SO distinto al oficial, pasara siempre que se arranque un SO distinto al oficial que este activo, igualmente pasara al por ejemplo cargar una emunand. Mientras que todo este en un solo SO no habra problemas de bateria.

Saludos
Entiendo que pfba carga con el os de switch??

0 desincronización entoces.
[Lande] escribió:Entiendo que pfba carga con el os de switch??

0 desincronización entoces.

Si, asi es.
Si me da "Driver init Failed" cuando intento abrir las Roms sabéis cual puede ser el problema? BIOS?
@kuatro parece romset, miratelo que el que tengas sea igual o inferior al soportado.
Funcionan los shaders en esta versión de SWITCH?


Saludos!
kai_dranzer20 está baneado por "Game Over"
No sé porqué nadie había creado este hilo, funciona perfecto en 4.1 :)
Alucinado estoy de lo tremendamente bien q funciona este emu.Es un lujo poder jugar así en esta consola.

No quiero ni pensar todo lo q va a salir en los próximos meses !!!
Salamander de msx con dos mandos es una delicia. Me falta un boton para el f5 de continue. No se si se podra hacer.
inu64 escribió:Salamander de msx con dos mandos es una delicia. Me falta un boton para el f5 de continue. No se si se podra hacer.

dentro del juego puedes editar los botones, así que mira a ver...
etolini escribió:
inu64 escribió:Salamander de msx con dos mandos es una delicia. Me falta un boton para el f5 de continue. No se si se podra hacer.

dentro del juego puedes editar los botones, así que mira a ver...


Lo malo es que es un boton del teclado y no creo que hayan pensado en ello ya que es un ordenador
Pregunta: Para jugar a los shooters verticales, se puede poner la Switch en vertical???

Gracias por las respuestas.
@Mordr3d si se puede, hay una opcion que es rotate, por defecto creo que te los pone así ( para jugar a los bullethell como dondonpachi me va genial)

@inu64 creo que habrán pensado en ello, míralo a ver.
yo estoy en 3.0.0 con pfba 1.50 y el sonido no me va para nada, algun consejo??
@_PaPaUpA_ y mirar que tengas el sonido on en el menu de pFBA
Yo tengo el sonido puedo pero en el link del primer post solo esta la 1.50 donde consigo la 1.55???
_PaPaUpA_ escribió:Yo tengo el sonido puedo pero en el link del primer post solo esta la 1.50 donde consigo la 1.55???


Aquí tienes la última versión

https://github.com/Cpasjuste/pfba/releases
La verdad es que va genial este emulador, lástima que no funcione en modo dock para jugar en la TV, ¿Se sabe si implementarán esta función?
A mi me fallo al principio, pero al tiempo volvi a probar en el modo dock y me fue bien.
Intenta poner la switch con los mandos quitados en el dock.
Saludos
x-twin escribió:A mi me fallo al principio, pero al tiempo volvi a probar en el modo dock y me fue bien.
Intenta poner la switch con los mandos quitados en el dock.
Saludos

Ok, lo probaré, muchas gracias!
Uliga escribió:La verdad es que va genial este emulador, lástima que no funcione en modo dock para jugar en la TV, ¿Se sabe si implementarán esta función?


¿Te refieres a cuando estás jugando y salta un error con la pantalla en negro? Pensaba que sólo me pasaba a mí... Se supone que no se puede usar el emulador en el dock?

Y otra cosa, hay alguna manera de ver una imagen del juego antes de cargarlo, tal como sale en la imagen del creador del post?

Saludos.
Ayer lo probe en la mia con el 4.0.1 y funciona perfectamente, no todas las rom pero me jugue buenos vicios al Final Fight.
@Rodimus poniendo la imagen dentro de pfba, en una carpeta llamada covers creo recordar.

para más info tenéis el hilo original ya que yo solo enlacé la noticia, ni soy el creador ni nada
Lo suyo seria un tuto para arrancarlo.
Rodimus escribió:
Uliga escribió:La verdad es que va genial este emulador, lástima que no funcione en modo dock para jugar en la TV, ¿Se sabe si implementarán esta función?


¿Te refieres a cuando estás jugando y salta un error con la pantalla en negro? Pensaba que sólo me pasaba a mí... Se supone que no se puede usar el emulador en el dock?

Y otra cosa, hay alguna manera de ver una imagen del juego antes de cargarlo, tal como sale en la imagen del creador del post?

Saludos.

Es lo que comentas, cuando lo pongo en el dock, me sale error. Tengo que probarlo sin los joycons puestos a ver qué.
Respecto a lo de ver las imagenes, busqué los "previews" y los "titles" (que son imagenes en png de cada juego) y los puse en las carpetas con esos nombres dentro de pfba.
Saludos
@[Lande] tuto:

Ir a la pagina de la Noticia de GBAtemp. Aquí
Bajar la ultima versión: Aquí
Poner el contenido del zip en la SD dentro de la carpeta switch
Buscar el romset adecuado.( Mirar noticia original): pack de roms
Dentro de la carpeta pfba poner todas las roms donde indica el hilo original.
A jugar

Pero claro, esto estaria echo si se lee directamente la noticia original que está en la primera pag...
si es que hay pocas ganas de seguir los pasos, lo queremos todo echo [mamaaaaa]
@etolini geacias por la respuesta.

En ningun link de la primera página viene como hacerlo cargar en switch, por eso pregunte, soy de los que suele leer incluso facilitar las cosas a los demás.

Un saludo.

Edit: en concreto me referia a como cargarlo por ejemplo en 4.0.1
750 respuestas
1, 2, 3, 4, 516