(HO) NSC_Builder 1.01B. Multiherramienta conversor nsp\xci, verificación e información de archivos..

@chekbo nunca he tenido ningún problema, me va como si estuviera normal la cosa.
RolleR escribió:@chekbo nunca he tenido ningún problema, me va como si estuviera normal la cosa.


Pero estás en la última versión de firm? Yo estoy en la última.
hellionz escribió:@JulesRussel si te da por ponerle un GUI ....seria cuasiperfecto.....o una barrita de progreso para los archivos grandes xDDD

Estoy convirtiendo un par de NSP a XCI y esta tarde pruebo

Con esta herramienta no seria necesario instalas lor certificados para que funcione no? metes el XCI y a rodar

Muchas gracias, buen script de python , yo que estoy aprendiendo por tema profesional aun me cuesta scriptar XDDD

saludos

Es que me resulta más cómodo así que con una gui. Lo único que veo que podría facilitaros es la elección de archivos.
Pero la verdad veo más rápido arrastrar directamente los archivos y carpetas y el modo manual es mi respuesta a lo de la gui ya que permite crear listas para procesarlas.
Veo las guis más lentas al tener que usar el explorador para buscar los archivos. Solo creo que me podrían aportar mostrar la imagen del jugo que estoy procesando.

En cuanto a lo de la barra supongo que acabaré pasando a usar la opción "create" de nut, la cuál la usa, aunque sea tirar sí o sí de dependencias.

La parte de Python es casi toda de blawar realmente, tengo modificaciones pero la mayoría están sin meter. Para convertir en masa esperaría al lunes, tengo algo preparado que merecerá la pena.
chekbo escribió:
RolleR escribió:@chekbo nunca he tenido ningún problema, me va como si estuviera normal la cosa.


Pero estás en la última versión de firm? Yo estoy en la última.


Sí estoy en la 6.0.1 y acabo de probar el hollo Knight con todos los dlc y no me da ningún error.
@RolleR Creo que es porque él está en ReiNX y tú en SX OS. TX parece que parcheo esto correctamente con los sigpatches, aunque según me dijeron Rei también.
@chekbo ¿Estás seguro de que tienes los últimos sigpatches de Rei y que están activos? Yo suelo hacer Tomger sobreescribir con Metheos y luego con el último ReiNX.
@JulesRussel Por mi parte puedo decir que estoy en SXOS, con lo de carga de XCI ya se supone [looco]
JulesRussel escribió:@RolleR Creo que es porque él está en ReiNX y tú en SX OS. TX parece que parcheo esto correctamente con los sigpatches, aunque según me dijeron Rei también.
@chekbo ¿Estás seguro de que tienes los últimos sigpatches de Rei y que están activos? Yo suelo hacer Tomger sobreescribir con Metheos y luego con el último ReiNX.


@JulesRussel Realmente estoy en SX OS también con la última versión 2.2, ya que recibí el dongle y la licencia esta semana. Lo que hice fue pasar por el NUT backups en formato nsp a xci, y los updates y dlc limpiados en nsp sin titles, pero cuando inició el juego me continúa saliendo el mensaje de "que tengo contenido descargado que no se puede utilizar y que necesito conectarme a internet para comprobaciones". Los nsp los instalo desde el mismo instalador del SX.

Por tanto me sucede lo mismo que con ReiNX con juegos como Pokemon, Snipperclips, Mario y Rabbids.....ya no entiendo que puede ser.

Muchas gracias!
@chekbo Hmm me habían dicho que eso ya no pasaba. Igual es @Roller usa el xci como base.
@JulesRussel @chekbo en algunos sí uso XCI como base, pero por ejemplo Hollow Knight no hay XCI, yo pasé el juego NSP a XCI, y luego las actas y DLCs a NSP sin titules y me va perfecto.
He pasado el NBA 2K Playgrounds 2 por el NUT para pasar de NSP a XCI y me pasa lo que me pasaba con el Armello o Pinball FX3, lo inicio y al poco "se ha cerrado el programa a causa de un error". Tengo Xecuter 2.2 y Firm 6 de Switch.
@twiggyfilth Ni idea, lo único que sea cosa de 6.0. Acuérdate que armello y pinball los había probado yo convertidos en 5.1.
La opción 2 qie te queda es probar a convertirlos con titlerights einstalar los tickets con mi otro programa xci_batchbuilder. A ver si te pasa lo mismo.
Unos pocos tickets tampoco tienen porqué ser malos, además ahora con deez los podeis borrar fácilmente antes de entrar en los servicios online. Luego los reinstalais con el [lc].nsp
RolleR escribió:@JulesRussel @chekbo en algunos sí uso XCI como base, pero por ejemplo Hollow Knight no hay XCI, yo pasé el juego NSP a XCI, y luego las actas y DLCs a NSP sin titules y me va perfecto.


@RolleR @JulesRussel Sigo haciendo pruebas, y probé con el DBZ, Pokemon Tournament y Mario y Rabbids con XCI como base y me sucede lo mismo con los dlc limpiados con el Nut, el error con el contenido descargado.

Si puede el compañero que pruebe con los backups que cito arriba para comprobar si le aparece error también.

Por otro lado con el backup del NBA PLAYGROUNDS 2 en nsp convertido a xci con Nut da error y no llega a arrancar.
Os confirmo que el Playgrounds 2 con el Xci Builder me funciona. Lo paso a Xci y me da error, pero le instalo la licencia LC\tickets y entonces si me funciona. Segun comentas Jules, esto parece pasar en 6.0, porque a ti en 5.1 te funcionaban el Armello y Pinball FX3. Probare estos dos a ver si con el Xci Builder me funcionan.
@twiggyfilth Sí, prece ser que en 6.X hay juegos/dlc en los que da problemas la eliminación de titlerights de diversas formas por lo que me comentais. Con xci builder no te debería de dar problemas ya que los nca siguen siendo idénticos que en el nsp, lo malo es la necesidad de instalar el ticket.
Hoy me ha pasado una cosa muy curiosa. Ayer probe el dark soul en xci y funciono correctamente. Luego lo pase por el nx trimmer para reducir el tamaño y al probarlo en la consola esta me pide actualizarla... no entiendo que es lo que ha podido pasar.
Mi consola esta en 5.1 y uso SX os 2.2

Edito: ni caso, que habia instalado la actualizacion del juego, que pide firm 6.0. la he desinstalado y listo
chekbo escribió:
RolleR escribió:@JulesRussel @chekbo en algunos sí uso XCI como base, pero por ejemplo Hollow Knight no hay XCI, yo pasé el juego NSP a XCI, y luego las actas y DLCs a NSP sin titules y me va perfecto.


@RolleR @JulesRussel Sigo haciendo pruebas, y probé con el DBZ, Pokemon Tournament y Mario y Rabbids con XCI como base y me sucede lo mismo con los dlc limpiados con el Nut, el error con el contenido descargado.

Si puede el compañero que pruebe con los backups que cito arriba para comprobar si le aparece error también.

Por otro lado con el backup del NBA PLAYGROUNDS 2 en nsp convertido a xci con Nut da error y no llega a arrancar.


@chekbo @JulesRussel Pues he probado con el DBZ fighter y si, da error, "Se ha encontrado contenido descargable que no s epuede utilizar. Debes conectar la consola a internet para llevar a cabo una comprobación más detallada." y con botones inciar el programa, cancelar o comprobar.
Si le das a iniciar el programa, no he encontrado ninguna falta de ningún DLC. Esto se puede reparar de alguna manera?

En el hollow knight no me pasa, y eso que tengo todos los DLC también, como en el DBZ. Podría ser que los DLC de hollow knight los vea como updates?
Tambieén puede ser, aunque lo veo menos probable, que el DBZ ya es backup de un xci, y el hollow es un nsp convertido a xci? Hoy probaré de pasar el DBZ nsp a xci para probarlo, puede que si es un juego fisico con su backup a XCI, acepta las actualizaciones nsp pasadas por el nut, pero de error si este juego tiene DLC's pasados por el nut, en cambio juegos que son nsp pasados a xci por el nut, updates y dlc's pasados por el nut no den error... Voy a corroborar todo esto pasando el nsp del DBZ fighter a xci con el nut.
Si no, también se podría probar de reinstalarlo ya todo desde la 6.0.1, quizás ha sido al subir de versión con todo ya instalado, lo has probado @chekbo ? Quizá si borramos todo el contenido de DBZ de la switch y lo volvemos a poner desde 6.0.1 no se queje con el error.
Saludos!
@RolleR Mi teoría es que eso pasa en los juegos que tienen deltas y que es simplemente una validación de integridad del contenido. Diría que lo más fácil sería avisar a los de SX para que lo parcheen y no de el mensaje. Habría que ver también metiéndolos dentro del xci ya que este hace una validación distinta.
Los deltas según switchbrew almacenan nombre y hash de nca referidos en actualizaciones antiguas así que creo que ahí puede estar el tema.
JulesRussel escribió:@RolleR Mi teoría es que eso pasa en los juegos que tienen deltas y que es simplemente una validación de integridad del contenido. Diría que lo más fácil sería avisar a los de SX para que lo parcheen y no de el mensaje. Habría que ver también metiéndolos dentro del xci ya que este hace una validación distinta.
Los deltas según switchbrew almacenan nombre y hash de nca referidos en actualizaciones antiguas así que creo que ahí puede estar el tema.


Vamos, que con todo lo que he comentado anteriormente no creo que se arregle? [+risas]
A ver como se lo explico esto a xecuter
@RolleR
Dudes with ticketless nsp I've got this issue.
(pantallazo del mensaje)
It only happens in FW6.X not in FW5.1. DLCs are working fine by the way even after showing that message.
Dev told me it seems to be an integrity check. Can you patch it like in FW5.1 so it doesn't give the message?

Algo como eso.
RolleR escribió:
chekbo escribió:
RolleR escribió:@JulesRussel @chekbo en algunos sí uso XCI como base, pero por ejemplo Hollow Knight no hay XCI, yo pasé el juego NSP a XCI, y luego las actas y DLCs a NSP sin titules y me va perfecto.


@RolleR @JulesRussel Sigo haciendo pruebas, y probé con el DBZ, Pokemon Tournament y Mario y Rabbids con XCI como base y me sucede lo mismo con los dlc limpiados con el Nut, el error con el contenido descargado.

Si puede el compañero que pruebe con los backups que cito arriba para comprobar si le aparece error también.

Por otro lado con el backup del NBA PLAYGROUNDS 2 en nsp convertido a xci con Nut da error y no llega a arrancar.


@chekbo @JulesRussel Pues he probado con el DBZ fighter y si, da error, "Se ha encontrado contenido descargable que no s epuede utilizar. Debes conectar la consola a internet para llevar a cabo una comprobación más detallada." y con botones inciar el programa, cancelar o comprobar.
Si le das a iniciar el programa, no he encontrado ninguna falta de ningún DLC. Esto se puede reparar de alguna manera?

En el hollow knight no me pasa, y eso que tengo todos los DLC también, como en el DBZ. Podría ser que los DLC de hollow knight los vea como updates?
Tambieén puede ser, aunque lo veo menos probable, que el DBZ ya es backup de un xci, y el hollow es un nsp convertido a xci? Hoy probaré de pasar el DBZ nsp a xci para probarlo, puede que si es un juego fisico con su backup a XCI, acepta las actualizaciones nsp pasadas por el nut, pero de error si este juego tiene DLC's pasados por el nut, en cambio juegos que son nsp pasados a xci por el nut, updates y dlc's pasados por el nut no den error... Voy a corroborar todo esto pasando el nsp del DBZ fighter a xci con el nut.
Si no, también se podría probar de reinstalarlo ya todo desde la 6.0.1, quizás ha sido al subir de versión con todo ya instalado, lo has probado @chekbo ? Quizá si borramos todo el contenido de DBZ de la switch y lo volvemos a poner desde 6.0.1 no se queje con el error.
Saludos!


@RolleR @JulesRussel Buenas compañeros, comentar que en el caso del DBZ probé también a convertir el bakcup nsp en xci con el Nut y aparecía el mensaje igualmente. No hay modo de momento de saltarse el error en estos juegos, deberemos esperar a Xecuter como comentó JulesRussel.
@chekbo Por mi parte he enviado a xecuter el mensaje que ha escrito @JulesRussel
Saludos!
RolleR escribió:@chekbo Por mi parte he enviado a xecuter el mensaje que ha escrito @JulesRussel
Saludos!


Ok perfecto. Otro backup que da error con los Dlc es el Sonic manía en formato nsp.
He probado a limpiar y convertir a xci el nba 2k playground como comento el compañero @twiggyfilth pero al iniciar el juego me aparece este mensaje y no me deja utilizarlo.


Es posible que se haya desvinculado la cuenta nintendo utilizada para adquirir este programa o que esta concosla ya no este registrada como la consola activa para descargas de tu cuenta nintento.
@adir Porque no te funcionó nut y te está pidiendo el "ticket".

Repasa si instalaste bien las dependencias de python así como python 3. Si no ves algo similar a esto nut no funciona:
Imagen

So te da igual la instalación de ticket puedes usar también xci_batch_builder.
JulesRussel escribió:@adir Porque no te funcionó nut y te está pidiendo el "ticket".

Repasa si instalaste bien las dependencias de python así como python 3. Si no ves algo similar a esto nut no funciona

So te da igual la instalación de ticket puedes usar también xci_batch_builder.



Despues probare, lo primero que instale fue el python a la ultima version si es verdad q no me ha dado ningun fallo pero creo que no vi nada relacionado con la imagen.
@adir Ncesitas ejecutar tambien el install-dependencies.bat
Me falta el TID de un backup, ¿funciona el NSP sin él en la descripción? Por otro lado, dónde hay una base de datos de TID, la tenía pero ni me acuerdo ya dónde está...
@Mobutu16 ¿Si lo convierte dices? Sí, en la v0.4 le añadí que lo lea del nca meta. Puedes convertir a un juego llamado juego.nsp sin problemas usando el cleaner. Incluso si te funciona nstool y activas la opción 10 cambiándole el valor a true te lo renombrará añadiendo el nombre, la titleid,...
Por defecto creo que está en valor "oinfo"->output info y le añade las tags [titleid][v0][ipd][dlc][vnumber] según corresponda.

La mejor actualmente de la scene: http://datomatic.no-intro.org
La otra: http://nswdb.com

También te lo dan xci-explorer y switch backup manager, si bien al menos en la release anterior no funcionaban con cosas sin ticket en los nsp ya que leían la id donde no debían en los nsp. En vez de en los nca la leían creo que en el cnmt.xml (creo que con los mios si funciona porque dejo el xml dentro)
Offtopic: El tio que hace no-intro me dijo que se llama así porque solo incluye releases sin intro, así que aunque tiene bases de datos de gameboy, gba,... si fueron releases con a intro en el boot del grupo de releases los deja fuera.
JulesRussel escribió:@Mobutu16 ¿Si lo convierte dices? Sí, en la v0.4 le añadí que lo lea del nca meta. Puedes convertir a un juego llamado juego.nsp sin problemas usando el cleaner. Incluso si te funciona nstool y activas la opción 10 cambiándole el valor a true te lo renombrará añadiendo el nombre, la titleid,...
Por defecto creo que está en valor "oinfo"->output info y le añade las tags [titleid][v0][ipd][dlc][vnumber] según corresponda.

La mejor actualmente de la scene: http://datomatic.no-intro.org
La otra: http://nswdb.com

También te lo dan xci-explorer y switch backup manager, si bien al menos en la release anterior no funcionaban con cosas sin ticket en los nsp ya que leían la id donde no debían en los nsp. En vez de en los nca la leían creo que en el cnmt.xml (creo que con los mios si funciona porque dejo el xml dentro)
Offtopic: El tio que hace no-intro me dijo que se llama así porque solo incluye releases sin intro, así que aunque tiene bases de datos de gameboy, gba,... si fueron releases con a intro en el boot del grupo de releases los deja fuera.


Aclarado y perfecto. Siempre al cañón, muchas gracias!!!!
Sabeis por qué el diablo III no pasa por el NUT y tampoco lo pasa a xci ??

Gracias !!!!!!!!
tinete escribió:Sabeis por qué el diablo III no pasa por el NUT y tampoco lo pasa a xci ??

Gracias !!!!!!!!



Todavía no ha salido:

http://datomatic.no-intro.org
tinete escribió:@Mobutu16 pues yo lo tengo ya.

a Mi con la V 0.4 si que me lo ha pasado a xci. Aunque no lo he pasado a la switch para probarlo, pero la conversion parece que ha ido sin problema
Esto puede servir para utilizar mi fifa 19 en la switch en la version 4.0.1?
Al final he tenido que retrasar la próxima versión. Fui demasiado ambicioso con lo que añadí.
@lolailo Probablemente fuera cosa de las opciones de renombrado. En la próxima versíon puedo prescindir de ellas, ahora copio los nca de dentro del nsp y elimino al vuelo los titlerights.
De todas formas las desactivas/configuras en el archivo de opciones "opciones 9 y 10".
@sckay No, no tiene nada que ver con eso.
lolailo escribió:
tinete escribió:@Mobutu16 pues yo lo tengo ya.

a Mi con la V 0.4 si que me lo ha pasado a xci. Aunque no lo he pasado a la switch para probarlo, pero la conversion parece que ha ido sin problema

Al fi al te fue el diablo compañero ?
Saludos
Lo estoy pasando ahora a un USB y lo pruebo. Lo que tarde en hacerlo y lo comento
lolailo escribió:Lo estoy pasando ahora a un USB y lo pruebo. Lo que tarde en hacerlo y lo comento

Gracias, esperaré a tus comentarios
Saludos
Pues nada, no me ha funcionado. Me sale en el SX OS y lo carga bien pero al iniciarlo salta un error.
@lolailo Me imagino que con la nueva versión que tengo funcionará, tendrá seguramente más de 4nca y aunque el programa borre el manual habrá algún nca tipo "data" o similar, tengo que mirarlo.
La otra alternativa sería que fuese problema de NUT como en el Xeno 2 o que esté mal el ticket. Intentaré echarle un vistazo hoy de noche con la versión que tengo en desarrollo.
Gracias @JulesRussel Esperare entonces a ver que es lo que pasa
Ahora no me reconoce el comando py (py no se reconoce como comando interno....)...meigas al poder, después de pasar bastantes, ha dejado de funcionar.

He vuelto a instalar el 3.7, y las dependencias ya no me funcionan, me dicen lo mismo, py no se recon….


¿Es posible que alguna actualización de Windows me haya influido? lo único que he hecho es pasar un malware, el SpyBot hace unos días...


Vaya tela.
lolailo escribió:Pues nada, no me ha funcionado. Me sale en el SX OS y lo carga bien pero al iniciarlo salta un error.

Gracias por la info compa
Saludos
@Mobutu16 Hmm bájate el máster de GitHub, tiene una opción para cambiar el comando, creo que es la 11 o 12 del archivo de opciones.
Prueba antes si te va con "python" y si no instala anaconda y cambia la instrucción por "conda".
En el archivo de instalar dependencias también usa la variable "pycommand" si no recuerdo mal.
JulesRussel escribió:@Mobutu16 Hmm bájate el máster de GitHub, tiene una opción para cambiar el comando, creo que es la 11 o 12 del archivo de opciones.
Prueba antes si te va con "python" y si no instala anaconda y cambia la instrucción por "conda".
En el archivo de instalar dependencias también usa la variable "pycommand" si no recuerdo mal.


Nada, soy incapaz. cagonlá
@Mobutu16 ¿Probaste a desinstalar e instalar como "path"? ¿Y a intentar introducir la instrucción desde la consola del sistema?
JulesRussel escribió:@Mobutu16 ¿Probaste a desinstalar e instalar como "path"? ¿Y a intentar introducir la instrucción desde la consola del sistema?


Correcto, siempre lo había hecho así...y ahora nada, "py no se reconoce como un comando interno o externo....blah, blah,,," tanto desde el bat tuyo como desde el cmd.

He borrado y vuelto a instalar con la opción PATH habilitada. LO que no acabo de entender es por qué desde que lo publicaste me ha funcionado perfecto y de repente ya no...eso me mata.


Gracias por preocuparte.
@Mobutu16 windows, actualizaciones, meigas informáticas... XD

lolailo escribió:Pues nada, no me ha funcionado. Me sale en el SX OS y lo carga bien pero al iniciarlo salta un error.

Me dicen que usa masterkey5 (FW 6.0) y que no son capaces a extraer el nca con lo que el problema está en nut.
Si no te importa instalar el [lc].nsp y usas xci_batchbuilder debería de funcionar.

@EVILRAVER Lo mismo digo, parece que pasa algo con la masterkey 6.0 que tenemos.
@JulesRussel más temprano que tarde seguro que dan con la tecla
Por cierto aún tengo pendiente de hacer la prueba con el hub usb que yo puse para ver si sirve para lo que te quieres, ya vez que no me he olvidado de ti compa
Saludos
1613 respuestas
15, 6, 7, 8, 933