[Hilo Oficial] Retropie

ppmateos escribió:
Thundertwin72 escribió:@ppmateos Sólo puedo contestarte a tu última duda: para entrar en el menú de Retroarch desde el juego has de pulsar SELECT + X


Gracias, me ha servido mucho la ayuda [beer]

Ahora he podido configurar los botones del panel de mandos accediendo a ese menu.

Pero me surge un pequeño problema: si pulso select + start en el teclado dentro de un juego me saca al menu de seleccion de roms. El problema es que solo me lo hace si lo hago con el teclado, se supone que he asignado bien los botones del mando al select y al start, y hacen su funcion dentro de los juegos, pero si los pulso a la vez no me sacan al menu de seleccion de roms... Que hago mal?


Depende del mando. A mi por ejemplo con el Mayflash no me saca de los juegos pulsando select+start. Pero con otros mandos arcade que tengo si que lo consigue.

De todas formas puedes salir desde el menu de Retroarch.
ppmateos escribió:
Thundertwin72 escribió:@ppmateos Sólo puedo contestarte a tu última duda: para entrar en el menú de Retroarch desde el juego has de pulsar SELECT + X


Gracias, me ha servido mucho la ayuda [beer]

Ahora he podido configurar los botones del panel de mandos accediendo a ese menu.

Pero me surge un pequeño problema: si pulso select + start en el teclado dentro de un juego me saca al menu de seleccion de roms. El problema es que solo me lo hace si lo hago con el teclado, se supone que he asignado bien los botones del mando al select y al start, y hacen su funcion dentro de los juegos, pero si los pulso a la vez no me sacan al menu de seleccion de roms... Que hago mal?


En las últimas versiones hay añadido el boton hotkey, por lo que para salir es hotkey+start o hotkey+select

Yo tengo asignado el hotkey al mismo boton que select, para que funcione como las versiones de antes.
ditifet escribió:
ppmateos escribió:
Thundertwin72 escribió:@ppmateos Sólo puedo contestarte a tu última duda: para entrar en el menú de Retroarch desde el juego has de pulsar SELECT + X


Gracias, me ha servido mucho la ayuda [beer]

Ahora he podido configurar los botones del panel de mandos accediendo a ese menu.

Pero me surge un pequeño problema: si pulso select + start en el teclado dentro de un juego me saca al menu de seleccion de roms. El problema es que solo me lo hace si lo hago con el teclado, se supone que he asignado bien los botones del mando al select y al start, y hacen su funcion dentro de los juegos, pero si los pulso a la vez no me sacan al menu de seleccion de roms... Que hago mal?


En las últimas versiones hay añadido el boton hotkey, por lo que para salir es hotkey+start o hotkey+select

Yo tengo asignado el hotkey al mismo boton que select, para que funcione como las versiones de antes.


En que version de retropie estas? y en que menú seleccionas estos hotkeys?
ppmateos escribió:
ditifet escribió:
ppmateos escribió:
Gracias, me ha servido mucho la ayuda [beer]

Ahora he podido configurar los botones del panel de mandos accediendo a ese menu.

Pero me surge un pequeño problema: si pulso select + start en el teclado dentro de un juego me saca al menu de seleccion de roms. El problema es que solo me lo hace si lo hago con el teclado, se supone que he asignado bien los botones del mando al select y al start, y hacen su funcion dentro de los juegos, pero si los pulso a la vez no me sacan al menu de seleccion de roms... Que hago mal?


En las últimas versiones hay añadido el boton hotkey, por lo que para salir es hotkey+start o hotkey+select

Yo tengo asignado el hotkey al mismo boton que select, para que funcione como las versiones de antes.


En que version de retropie estas? y en que menú seleccionas estos hotkeys?


4.4
Gente hace meses que no toco retropie en mi raspi 3, la última vez que lo usé psp aun dejaba mucho que desear en la raspi, esto ha avanzado mucho? los 3d rascaban demasiado.
Más que nada porque me ha parecido leer como si se estubiera emulando de lujo en la raspi 3.
Hola.

A ver si alguien puede ayudarme, soy bastante torpe en estas cosas.

Llevo tiempo queriendo tener un aparato donde poder jugar a las recreativas de los 90, finalmente me he hecho con una raspberry pi3+ y un stick mayflash f300.

Le he instalado Retropie 4.4 (en una sd de 32gb) y he metido algunas roms en la carpeta MAME4fall.

Todo va bien hasta que inicia el juego, me sale una ventana que pone:
Launching JUEGO (mame4all)...
Press a button to configure
Errors are logged to /dev/shm/runcommand.log

Si presiono sale otra ventana con opciones para modificar cosas como: resolución,...
Si no presiono nada se inicia el juego pero no puedo hacer nada, es como si los mandos/stick/teclado no funcionasen, no puedo ni salir del juego.

¿Cómo puedo solucionarlo? ¿Qué hago?

Llevo días buscando y debo ser lo peor porque no se qué hacer. [+furioso] [buuuaaaa] [mamaaaaa]

Gracias y saludos ;)
merynaiss escribió:Hola.

A ver si alguien puede ayudarme, soy bastante torpe en estas cosas.

Llevo tiempo queriendo tener un aparato donde poder jugar a las recreativas de los 90, finalmente me he hecho con una raspberry pi3+ y un stick mayflash f300.

Le he instalado Retropie 4.4 (en una sd de 32gb) y he metido algunas roms en la carpeta MAME4fall.

Todo va bien hasta que inicia el juego, me sale una ventana que pone:
Launching JUEGO (mame4all)...
Press a button to configure
Errors are logged to /dev/shm/runcommand.log

Si presiono sale otra ventana con opciones para modificar cosas como: resolución,...
Si no presiono nada se inicia el juego pero no puedo hacer nada, es como si los mandos/stick/teclado no funcionasen, no puedo ni salir del juego.

¿Cómo puedo solucionarlo? ¿Qué hago?

Llevo días buscando y debo ser lo peor porque no se qué hacer. [+furioso] [buuuaaaa] [mamaaaaa]

Gracias y saludos ;)


No tienes que usar ese emulador de mame, es antiguo y vetusto además no usa libretro. "consigue" el romset 0.78 y metelo dentro de mame-libtetro

Ya podrás usar el myflash sin problemas y no te dará el error
ditifet escribió:No tienes que usar ese emulador de mame, es antiguo y vetusto además no usa libretro. "consigue" el romset 0.78 y metelo dentro de mame-libtetro

Ya podrás usar el myflash sin problemas y no te dará el error


GRACIAS compañero. ;)

Con MAME2003 hay rom que no me van.

Al final he conseguido que me vayan los mandos, menos el Mayflash F300 que no me va la palanca. No se porque no me va dentro de los juegos sin por Retropie va genial. ¬_¬ ¬_¬ cawento
merynaiss escribió:
ditifet escribió:No tienes que usar ese emulador de mame, es antiguo y vetusto además no usa libretro. "consigue" el romset 0.78 y metelo dentro de mame-libtetro

Ya podrás usar el myflash sin problemas y no te dará el error


GRACIAS compañero. ;)

Con MAME2003 hay rom que no me van.

Al final he conseguido que me vayan los mandos, menos el Mayflash F300 que no me va la palanca. No se porque no me va dentro de los juegos sin por Retropie va genial. ¬_¬ ¬_¬ cawento


Cuáles? Porque el mame2003 es el emulador mame por excelencia en retropie. Mame4all o mame2000 que es el que usas tú se usaba en las primeras rpi a o en las zero ya que no necesita tanta potencia pero el romset es muy inferior.

O no usas el romset correcto o te bajas las roms a boleo sin mirar.

Pd: No debes usar las mismas ROMs que tienes en mame4all para mame2003, no?
ditifet escribió:
merynaiss escribió:
ditifet escribió:No tienes que usar ese emulador de mame, es antiguo y vetusto además no usa libretro. "consigue" el romset 0.78 y metelo dentro de mame-libtetro

Ya podrás usar el myflash sin problemas y no te dará el error


GRACIAS compañero. ;)

Con MAME2003 hay rom que no me van.

Al final he conseguido que me vayan los mandos, menos el Mayflash F300 que no me va la palanca. No se porque no me va dentro de los juegos sin por Retropie va genial. ¬_¬ ¬_¬ cawento


Cuáles? Porque el mame2003 es el emulador mame por excelencia en retropie. Mame4all o mame2000 que es el que usas tú se usaba en las primeras rpi a o en las zero ya que no necesita tanta potencia pero el romset es muy inferior.

O no usas el romset correcto o te bajas las roms a boleo sin mirar.


Yo apostaría por esto último [+risas] [+risas] ; me estoy desvirgando ahora en esto y las paginas que tenía guardadas como fiables ya no hay roms.

Hace un mes para mi las Raspberry eran una placas mierder que no sabía ni si valían para algo, pero buscando descubrí que podían ser la solución para poder jugar a las recreativas viejunas . Me compré una Rapberry Pi3b+, una carcasa Megapi (me encanta :p ), un Mayflash F300 y aquí me hayo; ilusionado, liado y perdido [+risas] [+risas]

Sólo quiero aprender, saber cual es lo mejor y donde está lo bueno. [tadoramo]
merynaiss escribió:
ditifet escribió:
merynaiss escribió:
GRACIAS compañero. ;)

Con MAME2003 hay rom que no me van.

Al final he conseguido que me vayan los mandos, menos el Mayflash F300 que no me va la palanca. No se porque no me va dentro de los juegos sin por Retropie va genial. ¬_¬ ¬_¬ cawento


Cuáles? Porque el mame2003 es el emulador mame por excelencia en retropie. Mame4all o mame2000 que es el que usas tú se usaba en las primeras rpi a o en las zero ya que no necesita tanta potencia pero el romset es muy inferior.

O no usas el romset correcto o te bajas las roms a boleo sin mirar.


Yo apostaría por esto último [+risas] [+risas] ; me estoy desvirgando ahora en esto y las paginas que tenía guardadas como fiables ya no hay roms.

Hace un mes para mi las Raspberry eran una placas mierder que no sabía ni si valían para algo, pero buscando descubrí que podían ser la solución para poder jugar a las recreativas viejunas . Me compré una Rapberry Pi3b+, una carcasa Megapi (me encanta :p ), un Mayflash F300 y aquí me hayo; ilusionado, liado y perdido [+risas] [+risas]



Te lo he dicho antes, CONSIGUE el romset 0.78 y te irán el mayflash y el 99.9999% de las roms sin problema
ditifet escribió:
merynaiss escribió:
Yo apostaría por esto último [+risas] [+risas] ; me estoy desvirgando ahora en esto y las paginas que tenía guardadas como fiables ya no hay roms.

Hace un mes para mi las Raspberry eran una placas mierder que no sabía ni si valían para algo, pero buscando descubrí que podían ser la solución para poder jugar a las recreativas viejunas . Me compré una Rapberry Pi3b+, una carcasa Megapi (me encanta :p ), un Mayflash F300 y aquí me hayo; ilusionado, liado y perdido [+risas] [+risas]



Te lo he dicho antes, CONSIGUE el romset 0.78 y te irán el mayflash y el 99.9999% de las roms sin problema


¡¡Qué vale!!! ¡¡Qué sí!! Que tienes razón!! Qué me estaba complicando la vida, pa' na!! [carcajad] [carcajad] [jaja] [jaja]

Me va todo perfecto; muchas gracias compi ;) [plas] [plas]

[oki]
Ho!a qué tal alguien me puede ayudar tengo unas dudas primero es con la tecla hotskey en el mando de super Nintendo como la asigno si tengo todos los botones asignado , se puede hacer dos botones a la vez?por ejemplo selet y star y otra cosa una vez configurado el mando al principio esa configuración vale ya dentro de los emuladores o hay que volver a configurar por el propio emulador uno por uno? Tengo la rasberry pi3+ y por último como se pone la tecla de @ en el teclado para poner la contraseña de la red wifi? no se poner esa tecla
periquinx escribió:Ho!a qué tal alguien me puede ayudar tengo unas dudas primero es con la tecla hotskey en el mando de super Nintendo como la asigno si tengo todos los botones asignado , se puede hacer dos botones a la vez?por ejemplo selet y star y otra cosa una vez configurado el mando al principio esa configuración vale ya dentro de los emuladores o hay que volver a configurar por el propio emulador uno por uno? Tengo la rasberry pi3+ y por último como se pone la tecla de @ en el teclado para poner la contraseña de la red wifi? no se poner esa tecla


Hotkey lo idóneo es que la asignes al mismo botón que has asignado select y te actuará como la anteriores versiones que pulsabas select + boton para las funciones

La @ si no recuerdo mal es alt + E
ditifet escribió:
periquinx escribió:Ho!a qué tal alguien me puede ayudar tengo unas dudas primero es con la tecla hotskey en el mando de super Nintendo como la asigno si tengo todos los botones asignado , se puede hacer dos botones a la vez?por ejemplo selet y star y otra cosa una vez configurado el mando al principio esa configuración vale ya dentro de los emuladores o hay que volver a configurar por el propio emulador uno por uno? Tengo la rasberry pi3+ y por último como se pone la tecla de @ en el teclado para poner la contraseña de la red wifi? no se poner esa tecla


Hotkey lo idóneo es que la asignes al mismo botón que has asignado select y te actuará como la anteriores versiones que pulsabas select + boton para las funciones

La @ si no recuerdo mal es alt + E

Muchas gracias ya te contaré y otra cosa por qué no me guarda la configuración del mapeo de teclas cuando entro en un emulador por ejemplo el MSX y no me funciona el mando hay que configurar también el mando para cada uno de emuladores?y para salir de los emuladores que combinación de botón hay hacer con el hotkey
periquinx escribió:
ditifet escribió:
periquinx escribió:Ho!a qué tal alguien me puede ayudar tengo unas dudas primero es con la tecla hotskey en el mando de super Nintendo como la asigno si tengo todos los botones asignado , se puede hacer dos botones a la vez?por ejemplo selet y star y otra cosa una vez configurado el mando al principio esa configuración vale ya dentro de los emuladores o hay que volver a configurar por el propio emulador uno por uno? Tengo la rasberry pi3+ y por último como se pone la tecla de @ en el teclado para poner la contraseña de la red wifi? no se poner esa tecla


Hotkey lo idóneo es que la asignes al mismo botón que has asignado select y te actuará como la anteriores versiones que pulsabas select + boton para las funciones

La @ si no recuerdo mal es alt + E

Muchas gracias ya te contaré y otra cosa por qué no me guarda la configuración del mapeo de teclas cuando entro en un emulador por ejemplo el MSX y no me funciona el mando hay que configurar también el mando para cada uno de emuladores?y para salir de los emuladores que combinación de botón hay hacer con el hotkey


Si el emu es de libretto y la configuración la haces dentro de retroarch tienes que marcar la opción "save on exit"

Para salir es exit en retroarch, creo que puedes salir con hotkey + un botón también
ditifet escribió:
periquinx escribió:
ditifet escribió:
Hotkey lo idóneo es que la asignes al mismo botón que has asignado select y te actuará como la anteriores versiones que pulsabas select + boton para las funciones

La @ si no recuerdo mal es alt + E

Muchas gracias ya te contaré y otra cosa por qué no me guarda la configuración del mapeo de teclas cuando entro en un emulador por ejemplo el MSX y no me funciona el mando hay que configurar también el mando para cada uno de emuladores?y para salir de los emuladores que combinación de botón hay hacer con el hotkey


Si el emu es de libretto y la configuración la haces dentro de retroarch tienes que marcar la opción "save on exit"

Para salir es exit en retroarch, creo que puedes salir con hotkey + un botón también

gracias al final he empezado de nuevo he creado una imagen nueva y ahora si me funciona todo bien es raro la verdad hecho lo mismo de antes en fin ahora si me funciona bien por ahora ,gracias por tu ayuda
@ditifet libretro leches... Lib-Retro
josete2k escribió:@ditifet libretro leches... Lib-Retro


Calla chondujoin o chonjudoir o choniyjhony

XD
sabeis si hay algun retroarch de 128 gigas que funcione en la raspbery pi 3b+ ?y otra cosa como puedo rampear las teclas de spectrum y amstrad por que cuando se configuro el mando al principio no me lo detecta en esas plataformas?
periquinx escribió:sabeis si hay algun retroarch de 128 gigas que funcione en la raspbery pi 3b+ ?y otra cosa como puedo rampear las teclas de spectrum y amstrad por que cuando se configuro el mando al principio no me lo detecta en esas plataformas?


en spectrum ni puta idea,pero en dosbox use un teclado de toda la vida de dios y lo mapea automaticamente el sistema
fakemaria escribió:
periquinx escribió:sabeis si hay algun retroarch de 128 gigas que funcione en la raspbery pi 3b+ ?y otra cosa como puedo rampear las teclas de spectrum y amstrad por que cuando se configuro el mando al principio no me lo detecta en esas plataformas?


en spectrum ni puta idea,pero en dosbox use un teclado de toda la vida de dios y lo mapea automaticamente el sistema

ok muchas gracias por cierto ¿que es dosbox?
periquinx escribió:
fakemaria escribió:
periquinx escribió:sabeis si hay algun retroarch de 128 gigas que funcione en la raspbery pi 3b+ ?y otra cosa como puedo rampear las teclas de spectrum y amstrad por que cuando se configuro el mando al principio no me lo detecta en esas plataformas?


en spectrum ni puta idea,pero en dosbox use un teclado de toda la vida de dios y lo mapea automaticamente el sistema

ok muchas gracias por cierto ¿que es dosbox?


Emulador de juegos de pc de ms-dos.
Buenas, me acabo de instalar RetroPie en mi raspberry y tengo una duda, ¿cómo puedo hacer para que en el listado de juegos me aparezcan todos a la izquierda?, en vez de estar centrados.

Otra cosa, he puesto el Tombi de PSX y el juego va genial pero el sonido falla mucho en las escenas de vídeo, como si petardeara constantemente, ¿a alguien más le pasa o sabe como solucionarlo?

Gracias de antemano!
por que en el menu de emustation le subo el sonido al 100% y cuando vuelvo a entrar esta al 0% ???? he conseguido sacar sonido por jack con los emuladores de snes y megadrive pero con el de mame no logro que saque sonido ,alguien me puede ayudar?
muskulman escribió:por que en el menu de emustation le subo el sonido al 100% y cuando vuelvo a entrar esta al 0% ???? he conseguido sacar sonido por jack con los emuladores de snes y megadrive pero con el de mame no logro que saque sonido ,alguien me puede ayudar?


Usas la salida analógica?
ditifet escribió:
muskulman escribió:por que en el menu de emustation le subo el sonido al 100% y cuando vuelvo a entrar esta al 0% ???? he conseguido sacar sonido por jack con los emuladores de snes y megadrive pero con el de mame no logro que saque sonido ,alguien me puede ayudar?


Usas la salida analógica?


si , la del jack , lo acabo de solucionar toqueteando los archivos de config , parece que tenia mal puesto el driver en el archivo
muskulman escribió:
ditifet escribió:
muskulman escribió:por que en el menu de emustation le subo el sonido al 100% y cuando vuelvo a entrar esta al 0% ???? he conseguido sacar sonido por jack con los emuladores de snes y megadrive pero con el de mame no logro que saque sonido ,alguien me puede ayudar?


Usas la salida analógica?


si , la del jack , lo acabo de solucionar toqueteando los archivos de config , parece que tenia mal puesto el driver en el archivo


Si por analógico solo tienes que ir al menu Retropie > raspiconfig y elegir jack 3.5

https://lofi-gaming.org.uk/blog/wp-cont ... setup2.png

Después en Retropie - Audio subir el audio PCM

https://i.stack.imgur.com/Aa9Tu.png

(no esta foto pero es calcada)

Así es como se controla el volumen analógico
Toma ya !! con post oficial y todo y yo sin saberlo XD [360º] . Alguien ha conseguido hacer funcionar lr-hatari ?¿


Justo preguntarlo y dar con el error que me volvia loco "Tos.img a tos.img". [looco]
Hola buenas, tengo una raspi 3+, utilizo retropie 4.4, tengo un mando de cable usb logitech precision y un tronsmart g mars 02 que se puede conectar con un receptor usb o en modo bluetooth y que creo que identifica retropie como un shanwan..
Me gustaria saber como configurar estos mandos para que me los reconozca con dreamcast, psp y psx... Los botones si me los reconoce pero la cruceta no... Echadme un cable xfa.. muchas gracias [bye] !!
Muy buenas. Hoy he actualizado, después de un tiempo, a la última versión disponible de Retropie en mi RB 3B.

Todo va bien, pero ahora al entrar en cualquier juego de cualquier plataforma me sale un contador de frames en la esquina inferior izquierda.

Haciendo búsquedas leí comentarios que dicen que se puede desactivar desde retroarch-video-display framerate, pero a mí no me aparece esa opción, y la única opción en la que me aparece "framerate" no me deja tocarla (N/A).

Cómo carajo oculto eso? Gracias!
Acabo de adquirir una raspberry, le instalo la imagen de retropie o tengo que instalarle algun s.o antes? Es posible cambiar el idioma de retropie,como? Gracias.
Buenas, tengo una Raspberry Pi 3b+ con retropie funcionando con diversas ROMs y quiero cambiar la SD por otra de mayor capacidad, ¿Basta con hacer una copia en la nueva SD o hace falta instalar todo de nuevo?
Lo que tienes que hacer es crear una imagen de la sd donde tienes retropie, grabarla en la nueva (primero la formateas con SDFormatter) y una vez arranques Retropie entras en RASPI-CONFIG para expandir el espacio y poder usar el tamaño total de la nueva tarjeta.
Malaguitar escribió:Muy buenas. Hoy he actualizado, después de un tiempo, a la última versión disponible de Retropie en mi RB 3B.

Todo va bien, pero ahora al entrar en cualquier juego de cualquier plataforma me sale un contador de frames en la esquina inferior izquierda.

Haciendo búsquedas leí comentarios que dicen que se puede desactivar desde retroarch-video-display framerate, pero a mí no me aparece esa opción, y la única opción en la que me aparece "framerate" no me deja tocarla (N/A).

Cómo carajo oculto eso? Gracias!


Nadie? Sigo sin dar con la tecla :(
Buenas tardes compañeros.
Estoy a punto de finalizar mi bartop con un kit de montaje donde puedo meter pantallas de hasta 25".
El caso es que el tamaño ideal es una de 24" (60 cm de diagonal), pero me encuentro que el vinilo del bezel para montar tiene un hueco de 43x29,25 cm. No queria cortarlo, y si monto esta television se quedarán tapados los laterales por el bezel. Unos 5 cm por cada lado. El alto es perfecto.

Hay manera en algun menu de retropie de configurar el ancho y el largo que sale por la television para ajustarlo justo al hueco del bezel.

Sino hay manera supongo que recortaré el bezel para liberar ese espacio, pero ya está pegado y me gusta que no quede tan fino.

Gracias de antemano
Prueba a activar el overscan y a jugar con sus parámetros en el config.txt
Hola a todos,

He reinstalado retropie para cambiar de sd a una de más capacidad, he montado un disco duro conectado al nas en la ruta /media/ROMs hasta aquí todo bien, si entro en las carpeta veo las ROMs del nas, ahora, he modificado el archivo es_systems.cfg para cambia la ruta a /media/ROMs pero no las pilla, sigue buscando las ROMs en la carpeta de ROMs por defecto, por ejemplo, meto una rom de Nes en la carpeta /media/ROMs/nes y al reiniciar no aparece el menú de Nintendo, la misma rom la meto en la carpeta por defecto de las ROMs, y ahora si aparece, me he asegurado en varias ocasiones que la ruta de es_systems.cfg es la nueva ¿de donde puede estar pillando es ruta? En la versión anterior solo lo modificaba ahí.

Edito: me respondo yo, el archivo que debía modificar era: /opt/retropie/configs/all/emulestation/es_system.cfg

Un saludo
Alguien ha probado la version 4.5?
Salió hace 1 o 2 dias. Veo que ponen una advertencia sobre un problema del video. Me la he descargado para hacer una instalacion limpia, porque despues de mas de 1 año sin lanzar una version nueva...le tengo ganas a ver
No se yo si dará problemas y esperarme a ver si actualizan
@Snake Plissken yo la tengo puesta y funcionando en una raspb 1b y sin problema.
Ok, pues a ver si me animo a probar
Hola a todos, quería saber que tal funcionan en Retropie con Raspi 3b+, los juegos de psx como los tomb raider, los 3 crash y los 3 spyros. Gracias y espero una respuesta :).
4893 respuestas
194, 95, 96, 97, 98