[Hilo Oficial] Retropie

Solinete escribió:Me han regalado una raspberry por los reyes, y ando buscando nuevas tarjetas de memoria para instalar el retropie, ¿qué capacidad me recomendais?

¿Como veis la emulación de psx y psp?

Por último, estoy buscando un mando que pueda usar con retropie, y en Amazon solo he visto el mando de la xbox360 con cable. Solo quiero un mando fiable y con cable, ¿Cuáles me recomendais?


Psx Perfecto en un 99,99% de juegos
PSP Mal en un 98% de juegos

Mando, el mejor que puedes comprar es el de 360 o un Dual shock3 / sisaxis
Hola...
Estoy probando el emulador scummvm y no se cómo se hace para que que salgan los juegos en la lista de emulationstation.

He arrancado el emulador he cargado el monkey y funciona pero el puntero me va lento y no se cómo sacar el teclado virtual.

A ver si me podéis ayudar...

Gracias y saludos.
Hola compañeros, me acabo de comprar una Raspberry y estoy trasteando con el Retropie pero tengo un problema y vengo en busca de ayuda.

El problema es que los emuladores que instalo desde el optional package no me salen en la lista del menu principal. He probado con varios por si era caso de uno en concreto pero no sale ninguno. El procedimiento que hago es entrar en Retropie setup voy a manage optional packages e instalo el emu que me interesa. En la carpeta de roms me crea las carpetas bien, pongo roms en ellos pero al reiniciar no me sale. En los emuladores que viene de serie si que a la que le meto alguna rom sí que me sale en el menú principal correctamente.

Para más info al principio instalé Kodi desde optional packages y me salió el menú "ports" donde estaba Kodi funcionando todo perfectamente. Seguí un tutorial que vi por ahi para que Kodi tuviera su propio menú y quedara mejor, sospecho que el problema puede venir de aqui.

Esto es lo que hice:

The first method here is a cleaner method that wont mess with the RetroPie setup script updates (note that in the future you will have to manually update the es_systems.cfg in .emulationstation as they arent overwritten on updates from RetroPie). Once you've installed kodi from the experimental menu of the setup script, Drop into a terminal with f4 or access the pi over SSH

create an es_systems.cfg file so that kodi will show up in emulationstation

1. sudo cp /etc/emulationstation/es_systems.cfg /home/pi/.emulationstation/es_systems.cfg

2. sudo nano /home/pi/.emulationstation/es_systems.cfg

3. add the following codeblock anywhere after <systemList>:

  <system>
    <fullname>Kodi</fullname>
    <name>kodi</name>
    <path>~/RetroPie/roms/kodi</path>
    <extension>.sh .SH</extension>
    <command>bash %ROM%</command>
    <platform>kodi</platform>
    <theme>kodi</theme>
  </system>
save you changes with ctrl+x , y , enter

Then make a kodi rom directory

4. mkdir /home/pi/RetroPie/roms/kodi
make a launch script:

5. sudo nano /home/pi/RetroPie/roms/kodi/kodi.sh

6. add the following line:
kodi-standalone
save you changes with ctrl+x , y , enter

make the launch script executable:

7. sudo chmod +x /home/pi/RetroPie/roms/kodi/kodi.sh

type emulationstation to go back into emulationstation and kodi should be there as its own system.



No tengo mucha idea de linux, entiendo algo más o menos de mis tiempos mozos de msdos pero no sé si he tocado algo que no debería. Sobre todo por la parte que dice: (note that in the future you will have to manually update the es_systems.cfg in .emulationstation as they arent overwritten on updates from RetroPie) aunque en teoría no debería haber problema.

Hay algo que estoy pasando por alto?

Gracias ;)
Muy buenas chicos!

Alguno sabe porqué cuando scrapeo con el sistema "Steven Selph's Scraper" el sistema de NES y PCENGINE no me los coge, el resto me lo ha cogido todo bien salvo algún juego que no ha encontrado. Muchas gracias.

Edit: Hablo de vídeos por supuesto.

Edit2: Me autorespondo, era problema de espacio, pensaba que los vídeos ocuparían menos, madremía.

Un saludo!
Buenas, tras semanas esperando mi raspbery pi 3 model B, Amazon me devuelve el dinero porque han perdido el paquete en el envio... La he pedido en otra tienda, por lo que aun no me he podido poner de lleno en el tema.

Mi idea era instalarme Retropie para cargar emuladores, pero he visto algo que me ha llamado mucho la atención [amor] . He visto que se puede cargar DosBox desde Retropie, pero no me queda claro que es la marca de RetroArch en la tabla de los emuladores que hay en la wiki, ¿es la compatibilidad que tienen con el uso de joysticks/mandos?

Otra duda que tengo, en otro foro leí que Retropie es compatible con los mandos de ps4 mientras están conectados por USB, pero no los veo mencionados en la wiki.

Y por último, que opción recomendais para cargar juegos de ordenador antiguos, he visto que alguien mencionaba rpix86, en la lista está el DosBox. También he visto alguna opción de pago, como exagear desktop, pero esto ya sería para juegos más modernos, tienen videos en los que funcionan bastante bien Counter Strike o Unreal Tournament. Habría algo como este ultimo pero gratuito ¿? [360º]
También tengo dudas con el emulador de pc de retropie. He puesto varias roms en sus respectivas carpetas de diferentes consolas y retropie los detecta, funcionando sin problemas.

Pero los juegos de PC antiguos (DOS), he puesto varios en la carpeta PC Engine que crea retropie en la memoria USB, cada uno en su propia carpeta, y no me aparece ninguno ni ningun emulador de PC ni DosBox ni nada así.

Algún consejo de como o donde debería poner los juegos de PC en el USB para que los reconozca retropie¿?

Por ejemplo uno de estos juegos tenia una subcarpeta llamada SAVE y al iniciar la raspberry se quedó bloqueada con un mensaje de error folder SAVE, así que supongo que no puede haber subcarpetas dentro de las carpetas de los juegos.

Gracias de antemano por cualquier ayuda!
bleiser escribió:Pero los juegos de PC antiguos (DOS), he puesto varios en la carpeta PC Engine que crea retropie en la memoria USB, cada uno en su propia carpeta, y no me aparece ninguno ni ningun emulador de PC ni DosBox ni nada así.

Algún consejo de como o donde debería poner los juegos de PC en el USB para que los reconozca retropie¿?



Has confundido la carpeta PC con PC Engine (esta última es una consola, mas conocida por Europa como Turbografx 16)
@bleiser La carpeta para dosbox, si no recuerdo mal, es Ports
Y @bleiser, añado que SI se pueden crear subcarpetas sin ningún problema
Emulador recomendado para neo geo?
doblete escribió:Emulador recomendado para neo geo?


lr-fbalpha indiscutiblemente
@ditifet muchas gracias por la recomendación.
Estaba probando los emuladores de msx con un mando de la 360, y por lo que parece tengo que mapear botones del teclado al mando, porque el joystick solo tiene 2 botones activos. Lo estuve probando a ojo con el menu de "input bind device" solo por probar si daba con alguna tecla mas del juego (metal gear 1 y 2). Y por lo que veo ahora al entrar al menu interno de settings de retropie (donde se eligen e instalan los emuladores) ya no se aceptan las opciones con el boton A (x en Ps) sino con el LB (L1), he probado dandole a default en las opciones de input bind device pero no cambia nada, y he probado a ponerlo como estaba pero aun dándole a guardar sigue igual. Lo curioso es que al poner un mando de ps4 la configuración es como era antes.

Hay alguna manera de mapear los botones del teclado al joystick sin afectar a los menús de opciones de retropie?

Tengo un par de consultas más xD Del emulador de dreamcast hay alguna manera de que se guarde la hora¿? Ya que siempre me la pide al iniciar una rom.

Y del emulador DosBox, se pueden mapear botones del teclado al joystick?

Gracias!!
doblete escribió:Emulador recomendado para neo geo?

eso depende del romset que tengas. no se puede recomendar ninguno sin saber cual usas.
doblete escribió:@ditifet muchas gracias por la recomendación.


De nada, tu usa lr-fbalpha independientemente del romset a usar, tanto si usas del 0.2.97.32 a 0.2.97.42 de fba como el 0.78 de mame, aunque para tenerlo separado, organizado y las últimas ROMs tochas como metal slug 5 o el X es recomendable las últimas de fba
claro los emuladores tienen su correspondiente romset para saltarselo y usar el que te venga en gana... :-|

Lo mejor es caso de hacer lo que te de la gana es usar el 2012 que al menos no tiene esa horrenda intro verde y funciona perfecto con los 148 juegos de neogeo
Modo ironic on:

Si usa el de hace 6 años o sea el 2012 y no uses la ultima version del fbalpha actualizado a dia de hoy

Modo ironic off:

Y usando el ultimo fbalpha puedes usar CUALQUIER romset de neogeo, todos funcionan perfectamente

Otra cosa seria un mame (2003 con 0.78, 2010 con 0.139, 2016 con .0159) pero eso es otro tema, el último de fbalpha que es el que te recomendé funciona cualquier romset de neogeo y obviamente al tener el core actual tiene mejoras.
(mensaje borrado)
@Canitoman en EOL no se da soporte a la piratería y tampoco se pueden poner enlaces de descarga a contenidos con derechos de autor.
Tengo una version antigua de retropie y quiero actualizar a la mas nueva y tengo una par de dudas:
1. Antes de nada haré una copia de seguridad.
2. Al actualizar voy a tener algun problema con las ROMS que ya tengo?
3.Con la nueva actulización que instale viene algo nuevo?

Gracias y espero que me ayudeis.
1. SIEMPRE copia de seguridad... tu post ha empezado como debe ser!!!! qué siempre nos come el ansia de hacer las cosas rápido y luego vienen las sorpresas!!!!

2. yo creo que no tendrás problemas. La duda la tengo en el emulador de MAME, por si te actualiza la versión y ya no es compatible con el mismo romset, pero seguramente todo siga funcionando (y de todas formas tiene tu backup!)

3. Aqui te dejo las novedades de la última versión (en inglés): https://retropie.org.uk/2017/09/retropie-4-3-released/
Estoy leyendo sobre el Netplay, y me parece increíble que esta opción se comente tan poco. Lo que he visto del tema son comentarios de versiones anteriores de hace más de un año en el que dicen que el rendimiento por LAN es aceptable en emuladores de nes, snes, y hasta megadrive.

Alguien que lo haya probado por internet podría compartir su experiencia¿? Es jugable para ambas partes o el host va a tener siempre una ventaja enorme¿?

He visto que recomiendan dividir el ping que se tenga por 16 y el resultado ponerlo en ambas partes como frames perdidos.

EDIT:
Por si alguno no lo sabía el Netplay permite jugar online, siendo el host el mando 1 y el invitado el mando 2.
bleiser escribió:Estoy leyendo sobre el Netplay, y me parece increíble que esta opción se comente tan poco. Lo que he visto del tema son comentarios de versiones anteriores de hace más de un año en el que dicen que el rendimiento por LAN es aceptable en emuladores de nes, snes, y hasta megadrive.

Alguien que lo haya probado por internet podría compartir su experiencia¿? Es jugable para ambas partes o el host va a tener siempre una ventaja enorme¿?

He visto que recomiendan dividir el ping que se tenga por 16 y el resultado ponerlo en ambas partes como frames perdidos.

EDIT:
Por si alguno no lo sabía el Netplay permite jugar online, siendo el host el mando 1 y el invitado el mando 2.


El problema del Netplay con emuladores es que si tu ping es mayor que 16ms (1 fotograma) tu juego y el de la otra persona se van a desincronizar sí o sí. No tiene nada que ver con el rendimiento, sino mas con la problemática de que en ambos juegos ocurra exactamente lo mismo frame a frame.

Si los juegos se desincronizan, pasará que en tu juego igual matas a un enemigo, pero en el juego de la otra persona has fallado el tiro. Entonces a lo mejor tu mueres en el juego de la otra persona, pero en tu juego sigues vivo, asi que mientras en tu juego te mueves aqui y allá, en el otro juego has reaparecido en una esquina de la pantalla, y entonces la posicion de tu jugador en tu juego será diferente que en el juego de la otra persona, por lo que la otra persona verá que disparas a enemigos invisibles, que ignoras a otros enemigos que te atacan y te matan, y esto será asi porque en tu pantalla no estarán ocurriendo las mismas cosas que en la suya.

La unica solución que veo a esto es que uno de los dos juegos (por ejemplo el host) mande savestates continuamente al otro juego y que este los vaya cargando, para mantener la sincronía. Pero no sé en qué medida esto afectará a la "fluidez" del juego de la persona que carga los savestates, sobre todo en cuanto al sonido.
hi-ban escribió:
bleiser escribió:Estoy leyendo sobre el Netplay, y me parece increíble que esta opción se comente tan poco. Lo que he visto del tema son comentarios de versiones anteriores de hace más de un año en el que dicen que el rendimiento por LAN es aceptable en emuladores de nes, snes, y hasta megadrive.

Alguien que lo haya probado por internet podría compartir su experiencia¿? Es jugable para ambas partes o el host va a tener siempre una ventaja enorme¿?

He visto que recomiendan dividir el ping que se tenga por 16 y el resultado ponerlo en ambas partes como frames perdidos.

EDIT:
Por si alguno no lo sabía el Netplay permite jugar online, siendo el host el mando 1 y el invitado el mando 2.


El problema del Netplay con emuladores es que si tu ping es mayor que 16ms (1 fotograma) tu juego y el de la otra persona se van a desincronizar sí o sí. No tiene nada que ver con el rendimiento, sino mas con la problemática de que en ambos juegos ocurra exactamente lo mismo frame a frame.

Si los juegos se desincronizan, pasará que en tu juego igual matas a un enemigo, pero en el juego de la otra persona has fallado el tiro. Entonces a lo mejor tu mueres en el juego de la otra persona, pero en tu juego sigues vivo, asi que mientras en tu juego te mueves aqui y allá, en el otro juego has reaparecido en una esquina de la pantalla, y entonces la posicion de tu jugador en tu juego será diferente que en el juego de la otra persona, por lo que la otra persona verá que disparas a enemigos invisibles, que ignoras a otros enemigos que te atacan y te matan, y esto será asi porque en tu pantalla no estarán ocurriendo las mismas cosas que en la suya.

La unica solución que veo a esto es que uno de los dos juegos (por ejemplo el host) mande savestates continuamente al otro juego y que este los vaya cargando, para mantener la sincronía. Pero no sé en qué medida esto afectará a la "fluidez" del juego de la persona que carga los savestates, sobre todo en cuanto al sonido.


Gracias por tu aporte, por lo que he leido los problemas de sincronizado afectan al sonido básicamente, y supongo que creando la perdida forzada de frames dependiendo del ping de la conexión es lo que facilita una jugabilidad pasable, teniendo un menor número de fps, pero solucionando el problema que mencionas. Puesto que host e invitado tienen que ponerse el mismo numero de frames perdidos por segundo, no deberían ocurrir esos problemas a menudo.

En otro foro un usuario comentaba que lo único que le funcionaba bien (teniendo ambos una conexión de 100mb y por cable) era el emulador de NES, lo que apuntan es que lo realmente importante es la velocidad de subida del host. Pero claro todo esto son post antiguos.

A ver si puedo probarlo este fin de semana con un coleguita, pero visto lo visto no creo que vaya a funcionar muy bien, aun teniendo conexiones de 100 y 50 megas xD
torrex00 escribió:1. SIEMPRE copia de seguridad... tu post ha empezado como debe ser!!!! qué siempre nos come el ansia de hacer las cosas rápido y luego vienen las sorpresas!!!!

2. yo creo que no tendrás problemas. La duda la tengo en el emulador de MAME, por si te actualiza la versión y ya no es compatible con el mismo romset, pero seguramente todo siga funcionando (y de todas formas tiene tu backup!)

3. Aqui te dejo las novedades de la última versión (en inglés): https://retropie.org.uk/2017/09/retropie-4-3-released/

No he visto que me he habias contestado jejeje. A eso es lo que me refería, que tipo MAME u otras por ejemplos alomejor la romset deja de funcionar...Probare a actualizar y ver que pasa.
Hace tiempo que no le doy uso a mi Pi3 y ahora estoy mirando el Attract Mode y me está dando el gusanillo.

El caso es que estoy viendo vídeos y en general me parece un poco regular, casi siempre se ve ese front de la máquina arcade que no me convence, pero también he visto esto en fotos:

Imagen

La verdad es que esto me gusta más. La carátula y el título del juego en grande y detrás el vídeo. ¿Sabeis si este front viene por defecto para poner? Si no es así, agradecería saber donde encontrarlo antes de ponerme a cacharrear, crear imágenes y demás.
que tal funciona DC en pi? Me interesa sobretodo el MSR
Nalgisa escribió:Hace tiempo que no le doy uso a mi Pi3 y ahora estoy mirando el Attract Mode y me está dando el gusanillo.

El caso es que estoy viendo vídeos y en general me parece un poco regular, casi siempre se ve ese front de la máquina arcade que no me convence, pero también he visto esto en fotos:

Imagen

La verdad es que esto me gusta más. La carátula y el título del juego en grande y detrás el vídeo. ¿Sabeis si este front viene por defecto para poner? Si no es así, agradecería saber donde encontrarlo antes de ponerme a cacharrear, crear imágenes y demás.


Hay varios temas para usar, en la propia pagina y en el foro tienes varios enlaces te recomiendo que lo instales y sigas el foro oficial, se pueden conseguir cosas muy muy chulas :)
Buenas chicos. La model 3b+ está a la vuelta de la esquina y nos va a traer un chip de cuatro núcleos ARM Cortex-A53 a 1,4 GHz y 64 bits, en vez de los 1,2 GHz del modelo anterior.

Creéis que esta leve mejora se va a notar jugablemente?

Van a fluir las roms de la 0.139 que actualmente se ejecutan muy justitas?

Y se van a poder ejecutar las mismas isos que en el modelo actual?
@debicho Por las primeras noticias que he visto, pocas cosas cambian: encapsulamiento del procesador (seguramente para mejorar la refrigeración), mejoras del puerto ethernet, WiFi compatible con redes de 5Ghz, Bluetooth mejorado... Vamos que lo que nos interesa a nosotros, para emulación, poco a cambiado: misma a RAM, misma GPU y mismo procesador, eso sí: este overclockeado de fábrica.

Es seguro que por aquí haya gente que sepa más de estas cosas pues yo, de conocimientos, los justos, pero me da a mí que pocas incompatibilidades van a verse con las I SOS actuales.

En fin, que no creo que (ojalá me equivoque) mejore mucho la emulación respecto a la Rpi3 "normal" con overclock.
Hola, estoy usando los overlays de rp video manager en retropie y cuando configuro el aspect ratio y la resolución no consigo que la imagen se centre dentro del overlay, alguien sabe que debo cambiar para que quede perfecto

https://www.dropbox.com/s/3mk2fzdfbdidi ... 7.jpg?dl=0

Gracias anticipadas

Edit: Solucionado tocando el aspect ratio custom y los valores x,y, weight y high [beer]
Buenas, estoy intentando configurar botones para usar como hotkeys pero sin tener que pulsar dos botones. He visto recreativas de gente que lo tiene así, y no sé cómo lo han hecho.
Pensé que configurando como hotkey_enable = "8" y la de pause = "8", solo tendría que pulsar esa tebla para pausar la partida y Efectivamente, así es, se pausa. Pero cómo puedo configurar varios botones como hotkey_enable??
Sabéis si se puede?
He probado aponer vario valores "7,8" o "7" "8" etc, pero no hay manera.
Cómo hace la gente para configurar Guardar, Salir, Cargar, Pause, etc, en un solo boton?
Muchas gracias de ante mano.
Un saludo
Hola,

me he hecho un mando doble con 2 placas zero delay y una Pi 3B con retropie.

Pero, tengo un problema, configuro los mandos.... y todo funciona bien, pero al rato siempre uno de los mandos falla...

Me explico, de repente no funciona la palanca hacia la izquierda o bien una u otra.... va variando la direccion, a veces es arriba otras derecha...

¿Hay algun problema en usar 2 placas zero delay con retropie?

¿Hay que hacer alguna modificacion que no sea la de configurar el mando normalmente?

Muchas Gracias...

PD:Agraderia cualquier sugerencia..... ya que no se como resolverlo y tampoco he visto nada claro en internet.

Un saludo.
kouldeka escribió:Hola,

me he hecho un mando doble con 2 placas zero delay y una Pi 3B con retropie.

Pero, tengo un problema, configuro los mandos.... y todo funciona bien, pero al rato siempre uno de los mandos falla...

Me explico, de repente no funciona la palanca hacia la izquierda o bien una u otra.... va variando la direccion, a veces es arriba otras derecha...

¿Hay algun problema en usar 2 placas zero delay con retropie?

¿Hay que hacer alguna modificacion que no sea la de configurar el mando normalmente?

Muchas Gracias...

PD:Agraderia cualquier sugerencia..... ya que no se como resolverlo y tampoco he visto nada claro en internet.

Un saludo.


Buenas, yo tengo dos placas zeroDelay y no tengo problemas; no debería ser por eso. Lo que si me pasa a veces es que el USB no hace contacto bien con la Raspberry, no sé si por ahí irán los tiros de tu problema.
Si se me ocurre algo más, te digo.
Un saludo
kouldeka escribió:Hola,

me he hecho un mando doble con 2 placas zero delay y una Pi 3B con retropie.

Pero, tengo un problema, configuro los mandos.... y todo funciona bien, pero al rato siempre uno de los mandos falla...

Me explico, de repente no funciona la palanca hacia la izquierda o bien una u otra.... va variando la direccion, a veces es arriba otras derecha...

¿Hay algun problema en usar 2 placas zero delay con retropie?

¿Hay que hacer alguna modificacion que no sea la de configurar el mando normalmente?

Muchas Gracias...

PD:Agraderia cualquier sugerencia..... ya que no se como resolverlo y tampoco he visto nada claro en internet.

Un saludo.


- Fallo de alimentación
- Fallo de un cero
- Micro SD mal estado

Normal no es, hay un problema. Yo he llegado a tener 2 zeros + 2 gamepads USB sin problema. Y bueno estos arcade sticks dobles son los más comunes del mundo o sea que 0 problemas en tener solo 2 zeros.
johnorlok escribió:
kouldeka escribió:Hola,

me he hecho un mando doble con 2 placas zero delay y una Pi 3B con retropie.

Pero, tengo un problema, configuro los mandos.... y todo funciona bien, pero al rato siempre uno de los mandos falla...

Me explico, de repente no funciona la palanca hacia la izquierda o bien una u otra.... va variando la direccion, a veces es arriba otras derecha...

¿Hay algun problema en usar 2 placas zero delay con retropie?

¿Hay que hacer alguna modificacion que no sea la de configurar el mando normalmente?

Muchas Gracias...

PD:Agraderia cualquier sugerencia..... ya que no se como resolverlo y tampoco he visto nada claro en internet.

Un saludo.


Buenas, yo tengo dos placas zeroDelay y no tengo problemas; no debería ser por eso. Lo que si me pasa a veces es que el USB no hace contacto bien con la Raspberry, no sé si por ahí irán los tiros de tu problema.
Si se me ocurre algo más, te digo.
Un saludo



Hola,

gracias por la sugerencia..

ditifet escribió:
kouldeka escribió:Hola,

me he hecho un mando doble con 2 placas zero delay y una Pi 3B con retropie.

Pero, tengo un problema, configuro los mandos.... y todo funciona bien, pero al rato siempre uno de los mandos falla...

Me explico, de repente no funciona la palanca hacia la izquierda o bien una u otra.... va variando la direccion, a veces es arriba otras derecha...

¿Hay algun problema en usar 2 placas zero delay con retropie?

¿Hay que hacer alguna modificacion que no sea la de configurar el mando normalmente?

Muchas Gracias...

PD:Agraderia cualquier sugerencia..... ya que no se como resolverlo y tampoco he visto nada claro en internet.

Un saludo.


- Fallo de alimentación
- Fallo de un cero
- Micro SD mal estado

Normal no es, hay un problema. Yo he llegado a tener 2 zeros + 2 gamepads USB sin problema. Y bueno estos arcade sticks dobles son los más comunes del mundo o sea que 0 problemas en tener solo 2 zeros.


Muchas Gracias por las sugrencias.


Explico un poco mas. La Raspberry 3B esta dentro del mando con ventilador conectado a la misma via GPIO, y luego tiene 2 USB ocupados por los 2 Zero delay y otros 2 por dos alargadores USB que salen de la caja del mando para conectar supuestamente un 3er y 4o player.

Ademas, el problema que digo, me pasa a veces en el mando 1 player y a veces en el player 2....
por eso teoricamente descarto que sean las placas zero delay.... seria mucha casualidad que fallasen las 2 ¿no?

Por otro lado, el USB tampoco deberia ser entiendo yo, porque si fuese el USB fallaria todo el mando y los botones..... y no solo una direccion de un mando....

Es como si se desconfigurase... de repente, el mando no va la izquierda o derecha o arriba... es aleatorio y varia a veces es mando 1 otras el 2.


La SD, lo descarto porque he probado 2....

El tema de alimentacion.... ¿Cuantos amperios utilizais en una Pi con 2 placas Zero Delay conectadas?

¿Mas de 2A? Cierto es que, me sale el cuadradito de que le falta energia durante la carga....

No se, deberia probar con otro cargador....

Porque segun decís hay gente con Pi, retropie y 2 zero delays con zero problemas, sin hacer cosas raras... solo configurandolo normalmente.

Gracias por las sugerencias.... Seguire investigando.

Muchas Gracias.
kouldeka escribió:
johnorlok escribió:
kouldeka escribió:Hola,

me he hecho un mando doble con 2 placas zero delay y una Pi 3B con retropie.

Pero, tengo un problema, configuro los mandos.... y todo funciona bien, pero al rato siempre uno de los mandos falla...

Me explico, de repente no funciona la palanca hacia la izquierda o bien una u otra.... va variando la direccion, a veces es arriba otras derecha...

¿Hay algun problema en usar 2 placas zero delay con retropie?

¿Hay que hacer alguna modificacion que no sea la de configurar el mando normalmente?

Muchas Gracias...

PD:Agraderia cualquier sugerencia..... ya que no se como resolverlo y tampoco he visto nada claro en internet.

Un saludo.


Buenas, yo tengo dos placas zeroDelay y no tengo problemas; no debería ser por eso. Lo que si me pasa a veces es que el USB no hace contacto bien con la Raspberry, no sé si por ahí irán los tiros de tu problema.
Si se me ocurre algo más, te digo.
Un saludo



Hola,

gracias por la sugerencia..

ditifet escribió:
kouldeka escribió:Hola,

me he hecho un mando doble con 2 placas zero delay y una Pi 3B con retropie.

Pero, tengo un problema, configuro los mandos.... y todo funciona bien, pero al rato siempre uno de los mandos falla...

Me explico, de repente no funciona la palanca hacia la izquierda o bien una u otra.... va variando la direccion, a veces es arriba otras derecha...

¿Hay algun problema en usar 2 placas zero delay con retropie?

¿Hay que hacer alguna modificacion que no sea la de configurar el mando normalmente?

Muchas Gracias...

PD:Agraderia cualquier sugerencia..... ya que no se como resolverlo y tampoco he visto nada claro en internet.

Un saludo.


- Fallo de alimentación
- Fallo de un cero
- Micro SD mal estado

Normal no es, hay un problema. Yo he llegado a tener 2 zeros + 2 gamepads USB sin problema. Y bueno estos arcade sticks dobles son los más comunes del mundo o sea que 0 problemas en tener solo 2 zeros.


Muchas Gracias por las sugrencias.


Explico un poco mas. La Raspberry 3B esta dentro del mando con ventilador conectado a la misma via GPIO, y luego tiene 2 USB ocupados por los 2 Zero delay y otros 2 por dos alargadores USB que salen de la caja del mando para conectar supuestamente un 3er y 4o player.

Ademas, el problema que digo, me pasa a veces en el mando 1 player y a veces en el player 2....
por eso teoricamente descarto que sean las placas zero delay.... seria mucha casualidad que fallasen las 2 ¿no?

Por otro lado, el USB tampoco deberia ser entiendo yo, porque si fuese el USB fallaria todo el mando y los botones..... y no solo una direccion de un mando....

Es como si se desconfigurase... de repente, el mando no va la izquierda o derecha o arriba... es aleatorio y varia a veces es mando 1 otras el 2.


La SD, lo descarto porque he probado 2....

El tema de alimentacion.... ¿Cuantos amperios utilizais en una Pi con 2 placas Zero Delay conectadas?

¿Mas de 2A? Cierto es que, me sale el cuadradito de que le falta energia durante la carga....

No se, deberia probar con otro cargador....

Porque segun decís hay gente con Pi, retropie y 2 zero delays con zero problemas, sin hacer cosas raras... solo configurandolo normalmente.

Gracias por las sugerencias.... Seguire investigando.

Muchas Gracias.


Es falta de energía 100%
Si me imagino que sera falta de energia...


¿Cuantos amperios recomendais 2.5 A o 3 A debreria ser suficiente no?

Gracias de nuevo.
Alguien sabria decirme como configurar la resolucion de raspberry pi para un monitor crt.
Por que he conectado la raspberry mediante el cable de video compuesto a una television antigua y he descomentado en el archivo config.txt la linea de sdtv_mode=2
Y la verdad es que se ve en la tele, pero la imagen parpadea demasiado. yo creo que tiene que ser cosa de la frecuencia de refresco de pantalla, pero no se donde se configura ni cual seria la adecuada
Cual seria la configuracion correcta?
Tambien he estado intentado de poner una resolucion de 768x240 a 15hz, pero tampoco se donde esta para cambiarlo.

Alguno sabria decirme donde poder cambiar estas configuraciones?
Buenas peña,voy a pillarme una recreativa y tengo una preguntilla sobre este sistema,me cobran 30€ mas de diferencia por ponerle Attract Mode (64gb) en vez de Retropie (32gb),¿Merece la pena esos 30€ para tener Attract mode?
https://retropie.org.uk/2018/04/retropi ... -released/

recomiendan instalar desde una versión limpia .. ¿ alguien se atreve a actualizar simplemente y que cuente su experiencia .. ? [angelito]
Hola eolianos, busco alguna página de mods para roms, ya sean traducciones o mejoras gráficas, etc...
DJM84 escribió:Hola eolianos, busco alguna página de mods para roms, ya sean traducciones o mejoras gráficas, etc...


romhacking es tu página.
XeNoMoRPH escribió:https://retropie.org.uk/2018/04/retropie-4-4-is-released/

recomiendan instalar desde una versión limpia .. ¿ alguien se atreve a actualizar simplemente y que cuente su experiencia .. ? [angelito]



Yo tengo dualboot y he actualizado sin problema aparente. Claro que el uso principal de la Raspi ahora mismo es libreelec...
josete2k escribió:
XeNoMoRPH escribió:https://retropie.org.uk/2018/04/retropie-4-4-is-released/

recomiendan instalar desde una versión limpia .. ¿ alguien se atreve a actualizar simplemente y que cuente su experiencia .. ? [angelito]



Yo tengo dualboot y he actualizado sin problema aparente. Claro que el uso principal de la Raspi ahora mismo es libreelec...



O sea que digamos .. no usas emuladores ni nada verdad .. ? he visto algún post también en el foro de retropie de alguien que ha actualizado y no ha tenido problemas .. es que no quiero actualizar y que luego me implosione la raspberry }:/
Sí, los uso y por ahora bien. Pero no he profundizado.

ES carga sin problemas también y el mod de música que le puse sigue sonando.
@squalltrivi el sistema ya es cuestión de gustos. A mi inicialmente me gustaba más el atract mode, pero ahora, con el tema de retrorama para emulationstation o incluso el de cómic, me quedo de calle con emulationestation. Personalmente me los ahorraba.

Un saludo.
XeNoMoRPH escribió:https://retropie.org.uk/2018/04/retropie-4-4-is-released/

recomiendan instalar desde una versión limpia .. ¿ alguien se atreve a actualizar simplemente y que cuente su experiencia .. ? [angelito]


Yo he actualizado y todo perfecto.
kocinsky escribió:
XeNoMoRPH escribió:https://retropie.org.uk/2018/04/retropie-4-4-is-released/

recomiendan instalar desde una versión limpia .. ¿ alguien se atreve a actualizar simplemente y que cuente su experiencia .. ? [angelito]


Yo he actualizado y todo perfecto.


Vale .. me la jugaré , un dia de estos , gracias [chulito]
Una pregunta compis, si hago instalación desde cero a la 4.4 ¿Como puedo mantener mi configuración de pantalla y toda la pesca? ¿Alguna forma más sencilla que guardar las files de configuración?
4893 respuestas
194, 95, 96, 97, 98