HILO de RECALBOX

1, 2, 3, 4
@kocinsky pues me esperaré, no es algo fundamental para mí el tema de la pistola.

Y mira que le dediqué muchas horas en su día a la NES con Duck Hunt y Wild Gunman, me encantaban y me traen muchos recuerdos, pero puedo esperar XD

Además ahora imagino que será apuntando con el puntero, a lo Wii. En NES lo gracioso era que por el sistema utilizado era más realista, porque el disparo en la pantalla se producía donde estabas apuntando realmente, no era moviendo un puntero a ojo.

Pero en este caso no hay otra manera de hacerlo, así que se agradece el avance, al menos los puedes jugar, aunque sea de otra manera distinta.
Nose que pasa con algunos juegos de psx como FF9 o MGS que no rulan con el emulador por defecto y en el otro(creo que mednafen o algo asi) van fatal.Hablo de RP4 y Recalbox 7.2.
Algun consejo o idea de que hago mal?
elbrujoguru escribió:Nose que pasa con algunos juegos de psx como FF9 o MGS que no rulan con el emulador por defecto y en el otro(creo que mednafen o algo asi) van fatal.Hablo de RP4 y Recalbox 7.2.
Algun consejo o idea de que hago mal?


pues nose... tienen que ir bien, pruba a bajarte otras bios distintas de psx a ver si es eso, sino restaura recalbox de fabrica (no perderas las roms solo la configuración del SO)
@ebsigma si,al final he probado con un .bin .cue y me ha funcionado..en cambio lo he convertido en .pbp para tener el MGS en un solo archivo y ya no funciona,no lo entiendo.
Sabes si ahora retroarch permite el cambio de disco para los juegos multidisco?
Saludos
elbrujoguru escribió:@ebsigma si,al final he probado con un .bin .cue y me ha funcionado..en cambio lo he convertido en .pbp para tener el MGS en un solo archivo y ya no funciona,no lo entiendo.
Sabes si ahora retroarch permite el cambio de disco para los juegos multidisco?
Saludos


los juegos que he probado con multidisco, antes de cambiar de disco, se guarda la partida, por lo que solo he tenido que cerrar el emulador y cargar luego el disco nuevo... sino con "hotkey+a" abres el menú de retroarch y entre sus menús tiene que estár lo de cambiar de disco... por eso mismo es mejor tener los multidiscos en varios discos y no en un solo archivo para que te sea mas facil de cambiar, pero todo es probar...
Si alguien consigue hacer funcionar el Ignition (juego de coches) de MSDOS que me lo diga, Dios, no doy con la tecla.
Arkziel escribió:Si alguien consigue hacer funcionar el Ignition (juego de coches) de MSDOS que me lo diga, Dios, no doy con la tecla.

Hay un tutorial para poner juegos de MS-DOS en Recalbox.
cpcbegin escribió:
Arkziel escribió:Si alguien consigue hacer funcionar el Ignition (juego de coches) de MSDOS que me lo diga, Dios, no doy con la tecla.

Hay un tutorial para poner juegos de MS-DOS en Recalbox.


Si si, todo eso sé hacerlo. Tengo mis juegos favoritos retro de MS-DOS funcionando desde hace tiempo, pero Ignition en concreto se me resiste, creo que necesita alguna instalación/configuración más avanzada.
Si alguien consigue dejarlo niquelado que me avise XD

Gracias de todos modos por intentar ayudar.
@Arkziel A mi me funciona.

¿Que versión de Recalbox estás usando?

¿Usas el core Dosbox por defecto o DosBoxPure?

Suponiendo que usas el DosBox por defecto, y tienes todos los archivos del juego incluido el ISO. El fichero dosbox.bat que necesitas debe llevar dentro:

cycles=max
disney=false
imgmount D "Ignition.cue" -t iso
cd IGNITION
IGN_DOS.BAT
poseiido escribió:@Arkziel A mi me funciona.

¿Que versión de Recalbox estás usando?

¿Usas el core Dosbox por defecto o DosBoxPure?

Suponiendo que usas el DosBox por defecto, y tienes todos los archivos del juego incluido el ISO. El fichero dosbox.bat que necesitas debe llevar dentro:

cycles=max
disney=false
imgmount D "Ignition.cue" -t iso
cd IGNITION
IGN_DOS.BAT



¡FUNCIONA! muchas gracias!!

Mi problema estaba en que no usaba la iso, solo usaba la carpeta con el juego descomprimido.
Además no hubiese sabido montar la imagen ni aunque la hubiese incluído, en mi dosbox.bat simplemente ponía "IGN_DOS.BAT".

Al final probé lo que me dijiste, metí los comandos en el dosbox.bat cambiando la línea imgmount D "Ignition.cue" -t iso por imgmount D "Ignition.bin" -t iso, ya que tengo la imagen "pesada" en .bin" (aunque viene acompañada de un .cue de 1 kb, pero supuse que el principal sería el otro en mi caso).
También puse "cd Iginiton.pc" ya que tengo las carpetas con la terminación ".pc", cambié esas dos líneas para adaptarlas a mi caso y bingo a la primera!

Muchas gracias! Pensé que iba a ser imposible hacerlo funcionar! Solo tenía que incluir la iso y modificar el dosbox.bat montando la imagen y no tenía ni idea de hacerlo si no llega a ser por tu ayuda.
@Arkziel Me alegra que te sirviera. A disfrutarlo!
poseiido escribió:@Arkziel Me alegra que te sirviera. A disfrutarlo!


Muchas gracias de nuevo.

¿Te funcionan las pistas de música? Me va todo perfecto pero sin música, quizás me falta algo.

La resolución tengo que usar la más baja, ya que si subo a 800x600 noto perdida de fluidez y no va del todo fino, sin embargo con la resolución baja es muy estable para jugar, aunque te comes unos ricos pixels XD

EDIT: solucionado lo del sonido, que tontería, aunque el archivo tocho sea el .bin, debía montar igualmente el .cue para que las pistas de audio sonasen XD
Arkziel escribió:¿Qué mandos inalámbricos usáis?

Yo desde hace varios años uso el mando Pro de la Nintendo Switch y genial, pero estaba pensando en tener un segundo mando para jugar a dobles de manera cómoda.


Yo quiero ponerme la imagen de Recalbox, el mando Pro de la Switch lo detecta por bluetooth a la primera? Pero no se te queda los leds parpadeando todo el tiempo?
Gracias.
cristian_n escribió:
Arkziel escribió:¿Qué mandos inalámbricos usáis?

Yo desde hace varios años uso el mando Pro de la Nintendo Switch y genial, pero estaba pensando en tener un segundo mando para jugar a dobles de manera cómoda.


Yo quiero ponerme la imagen de Recalbox, el mando Pro de la Switch lo detecta por bluetooth a la primera? Pero no se te queda los leds parpadeando todo el tiempo?
Gracias.


Lo detecta a la primera y sin ningún problema, va estupendo. Eso sí, es lo que dices, los leds se quedan en plan coche fantástico de un lado para otro, pero aparte del efecto visual no tiene un impacto evidente en la batería ni ninguna otra molestia.

Por cierto, ya está la 7.2.1, estoy probándola a ver qué tal [fumando]
si, hay muchos mandos que se sincronizan y funcionan pero los leds no los administra ya que no saben si son el 1, 2... supongo que será por tema de drivers pero bueno, al menos funciona...

expongo pregunta: quiero jugar al silent hill 1 de psx, pero el tema de los trucos (los que te vienen en retroarch) no me funcionan y los que he probado por mi cuenta tampoco... alguna posible solucion?
@poseiido Ya que seguramente tengas todo el ecosistema funcionando y bastante optimizado, te vuelvo a preguntar por un juego en concreto: World Rally 2 de MAME.

No consigo que funcione bien, me da problemas este juego. El coche no responde bien y cuando se estrella o vuelcas, al juego se le va la olla y el coche aparece en mitad del decorado del escenario. Además, al principio de todo cuando sale la pantalla de carga, me pone en rojo "Coprocessor Not Ready", así que algo no va bien con este juego, no sé como lo tendrás tú (he probado varias versiones de esta rom, y la única que me funciona va de esta manera, las demás ni arrancan).

Me han dicho que si en vez de tenerlo en "mame" lo meto en "fbneo" se soluciona, pero aunque así fuese no es cuestión de tener un juego ahí marginado cuando tengo toda la recopilación funcionando en mame.

A ver si puedes iluminarme, no sé si será problema de no dar con la rom correcta, ya que he probado todos los cores.

Por cierto, tras varios intentos de meterme en 7.2.1 he desistido en aras de la 7.1.1, el principal problema es que ha empeorado la compatibilidad con el 8Bitdo SF30 Pro (se puede conectar con el firm 1.33 si usas el modo de emparejamiento Android, pero cuando apagas y vuelves a encender tiene problemas para volver a reconocerlo), y para mí es fundamental que funcione bien este mando (en 7.1.1 va perfecto).

Además supuestamente una de las mejoras de la 7.2 era la emulación de Nintendo 64 (fundamental esta consola para mí también), e irónicamente me va mejor Nintendo 64 en la 7.1.1, así que no entiendo muy bien qué pasa en ese aspecto XD

Un saludo!
@Arkziel

El world rally 2 se parcheó hace unos pocos años. Sin duda tienes una rom de las que no estaban parcheadas ya que el error que comentas es precisamente el que lo hacía injugable hasta que lo solucionaron.
Con la rom correcta solo tienes que ajustar en opciones para que muestre 1 monitor salvo que quieras jugar a dobles, cosa que por cierto está genial.

La versión 7.2.1 poco ha arreglado.
¿Has probado a hacer un overclock a la pi4 para el tema de n64?

Un saludo
Arkziel escribió:@poseiido Ya que seguramente tengas todo el ecosistema funcionando y bastante optimizado, te vuelvo a preguntar por un juego en concreto: World Rally 2 de MAME.

No consigo que funcione bien, me da problemas este juego. El coche no responde bien y cuando se estrella o vuelcas, al juego se le va la olla y el coche aparece en mitad del decorado del escenario. Además, al principio de todo cuando sale la pantalla de carga, me pone en rojo "Coprocessor Not Ready", así que algo no va bien con este juego, no sé como lo tendrás tú (he probado varias versiones de esta rom, y la única que me funciona va de esta manera, las demás ni arrancan).

Me han dicho que si en vez de tenerlo en "mame" lo meto en "fbneo" se soluciona, pero aunque así fuese no es cuestión de tener un juego ahí marginado cuando tengo toda la recopilación funcionando en mame.

A ver si puedes iluminarme, no sé si será problema de no dar con la rom correcta, ya que he probado todos los cores.

Por cierto, tras varios intentos de meterme en 7.2.1 he desistido en aras de la 7.1.1, el principal problema es que ha empeorado la compatibilidad con el 8Bitdo SF30 Pro (se puede conectar con el firm 1.33 si usas el modo de emparejamiento Android, pero cuando apagas y vuelves a encender tiene problemas para volver a reconocerlo), y para mí es fundamental que funcione bien este mando (en 7.1.1 va perfecto).

Además supuestamente una de las mejoras de la 7.2 era la emulación de Nintendo 64 (fundamental esta consola para mí también), e irónicamente me va mejor Nintendo 64 en la 7.1.1, así que no entiendo muy bien qué pasa en ese aspecto XD

Un saludo!



Yo tengo el SF30 Pro con la 7.2.1 y funciona perfecto, se me conecta perfecto despues de cada inicio o reinicio.
Respecto a World Rally 2, te recomiendo usar fbneo antes que MAME. Sino, lo que puedes hacer es usar solo la rom de World Rally 2 en fbneo, y activar el sistema virtual ARCADE, para que se unan en un único sistema, MAME y fbneo, y asi no tener solo ese juego marginado en fbneo.

Respecto a N64, ¿que core usas y que modelo de Pi?

Un saludo!
Dreifus escribió:@Arkziel

El world rally 2 se parcheó hace unos pocos años. Sin duda tienes una rom de las que no estaban parcheadas ya que el error que comentas es precisamente el que lo hacía injugable hasta que lo solucionaron.
Con la rom correcta solo tienes que ajustar en opciones para que muestre 1 monitor salvo que quieras jugar a dobles, cosa que por cierto está genial.

La versión 7.2.1 poco ha arreglado.
¿Has probado a hacer un overclock a la pi4 para el tema de n64?

Un saludo


Sí, hice pruebas con OC en N64 y no noté tampoco gran cosa, pruebo con la misma resolución en ambas versiones y 7.1.1 me funciona mejor, es irónico.
Si alguien consigue en 7.2.1 que por ejemplo Mario Tennis funcione bien que me diga qué opciones y core usa porque no hay manera XD
Respecto a la rom correcta de World Rally 2 no sé si la tienes o sabes dónde conseguirla, si realmente ese fuese mi problema espero que no te importe mandarme un privado con esa info.
¡Muchas gracias!
EDIT: parece que el problema no es la rom en sí, es que no hay manera de que funcione en "mame", hay que jugarla en fbneo.


poseiido escribió:Yo tengo el SF30 Pro con la 7.2.1 y funciona perfecto, se me conecta perfecto despues de cada inicio o reinicio.


¿Cómo lo has sincronizado para que te lo detecte rápido y sin problemas cuando enciendes? Yo siguiendo instrucciones del foro de recalbox, utilicé el firm 1.33 en el mando y emparejé utilizando el modo Android (Start + B). Se empareja y configura correctamente, pero una vez que apago la Pi4...cuando vuelvo a encender me cuesta horrores que vuelva a detectar el mando (¿Haces algo en especial en este punto? ¿Alguna combinación de teclas en especial o algo?).

poseiido escribió:Respecto a World Rally 2, te recomiendo usar fbneo antes que MAME. Sino, lo que puedes hacer es usar solo la rom de World Rally 2 en fbneo, y activar el sistema virtual ARCADE, para que se unan en un único sistema, MAME y fbneo, y asi no tener solo ese juego marginado en fbneo.


Estoy encabezonado en que funcione en MAME porque tengo todos mis juegos funcionando ahí perfectamente a excepción del World Rally 2, y no quería tener un juego por separado en otra plataforma (soy muy tiquismiquis), por eso preguntaba qué podía estar pasando.
Eso sí, me interesa lo que comentas de "activar el sistema virtual ARCADE" porque eso solucionaría mi problema si tuviera que marginar ese juego, ni conocía que existiera esa opción, no me suena haberla visto.
EDIT: ya he visto esa opción, no la había visto nunca.

poseiido escribió:Respecto a N64, ¿que core usas y que modelo de Pi?


Como le dije a Dreifus, he probado los dos núcleos que hay en 7.2.1 y con ninguno tengo tan buen resultado como en 7.1.1, de hecho juegos como Mario Tennis ahora me funcionan peor, y eso que también intenté copiar las resoluciones que uso en 7.1.1, así que no entiendo, va todo muy lento y con tirones.
Esto me extrañó en especial porque una de las novedades de estas últimas versiones era la supuesta mejoría en la emulación de N64, por eso creo que debo estar haciendo algo mal.
Lo dicho, si me dices alguna configuración en especial para Pi4 (4GB) en la que realmente se note esa mejoría de N64 lo agradeceré.

Un saludo!
Parece que efectivamente hay algún problema con N64 a partir de la 7.2

Sería genial, si pudieras añadir tu info ( y si puedes algun video diferenciando el mismo juego entre 7.1.1 y 7.2.1) a esta issue que existe.

https://gitlab.com/recalbox/recalbox/-/issues/1712

Respecto a SF30 Pro, yo uso el firmware 1.34.
poseiido escribió:Parece que efectivamente hay algún problema con N64 a partir de la 7.2

Sería genial, si pudieras añadir tu info ( y si puedes algun video diferenciando el mismo juego entre 7.1.1 y 7.2.1) a esta issue que existe.

https://gitlab.com/recalbox/recalbox/-/issues/1712

Respecto a SF30 Pro, yo uso el firmware 1.34.


Probaré el 1.34, vaya que ese simple detalle marque la diferencia.
Es que en la 7.1.1 el SF30 Pro va de maravilla, cuando enciendo la Pi4 y le doy al “start”, el mando tarda segundos en ser reconocido (v. 1.33 previamente emparejado en Switch mode).
Sin embargo en la 7.2 y 7.2.1 al encender la Pi no hay manera de que lo reconozca rápido, tarda muchísimo y varios intentos (v. 1.33 previamente emparejado en Android mode, porque Switch mode no empareja en estas versiones).

Imagino que emparejas en Android mode tú también, así que probaré 1.34 a ver si va a ser esa tontería…
Para mí es fundamental que el mando vaya fino fino como en la 7.1.1.

Respecto al hilo de N64 echaré un vistazo a ver si saco tiempo para trastear más y poner algo.
Vuelvo a reflotar ahora que han pasado más de 5 días (me extraña que haya tan poca actividad en este hilo cuando el proyecto está activo y con actualizaciones recientes).

poseiido escribió:lo que puedes hacer es usar solo la rom de World Rally 2 en fbneo, y activar el sistema virtual ARCADE, para que se unan en un único sistema, MAME y fbneo, y asi no tener solo ese juego marginado en fbneo.


Eso es lo que hice y todo perfecto [beer]
Eso sí, me hubiese gustado que Atomiswave también se unificase en el sistema virtual Arcade (al igual que sí lo hace Neo-Geo), ya que al fin y al cabo también es una placa/mueble arcade.
Siguiendo en la línea de Atomiswave, menudo descubrimiento el Dolphin Blue (con lo que me gustan los juegos estilo Metal Slug).

Y aprovecho para preguntar sobre Atomiswave.
Me funciona el romset completo a excepción de 4 juegos: Smashing Drive (no arranca), ATV Track (no arranca), King of Fighters Neowave (se congela en la pantalla de inicio) y Extreme Hunting 2 (lanza error al iniciar).
Quisiera saber si es porque no son compatibles a día de hoy con Recalbox en Pi4, o si es problema de mis roms.

Y continuando con el tema arcade, también pregunto:
¿Qué tal os funcionan en la 7.2.1 los Time Crisis (1 y 2) y House of the Dead (1 y 2) en MAME con la pistola?
Menudos vicios en las recreativas...

Si me decís que estos juegos funcionan bien en la 7.2.1, y más adelante arreglan los problemas de rendimiento con N64 (parece que el problema es haber quitado el core mupen64plus, que tenía mejor rendimiento, al menos en Pi4), intentaría da el salto a actualizar, ya que mi único problema sería el funcionamiento del SF30 Pro, que por lo que dice @poseiido debe funcionar perfecto, al menos en la versión 1.34, la cual no llegué a probar (probé la 1.33).

Vamos, que básicamente estoy echando el freno a mis ganas de actualizar por culpa de N64 y el SF30 Pro (por suerte esto me tranquiliza pensar que tiene solución).

Como me digáis que los shooters arcade funcionan bien....voy a tener un problema XD

He tenido que soltar el tocho después de 5 días acumulando experiencias y dudas XD

Un saludo!
Arkziel escribió:Vuelvo a reflotar ahora que han pasado más de 5 días (me extraña que haya tan poca actividad en este hilo cuando el proyecto está activo y con actualizaciones recientes).

poseiido escribió:lo que puedes hacer es usar solo la rom de World Rally 2 en fbneo, y activar el sistema virtual ARCADE, para que se unan en un único sistema, MAME y fbneo, y asi no tener solo ese juego marginado en fbneo.


Eso es lo que hice y todo perfecto [beer]
Eso sí, me hubiese gustado que Atomiswave también se unificase en el sistema virtual Arcade (al igual que sí lo hace Neo-Geo), ya que al fin y al cabo también es una placa/mueble arcade.
Siguiendo en la línea de Atomiswave, menudo descubrimiento el Dolphin Blue (con lo que me gustan los juegos estilo Metal Slug).

Es una mejora de la 7.2.1: Fix arcade view systems missing model3, atomiswave, naomi, naomigd, daphné


Y aprovecho para preguntar sobre Atomiswave.
Me funciona el romset completo a excepción de 4 juegos: Smashing Drive (no arranca), ATV Track (no arranca), King of Fighters Neowave (se congela en la pantalla de inicio) y Extreme Hunting 2 (lanza error al iniciar).
Quisiera saber si es porque no son compatibles a día de hoy con Recalbox en Pi4, o si es problema de mis roms.

Primero comprueba tus roms con los dats que están en la carpeta \bios\dc
Pero te recomiendo actualizar a 7.2.1.


Y continuando con el tema arcade, también pregunto:
¿Qué tal os funcionan en la 7.2.1 los Time Crisis (1 y 2) y House of the Dead (1 y 2) en MAME con la pistola?
Menudos vicios en las recreativas...

Juegos en 3D de MAME no irán bien en Pi4 por falta de potencia. En un Recalbox-PC no hay problema. Te recomiendo jugar al Time Crisis de PSX con pistola, que funciona de lujo en una Pi4.

Si me decís que estos juegos funcionan bien en la 7.2.1, y más adelante arreglan los problemas de rendimiento con N64 (parece que el problema es haber quitado el core mupen64plus, que tenía mejor rendimiento, al menos en Pi4), intentaría da el salto a actualizar, ya que mi único problema sería el funcionamiento del SF30 Pro, que por lo que dice @poseiido debe funcionar perfecto, al menos en la versión 1.34, la cual no llegué a probar (probé la 1.33).

Vamos, que básicamente estoy echando el freno a mis ganas de actualizar por culpa de N64 y el SF30 Pro (por suerte esto me tranquiliza pensar que tiene solución).

Están revisando los problemas de N64, a ver si dan con la tecla.

Como me digáis que los shooters arcade funcionan bien....voy a tener un problema XD

He tenido que soltar el tocho después de 5 días acumulando experiencias y dudas XD

Un saludo!
poseiido escribió:Es una mejora de la 7.2.1: Fix arcade view systems missing model3, atomiswave, naomi, naomigd, daphné


Bien bien, me alegra leer eso.


poseiido escribió:Primero comprueba tus roms con los dats que están en la carpeta \bios\dc
Pero te recomiendo actualizar a 7.2.1.


No sé que es lo que tengo que comprobar ahí ni qué es lo que tiene que coincidir. Solo son esos 4 juegos (Smashing Drive, ATV Track, King of Fighters Neowave y Extreme Hunting 2), y no sé si es porque uso una versión incorrecta de esas roms, pero no sé comprobar eso. ¿A ti o a alguien que nos lea le funcionan esos juegos en Pi 4? (lo mismo es incompatibilidad actual, ando perdido).
Respecto a actualizar a la 7.2.1...más ganas que tengo yo de actualizar...siempre me gusta estar en la última versión, pero es que tengo todo funcionando de maravilla en la 7.1.1, y perder así porque sí Nintendo 64 (juegos a los que me gusta jugar como Mario Tennis se vuelven injugables)...
Pierdo más de lo que gano, aún suponiendo que soluciono lo del mando.


poseiido escribió:Están revisando los problemas de N64, a ver si dan con la tecla.


Esto sería fantástico que se solucionase.

De momento lo que creo que haré es trastear en la versión 7.2.1 usando la tarjeta de 16gb que tengo para cacharrear y hacer experimentos. Así puedo comprobar, entre otras cosas, si el 8Bitdo SF30 Pro funciona perfectamente con el firm 1.34 como anteriormente me dijiste.
Además si vuelven a sacar una actualización arreglando Nintendo 64 puedo comprobarlo in situ antes de mudarme con la tarjeta buena (así no tengo que estar restaurando copia de seguridad todo el rato).
De paso busco si tengo más problemas en la 7.2.1 de los que no me hubiese dado cuenta, ya que es una pena ver como cosas que me funcionan bien me dejan de funcionar.
Al actualizar a la 7.2.1 además pierdo el sonido, y para recuperarlo tengo que restaurar las opciones a valores de fábrica (o hacer una instalación limpia), conllevando ello perder opciones y remapeado de mandos (en los que invertí mucho tiempo para dejar perfecto) en diferentes juegos, por lo que tengo que copiar todos los archivos específicos de configuraciones de mandos y demás.

Un saludo.
Respecto a los juegos de Atomiswave:

Smashing Drive, ATV Track (Estos juegos no están en la lista de compatibilidad de Flycast).

King of Fighters Neowave, Extreme Hunting 2 (Los probaré y te cuento)
poseiido escribió:Respecto a los juegos de Atomiswave:

Smashing Drive, ATV Track (Estos juegos no están en la lista de compatibilidad de Flycast).

King of Fighters Neowave, Extreme Hunting 2 (Los probaré y te cuento)


Perfecto, gracias!

Pues los he ocultado por si en el futuro funcionan (mejor que borrarlos).

Respecto a mi cacharreo con la versión 7.2.1 de Recalbox con mi tarjeta secundaria decir un par de cosas:
1. Respecto al mando 8Bitdo SF30 Pro, tienes razón, con el firm 1.34 funciona perfectamente (modo Android), lo reconoce al instante al encender o reiniciar, ya no tarda en reconectar, así que un problema (muy importante para mí) solucionado [beer]
2. Nintendo 64 no funciona bien por mucha resolución u opciones que cambie (ojalá den con la tecla o habiliten nuevamente mupen64plus), tocará esperar y agradecer el esfuerzo que hacen.
3. Los 4 juegos que te dije de Atomiswave (Smashing Drive, ATV Track, King of Fighters Neowave y Extreme Hunting 2) siguen sin funcionar en la versión 7.2.1, aunque al menos ya sé por lo que has dicho que dos de ellos es normal que no funcionen, ya veremos si los otros dos son problema mío. Añadir que en la 7.2.1 Metal Slug 6 (Atomiswave) se me congela en la pantalla inicial de carga, sin embargo en la versión 7.1.1 me funciona perfectamente.

Un saludo!
@Arkziel Creo que el problema está en la versión de Flycast. Prueba a eliminar los ficheros que hay en la ruta /share/saves/atomiswave/reicast y prueba de nuevo el Metal Slug.
poseiido escribió:@Arkziel Creo que el problema está en la versión de Flycast. Prueba a eliminar los ficheros que hay en la ruta /share/saves/atomiswave/reicast y prueba de nuevo el Metal Slug.


Hice lo que dijiste y ya vuelve a funcionarme Metal Slug 6 en la 7.2.1, eres una máquina [beer]

Gracias por la ayuda y de paso mantener este hilo vivo.

Ya solo me queda que arreglen lo de Nintendo 64 en la 7.2.1 (Pi 4), porque todo lo demás parece que me va perfecto nuevamente.

Un saludo.
@Arkziel He creado issue en Recalbox, ¿podrías pasarte y comentar que a ti también te ocurre? Gracias.

https://gitlab.com/recalbox/recalbox/-/issues/1737
@poseiido hecho [beer]

Ahora estoy "actualizando" mi imagen volviendo a scrapear todos los juegos para que tengan video (además del Mix de imágenes).

Cada vez se superan para que quede todo más bonito y cuando crees que has completado tu "trabajo", van y sacan algo mejor XD
ami me gustaría que dejasen meter los emuladores que uno quiera, amos que no fuese tan cerrado... pero bueno las mejoras siempre son bien venidas.
@poseiido ¿Sabes si está en el plan de ruta arreglar el rendimiento de Nintendo 64 en Pi4? Dijiste que lo estaban revisando, espero que den con la tecla.

He visto que en próximos avances figura: “Add Mupen64plus Next libretro core on PC platforms”

Solo he visto eso en referencia a N64, nada en Pi.
Me conformo con recuperar el rendimiento de la 7.1.1. (que iba mejor con el core Mupen64plus).
Arkziel escribió:@poseiido ¿Sabes si está en el plan de ruta arreglar el rendimiento de Nintendo 64 en Pi4? Dijiste que lo estaban revisando, espero que den con la tecla.

He visto que en próximos avances figura: “Add Mupen64plus Next libretro core on PC platforms”

Solo he visto eso en referencia a N64, nada en Pi.
Me conformo con recuperar el rendimiento de la 7.1.1. (que iba mejor con el core Mupen64plus).


Siguen trabajando en mejorar N64 en Pi. La mejora en PC ha sido a petición mía, y ahora al menos en PC hay una mejoria muy importante. A ver si consiguen mejorar también en Pi.
@poseiido parece que los Dioses han escuchado mis plegarias:

Imagen

XD XD
pues ami solo me va fluido con libretro_parallel_N46, pero claro no puedo ampliar la pantalla para que me pille toda, si aumento la resolucion se me ve mas pequeño...

con el emulador por defecto es injugable de lo lento y petardeante que va... no se si hay mas emuladores para usar o algo (me salen dos emus mas pero no cargan los juegos)

(rpi 4 4gb + overclock maxima)
Me pasa algo parecido a lo del compañero @ebsigma , aunque sin embargo yo si voy bien con parallel_N64 a pantalla completa.

Con el emulador por defecto (Libretro Mupen64Plus_Next) la mayoría de juegos van mal (a tirones o ralentizados), de hecho, algunos que antes iban con el emulador por defecto ahora no van.

Por el contrario si uso Libretro Parallel_N64 tengo un rendimiento bastante bueno y fluido (algunos juegos como Mario Tennis hasta van demasiado rápido), aunque con algunos fallos gráficos pasables. Quería tocar los parámetros desde retroarch para ajustar las opciones de Libretro Parallel_N64, pero no se guardan, desconozco el motivo. En el emulador por defecto Mupen64Plus_Next sí se guarda todo lo que cambio, al igual que en otros sistemas, pero en Parallel_N64 no hay manera de que se guarden las opciones (lo he intentado guardando manualmente o cerrando retroarch teniendo activado que se guarden los cambios al cerrar), así que no puedo corregir el rendimiento gráfico probando diferentes configuraciones, ¿por qué me pasa eso solo con este emulador?

Los otros dos emuladores (Mupen64Plus Glide64MK2 y Mupen64PlusRice) no funcionan con ningún juego, cosa rara.

Visto lo visto, me interesa poner Libretro Parallel_N64 como emulador por defecto, imagino que puedo hacerlo editando algún archivo de configuración. He probado desde opciones avanzadas de Emulationstation (Menú Principal -> Opciones avanzadas -> Configuración del emulador avanzada -> Nintendo 64 -> emulador Libretro Parallel_N64) , pero parece que ahí no debe ser, porque no surte efecto, no cambia el emulador por defecto.

Así que mis dos preguntas son:

1. ¿Dónde puedo cambiar el emulador de Nintendo 64 para poner Libretro Parallel_N64 por defecto?
Había pensado que quizás tocando en system/recalbox.conf, escribiendo alguna línea para N64 al lado de "## Default cores for RPi4 ;snes.core=snes9x".

2. ¿Cómo puedo cambiar parámetros en Libretro Parallel_N64 y que se queden guardados para poder hacer pruebas de configuración? Ya que desde retroarch no se me guardan por lo que sea, a las malas supongo que también puedo editar algún archivo de configuración para tocar opciones. He visto algunas opciones en retroarch-core-options.cfg (system\configs\retroarch\cores), pero no sé si es ahí, además solo veo unas pocas opciones a toquetear (parallel-n64-64dd-hardware = "disabled", parallel-n64-boot-device = "Default", parallel-n64-gfxplugin = "auto").

A ver si alguno sabe resolverme este par de dudas, o va a ser siempre @poseiido el que sepa todo XD

Un saludo.
Buenas @Arkziel , intentaré resolverte tus preguntas:

1. Selecciona en el menú de Recalbox: OPCIONES AVANZADAS / CONFIGURACIÓN DE EMULADOR AVANZADA / Nintendo 64, y ahí puedes seleccionar el emulador por defecto que usará para todos los juegos.

2. Prueba a crear un fichero de texto llamad ".core.cfg" (importante que tenga el punto en la primar posición), dentro de la carpeta de roms/n64. Y dentro del fichero, metes los parámetros que quieras que el emulador utilice.

Suerte!
poseiido escribió:1. Selecciona en el menú de Recalbox: OPCIONES AVANZADAS / CONFIGURACIÓN DE EMULADOR AVANZADA / Nintendo 64, y ahí puedes seleccionar el emulador por defecto que usará para todos los juegos.


Respecto a eso, como ya dije lo probé pero no se guarda, sigue por defecto el otro, o al menos eso pone en las opciones de los juegos (no llegué a abrirlos), probaré otra vez y abriré el juego en cuestión, a ver si abre con el otro.

Respecto al punto 2 haré pruebas a ver, un saludo!
Arkziel escribió:
poseiido escribió:1. Selecciona en el menú de Recalbox: OPCIONES AVANZADAS / CONFIGURACIÓN DE EMULADOR AVANZADA / Nintendo 64, y ahí puedes seleccionar el emulador por defecto que usará para todos los juegos.


Respecto a eso, como ya dije lo probé pero no se guarda, sigue por defecto el otro, o al menos eso pone en las opciones de los juegos (no llegué a abrirlos), probaré otra vez y abriré el juego en cuestión, a ver si abre con el otro.

Respecto al punto 2 haré pruebas a ver, un saludo!


En las opciones de los juegos no se cambia. Para verlo, abre las opciones de Retroarch dentro del juego y veras el core que estás utilizando.
poseiido escribió:
Arkziel escribió:
poseiido escribió:1. Selecciona en el menú de Recalbox: OPCIONES AVANZADAS / CONFIGURACIÓN DE EMULADOR AVANZADA / Nintendo 64, y ahí puedes seleccionar el emulador por defecto que usará para todos los juegos.


Respecto a eso, como ya dije lo probé pero no se guarda, sigue por defecto el otro, o al menos eso pone en las opciones de los juegos (no llegué a abrirlos), probaré otra vez y abriré el juego en cuestión, a ver si abre con el otro.

Respecto al punto 2 haré pruebas a ver, un saludo!


En las opciones de los juegos no se cambia. Para verlo, abre las opciones de Retroarch dentro del juego y veras el core que estás utilizando.


Correcto, vi que no se cambiaba en el menú de las opciones de los juegos en el propio EmulationStation y pensé que no me servía esa vía, pero al decirme tú eso ya probé a iniciar los juegos y efectivamente, aunque ponga en las opciones del juego en EmulationStation que tiene asignado el emulador por defecto Mupen64Plus_Next, al iniciar el juego efectivamente se abre con Parallel_N64 [beer]
De hecho en el archivo recalbox.conf se asignaron estas líneas automáticamente al tocar eso:
n64.emulator=libretro
n64.core=parallel_n64

Por ahí ya perfecto, porque viendo que Parallel_N64 rinde mucho mejor que Mupen64Plus_Next, me interesaba cambiar el emulador por defecto. Mupen64Plus_Next de hecho ni siquiera abre algunos juegos que antes iban con el emulador por defecto, así que quería cambiar eso sí o sí [+furioso]
Y respecto a Mupen64Plus Glide64MK2 y Mupen64PlusRice, no abren ningún juego de los que he probado, así que como si no existiesen de momento.

Ahora me queda ajustar las opciones de Parallel_N64 para ver si puedo corregir algunos errores gráficos (como el cielo en GoldenEye 007, que se ve mal).

Probaré con lo que me comentaste:
poseiido escribió:2. Prueba a crear un fichero de texto llamad ".core.cfg" (importante que tenga el punto en la primar posición), dentro de la carpeta de roms/n64. Y dentro del fichero, metes los parámetros que quieras que el emulador utilice.


¡Toca trastear! También tendré que mirar las opciones de system\configs\retroarch\cores\retroarch-core-options.cfg, ya que al menos ahí ya vienen "redactadas" algunas opciones del fichero, porque yo no sé programación ni comandos.
Aunque me jode que el resto de cores sí guardan lo que toco en retroarch y es muy fácil trastear, no sé por qué Parallel_N64 no guarda los cambios.

Un saludo y gracias!
189 respuestas
1, 2, 3, 4