CEMU - Emulador Wii U (para PC)

Daicon escribió:Buenas gente,
Estoy con cemu 1.8.1 y cdmuhook.
Intentado emular el Zelda en un 6500 y una AMD 480

Con OpenGL no consigo que me pase de 20fps.
Y con vulkan a pesar de pasar los 50 me pega unos tirones aleatorios que no entiendo

Es normal?

He leído que con vulkan no sirve las shsder cache? Que provoca los micro tirones?

Lo que no veo muy normal que con OpenGL me vaya a 20 fps no? O si,

En cualquier caso, lo idea sería utilizar vulkan en mi caso no?

Pero como digo, a pesar de tener una cache completa, me pega tirones aleatorios, y no aparece el icono de compilado cache....

A ver si me podéis ayudar.


Prueba la última versión, mejora la recopilación de shaders y por lo que se ya no hace falta el cemuhook.
michaelpegaso escribió:
Daicon escribió:Buenas gente,
Estoy con cemu 1.8.1 y cdmuhook.
Intentado emular el Zelda en un 6500 y una AMD 480

Con OpenGL no consigo que me pase de 20fps.
Y con vulkan a pesar de pasar los 50 me pega unos tirones aleatorios que no entiendo

Es normal?

He leído que con vulkan no sirve las shsder cache? Que provoca los micro tirones?

Lo que no veo muy normal que con OpenGL me vaya a 20 fps no? O si,

En cualquier caso, lo idea sería utilizar vulkan en mi caso no?

Pero como digo, a pesar de tener una cache completa, me pega tirones aleatorios, y no aparece el icono de compilado cache....

A ver si me podéis ayudar.


Prueba la última versión, mejora la recopilación de shaders y por lo que se ya no hace falta el cemuhook.

He probado la última sin el cemu hook

Pero me pasa igual,
Me pega tirones, sin aparecer el icono de shader compilado.

No se, leo cosas de que los shader de OpenGL no sirven...y no sé muy bien si el que me he descargado vale o no

Tengo un poco de lío

Se supone que se puedo jugar sin tirones con Viulkan?
@Daicon Teniendo gráfica amd es normal, los drivers opengl de amd son muy malos.

Saludos
Raugo escribió:@Daicon Teniendo gráfica amd es normal, los drivers opengl de amd son muy malos.

Saludos

Valdez entiendo, me centro en vulkan entonces...

Pero lo del shuttering aún bajando los shader completos?
Alguna solució?
@Daicon ¿Los shaders son los de Vulkan? Porque creo que son diferentes a los de Opengl. ¿Se te compilan al arrancar el juego?

Saludos
Raugo escribió:@Daicon ¿Los shaders son los de Vulkan? Porque creo que son diferentes a los de Opengl. ¿Se te compilan al arrancar el juego?

Saludos

Pues mira, he probado varios, pero es que no se seguro si son unos u otros.

En redit hay un hilo donde hay un listado que se supone que son, pero dice que son OpenGL compatibles con vulkan, o eso he entendido, pero no le veo sentido.

El caso es que si, compilan y tarda la vida la primera vez

Pero como te digo, luego jugando, hay shuttering muy aleatorio, el cual no se refleja en pantalla indicando que sea por compilación de shsder.
Mi experiencia en Vulkan me dice que tienes que jugar a los juegos...no valen los shaders de otro.

Y con la nueva versión publicada todo ha cambiado en Vulkan respecto a los shaders, que por cierto va bastante mejor.
paskhis escribió:Mi experiencia en Vulkan me dice que tienes que jugar a los juegos...no valen los shaders de otro.

Y con la nueva versión publicada todo ha cambiado en Vulkan respecto a los shaders, que por cierto va bastante mejor.

Pero entonces?
Nunca va a ir bien entonces? Hasta que te pases el juego una vez?

Y en qué ha cambiado en la última versión?

Pero entonces no vale nada de nada los.shsder estos que se transfieren?
Alguna pagina para descargar los shaders para 1.18?
Daicon escribió:
paskhis escribió:Mi experiencia en Vulkan me dice que tienes que jugar a los juegos...no valen los shaders de otro.

Y con la nueva versión publicada todo ha cambiado en Vulkan respecto a los shaders, que por cierto va bastante mejor.

Pero entonces?
Nunca va a ir bien entonces? Hasta que te pases el juego una vez?

Y en qué ha cambiado en la última versión?

Pero entonces no vale nada de nada los.shsder estos que se transfieren?

Ahora compilan más rápido y el efecto de suttering es menor. En la versión 1.19 van a introducir caché para que no exista suttering a cambio de que puedan no verse en tiempo real algunas texturas, es un hack para primar el juego a la fidelidad de emulación.
Hola a todos, un par de dudas, las keys que son y para que sirven? no he puesto ninguna y los juegos corren bien, solo esta el problema de los microtirones cuando carga los shaders, es posible instalarlos directamente? del mismo backup no se puede? Gracias
ainu3000 escribió:Hola a todos, un par de dudas, las keys que son y para que sirven? no he puesto ninguna y los juegos corren bien, solo esta el problema de los microtirones cuando carga los shaders, es posible instalarlos directamente? del mismo backup no se puede? Gracias


No me hagas mucho pero las keys creo q sirven para poder desencriptar un formato especial de dumps de juegos, si los tienes en archivos sueltos no te hacen falta.
Crash_alone escribió:
ainu3000 escribió:Hola a todos, un par de dudas, las keys que son y para que sirven? no he puesto ninguna y los juegos corren bien, solo esta el problema de los microtirones cuando carga los shaders, es posible instalarlos directamente? del mismo backup no se puede? Gracias


No me hagas mucho pero las keys creo q sirven para poder desencriptar un formato especial de dumps de juegos, si los tienes en archivos sueltos no te hacen falta.

Cierto, ya lo pude comprobar, segun el formato del backup necesita la key.

Ahora el tema de los shaders, se pueden usar shaders precargados en la ultima version del emulador?, los juegos me van bien pero pegan tirones al cargar los shaders por primera vez
Muy buenas, tengo la versión 1.13 me gustaría actualizarme, cómo lo puedo hacer sin perder las cosas.

Me recomendáis algún juego que enganche?
@ainu3000 Si, se pueden, pero solo con opengl, bajate el que necesites y cuando inicias el juego selecciona que vas a usar el shader existente pq ahora se usa una versión nueva shaders pero podes importar el formato antiguo de esa manera.

@Tardy Bajas la versión más reciente, reemplaza todos los archivos y actualiza los graphic packs, lo bueno es que en las últimas versiones incorporaron un actualizador en el mismo programa, saludos!
Zelda, Super Mario 3d land, new super mario, kirby, yoshi etc etc
En efecto, con la 1.19.0 yo ya no me preocuparía por los shader caché:

Se puede jugar online con el emulador? Aunque sea con otra persona que tenga el emulador.
@adriano_99 Si, pero no, no es como en dolphin, en cemu debes dumpear ciertos archivos de tu wiiU física y ponerlas en el emulador y asi poder usa el sistema online oficial de nintendo, ojala algun dia agreguen netplay como en dolphin, saludos!
Alejandro_Tomas escribió:En efecto, con la 1.19.0 yo ya no me preocuparía por los shader caché:



He instalado la nueva version de CEMU, cuando activo la nueva opción experimental "Async compile (Vulcan)" al arrancar cualquier juego me salta un error "Requiered extension: VK_EXT_pipeline_creation_cache_control" y me dice que para solucionar el error instale los últimos drivers de mi gráfica. La cosa es que he mirado en la pagina y tengo los últimos drivers instalados, a alguien mas le pasa y lo ha solucionado????
A mi me funciona perfecto, es una maravilla!!!!

He instalado los últimos drivers de AMD. Necesitas la última versión y creo que para NVIDIA aún no hay soporte en Linux.
michaelpegaso escribió:
Alejandro_Tomas escribió:En efecto, con la 1.19.0 yo ya no me preocuparía por los shader caché:



He instalado la nueva version de CEMU, cuando activo la nueva opción experimental "Async compile (Vulcan)" al arrancar cualquier juego me salta un error "Requiered extension: VK_EXT_pipeline_creation_cache_control" y me dice que para solucionar el error instale los últimos drivers de mi gráfica. La cosa es que he mirado en la pagina y tengo los últimos drivers instalados, a alguien mas le pasa y lo ha solucionado????

Te has instalado los últimos drivers en beta?
A mi me va perfecto también.
adriano_99 escribió:
michaelpegaso escribió:
Alejandro_Tomas escribió:En efecto, con la 1.19.0 yo ya no me preocuparía por los shader caché:



He instalado la nueva version de CEMU, cuando activo la nueva opción experimental "Async compile (Vulcan)" al arrancar cualquier juego me salta un error "Requiered extension: VK_EXT_pipeline_creation_cache_control" y me dice que para solucionar el error instale los últimos drivers de mi gráfica. La cosa es que he mirado en la pagina y tengo los últimos drivers instalados, a alguien mas le pasa y lo ha solucionado????

Te has instalado los últimos drivers en beta?
A mi me va perfecto también.


Me puedes pasar el enlace de esos drivers beta ?? Mi tarjeta es una gtx 1060 y uso los drivers 445.98
michaelpegaso escribió:
Me puedes pasar el enlace de esos drivers beta ?? Mi tarjeta es una gtx 1060 y uso los drivers 445.98

Está en la descripción del vídeo: https://developer.nvidia.com/vulkan-driver
adriano_99 escribió:
michaelpegaso escribió:
Me puedes pasar el enlace de esos drivers beta ?? Mi tarjeta es una gtx 1060 y uso los drivers 445.98

Está en la descripción del vídeo: https://developer.nvidia.com/vulkan-driver


Gracias, me han funcionado los drivers beta "443.15_geforce_win10_64bit_international"
Hola, a ver que me pierdo, he actualizado a la ultima version y el tema de shaders va igual, hay que poner la opcion vulcan experimental en api graficos?, si lo hago se cierra el emulador, la opcion de los shaders se deja en auto? en dispositivo grafico no me sale nada no se por que, tengo una 1050ti, he de instalar los beta teniendo la certificada mas reciente que esa? o van a parte los vulkan? Gracias
jjuanji escribió:BRUTAL! [amor]



Soy incapaz de hacer que me funcione reshade con cemu.
Hola, ya logre instalar los drivers beta para vulkan y en configuracion 3d de nvidia active varias opciones para nemu, no se si es necesario pero ahora si me marca mi tarjeta grafica y no se me crashea el emulador al poner la opcion vulkan.
El problema es que me sigue pasando los tirones por la carga de los shaders en casi todos los juegos menos en el mario kart 8 que ahora va bien, no entiendo nada, tengo la configuracion asi no se si es lo correcto para el tema de los shaders.
@ainu3000 Tenes que activar la opcion en depurar, experimental, activa el async, saludos!
Crash_alone escribió:@ainu3000 Tenes que activar la opcion en depurar, experimental, activa el async, saludos!

Ostras gracias, voy a probar, el resto lo tengo bien configurado?
@ainu3000 aparentemente si, aunque yo tengo en sombreadores precompilados la opción en auto
Bueno ya estuve probando varios juegos y el cambio de la nueva version con vulkan etc es brutal, ya no hay tirones por carga de shaders, quiza algun pequeño glitch grafico pero algo muy puntual y momentaneo, los juegos se ven increibles a 1080.

Solo tengo un problema y es con el Zelda breath of the wild, y es que va bien pero con pocos fps, el resto de juegos van perfectos con graficos al max pero este no, de 20 fps no pasaba, active 3 opciones en el mod grafico que pone fps++ y logre subir a unos aceptables 25-30 fps, pero me gustaria subir algo mas, no se si habra alguna opcion mas en el paquete grafico o alguna opcion del emulador para mejorar el rendimiento, porque con un i7 y una 1050ti deberia de sacar mas creo yo, que me decis? Gracias
@ainu3000
Imagen

Así lo tengo yo, tengo un I5 7600k con una gtx 1070, con Vulkan va clavado a 60 fps, espero q te sirva, saludos!
Crash_alone escribió:@ainu3000
Imagen

Así lo tengo yo, tengo un I5 7600k con una gtx 1070, con Vulkan va clavado a 60 fps, espero q te sirva, saludos!

Hola, gracias por esa configuracion, la acabo de probar pero solo he subido unos 3 fps mas, no se si habra alguna opcion mas en el emulador que debiera activar o en la configuracion 3d de nvidia, me parece poco aumento de fps, aunque es jugable a una media de 28-32 fps algunos fps vendrian bien, ire trasteando, gracias
@ainu3000

Sigue esa guía y después nos cuentas, saludos.
Ya está liberado el 1.19?
Dónde le puedo pillar?
@Tardy

si, si tienes instalada una version anterior la puedes actualizar online

sino, desde la web de cemu ya esta colgada
todavia no se puede conectar el gampead de la wiiu, para utilizar la segunda pantalla?
Bueno al final viendo el video que pusisteis me di cuenta de que habia una configuracion para cada juego para los nucleos del procesador que desconocia, lo tenia en single y lo puse en triple core y el zelda paso automaticamente de 28-34 fps a 38-44fps, asi que va perfecto ahora.

Alguno usa el mod Clarity del pack grafico? el mejor preset es el default no? cambia mucho con esos presets aunque un poco exagerados algunos
Hay alguna forma de saber si la característica async shaders vulkan es compatible con las 970GTX?

Saludos.
@ainu3000 Esos mods son una cuestión personal, depende de tu gusto, yo lo dejo por defecto.

@gordon81 https://developer.nvidia.com/vulkan-driver Se supone que si puedes instalar el beta driver te funcionara, tu VGA figura en la lista, saludos!
¿Alguien sabe como arreglar esto?
https://www.reddit.com/r/cemu/comments/ ... s_in_botw/



Es como que las texturas parpadean, bueno los bordes y las sombras, el juego se ve bien pero hace eso raro ya me lo hizo en la última versión que lo probé.

Lo siento por no poder grabar un vídeo pero en este momento no puedo.

Lo que me pasa se parece mucho a esto:

El emulador solo me usa como mucho el 50% del procesador, aunque lo ponga en "recompilador de triple núcleo". Mi CPU es un i7 4770K (4 núcleos, 8 hilos). ¿Alguien sabe por qué? A causa de esto, hay juegos que no me terminan de tirar bien como Mario Kart 8 (no es que me vaya muy mal, pero no va fluido del todo) o Breath of the Wild a 60 fps (a 30 me va perfecto).
@GordonFreeman
A mi me pasa lo mismo, con el ordenador de mi firma nunca lo he visto mas del 55%. Pero lo que si noto es que llega al tope de frecuencia turbo de la cpu, se me queda a 3´9, pero de uso de la cpu 55%.
@michaelpegaso Eso os pasa porque el emulador usa como mucho 3 cores. Si vuestro pc tiene, por ejemplo, 12 cores el máximo porcentaje al que va a llegar es 25% de uso. El turbo sube a tope pero al no usar todos los cores del procesador el % no llegará al 100%.
ashurek escribió:@michaelpegaso Eso os pasa porque el emulador usa como mucho 3 cores. Si vuestro pc tiene, por ejemplo, 12 cores el máximo porcentaje al que va a llegar es 25% de uso. El turbo sube a tope pero al no usar todos los cores del procesador el % no llegará al 100%.


Pero si usara 3 cores, a mi me pondría 75% de uso, no 50, ya que tengo 4...
@GordonFreeman tienes 8 hilos y usa 4 (3 para cpu y uno extra para el resto de cosas) por lo que que ronde el 50% es lo normal.

Saludos
Me he enganchado a base de bien al Zelda Botw, va de maravilla, pero me he encontrado con un problema, juego con el mando de la 360 y en cemu como el controller pro y todo perfecto, el caso que me encuentro ahora algunas criptas que requieren el Gamepad por el tema de acelerometros, alguien tiene alguna solucion?, lo configure para usar el teclado y raton y consigo que funcione pero es inmanejable con raton, no se si hay alguna solucion mas efectiva o alguna configuracion mejor, Gracias
ainu3000 escribió:Me he enganchado a base de bien al Zelda Botw, va de maravilla, pero me he encontrado con un problema, juego con el mando de la 360 y en cemu como el controller pro y todo perfecto, el caso que me encuentro ahora algunas criptas que requieren el Gamepad por el tema de acelerometros, alguien tiene alguna solucion?, lo configure para usar el teclado y raton y consigo que funcione pero es inmanejable con raton, no se si hay alguna solucion mas efectiva o alguna configuracion mejor, Gracias


Yo me lo pase con un mando de xbox one y con el raton sin configurar, algunas mazmorras me costaron mas de 30 intentos. Yo lo pase hace mucho, ahora se puede configurar el acelerometro de cualquier movil para hacerlo, busca información en youtube para seguir los pasos.
@ainu3000 Hay una manera de usar cualquier dispositivo andriod con una app.
4399 respuestas
184, 85, 86, 87, 88