CEMU - Emulador Wii U (para PC)

Cory escribió:El problema de cemu es que no está disponible el código fuente. El día que sea un emulador de código abierto como dolphin veremos mejoras radicales.

Pero a saber si algún día se libera el código fuente

Tenemos decaf-emu
https://github.com/decaf-emu/decaf-emu

Que tiene peor rendimiento
Ronbin escribió:
Cory escribió:El problema de cemu es que no está disponible el código fuente. El día que sea un emulador de código abierto como dolphin veremos mejoras radicales.

Pero a saber si algún día se libera el código fuente

Tenemos decaf-emu
https://github.com/decaf-emu/decaf-emu

Que tiene peor rendimiento


Para GameCube tenemos el emulador gecko que también es de código abierto

https://github.com/shonumi/gekko-gc-emu

Que también tiene peor rendimiento que dolphin.

Cemu ya tiene una velocidad decente así que si lo pasan a código abierto veremos muchas mejoras pronto
Es normal que con un ordenador portatil con un procesador i7-8750h, 16gb de ram y una rtx 2060 el zelda de la wii u me vaya a 15 fps.. o menos..
¿Es culpa de mi ordenador o del emulador que le queda trabajo? gracias!
valdivia escribió:Es normal que con un ordenador portatil con un procesador i7-8750h, 16gb de ram y una rtx 2060 el zelda de la wii u me vaya a 15 fps.. o menos..
¿Es culpa de mi ordenador o del emulador que le queda trabajo? gracias!

algo tienes mal, a mi con una 750ti y un i5 3440 me iba a 30 fps... ya hace que no toco el emulador, pero imagino que irá mejor ahora
valdivia escribió:Es normal que con un ordenador portatil con un procesador i7-8750h, 16gb de ram y una rtx 2060 el zelda de la wii u me vaya a 15 fps.. o menos..
¿Es culpa de mi ordenador o del emulador que le queda trabajo? gracias!

Tienes los shader caché ya completos o el ordenador los esta creando?
Por que al principio va lento si tiene que ir recopilando los shader caché.
fulfidor escribió:
valdivia escribió:Es normal que con un ordenador portatil con un procesador i7-8750h, 16gb de ram y una rtx 2060 el zelda de la wii u me vaya a 15 fps.. o menos..
¿Es culpa de mi ordenador o del emulador que le queda trabajo? gracias!

Tienes los shader caché ya completos o el ordenador los esta creando?
Por que al principio va lento si tiene que ir recopilando los shader caché.


Pues los esta creando, yo solo cargue el juego.. lo mismo me falta eso verdad?
valdivia escribió:
fulfidor escribió:
valdivia escribió:Es normal que con un ordenador portatil con un procesador i7-8750h, 16gb de ram y una rtx 2060 el zelda de la wii u me vaya a 15 fps.. o menos..
¿Es culpa de mi ordenador o del emulador que le queda trabajo? gracias!

Tienes los shader caché ya completos o el ordenador los esta creando?
Por que al principio va lento si tiene que ir recopilando los shader caché.


Pues los esta creando, yo solo cargue el juego.. lo mismo me falta eso verdad?

Si, da igual el ordenador que tengas, sin shader caché te irá lento hasta que los haya creado (o los consigas tu por otros lados)
Realice lo de la shader cache con mejora de rendimiento en super mario 3d world, pero en zelda sigue igual de 13 a 15 fps dando gracias...
Buenas a ver si alguien me ayuda ya que soy nuevo y ando perdido. He instalado la última versión a día de hoy y tengo el zelda breath of the wild pero no sé configurar el mando de xbox one. El mando lo conecto por cable usb por si es importante

Ayuda por favor.
Ya está disponible la versión 1.16.0 que viene con Vulkan. Mejora ostensible del rendimiento en equipos con AMD.
TitoKeren escribió:Ya está disponible la versión 1.16.0 que viene con Vulkan. Mejora ostensible del rendimiento en equipos con AMD.

E incluso en equipos con intel y nvidia, no por rendimiento neto, porque hay en juegos que va mejor y en otros peor, pero lo que si que es cierto es que vulkan apaliza a opengl a la hora de cachear los shaders; es que puedes jugar directamente sin haber hecho cacheo y casi ni lo notas, y si ya has cacheado, los shaders cargan en 3 segundos en lugar de tirarse 3 minutos.
Intento emular Pikmin 3 con la última versión del emulador, parece que va muy bien, salvo porque no consigo que el personaje se mueva bien, asigno los botones de mi mando de One, y al mover al personaje, se para en seco cuando giro el stick hacia arriba, y tengo que insistir para que vaya en esa dirección. ¿Alguien sabe por qué?
¿Bayonetta 2 os crashea? Porque en la versión anterior me funcionaba pero en la actual 1.16 no. Igual es por los shaders caché viejos pero vamos que no le encuentro explicación...
VEGASFII escribió:¿Bayonetta 2 os crashea? Porque en la versión anterior me funcionaba pero en la actual 1.16 no. Igual es por los shaders caché viejos pero vamos que no le encuentro explicación...


A mi me funciona bien sin shaders (tampoco los tenía de antes). Eso sí, a 30fps.

Saludos,
Me interesaba el emulador pero viendo que usuarios con mejores equipos (https://insertmorecoins.es/foro/wii-u/c ... -con-cemu/) no lo han podido mover decentemente; mejor ni lo intento, no?

PD: El mío está en la firma
@llAsturianoll

Por intentarlo creo que no pierdes nada. A lo mejor te llevas una sorpresa. ;)
llAsturianoll escribió:Me interesaba el emulador pero viendo que usuarios con mejores equipos (https://insertmorecoins.es/foro/wii-u/c ... -con-cemu/) no lo han podido mover decentemente; mejor ni lo intento, no?

PD: El mío está en la firma


En un Fx6300 he movido yo Zelda, Captain Toad, Donkey Kong, SM 3d World...si le puedes hacer un poco de OC (hasta 3,9 deberia llegar sin subir voltaje, casi asegurado), mejor.

Lo que te puede lastrar son los 8gb de Ram, especialmente en el Zelda con el Shader Caché completo. Hay una opción para mejorar esto, pero no recuerdo cual es ya que hace tiempo pasé a 16.
Probaré a ver entonces, hacer OC no me apetece mucho solo para emular esto. Gracias por vuestra ayuda, a ver si puedo mover algún juego [+risas]
Hacer OC en tu placa, la he tenido, es sencillo como ello solo, yo tenia ese FX subido a 3,9 a menor voltaje que por defecto, no te digo mas.

Pero, bueno, aun con la CPU en defecto te animo a que vayas cacharreando con el CEMU, es un emulador bastante amigable, aunque lo mejor es que veas/leas alguna guia para lo básico.
jhunt escribió:Hacer OC en tu placa, la he tenido, es sencillo como ello solo, yo tenia ese FX subido a 3,9 a menor voltaje que por defecto, no te digo mas.

Pero, bueno, aun con la CPU en defecto te animo a que vayas cacharreando con el CEMU, es un emulador bastante amigable, aunque lo mejor es que veas/leas alguna guia para lo básico.


Igual lo hago si veo que va mal el emulador. No se subía mucho la temperatura, no? Es que nunca he hecho OC a nada [+risas]
@llAsturianoll

Si consigues subirle frecuencia bajando voltaje tal como te ha dicho el compañero, no sólo no aumentará su temperatura, sino que probablemente, disminuya.
SirAzraelGrotesque escribió:@llAsturianoll

Si consigues subirle frecuencia bajando voltaje tal como te ha dicho el compañero, no sólo no aumentará su temperatura, sino que probablemente, disminuya.


Qué consecuencia negativa podría traer eso? Disminuir la vida útil de la gráfica ligeramente?

(Perdón por desviar el tema momentáneamente)
Ostras....estas verde verde jeje

Al contrario, tu si a un componente le disminuyes el voltaje al que funciona, se calienta menos, y por ende durará mas.

Los FX son conocidos por traer un voltaje alto de fábrica por eso, incluso a menor voltaje del que viene por defecto, suelen subir practicamente todos 300-400-500 mhz sin despeinarse.

Pero, ya te digo, busca alguna guia o video de youtube y verás que es cosa de 5 minutos (aunque si quieres testear estabilidad te irás a mas tiempo) y te puedo asegurar que ese 6300 sube a 3,8-3,9 sin necesidad de incrementar voltaje. Y que si por defecto lo tienes a 1,35V lo habrás bajado a 1,20V o menos (ahi ya es buscarle el punto).

Para esto, creeme, no es necesario ser ningun entendido, y ganaras en temperaturas, rendimiento, etc.

Tampoco es que el CEMU vaya a volar con ese OC pero te irá algo mejor.

Edit: tambien, si puedes apañar 8gb mas de Ram, lo vas a agradecer. A mi el Zelda me come entre 9 y 10. Los demas no tanto.
jhunt escribió:Ostras....estas verde verde jeje

Al contrario, tu si a un componente le disminuyes el voltaje al que funciona, se calienta menos, y por ende durará mas.

Los FX son conocidos por traer un voltaje alto de fábrica por eso, incluso a menor voltaje del que viene por defecto, suelen subir practicamente todos 300-400-500 mhz sin despeinarse.

Pero, ya te digo, busca alguna guia o video de youtube y verás que es cosa de 5 minutos (aunque si quieres testear estabilidad te irás a mas tiempo) y te puedo asegurar que ese 6300 sube a 3,8-3,9 sin necesidad de incrementar voltaje. Y que si por defecto lo tienes a 1,35V lo habrás bajado a 1,20V o menos (ahi ya es buscarle el punto).

Para esto, creeme, no es necesario ser ningun entendido, y ganaras en temperaturas, rendimiento, etc.

Tampoco es que el CEMU vaya a volar con ese OC pero te irá algo mejor.

Edit: tambien, si puedes apañar 8gb mas de Ram, lo vas a agradecer. A mi el Zelda me come entre 9 y 10. Los demas no tanto.


Muchísimas gracias por tu explicación, la verdad que en tema ordenadores entiendo lo justo.

Seguramente se lo haga entonces ya no solo por el emulador sino por todo en general. La RAM miraré a ver más adelante, de momento tendrá que esperar que acabo de actualizarme con un SSD [carcajad]
Buenas. Estaba probando cemu 1.16.1 con todo el rollo este de Vulkan y las mejoras de rendimiento que se venían diciendo y mi intención es jugar a Zelda a 60fps relativamente estables, pero con el equipo de la firma, ajustes gráficos configurados y shaders precompilados descargados de otro ususario el juego me va con bastante stuttering y caídas de fps randoms. Lo juego a 2k pero es que pasa igual a 1080p y si lo pongo a 4k el juego va a 50-55fps así que debería ir sobrado a 2k. ¿Alguien sabe si con el equipo de la firma se puede jugar a 60fps medianamente estables de alguna forma?

Edit: cuando llevas un rato jugando va bastante decente, pero cada vez que ves algo o haces algo por primera vez mete stuttering aunque tenga los shaders ya creados.
Suele ser normal si lo estas empezando, aun con los shaders, con ese equipo te deberia ir a 60 sin problemas.

llAsturianoll escribió:Muchísimas gracias por tu explicación, la verdad que en tema ordenadores entiendo lo justo.

Seguramente se lo haga entonces ya no solo por el emulador sino por todo en general. La RAM miraré a ver más adelante, de momento tendrá que esperar que acabo de actualizarme con un SSD [carcajad]


Meter un SSD es una de las mejores cosas que puedes hacer en un PC, muy buena idea. Tu vete haciendote al emulador, trastea, prueba cosas...es lo divertido, aparte de jugar claro :)

Yo tuve la Wii U y unos cuantos juegos pero la comodidad de poder ejecutarlos en PC, con mejores opciones, calidad, poder personalizarlos (graphic packs, ya lo iras viendo), no tiene precio.

Yo juego al Zelda a 30fps con un Fx tambien, pero estable como una roca y con mejor resolución, graphic packs a mi gusto, etc, una maravilla y eso que ya le di 100 horas en consola, pero en PC lo que me queda....
¿Hay alguna diferencia entre tener CEMU y el juego en un SSD y un HDD? Porque en mi experiencia no parece que estrese mucho el HDD. Aunque igual al tener que estar leyendo miles de archivos de shaders se puede notar algo...
Strait escribió:¿Hay alguna diferencia entre tener CEMU y el juego en un SSD y un HDD? Porque en mi experiencia no parece que estrese mucho el HDD. Aunque igual al tener que estar leyendo miles de archivos de shaders se puede notar algo...

Dónde la vas a notar es a la hora de cargar los shaders
michaelpegaso escribió:
Strait escribió:¿Hay alguna diferencia entre tener CEMU y el juego en un SSD y un HDD? Porque en mi experiencia no parece que estrese mucho el HDD. Aunque igual al tener que estar leyendo miles de archivos de shaders se puede notar algo...

Dónde la vas a notar es a la hora de cargar los shaders


¿Pero en los juegos se nota menos stuttering mientras juegas o sigue yendo igual? Porque si solo es cargar lo dejo en el HDD que tampoco tengo prisa.
Te va a dar igual, solo se nota al cargar el caché y la diferencia tampoco creo que sea mucha.
con vulkan ademas la cosa a mejorado.
Con Nvidia, va mejor OpenGL que Vulkan. Tanto en las 960 o 1070 que tuve, como en mi actual 1080Ti.
supermuto escribió:Con Nvidia, va mejor OpenGL que Vulkan. Tanto en las 960 o 1070 que tuve, como en mi actual 1080Ti.


Quitando el tema del stuttering al crear shaders me va bastante más estable en vulkan que en opengl con una nvidia.
Strait escribió:
supermuto escribió:Con Nvidia, va mejor OpenGL que Vulkan. Tanto en las 960 o 1070 que tuve, como en mi actual 1080Ti.


Quitando el tema del stuttering al crear shaders me va bastante más estable en vulkan que en opengl con una nvidia.


Pues entonces no será ni por Nvidia ni por Endibias. A mi cualquier emulador me tira siempre mejor en OpenGL, por delante de DirectX o Vulkan... a saber.
Buenas, hace tiempo probé el breath of the wild con una 970 y un r7 1700 pero no me iba a 60 fps justos así que decidí esperarme a tener una mejor gráfica.
Ahora lo estoy jugando con una 2070 super pero da igual lo que haga, empieza entre 15 y 20 fps durante unos segundos y luego se queda clavado a 20 fps.
Da igual que cambie, que baje la resolucion, opngl o vulkan, va a 20 fps con la gráfica sin inmutarse.
No debería ser el procesador porque tenia el mismo con la 970 y ningun núcleo esta colapsado.
Tengo la última versión de cemu 1.16.1 con el new super mario bross wii u y no se que hacer pero el juego se crashea, congela,... y como no puedes salvar las partidas hasta los castillos, no me apetece ni jugar para que lleves 10 minutos jugando y no puedas ni guardar. Hay alguna solución?

Tengo los shader, he bajado el fix para el crasheo del inicio de carga, lo tengo en vulkan con la RX 580 ya que en OpenGL tiene peor rendimiento. A ver si alguien me puede iluminar porque este juego va mal o es mi pc.
apriliars3 escribió:Tengo la última versión de cemu 1.16.1 con el new super mario bross wii u y no se que hacer pero el juego se crashea, congela,... y como no puedes salvar las partidas hasta los castillos, no me apetece ni jugar para que lleves 10 minutos jugando y no puedas ni guardar. Hay alguna solución?

Tengo los shader, he bajado el fix para el crasheo del inicio de carga, lo tengo en vulkan con la RX 580 ya que en OpenGL tiene peor rendimiento. A ver si alguien me puede iluminar porque este juego va mal o es mi pc.


En los pack gráficos donde los pones a 4k o resolución que quieras hay una opción para evitar eso.
adriano_99 escribió:Buenas, hace tiempo probé el breath of the wild con una 970 y un r7 1700 pero no me iba a 60 fps justos así que decidí esperarme a tener una mejor gráfica.
Ahora lo estoy jugando con una 2070 super pero da igual lo que haga, empieza entre 15 y 20 fps durante unos segundos y luego se queda clavado a 20 fps.
Da igual que cambie, que baje la resolucion, opngl o vulkan, va a 20 fps con la gráfica sin inmutarse.
No debería ser el procesador porque tenia el mismo con la 970 y ningun núcleo esta colapsado.


Yo lo estoy jugando a 60fps con algo de stuttering al generar shaders (los que tiene que generar tu propio PC sí o sí) y más o menos quitando eso el juego va a 2k 60fps relativamente bien. Cuando te llevas un buen rato en una misma zona y no te aparece nada nuevo mantiene los 60 como rocas.
Strait escribió:
adriano_99 escribió:Buenas, hace tiempo probé el breath of the wild con una 970 y un r7 1700 pero no me iba a 60 fps justos así que decidí esperarme a tener una mejor gráfica.
Ahora lo estoy jugando con una 2070 super pero da igual lo que haga, empieza entre 15 y 20 fps durante unos segundos y luego se queda clavado a 20 fps.
Da igual que cambie, que baje la resolucion, opngl o vulkan, va a 20 fps con la gráfica sin inmutarse.
No debería ser el procesador porque tenia el mismo con la 970 y ningun núcleo esta colapsado.


Yo lo estoy jugando a 60fps con algo de stuttering al generar shaders (los que tiene que generar tu propio PC sí o sí) y más o menos quitando eso el juego va a 2k 60fps relativamente bien. Cuando te llevas un buen rato en una misma zona y no te aparece nada nuevo mantiene los 60 como rocas.

A mí no, de 20 no me pasa.
adriano_99 escribió:
Strait escribió:
adriano_99 escribió:Buenas, hace tiempo probé el breath of the wild con una 970 y un r7 1700 pero no me iba a 60 fps justos así que decidí esperarme a tener una mejor gráfica.
Ahora lo estoy jugando con una 2070 super pero da igual lo que haga, empieza entre 15 y 20 fps durante unos segundos y luego se queda clavado a 20 fps.
Da igual que cambie, que baje la resolucion, opngl o vulkan, va a 20 fps con la gráfica sin inmutarse.
No debería ser el procesador porque tenia el mismo con la 970 y ningun núcleo esta colapsado.


Yo lo estoy jugando a 60fps con algo de stuttering al generar shaders (los que tiene que generar tu propio PC sí o sí) y más o menos quitando eso el juego va a 2k 60fps relativamente bien. Cuando te llevas un buen rato en una misma zona y no te aparece nada nuevo mantiene los 60 como rocas.

A mí no, de 20 no me pasa.


A mi me pasa igual... de 15 o 20 no pasa
valdivia escribió:
A mi me pasa igual... de 15 o 20 no pasa

Que equipo tienes?
Aunque da un poco igual porque tanto mi gráfica como el procesador estan en porcentajes de uso ridículos y da igual cuanto baje la resolucion.
michaelpegaso escribió:
apriliars3 escribió:Tengo la última versión de cemu 1.16.1 con el new super mario bross wii u y no se que hacer pero el juego se crashea, congela,... y como no puedes salvar las partidas hasta los castillos, no me apetece ni jugar para que lleves 10 minutos jugando y no puedas ni guardar. Hay alguna solución?

Tengo los shader, he bajado el fix para el crasheo del inicio de carga, lo tengo en vulkan con la RX 580 ya que en OpenGL tiene peor rendimiento. A ver si alguien me puede iluminar porque este juego va mal o es mi pc.


En los pack gráficos donde los pones a 4k o resolución que quieras hay una opción para evitar eso.


Sigue pasando, jugando se crashea, no se que más puedo hacer.

No es al iniciar el juego, sino jugando en cualquier momento, ya puede ser cuando llevas 2 minutos o 5 minutos. Solo he probado este juego.

Los shader los he bajado de aqui https://www.reddit.com/r/CEMUcaches/com ... ollection/

Aunque con la opción que dices tu se ha descargado todos los packs a 1080 y se ve mucho mejor, pero sigue crasheando cemu 1.16.1 con la opción vulkan experimental en la RX 580.

PD: Se queda colgado o crashea, da igual lo que haga, hasta he probado sin vsync.

Imagen
adriano_99 escribió:
valdivia escribió:
A mi me pasa igual... de 15 o 20 no pasa

Que equipo tienes?
Aunque da un poco igual porque tanto mi gráfica como el procesador estan en porcentajes de uso ridículos y da igual cuanto baje la resolucion.


Un ordenador portatil con un procesador i7-8750h, 16gb de ram DDR4 y una rtx 2060 6GB
¿Y teneis el emulador bien configurado? Buscad alguna guia estilo las del canal de BsoD que son bastante detalladas y explica especialmente como configurarlo para el Zelda, elegir la guia mas reciente que tenga y listo. Con esos equipos deberia iros a 30, minimo, sin problemas.

De todas maneras, lo primordial para los fps es precisamente toquitear los graphic packs y ahi elegir la tasa, resolución, etc.
jhunt escribió:¿Y teneis el emulador bien configurado? Buscad alguna guia estilo las del canal de BsoD que son bastante detalladas y explica especialmente como configurarlo para el Zelda, elegir la guia mas reciente que tenga y listo. Con esos equipos deberia iros a 30, minimo, sin problemas.

De todas maneras, lo primordial para los fps es precisamente toquitear los graphic packs y ahi elegir la tasa, resolución, etc.

He mirado un montón y he probado todas las configuraciones posibles
Pues se me hace raro. Comentas que cambiaste la gráfica y esperabas jugar mejor pero con esa 970 tenias de sobra (aunque ya imagino que no la has cambiado solo por eso) para el CEMU, en este importa mas la CPU, luego si tienes graficón está bien para subir a 4k y tal.

Tengo peor gráfica y cpu y los 30 me los hace fácil, si pongo el limite en 60 me va entre 50 y 55 asi que prefiero los 30 estables.

Deberias poder jugarlo bien con ese equipo, yo te insisto en que sigas alguna guia al dedillo aunque implique empezar de cero. Y esencial usar el shader cache, claro, aunque doy por supuesto que lo haces.
De donde bajáis las roms? Me baje el usb helper y se descarga las rom en formatos que no lee cemu, y no se como hacerlo.

Ya conseguí que funcione mejor new super mario bross wii usando el cemu hook, o por lo menos eso parece ya que desde que hice eso nunca se cuelga ni crashea.
Ya ha salido la versión 1.17 y Xenoblade Chronicles X sigue sin funcionar bien, algo pasa que desde la versión 1.16.1 con Vulkan no se puede jugar. Asi que toca volver a la 1.16 para jugar a este título. Alguna manera de descargar esta versión desde la propia página de Cemu?
apriliars3 escribió:De donde bajáis las roms? Me baje el usb helper y se descarga las rom en formatos que no lee cemu, y no se como hacerlo.

Ya conseguí que funcione mejor new super mario bross wii usando el cemu hook, o por lo menos eso parece ya que desde que hice eso nunca se cuelga ni crashea.


Hasta hace no mucho usaba una web con torrents llamada portalroms que estaba genial, pero por lo visto la han tirado abajo hace poco, esa y emuparadise pero a esta tambien le prohibieron alojar roms y solo queda la parte de información (que no está nada mal).

Hace tiempo que no uso el helper pero que yo recuerde leia perfectamente lo que me bajaba de cemu, lo unico que tienes que ponerlo dentro de una de las carpetas del emulador porque lo lee como si fuera un juego "a instalar" por decirlo asi, googleando no creo que tardes en encontrarlo.
jhunt escribió:
apriliars3 escribió:De donde bajáis las roms? Me baje el usb helper y se descarga las rom en formatos que no lee cemu, y no se como hacerlo.

Ya conseguí que funcione mejor new super mario bross wii usando el cemu hook, o por lo menos eso parece ya que desde que hice eso nunca se cuelga ni crashea.


Hasta hace no mucho usaba una web con torrents llamada portalroms que estaba genial, pero por lo visto la han tirado abajo hace poco, esa y emuparadise pero a esta tambien le prohibieron alojar roms y solo queda la parte de información (que no está nada mal).

Hace tiempo que no uso el helper pero que yo recuerde leia perfectamente lo que me bajaba de cemu, lo unico que tienes que ponerlo dentro de una de las carpetas del emulador porque lo lee como si fuera un juego "a instalar" por decirlo asi, googleando no creo que tardes en encontrarlo.


De Emuparadise de puede seguir bajando todo. Al menos lo que no es de Nintendo.

P.D.: Acabo de estar mirando y lo de la propia Nintendo no está. Pero sí el resto de juegos para sus plataformas.
4274 respuestas
182, 83, 84, 85, 86