[TUTORIAL]Instalar y poner a punto psl1ght en Windows

15, 6, 7, 8, 9
¿Sería mucha molestia actualizar el hilo principal con las herramientas actualizadas y demás?
Es que lo estoy instalando pero después he visto muchas actualizaciones y demás... :-?

Muchas gracias igualmente!! ;)
Qarl escribió:¿Sería mucha molestia actualizar el hilo principal con las herramientas actualizadas y demás?
Es que lo estoy instalando pero después he visto muchas actualizaciones y demás... :-?

Muchas gracias igualmente!! ;)


Puedes descargar la versión de marioga.
Está ya explicado

hilo_ps3sdk-3-0_1532294
varios escribió:
Qarl escribió:¿Sería mucha molestia actualizar el hilo principal con las herramientas actualizadas y demás?
Es que lo estoy instalando pero después he visto muchas actualizaciones y demás... :-?

Muchas gracias igualmente!! ;)


Puedes descargar la versión de marioga.
Está ya explicado

hilo_ps3sdk-3-0_1532294

Creo que es la mejor solución si.
Muchas gracias!! ;)

EDITO: Ya he conseguido instalarlo pero... no me firma las aplicaciones, ¿qué ocurre?
Buenas señores ya he colocado esta consulta en el hilo del CFW de hermes pero quizas alguien mas pueda ayudarme :) .

Tengo un problema a la hora de compilar el payload de hermes para su CFW, tengo la ultima version actualizada de PSL1GHT que la baje del Post de marioga PS3SDK 3.0, primero me daba errores con el freetype pero lo solucione copiando la carpeta "freetype" que se encontraba dentro de freetype2 pero luego me daba el error de que no encontraba msgdialog.h asi que lo busque en tu Fork de PSL1GHT en tu .Git y lo copie adonde faltaba en sysutils/msgdialog.h pero ahora me da el siguiente problema:

[R2H] andika_ttf.bin
[R2H] payload_groove_hermes.bin
[CC]  gfx.c
[CC]  main.c
[CC]  pad.c
[CC]  syscall8.c
[LD]  payloadhv4.elf
main.o: In function `main':
c:/ps3sdk/PLANRebug/payloadhv4/source/main.c:456: undefined reference to `.MsgDi
alogOpen'
c:/ps3sdk/PLANRebug/payloadhv4/source/main.c:465: undefined reference to `.MsgDi
alogClose'
collect2: ld returned 1 exit status
make[1]: *** [/c/ps3sdk/PLANRebug/payloadhv4/payloadhv4.elf] Error 1
make: *** [build] Error 2


He oido que el payload fue hecho en una version mas antigua de PSL1GHT y que de ahi vienen los problemas con esta nueva version, que me recomiendan que haga? he oido que ya habias logrado configurar y poner a funcionar la nueva version de PSL1GHT o quizas tenga que usar otra version de PSL1GHT para compilar el Payload hermesv4D de su CFW?.

Saludos!.
ing_pereira escribió:He oido que el payload fue hecho en una version mas antigua de PSL1GHT y que de ahi vienen los problemas con esta nueva version, que me recomiendan que haga? he oido que ya habias logrado configurar y poner a funcionar la nueva version de PSL1GHT o quizas tenga que usar otra version de PSL1GHT para compilar el Payload hermesv4D de su CFW?.

Saludos!.

Pues si te digo la verdad, pasé de Windows y me puse de lleno a instalar el PSL1GHT en Ubuntu de nuevo y... tras muchos quebraderos de cabeza conseguí instalarlo y ahora complia los pkg firmados perfectamente, así que cuando tenga menos líos con mis estudios empezaré ha trastear y hacer pruebecillas.
Para instalarlo seguí el tutorial oficial del PSL1GHT pero sin hacer el paso de "Building" (una vez terminas el de "Environment" ya tienes todo listo).

PD: Haber si saco un hueco y hago un pequeño tutorial actualizado porque al fin y al cabo no es difícil instalarlo en Ubuntu y además tiramos de software libre, muy importante jaja.

Suerte!! ;)
he actualizado ps3sdk ejecuta el actualizador.bat, actualiza todo (A fecha de ayer a las 3 del medio dia o asi)

Changes:
Se actualiza PSL1GHT
Se actualiza SDL
Se arregla problema con freetype
Se añade libfont de hermes (k tenia el makefile sin arreglar y por eso no se instalo)
Aquí está una primera versión de lo que estoy haciendo:

http://www.multiupload.com/7Z9UD4Z8K7

Esta probada con CFW 3.41. No sé si funciona en otro firmware ya que no puedo probar ni sé si firma bien el SDK. Agradecería que alguien lo probara en algún CFW 3.55.

Acepto opiniones de mi aplicación .... [jaja].
Es una primera versión y he puesto sonidos que luego pienso cambiar y las imágenes están hechas en poco tiempo ... luego igual las cambio.

Hermes aparece y di que te parece, gran parte es gracias a ti por ps3soundlib y tiny3D. Y a marioga porque ahora uso su SDK.

Saludos.
dark_on_5 está baneado por "saltarse baneo temporal con clon"
1 error y 2 warning:

[CC]  utils.c
c:/PS3SDK/source/utils.c: In function 'wait_dialog':
c:/PS3SDK/source/utils.c:50:5: warning: implicit declaration of function 'msgDia
logAbort'
c:/PS3SDK/source/utils.c: In function 'DrawDialogOK':
c:/PS3SDK/source/utils.c:58:5: warning: implicit declaration of function 'msgDia
logOpen2'


[LD]  PS3SDK.elf
c:/ps3sdk/host/ppu/bin/../lib/gcc/ppu/4.5.2/../../../../ppu/bin/ld.exe: cannot f
ind -lmod
collect2: ld returned 1 exit status
make[1]: *** [/c/PS3SDK/PS3SDK.elf] Error 1
make: *** [build] Error 2
Presione una tecla para continuar . . .


Es el source original de HManager.
Parecen errores de diferentes versiones.
El primero de versión de psl1ght o eso parece.
El segundo error de ps3soundlib, hay descargar la ultima versión de ps3lib, compilar y copiar la libreria en c:\ps3sdk\target\lib;

Voy a mirarlo ...

Edito: acabo de compilar libmod.a, la adjunto extraela y copiala en c:\ps3sdk\target\lib
T_T Hermes anda borrando sus mensajes y ya me atore

compile una prueba pero creo que no esta firmada para 3.55 (me sale error 8003-519 en la ps3)

xD de por si no sabia usar el .bat (uso minGW)

Alguna forma para que funcione en 3.55?????? [buuuaaaa]
Parece que hackerchannel tmbn se esta tomando un descanso, he encontrado este github en el que siguen metiendo mejoras constantemente pero yo no voy a actualizar el ps3sdk hasta k la cosa no se aclare pk yo no puedo hacer 2000 versiones una para cada git

https://github.com/miigotu Nuevos ps3toolchain, ps3libraries, y 2 psl1ght distintos?

https://github.com/ps3dev Antiguo ps3libraries y ps3toolchain
https://github.com/HACKERCHANNEL antiguo psl1ght

https://github.com/cebash/SDL_PSL1GHT SDL para psl1ght
Malphasbcs escribió:T_T Hermes anda borrando sus mensajes y ya me atore

compile una prueba pero creo que no esta firmada para 3.55 (me sale error 8003-519 en la ps3)

xD de por si no sabia usar el .bat (uso minGW)

Alguna forma para que funcione en 3.55?????? [buuuaaaa]


[carcajad] me autocito

ya encontre la solucion, lo encontre en el hilo de ubuntu [+risas] parece que las tools de Geo no estan en lo que baje (que es lo del la pagina 1) y se tiene que firmar por aparte, use el Ps3Signed

Deberian actualizar el wiki y poner una seccion para nubs (como yo) que hay partes muy basicas que no explican pero es quebradero de cabeza para muchos [bye]
Acabo de actualizar un poco la WIKI para el nuevo metodo de ps3toolchain
el enlace del ps3toolchain del wiki no jala

igual yo sigo con la compilacion viejita [+risas] que por cierto, no logro encontrar el soundlib de hemes [triston]
Depois der ler tudo isto fiquei confuso como devo proceder para instalar o psl1ght no windows?

Tradução google:
después de leer todo esto yo estaba confundido como proceder con la instalación psl1ght en windows?

Se puede poner paso a paso?
Gracias
414 respuestas
15, 6, 7, 8, 9