[HO] Yuzu (Emulador de Switch)

IRC_ketchUP escribió:Es la CPU sí, busca un núcleo físico que esté cercano al 100% de uso y confirmas.



Me he puesto a dar vueltas en una de las zonas de mayor estrés. Como se ve en la última versión de yuzu mainline y EA la carga de memoria RAM ya ha disminuido y está en unos valores normales aunque la VRAM sigue en valores altos.
astarothbcn escribió:¿Que tal funciona el mando pro original de la switch con el emu? Estoy pensando en pillarme uno por el tema de giroscopio y demás. ¿Por bluetooth funciona bien? Tengo bluetooth 5.3 en la placa base y nose si funciona bien por BT o mejor con cable.

Yo recomiendo el 8bitpro inalámbrico y con gyro, por precio-calidad, y los botones traseros (en TOTK yo los he usado para sprint y L2/LT/ZL; el escudo, que me servía para girar rápidamente la cámara a 180º por ejemplo), el dualsense normal que no tiene botones traseros no me ha valido por eso.

Sobre la latencia como decía el compañero @gordon81 no sé, no he notado nada raro. Eso sí, el dualsense tiene la mejor sensibilidad/resolución del stick analógico (puntos por recorrido 360º, el círculo vaya) que hay, cosa muy útil si quieres jugar con gyro+flickstick y emular lo que harías con un ratón en un shooter.
astarothbcn escribió:¿Que tal funciona el mando pro original de la switch con el emu? Estoy pensando en pillarme uno por el tema de giroscopio y demás. ¿Por bluetooth funciona bien? Tengo bluetooth 5.3 en la placa base y nose si funciona bien por BT o mejor con cable.



Píllate el DualSense, va de cojones y también tiene Giroscopio
Sobre el zelda por ahora se recomienda la recomprensión ASTC para equipos justo en hardware
@TitoKeren Probaste los modos de recomprensión ASTC si ayuda?

De todos modos hay constancia de reportes de fuga de memoria VRAM en este juego que aún no hay una solución incluso pasa también con algunas GPU nvidia..
https://github.com/yuzu-emu/yuzu/issues/10245
TitoKeren escribió:
IRC_ketchUP escribió:Es la CPU sí, busca un núcleo físico que esté cercano al 100% de uso y confirmas.



Me he puesto a dar vueltas en una de las zonas de mayor estrés. Como se ve en la última versión de yuzu mainline y EA la carga de memoria RAM ya ha disminuido y está en unos valores normales aunque la VRAM sigue en valores altos.

Teniendo en cuenta que los cores que muestras (12) incluyen también a los SMT (Simultaneous Multithreading), y que el Ryzen 5 1600 tiene 6 cores físicos, puedes comprobar si los cores mantienen max clock (3.6 GHz)?. Y si no fuera así, se me ocurre lo siguiente, prueba a limitar el uso de yuzu a través del admin de tareas de windows a solo 4-5 cores reales o 8-10 cores totales.

tab servicios, buscar proceso, click derecho establecer afinidad

Se mantienen los hercios mas altos? Yuzu solo necesita esos cores, puede ser que tu CPU este limitando el rendimiento de yuzu por que no es capaz de mantener los hercios en todos los 6 cores al mismo tiempo? en el vídeo se ve como la carga, aparte de ver cores a +80%, queda distribuida en mas o menos todos los 6 (12).

Es algo que hay que hacer manualmente (existen software de terceros que lo hacen auto) cada vez que inicias yuzu.

Y puestos a liarte mas (por rascar unos pocos mas de FPS), y si fuera tema de cores que no llegan a dar todo el rendimiento, en la bios (AMD siempre ha facilitado el OC) guardas la config que tengas, y trasteas a ver si puedes limitar el OC en los cores que no necesites y subirlo en los que sí.

Si no, en cualquier caso, cada FPS de mas que saques mejor, limitas a 35, 40, 45, etc.:
*usando siempre DynamicFPS + 60fps_stable_static y limitando con rivatuner o similares.
*o también a través del límite de emulación que trae el propio yuzu y usando únicamente DynamicFPS de chuck
*o solo el FPS++ (ahora llamado DynamicFPS++) y rivatuner o similares.

Las caídas de 60 a 30 se notan muchísimo, pero limitando a 40 por ejemplo, caídas de 40 a 30 ya son menos notables.
TitoKeren escribió:
IRC_ketchUP escribió:Es la CPU sí, busca un núcleo físico que esté cercano al 100% de uso y confirmas.



Me he puesto a dar vueltas en una de las zonas de mayor estrés. Como se ve en la última versión de yuzu mainline y EA la carga de memoria RAM ya ha disminuido y está en unos valores normales aunque la VRAM sigue en valores altos.


esa cpu para 60 fps te va a ir justita....si es a 20/30 fps y algun nucleo llega al 80%, imaginate cuando dupliques fps lo que va a pasar con esos nucleos....
aunque tengan 6/12 hilos, y un rendimiento decente en multi hilo, el rendimiento single core no es para tirar cohetes....
a partir de los r5 3600, amd consigue tener un ipc mas decente, y ya es equiparable a un i5 10400f....y aun siendo los r5 3600 iguales a los i5 10400f en single core, y superiores en multi core, los 10400f rinden mas EN JUEGOS que estos...solo hay que ver videos en yutuf donde enfrentan a ambas cpus EN JUEGOS y es raro ver al de amd por encima

ojo, que recalco EN JUEGOS

Imagen



@IRC_ketchUP compañero gracias por la aclaracion de las gpus amd en windows 10 y con vulkan...ese uso de gpu es exageradamente alto en comparacion con una gpu nvidia de la misma potencia
dinamita4922 escribió:esa cpu para 60 fps te va a ir justita....si es a 20/30 fps y algun nucleo llega al 80%, imaginate cuando dupliques fps lo que va a pasar con esos nucleos....
aunque tengan 6/12 hilos, y un rendimiento decente en multi hilo, el rendimiento single core no es para tirar cohetes....
a partir de los r5 3600, amd consigue tener un ipc mas decente, y ya es equiparable a un i5 10400f....y aun siendo los r5 3600 iguales a los i5 10400f en single core, y superiores en multi core, los 10400f rinden mas EN JUEGOS que estos...solo hay que ver videos en yutuf donde enfrentan a ambas cpus EN JUEGOS y es raro ver al de amd por encima

ojo, que recalco EN JUEGOS

De todas formas no busco los 60 fps con este juego en emulador. Se que con mi equipo aunque team yuzu optimice no me llega para los 60 fps. Lo más cerca que he tenido es con Breath of The Wild en Cemu versión 1.26.2f que me oscila entre los 40 y los 60 fps a 1080p.

Lo que si aspiro es a los 4K/30 fps ya que he estado haciendo pruebas y con el Breath of The Wild en Yuzu si me los da en las zonas de mayor estrés siendo al 90 % el mismo juego que el TOTK y con el mismo motor gráfico:



Con este juego si han conseguido que los valores de VRAM se mantengan lógicos (es raro que llegue a los 5GB teniendo una gráfica de 8 GB) al igual que la RAM. Así que a ver si con un poco de paciencia el Team Yuzu consigue optimizar al máximo la emulación del Tears of the Kingdom.
Con el zelda al empezar jugando consume unos 6GBVRAM en una nvidia 3090 (básicamente es la NVIDIA A100 SXM4 40 GB pero es detectectada como 3090)

Imagen

Con el paso del tiempo cuánto más juegues 21GB de VRAM [fumando]

Imagen

Solo queda tiempo y paciencia xq hay constancia desde bugs gráficos especificos y consumo de VRAM y ram altos en este juegos .
estoy seguro de que en unos meses estará solucionado, yo con mi humilde 3080ti me lo he pasado entero a x3 - SMAA- Amd Fidelity entre 45/60 FPS

con 3 o 4 bloqueos a lo sumo
@Mikel24 Dualsense tengo dos,probaré,no habia caido en eso. ¿Por usb o por bt valdria? Por comodidad seria mejor BT
Por ahora se sabe que los modos de recomprensión ASTC ayuda en GPUS con poca VRAM

BC3 parece funcionar bien para usuarios con 4 GB aunque en algunos modelos tienen un mal manejo en la VRAM y toca utilizar el sistema low BC1
BC1 logra que el juego se pueda reproducir en GPU de 2 GB y opciones de escalado de resolución sub-1X.
No se recomienda utilziar otras resoluciones que no sean 1X, 2X, 4X, y 8X siempre que haya suficiente hw para subir de resolución.
Los usuarios de Pascal/Maxwell (series GeForce 750/900/1000) deben actualizar al controlador más reciente y habilitar "Preferir DXGI Swapchain" en la configuración 3D del panel de control de NVIDIA, .
Las tarjetas GCN antiguas (serie Radeon 300 y anteriores, incluida la serie HD 7000) e Intel Gen 9/9.5 (serie HD/UHD 500/600) no son viables en Windows, sus controladores fuera de soporte son demasiado antiguos para este juego.
En cambio, los usuarios de AMD e Intel pueden usar Linux, los controladores de Mesa se actualizan y brindan una representación adecuada tanto en OpenGL como en Vulkan. Los usuarios de GCN1 y GCN2 deben forzar manualmente el módulo del kernel amdgpu para obtener compatibilidad con Vulkan.
Las GPU RDNA3 (serie RX 7000) tienen problemas de representación específicos que afectan a los controladores de Windows y Linux en el cual ya se ha reportado un reporte a AMD del motivo causante .
Intel Gen 12 (UHD 700/Iris Xe/Arc series) tiene controladores de Windows y Mesa rotos el juego no se puede jugar con ellos sin un archivo guardado más allá de la introducción y puede fallar al azar.
A la espera que intel saque un fix en sus drivers .
No se recomienda jugar con mods por ahora debido que se ha encontrado algunas inestabilidades y errores gráficos en determinados hw.

Un resumen del estado actual del juego [beer]
astarothbcn escribió:@Mikel24 Dualsense tengo dos,probaré,no habia caido en eso. ¿Por usb o por bt valdria? Por comodidad seria mejor BT


Bluetooth lo juego yo perfectamente, instala el programa https://ds4-windows.com/ configura todo bien y listo

También es válido para Cemu (Wiiu) y Dolphin (Wii)
Mikel24 escribió:
astarothbcn escribió:@Mikel24 Dualsense tengo dos,probaré,no habia caido en eso. ¿Por usb o por bt valdria? Por comodidad seria mejor BT


Bluetooth lo juego yo perfectamente, instala el programa https://ds4-windows.com/ configura todo bien y listo

También es válido para Cemu (Wiiu) y Dolphin (Wii)

Yo acabo de hacerme con un dualsense, probé esa app y no fui capaz de hacerla funcionar la verdad, no me reconoce el mando, pero vamos con Steam lo configuré todo (incluso le cambié el color al led a mi gusto) configuré el mando con Cemu y Yuzu sin problema alguno por buetooth, es super cómodo de encender y apagar sobre todo el dualsense, tengo el mando pro de Switch y es el que estaba usando en PC y me va perfecto pero es un coñazo el "encenderlo y apagarlo" en pc, cada vez que lo quiero usar lo tengo que sincronizar y cada vez que lo quiero apagar lo tengo que desincronizar
litos89 escribió:
Mikel24 escribió:
astarothbcn escribió:@Mikel24 Dualsense tengo dos,probaré,no habia caido en eso. ¿Por usb o por bt valdria? Por comodidad seria mejor BT


Bluetooth lo juego yo perfectamente, instala el programa https://ds4-windows.com/ configura todo bien y listo

También es válido para Cemu (Wiiu) y Dolphin (Wii)

Yo acabo de hacerme con un dualsense, probé esa app y no fui capaz de hacerla funcionar la verdad, no me reconoce el mando, pero vamos con Steam lo configuré todo (incluso le cambié el color al led a mi gusto) configuré el mando con Cemu y Yuzu sin problema alguno por buetooth, es super cómodo de encender y apagar sobre todo el dualsense, tengo el mando pro de Switch y es el que estaba usando en PC y me va perfecto pero es un coñazo el "encenderlo y apagarlo" en pc, cada vez que lo quiero usar lo tengo que sincronizar y cada vez que lo quiero apagar lo tengo que desincronizarlo



Yo recuerdo que el programa me dio un poco por saco, pero lo solucione quitando esta opción Settings/Hide DS4 controller
litos89 escribió:
Mikel24 escribió:
astarothbcn escribió:@Mikel24 Dualsense tengo dos,probaré,no habia caido en eso. ¿Por usb o por bt valdria? Por comodidad seria mejor BT


Bluetooth lo juego yo perfectamente, instala el programa https://ds4-windows.com/ configura todo bien y listo

También es válido para Cemu (Wiiu) y Dolphin (Wii)

Yo acabo de hacerme con un dualsense, probé esa app y no fui capaz de hacerla funcionar la verdad, no me reconoce el mando, pero vamos con Steam lo configuré todo (incluso le cambié el color al led a mi gusto) configuré el mando con Cemu y Yuzu sin problema alguno por buetooth, es super cómodo de encender y apagar sobre todo el dualsense, tengo el mando pro de Switch y es el que estaba usando en PC y me va perfecto pero es un coñazo el "encenderlo y apagarlo" en pc, cada vez que lo quiero usar lo tengo que sincronizar y cada vez que lo quiero apagar lo tengo que desincronizar



Si es la app original, hace tiempo que se dejo de acualizar, tienes que buscar la bifurcación de Ryochan7 creo que se llamaba...cuando tenga un rato la linkeo

edito

https://github.com/Ryochan7/DS4Windows

creo que es la misma
dinamita4922 escribió:
litos89 escribió:
Mikel24 escribió:
Bluetooth lo juego yo perfectamente, instala el programa https://ds4-windows.com/ configura todo bien y listo

También es válido para Cemu (Wiiu) y Dolphin (Wii)

Yo acabo de hacerme con un dualsense, probé esa app y no fui capaz de hacerla funcionar la verdad, no me reconoce el mando, pero vamos con Steam lo configuré todo (incluso le cambié el color al led a mi gusto) configuré el mando con Cemu y Yuzu sin problema alguno por buetooth, es super cómodo de encender y apagar sobre todo el dualsense, tengo el mando pro de Switch y es el que estaba usando en PC y me va perfecto pero es un coñazo el "encenderlo y apagarlo" en pc, cada vez que lo quiero usar lo tengo que sincronizar y cada vez que lo quiero apagar lo tengo que desincronizar



Si es la app original, hace tiempo que se dejo de acualizar, tienes que buscar la bifurcación de Ryochan7 creo que se llamaba...cuando tenga un rato la linkeo

edito

https://github.com/Ryochan7/DS4Windows

creo que es la misma

probaré a ver si la hago funcionar, por cierto ya que estoy os pregunto que lo mismo sabéis decirme, el dualsense en los juegos de pc compatibles con sus controles hápticos y tal, solo funcionan si esta el mando conectado por cable? en cuanto le quito el cable y lo conecto por bluetooth el mando funciona pero las funcionen esas no :-?
Solo funciona por cable los hapticos si
El dualsense funciona de forma nativa en las últimas versiones de yuzu (también cemu, y sin cemuhook) y sin tener que usar otro software. Yo recomiendo usar otros programas para ponerle efectos a los gatillos R2/L2, y además reducir el recorrido analógico cuando éste no lo utilice el juego (TOTK) y hacerlo más digital, para que no haga falta pulsar tan a fondo, yo he usado DS4W, sospecho que la vida útil del muellecillo que llevan dentro se ve afectada; me he cargado 3 hasta que he empezado a configurarlo así.
(mensaje borrado)
Hola de nuevo amig@s, a ver si me ayudais con este problema que me acaba de aparecer en el portátil pero en el de sobremesa no, sin hacer nada como siempre enciendo el portátil se pon buscando actualizaciones y demás y me ha aparecido este pantallita diciendo esto, muchas gracias de ante mano


Saludos
[quote="MaXiMu"]Por ahora se sabe que los modos de recomprensión ASTC ayuda en GPUS con poca VRAM

BC3 parece funcionar bien para usuarios con 4 GB aunque en algunos modelos tienen un mal manejo en la VRAM y toca utilizar el sistema low BC1
BC1 logra que el juego se pueda reproducir en GPU de 2 GB y opciones de escalado de resolución sub-1X.
No se recomienda utilziar otras resoluciones que no sean 1X, 2X, 4X, y 8X siempre que haya suficiente hw para subir de resolución.
Los usuarios de Pascal/Maxwell (series GeForce 750/900/1000) deben actualizar al controlador más reciente y habilitar "Preferir DXGI Swapchain" en la configuración 3D del panel de control de NVIDIA, .
Las tarjetas GCN antiguas (serie Radeon 300 y anteriores, incluida la serie HD 7000) e Intel Gen 9/9.5 (serie HD/UHD 500/600) no son viables en Windows, sus controladores fuera de soporte son demasiado antiguos para este juego.
En cambio, los usuarios de AMD e Intel pueden usar Linux, los controladores de Mesa se actualizan y brindan una representación adecuada tanto en OpenGL como en Vulkan. Los usuarios de GCN1 y GCN2 deben forzar manualmente el módulo del kernel amdgpu para obtener compatibilidad con Vulkan.
Las GPU RDNA3 (serie RX 7000) tienen problemas de representación específicos que afectan a los controladores de Windows y Linux en el cual ya se ha reportado un reporte a AMD del motivo causante .
Intel Gen 12 (UHD 700/Iris Xe/Arc series) tiene controladores de Windows y Mesa rotos el juego no se puede jugar con ellos sin un archivo guardado más allá de la introducción y puede fallar al azar.
A la espera que intel saque un fix en sus drivers .
No se recomienda jugar con mods por ahora debido que se ha encontrado algunas inestabilidades y errores gráficos en determinados hw.

Un resumen del estado actual del juego [beer][/quote

Buenas tardes:

Yo con una R9380x no puedo jugarlo. En vulkan corre perfecto hasta la primera introduccion, despues de eso no puedo abrirlo de ninguna manera. ¿Sabes como podria solucionarlo?

Muchas gracias compañero.
keygen82 escribió:
Yo con una R9380x no puedo jugarlo. En vulkan corre perfecto hasta la primera introduccion, despues de eso no puedo abrirlo de ninguna manera. ¿Sabes como podria solucionarlo?

Muchas gracias compañero.


Sobre la GPU R9 380x como no dices el sistema operativo que utilizas se recomienda por motivos obvios ya que no hay soporte en windows por amd (y no sacan nuevos drivers desde hace tiempo en el cual a nivel de implementaciones nuevas sobre Vulkan necesarias para yuzu ) y cada vez están saliendo errores especificos a que se cambie a linux si te pasa en linux y últimos drivers mesa 23.x yo intentaría reportarlo bajo discord a ver que te dicen

Si linux no es una opción para ti intenta cambiar a OpenGL a ver si puedes avanzar esa zona y luego volver a cambiar a vulkan pero te digo que en la actualidad este juego es muy irregular con el uso de la VRAM por lo que toca esperar a que lo perfeccionen en determinado hw

Porque has probado las opciones ASTC de recomprensión?
..
MaXiMu escribió:
keygen82 escribió:
Yo con una R9380x no puedo jugarlo. En vulkan corre perfecto hasta la primera introduccion, despues de eso no puedo abrirlo de ninguna manera. ¿Sabes como podria solucionarlo?

Muchas gracias compañero.


Sobre la GPU R9 380x como no dices el sistema operativo que utilizas se recomienda por motivos obvios ya que no hay soporte en windows por amd (y no sacan nuevos drivers desde hace tiempo en el cual a nivel de implementaciones nuevas sobre Vulkan necesarias para yuzu ) y cada vez están saliendo errores especificos a que se cambie a linux si te pasa en linux y últimos drivers mesa 23.x yo intentaría reportarlo bajo discord a ver que te dicen

Si linux no es una opción para ti intenta cambiar a OpenGL a ver si puedes avanzar esa zona y luego volver a cambiar a vulkan pero te digo que en la actualidad este juego es muy irregular con el uso de la VRAM por lo que toca esperar a que lo perfeccionen en determinado hw

Porque has probado las opciones ASTC de recomprensión?
..

Buenas noches:

Disculpa, el sistemaes windows, con un i5 4640 y 16gb de ram. Con Open GL imposible, fallos graficos y a 5 o 6 fps. He intentado avanzar un poco en Open GL como dices para luego volver a vulcan, pero de momento tampoco. Tambien he probado las opciones de ASTC.

Muchas gracias por todo.
Alucinando con Yuzu en Android. Mario 3D World y DKC a 60 fps estables en un Poco F5 Pro
¿Existe alguna manera de saber qué firmware tienes puesto en el emulador?
(mensaje borrado)
alaun escribió:Alguien conoce alguna web donde descargar shaders? MP please...



con Vulkan apenas noto tirones ni nada, así que hace años que deje de buscar Shaders
Mikel24 escribió:
alaun escribió:Alguien conoce alguna web donde descargar shaders? MP please...



con Vulkan apenas noto tirones ni nada, así que hace años que deje de buscar Shaders

Es que en Android supone ir a 58-60 fps estables... Se nota, por eso los pedía por MP....
alaun escribió:
Mikel24 escribió:
alaun escribió:Alguien conoce alguna web donde descargar shaders? MP please...



con Vulkan apenas noto tirones ni nada, así que hace años que deje de buscar Shaders

Es que en Android supone ir a 58-60 fps estables... Se nota, por eso los pedía por MP....



tema android mejor ir a su hilo oficial hilo_hilo-yuzu-emulador-de-nintendo-switch-en-android_2482401
Mikel24 escribió:
alaun escribió:Alguien conoce alguna web donde descargar shaders? MP please...



con Vulkan apenas noto tirones ni nada, así que hace años que deje de buscar Shaders


La primera vez que genera los shaders puede da algún tironcillo sobre todo si tienes menos de 16GB .

@alaun yo te recomiendo que si tienes PC para ello los generes en el PC que la generación está por ahora más pulida y luego lo pases al móvil

Por cierto no lo publique aquí pero envíe una socilitud para ejecutar yuzu en la misma switch o el mismo soc TX1 de la switch bajo linux Linux for tegra

https://github.com/yuzu-emu/yuzu/commit ... e7896d4c5b

Hay algunos juegos que ejecutándolos en la misma switch + linux encima todavía la switch es conseguir buenos resultados en fps

Quien diría que la switch puede "Emular" algunos encima de un sistema operativo XD .
MaXiMu escribió:
Mikel24 escribió:
alaun escribió:Alguien conoce alguna web donde descargar shaders? MP please...



con Vulkan apenas noto tirones ni nada, así que hace años que deje de buscar Shaders


La primera vez que genera los shaders puede da algún tironcillo sobre todo si tienes menos de 16GB .

@alaun yo te recomiendo que si tienes PC para ello los generes en el PC que la generación está por ahora más pulida y luego lo pases al móvil

Por cierto no lo publique aquí pero envíe una socilitud para ejecutar yuzu en la misma switch o el mismo soc TX1 de la switch bajo linux Linux for tegra

https://github.com/yuzu-emu/yuzu/commit ... e7896d4c5b

Hay algunos juegos que ejecutándolos en la misma switch + linux encima todavía la switch es conseguir buenos resultados en fps

Quien diría que la switch puede "Emular" algunos encima de un sistema operativo XD .

Yo es que solo juego a Yuzu en Android y ya te digo que la diferencia se nota...y mucho. Si algun alma caritativa de apiada... Algunos he encontrado, pero pocos...
@alaun Puedes dejar de trollear?.

Se te ha dicho 2 veces que este no es el hilo de Android y sigues erre que erre.

Y además, estás pidiendo que te envien enlaces ilegales de shaders.

Escribe en el hilo de Android de Yuzu y lo otro se puede uno buscar la vida en cuestión de segundos por Google. Pero aquí no se puede andar pidiendo enlaces de roms, shaders...
@alaun , como te han apuntado los compañeros, tienes el hilo de android para yuzu: [rtfm]

hilo_ho-yuzu-emulador-de-switch_2438245_s950#p1753950557

y como también han apuntado, no se puede solicitar contenido protegido por derechos de autor.
Volviendo al tema de yuzu en pc, en las ultimas Build (Early Access) han mejorado el filtro anisotrópico para zelda y el metroid (en otros juegos puede crear conflicto)

https://wccftech.com/yuzu-anisotropic-f ... e-kingdom/

Mas reportes sobre cambios en Yuzu: https://yuzu-emu.org/entry/yuzu-progres ... -may-2023/
DarkMessiah escribió:@alaun Puedes dejar de trollear?.

Se te ha dicho 2 veces que este no es el hilo de Android y sigues erre que erre.

Y además, estás pidiendo que te envien enlaces ilegales de shaders.

Escribe en el hilo de Android de Yuzu y lo otro se puede uno buscar la vida en cuestión de segundos por Google. Pero aquí no se puede andar pidiendo enlaces de roms, shaders...

Mis disculpas. Soy novato en todo esto y no sabía que son enlaces ilegales.
Buenas. A ver como puedo realizar esta pregunta sin caer en algún incumplimiento de normas. Mis disculpas de antemano por si acaso.

Tengo la switch, pero me gusta además utilizar el PC como emulador y trastear etc. Me descargué 4 juegos (en mi caso se deberían considerar copias de seguridad) que tienen incluida su propia versión del emulador Yuzu. Una especie de repack.

Ahora me gustaría todos "agruparlos" bajo la misma versión actualizada del emulador. Entonces me he descargado el emulador de cero, y los juegos que antes tenía cada uno con su propio emulador, he cogido el directorio de NAND donde está cada juego, lo he copiado a un directorio común, y desde el yuzu nuevo le he dicho que cargue esa carpeta. Todo me funciona correctamente, PERO:

Primero, cada "pack" en particular tiene dentro del NAND varios archivos, a pesar de que solo tenga un juego. Cuando cargo la carpeta común y tiene, digamos, 4 juegos pero 16 archivos, me muestra correctamente 4 juegos. Entonces los 12 archivos restantes para qué sirven?

Segundo, en cada "pack" particular me muestra el juego con su nombre y cover. Pero al cargarlo desde el emulador nuevo, sólo me muestra el HEX (digo que será eso :P) más el tamaño de cada uno. Debo copiar algo más o se me está pasando algo?

Si en lugar de hacerlo como comento, le pido instalar en la NAND del nuevo emulador el archivo, pasa exactamente lo mismo.

No hay posibilidad de "editar" título y cover? porque sí existe la posibilidad de darle "propiedades" al juego, pero los campos no son editables.
desconozco de donde has descargado los pack, lo que si te puedo decir es recomendarte lo siguiente

Yuzu en su ultima versión early access (actualiza cada 15 días por ejemplo, ya que salen versiones todos los días y es un coñazo): https://github.com/pineappleEA/pineapple-src/releases
buscar las ultimas Keys y Firmwares V16.0.3 (actualmente) usa Google
Backups con extensión .XCI o .NSP
Mikel24 escribió:desconozco de donde has descargado los pack, lo que si te puedo decir es recomendarte lo siguiente

Yuzu en su ultima versión early access (actualiza cada 15 días por ejemplo, ya que salen versiones todos los días y es un coñazo): https://github.com/pineappleEA/pineapple-src/releases
buscar las ultimas Keys y Firmwares V16.0.3 (actualmente) usa Google
Backups con extensión .XCI o .NSP



Muchas gracias. Eso pensaba hacer. Intuyo que del XCI o NSP "extrae" algún metadato del NAND que luego se queda reflejado en el listado de la NAND del juego, pero que a la hora de simplemente copiar y pegar no se refleja (probablemente se guarde en alguna configuración que desconozco, por eso decía que a lo mejor podía copiar algun archivo de configuración del pack al nuevo emulador).

Es que la idea final es tener un backup de todos los sistemas, como tengo de consolas de 16 bits etc. de forma que el día que quiera pasarlo a otro pc o lo que sea, copie la carpeta de roms y automáticamente salga todo el listado con sus nombres y covers. Pero intuyo que eso para emuladores más modernos es más complicado
Tengo parones en el Zelda Tears of the Kingdom. ¿Alguien sabe por qué es? Si no fuese por eso, iría de lujo con el mod a 60 fps, pero es que tengo parones de 1 o 2 segundos, parecen como cargas, pero no creo que lo sean. No es por cálculo de shaders. El PC que tengo está en mi firma... es decir, que potencia no me falta.
GordonFreeman escribió:Tengo parones en el Zelda Tears of the Kingdom. ¿Alguien sabe por qué es? Si no fuese por eso, iría de lujo con el mod a 60 fps, pero es que tengo parones de 1 o 2 segundos, parecen como cargas, pero no creo que lo sean. No es por cálculo de shaders. El PC que tengo está en mi firma... es decir, que potencia no me falta.


Probaste a actualizar a versiones recientes de early access no? Y tienes los últimos drivers gráficos actualizados ? Se ha mejorado en los últimos cambios pero aún no es del todo perfecto y recomiendo tener la recomprensión ASTC activada y comprobar con y sin si obtienes alguna mejoria .

Las funciones Decode ASTC textura Asincrona en gráficos - avanzado previene que haya algo de suttering en las cargas junto a usar Shader asíncronos hack

Si toqueteando esas opciones no lo solucionas poco puedes hacer por ahora .
MaXiMu escribió:
GordonFreeman escribió:Tengo parones en el Zelda Tears of the Kingdom. ¿Alguien sabe por qué es? Si no fuese por eso, iría de lujo con el mod a 60 fps, pero es que tengo parones de 1 o 2 segundos, parecen como cargas, pero no creo que lo sean. No es por cálculo de shaders. El PC que tengo está en mi firma... es decir, que potencia no me falta.


Probaste a actualizar a versiones recientes de early access no? Y tienes los últimos drivers gráficos actualizados ? Se ha mejorado en los últimos cambios pero aún no es del todo perfecto y recomiendo tener la recomprensión ASTC activada y comprobar con y sin si obtienes alguna mejoria .

Las funciones Decode ASTC textura Asincrona en gráficos - avanzado previene que haya algo de suttering en las cargas junto a usar Shader asíncronos hack

Si toqueteando esas opciones no lo solucionas poco puedes hacer por ahora .

Gracias por la respuesta.

Sí, uso la última versión EA del emulador, y los drivers están totalmente actualizados.

Parece que con esa opción se reduce algo, pero sigue habiendo. Volveré a probar en unos días, porque es bastante molesto. Está claro que van tocando continuamente cosas, pues probé el juego hace un par de días y el juego se colgaba, con la actual no.
@GordonFreeman No deberías tener ningún problema con esa máquina; las versiones estables de yuzu hace tiempo que te lo moverían a 60. Es algo de la configuración, alguna incompatibilidad de mods, o posible regresión de rendimiento con las versiones ea (esto último improbable en tú caso, por que la CPU va arramplar con todo). Sin mods a 30 no te pasa verdad? qué mods estás usando? tienes algo como MSI afterburner para comprobar el rendimiento en tiempo real?

Los parones en todo caso (causados por mods de 60 o compilación de shaders) son de micro segundos. 1-2 segundos es muy exagerado.
IRC_ketchUP escribió:@GordonFreeman No deberías tener ningún problema con esa máquina; las versiones estables de yuzu hace tiempo que te lo moverían a 60. Es algo de la configuración, alguna incompatibilidad de mods, o posible regresión de rendimiento con las versiones ea (esto último improbable en tú caso, por que la CPU va arramplar con todo). Sin mods a 30 no te pasa verdad? qué mods estás usando? tienes algo como MSI afterburner para comprobar el rendimiento en tiempo real?

Los parones en todo caso (causados por mods de 60 o compilación de shaders) son de micro segundos. 1-2 segundos es muy exagerado.

También pasa a 30 y sin mods. No sé por qué será, he probado activando y desactivando varias opciones. Estuve probando también el Super Mario Odyssey, y este me va perfecto.

Otro que acabo de probar es Link's Awakwening, y también perfecto. Este además va mejor que en la consola, que tiene ralentizaciones cada vez que pasas de zona o sales de un interior al exterior, en el emulador nada.
GordonFreeman escribió:
IRC_ketchUP escribió:@GordonFreeman No deberías tener ningún problema con esa máquina; las versiones estables de yuzu hace tiempo que te lo moverían a 60. Es algo de la configuración, alguna incompatibilidad de mods, o posible regresión de rendimiento con las versiones ea (esto último improbable en tú caso, por que la CPU va arramplar con todo). Sin mods a 30 no te pasa verdad? qué mods estás usando? tienes algo como MSI afterburner para comprobar el rendimiento en tiempo real?

Los parones en todo caso (causados por mods de 60 o compilación de shaders) son de micro segundos. 1-2 segundos es muy exagerado.

También pasa a 30 y sin mods. No sé por qué será, he probado activando y desactivando varias opciones. Estuve probando también el Super Mario Odyssey, y este me va perfecto.

Otro que acabo de probar es Link's Awakwening, y también perfecto. Este además va mejor que en la consola, que tiene ralentizaciones cada vez que pasas de zona o sales de un interior al exterior, en el emulador nada.

A mi me pasaba que tenía puesto el nivel de precisión en alto y me hacía microcortes molestos. Lo puse en normal y se aliviaron mucho. Seguía habiendo pero muchos menos. Me refiero a la opción que está en gráficos>avanzado>nivel de precisión.
TitoKeren escribió:
GordonFreeman escribió:
IRC_ketchUP escribió:@GordonFreeman No deberías tener ningún problema con esa máquina; las versiones estables de yuzu hace tiempo que te lo moverían a 60. Es algo de la configuración, alguna incompatibilidad de mods, o posible regresión de rendimiento con las versiones ea (esto último improbable en tú caso, por que la CPU va arramplar con todo). Sin mods a 30 no te pasa verdad? qué mods estás usando? tienes algo como MSI afterburner para comprobar el rendimiento en tiempo real?

Los parones en todo caso (causados por mods de 60 o compilación de shaders) son de micro segundos. 1-2 segundos es muy exagerado.

También pasa a 30 y sin mods. No sé por qué será, he probado activando y desactivando varias opciones. Estuve probando también el Super Mario Odyssey, y este me va perfecto.

Otro que acabo de probar es Link's Awakwening, y también perfecto. Este además va mejor que en la consola, que tiene ralentizaciones cada vez que pasas de zona o sales de un interior al exterior, en el emulador nada.

A mi me pasaba que tenía puesto el nivel de precisión en alto y me hacía microcortes molestos. Lo puse en normal y se aliviaron mucho. Seguía habiendo pero muchos menos. Me refiero a la opción que está en gráficos>avanzado>nivel de precisión.

Me pasa también, tanto en normal, como en alto y extreme.
Probastes ponerlo en modo portátil? Se que no es la solución más idónea pero algunas veces poniéndolo en modo portátil el comportamiento de tirones deja de suceder .
MaXiMu escribió:Probastes ponerlo en modo portátil? Se que no es la solución más idónea pero algunas veces poniéndolo en modo portátil el comportamiento de tirones deja de suceder .

Pasa lo mismo el dock y portátil.

¿Vosotros lo habéis probado con la última versión y os va perfecto?

Por cierto, otro juego que he probado es Kirby and the Forgotten Land. Con la última versión crashea al iniciar la cinemática inicial, ni llega a la pantalla de título, y además crashea con un sonido extremadamente desagradable. He bajado la versión de Yuzu EA 3600 de hace un mes, y funciona absolutamente perfecto con el mod de 60 fps, que por cierto, se ve muy bonito ese juego a 60 fps y 2K. Tengo que probar el Zelda con alguna versión anterior, a ver si mejora en el tema de los tirones.
Los tirones te han pasado siempre ? O desde alguna build en concreto ? Empezaría por ahora ir de build d hace 15 dias y probando de todas maneras se que hay constancias que hay gente que le sigue pasando y aún no se ha encontrado una solución certera.

Sobre Kirby and the Forgotten Land tiene pinta de regresión Puedes poner el log que genera yuzu que te pone cuando te pasa eso ?
MaXiMu escribió:Los tirones te han pasado siempre ? O desde alguna build en concreto ? Empezaría por ahora ir de build d hace 15 dias y probando de todas maneras se que hay constancias que hay gente que le sigue pasando y aún no se ha encontrado una solución certera.

Sobre Kirby and the Forgotten Land tiene pinta de regresión Puedes poner el log que genera yuzu que te pone cuando te pasa eso ?

El Zelda lo llevo probando desde hace solo una semana. Los tirones solo me pasan en este juego hasta donde he probado.

El Kirby crasheaba sin dar mensaje de error ni log de ningún tipo, a no ser que el log se genere en un archivo, pero ya borre esa versión del emulador. Yo es que uso Yuzu en modo portable (se hace poniendo la carpeta "user" en la carpeta del emulador), uno para cada juego. Es decir, para el Kirby lo tengo en la versión 3600 y con en el Mario en la 3698. Lo hago así porque me gusta tener cada juego independiente, y además así si veo que un juego funciona bien en una versión, pues con esa versión en concreto se queda, precisamente por cosas como esta, sabiendo que Yuzu está todavía en desarrollo muy intenso con varios cambios diarios, y que un juego que funciona bien en una versión, puede no funcionar bien en una posterior, como pasa con el Kirby.
1433 respuestas