[HO] Yuzu (Emulador de Switch)

@Mikel24 pensé que sólo era yo al que le iba el metroid remastered en vulkan a 44fps.

De todas formas para haber salido hoy, no está nada pero que nada mal.

Imagino que en un par de meses irá a full en vulkan.
gordon81 escribió:@Mikel24 pensé que sólo era yo al que le iba el metroid remastered en vulkan a 44fps.

De todas formas para haber salido hoy, no está nada pero que nada mal.

Imagino que en un par de meses irá a full en vulkan.


En ryujinx va a 60 fps clavado, pero tiene algún fallo y no se ven muchas texturas
Mikel24 escribió:
gordon81 escribió:@Mikel24 pensé que sólo era yo al que le iba el metroid remastered en vulkan a 44fps.

De todas formas para haber salido hoy, no está nada pero que nada mal.

Imagino que en un par de meses irá a full en vulkan.


En ryujinx va a 60 fps clavado, pero tiene algún fallo y no se ven muchas texturas

Con la actualización de hoy de ryujinx han arreglado el problema de las texturas. Con un Rizen 5 y una AMD 580 me va perfecto a 60 fps incluso con el escalado a 4K.
instalo en la steam deck el yuzu, pero no me crea las carpetas, a alguien más le pasó?
nenetaro escribió:instalo en la steam deck el yuzu, pero no me crea las carpetas, a alguien más le pasó?


Este hilo es de PC, pregunta en el de Steam Deck: hilo_emulacion_2451254_s1950
Qué juegos van finos en un Ryzen 2200G + 16gb RAM 3200mhz?
Tengo la CPU en 3,8ghz y la Vega 8 en 1500mhz.
TitoKeren escribió:
Mikel24 escribió:
gordon81 escribió:@Mikel24 pensé que sólo era yo al que le iba el metroid remastered en vulkan a 44fps.

De todas formas para haber salido hoy, no está nada pero que nada mal.

Imagino que en un par de meses irá a full en vulkan.


En ryujinx va a 60 fps clavado, pero tiene algún fallo y no se ven muchas texturas

Con la actualización de hoy de ryujinx han arreglado el problema de las texturas. Con un Rizen 5 y una AMD 580 me va perfecto a 60 fps incluso con el escalado a 4K.


doy fe, juegazo por cierto y en 4k es una pasada
Ah, ¿entonces es normal que el Metroid vaya a como a 40 o 50 fps? Pensaba que era por mi CPU de 10 años (i7 4770K), que ya está lenta para algunos emuladores más demandantes. Hay juegos de Switch que se me ralentizan un poco, por ejemplo, Fire Emblem Three Houses en la abadía (en las batallas va perfectamente). Aunque en general, Yuzu me va bastante bien, a diferencia de por ejemplo RPCS3.

EDITO: con 3394 ya va a 60 fps, con algo de stuttering. Aunque noto cierto lag en el control. Pero mejora la cosa.
Pues probando la demo de Octopath Traveler 2. Todo perfect de momento.

Imagen

Imagen

Imagen
Tenía una versión que iba en juegos como Xenoblade a 5fps.
Con otra más nueva a 20-30 con "parones".
Pero hay otros juegos donde va bien. Salvo que ponga vulkan, se me cuelga
Tanto yuzu como ryujinx los probé y el rendimiento era similar con mi equipo, que es totalmente arcaico.
Xeon w3670 del 2010 sin avx
Con la gráfica no cambian los fps prácticamente (gtx970)

Pensaba que no iría mejor que eso.
Hay otros emuladores donde no se puede ni probar como van los juegos con cpus sin avx, como Xenia.

PD: Anécdotas mías, no tengo el PC
para emular nada demandante.
Buenas.

Me han entrado ganas de jugar al Zelda bowt ahora que se acerca la segunda parte y todo el mundo habla maravillas de el.
He probado yuzu y cemu y cemu me esta dando un rendimiento superior, asi como disponibilidad de mas mods. Lo juego a 2k 60fps y algunos extras mas (rtx2070 y ryzen 7 3700) y va muy bien.
La duda que tengo es porque el juego en switch son unos 15gb y en WiiU son 6gb?
Tiene algo el de switch que no tenga el otro?

Y otra duda que tengo es si es mejor vulkan o opengl con mi grafica ? O va a depender del juego?

Saludos.

Pd: he visto mas atras que alguien decia que no le funcionaba bien el zelda a 60fps. A mi me pasaba y por si a alguien le sirve de ayuda, hay que tener la version 1.6.0. Sino el juego va como a camara rapida.
Theatrhythm Final Bar Line

Bueno pues este juego que salió ayer, va perfect en Yuzu.

Imagen

Imagen

Imagen

Imagen

Imagen

Está chulo, ir desbloqueando canciones según combates para hacer todas las canciones de ese título y obviamente aumentando nivel de dificultad. Entretenido.

---

EDIT: Comentar que el Tales of Symphonia Remastered + Update 1.1 no funciona. En Yuzu directamente se queda en el loading y en Ryujinx carga rápido, pero simplemente sale una pantalla negra con un mensaje del juego de "PAUSA" en todo el centro y no deja hacer más.
buenas ¿Ya no es necesario instalar el firmware del sistema en yuzu?
katatsumuri escribió:buenas ¿Ya no es necesario instalar el firmware del sistema en yuzu?


Mmm yo lo voy actualizando de vez en cuando. Que yo sepa sigues necesitando las keys y firmware.
@DarkMessiah lo digo porque he instalado windows 11 de cero, instalación limpia, e iniciado yuzu y me arranca los juegos sin firmware, las keys si que las he tenido que pone.

Solo he puesto las prodkeys, las tittle keys creo que no son necesarias en ryujinx, ha arrancado el super smash
katatsumuri escribió:@DarkMessiah lo digo porque he instalado windows 11 de cero, instalación limpia, e iniciado yuzu y me arranca los juegos sin firmware, las keys si que las he tenido que pone.

Solo he puesto las prodkeys, las tittle keys creo que no son necesarias en ryujinx, ha arrancado el super smash


Por lo que he visto parece que algunos juegos no lo necesitan y otros se ve que si (firmware).
Para un correcto funcionamiento es necesario tener el firmware y las keys en sus correspondientes carpetas.
Yo tengo el firmware 15.0.1 si no me equivoco, y aun así hay juegos que dan problemas.
En Yuzu el Metroid Prime ya funciona perfecto en Vulkan.
Buenas ! tengo una consulta, hay alguna forma de aprovechar el save del emulador para usarlo en la consola con el juego original?
jorgeandmanson escribió:Buenas ! tengo una consulta, hay alguna forma de aprovechar el save del emulador para usarlo en la consola con el juego original?


Quizás te ayude

DarkMessiah escribió:
jorgeandmanson escribió:Buenas ! tengo una consulta, hay alguna forma de aprovechar el save del emulador para usarlo en la consola con el juego original?


Quizás te ayude



Oh perfectisimo gracias!!!! a ver si me apaño con el ingles xD
gordon81 escribió:En Yuzu el Metroid Prime ya funciona perfecto en Vulkan.


¿Han arreglado lo de las sombras dinámicas?

Lo probé hace un par de días y ya no había tirones al abrir puertas y lo único que fallaba en el rato que estuve era la sombra de Samus y los enemigos.
Digimon World: Next Order lanzado hoy, funciona bien.

Imagen

Imagen

Imagen
Probado el Octopath Traveller 2 en la última EA y va fino fino.
Alguien ha probado el nuevo Kirby?
mingui escribió:Alguien ha probado el nuevo Kirby?


Lo acabo de probar y el juego al principio va cargando shaders, por lo que algún mini tirón te comes, pero si repites nivel ya te va perfecto.

Está bastante guapo, por cierto [sonrisa]

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen

Imagen


Ahora empecé el nivel 2 y es muy de vez en cuando y la 1ª vez que haces ese nivel, luego 100% perfecto. Pero vamos que no me molesta, son muy leves cuando aparecen.
Juegazo va genial, como dice el compañero algún tirón pero nada grave, muy jugable
Yo lo estoy jugando en Ryujinx, más que nada porque con RyuSak he bajado un montón de shaders y me da menos tirones, pero en ambos emuladores es totalmente jugable
rendor escribió:
gordon81 escribió:En Yuzu el Metroid Prime ya funciona perfecto en Vulkan.


¿Han arreglado lo de las sombras dinámicas?

Lo probé hace un par de días y ya no había tirones al abrir puertas y lo único que fallaba en el rato que estuve era la sombra de Samus y los enemigos.


Pues creo que me he equivocado, parece ser que cuando llegas al bioma de nieve, en la laguna de peces no se ve la textura de la superficie del agua.

Tengo que comprobar si son los shaders ya que uso dos equipos y me ha pasado en el segundo.
mingui escribió:Alguien ha probado el nuevo Kirby?


pues en mi caso lo acabo de probar y va perfecto, ni micro tirones ni carga de shader ni nada, desde el principio se clava el msi en 60 y de alli no se mueve ;)

este lo estuve jugando en su dia en wii con dolphin, parece que lo han remozado y porteado a la switch...aqui tengo a la parienta y al crio jugando como locos XD XD
dinamita4922 escribió:
mingui escribió:Alguien ha probado el nuevo Kirby?


pues en mi caso lo acabo de probar y va perfecto, ni micro tirones ni carga de shader ni nada, desde el principio se clava el msi en 60 y de alli no se mueve ;)

este lo estuve jugando en su dia en wii con dolphin, parece que lo han remozado y porteado a la switch...aqui tengo a la parienta y al crio jugando como locos XD XD


Cómo no te va a precargar shaders?. Yuzu primero precarga siempre.
DarkMessiah escribió:
dinamita4922 escribió:
mingui escribió:Alguien ha probado el nuevo Kirby?


pues en mi caso lo acabo de probar y va perfecto, ni micro tirones ni carga de shader ni nada, desde el principio se clava el msi en 60 y de alli no se mueve ;)

este lo estuve jugando en su dia en wii con dolphin, parece que lo han remozado y porteado a la switch...aqui tengo a la parienta y al crio jugando como locos XD XD


Cómo no te va a precargar shaders?. Yuzu primero precarga siempre.


ni tirones ni nada de nada, a 60 del tiron ;)

edito, acaban de conseguir la primera parte de la nave, que son las remos y los 13 primeros engranajes, sin haber arrancado el juego antes, y sin microtirones. se clava a 60 tal como empieza la siguiente fase y hasta que termina

utilizo el nsp sin mod de nada ni shaders precargada con anterioridad ni nada
Si, con Vulkan la 1ª vez no pega microtirones, con OpenGL alguna vez de vez en cuando pero segunda vez que pases no. Pero con ambos siempre hace la precarga de los shaders, eso se ve abajo que lo va indicando.

Por eso me extrañó que dijeras que no te hacía precarga de shaders, porque la hace. Otra cosa es que con Vulkan no se note y con OpenGL muy poco, pero la 1ª vez si.

En mi caso .xci
DarkMessiah escribió:Si, con Vulkan la 1ª vez no pega microtirones, con OpenGL alguna vez de vez en cuando pero segunda vez que pases no. Pero con ambos siempre hace la precarga de los shaders, eso se ve abajo que lo va indicando.

Por eso me extrañó que dijeras que no te hacía precarga de shaders, porque la hace. Otra cosa es que con Vulkan no se note y con OpenGL muy poco, pero la 1ª vez si.

En mi caso .xci


si compañero, he re leido el post y me exprese mal ;)

los shaders si los va compilando al vuelo, lo que esta compilacion no me genera son microtirones, en vulkan por supuesto, no uso opengl

lo acabo de probar en un segundo pc, este con un i5 2300, y en modo ventana para ir monitorizando la generacion de shaders y los microtirones

en este caso igual, la generacion de shaders no me hace bajar de los 60 fps ni pierdo fluidez en el juego y cuando veia que bajaba de 60, el afterburned me indicaba que la cpu estaba altita, rondando el 85/95% de uso...y por eso me bajaba de esos 60, falta de cpu
dinamita4922 escribió:
DarkMessiah escribió:Si, con Vulkan la 1ª vez no pega microtirones, con OpenGL alguna vez de vez en cuando pero segunda vez que pases no. Pero con ambos siempre hace la precarga de los shaders, eso se ve abajo que lo va indicando.

Por eso me extrañó que dijeras que no te hacía precarga de shaders, porque la hace. Otra cosa es que con Vulkan no se note y con OpenGL muy poco, pero la 1ª vez si.

En mi caso .xci


si compañero, he re leido el post y me exprese mal ;)

los shaders si los va compilando al vuelo, lo que esta compilacion no me genera son microtirones, en vulkan por supuesto, no uso opengl

lo acabo de probar en un segundo pc, este con un i5 2300, y en modo ventana para ir monitorizando la generacion de shaders y los microtirones

en este caso igual, la generacion de shaders no me hace bajar de los 60 fps ni pierdo fluidez en el juego y cuando veia que bajaba de 60, el afterburned me indicaba que la cpu estaba altita, rondando el 85/95% de uso...y por eso me bajaba de esos 60, falta de cpu


Eso es, los micro tirones es sólo con OpenGL, con Vulkan volando [beer]
Hola gente espero me puedan ayudar, lo que pasa que está emulando Luigi's mansión 3 en yuzu y pues todo bien solo que el la parte del tiburón pirata ahí es donde baja hasta 11 fps el juego y no se a que se deba ya que en las demás zonas no tiene ese rendimiento se mantiene entre 60 a 58 fps, por favor que me ayuden no se q hacer he probado de todo y no se que hacer alguna sugerencia
Kevin2701 escribió:Hola gente espero me puedan ayudar, lo que pasa que está emulando Luigi's mansión 3 en yuzu y pues todo bien solo que el la parte del tiburón pirata ahí es donde baja hasta 11 fps el juego y no se a que se deba ya que en las demás zonas no tiene ese rendimiento se mantiene entre 60 a 58 fps, por favor que me ayuden no se q hacer he probado de todo y no se que hacer alguna sugerencia



estaría bien saber varias cosas

Versión del emulador que estas usando
Datos de tu ordenador
si usas Opengl o vulkan

etc
¿Sabéis alguna forma "mágica" de mejorar el rendimiento de la emulación? por lo general el emulador me va bien (stuttering aparte, que no sé si es normal, pero el emulador parece tener un problema de framepacing que por mucho tiempo que pasa no solucionan), pero con algunos juegos me queda muy justo con mi viejo i7 4770K y me bajan los fps en determinadas situaciones, como con Super Mario Odyssey y Xenobalde Chronicle 3. Esto con Vulkan, con OpenGL es peor. Por cierto, algo que he observado es que las últimas versiones consumen una burrada de RAM, como 5 o 6 GB.
GordonFreeman escribió:¿Sabéis alguna forma "mágica" de mejorar el rendimiento de la emulación? por lo general el emulador me va bien (stuttering aparte, que no sé si es normal, pero el emulador parece tener un problema de framepacing que por mucho tiempo que pasa no solucionan), pero con algunos juegos me queda muy justo con mi viejo i7 4770K y me bajan los fps en determinadas situaciones, como con Super Mario Odyssey y Xenobalde Chronicle 3. Esto con Vulkan, con OpenGL es peor. Por cierto, algo que he observado es que las últimas versiones consumen una burrada de RAM, como 5 o 6 GB.

Mi hermano tenía un procesador como el tuyo y tenía un montón de problemas de rendimiento, ahora tiene un i5 10400f y es otra historia, todo perfecto.
Tanto en el i7 como ahora en el i5 monta una 1060 6gb.
mingui escribió:
GordonFreeman escribió:¿Sabéis alguna forma "mágica" de mejorar el rendimiento de la emulación? por lo general el emulador me va bien (stuttering aparte, que no sé si es normal, pero el emulador parece tener un problema de framepacing que por mucho tiempo que pasa no solucionan), pero con algunos juegos me queda muy justo con mi viejo i7 4770K y me bajan los fps en determinadas situaciones, como con Super Mario Odyssey y Xenobalde Chronicle 3. Esto con Vulkan, con OpenGL es peor. Por cierto, algo que he observado es que las últimas versiones consumen una burrada de RAM, como 5 o 6 GB.

Mi hermano tenía un procesador como el tuyo y tenía un montón de problemas de rendimiento, ahora tiene un i5 10400f y es otra historia, todo perfecto.
Tanto en el i7 como ahora en el i5 monta una 1060 6gb.

Mi placa es LGA1150, ese procesador no es compatible, es decir, tendría que cambiar la placa, ya para eso cambiaría el PC entero, pero por el momento no me viene bien.
De nuevo me vuelve a pasar lo que me sucedía hace tiempo.

Antes podía abrir Yuzu.exe sin problemas y cargaba y usaba Vulkan. Ahora vuelve a pasar que intento abrirlo, no abre nada pero si voy los procesos me salen 2 yuzu.exe y si cierro el 1º, se abre Yuzu con un error de Vulkan que me impide usar Vulkan, pero si uso OpenGL funciona.

Alguna idea de qué puede ser?.

Probaré a cambiar a los drivers previos a los que salieron el otro día de Nvidia, pero vamos no se si será eso...

Imagen

Imagen
Probando en un portátil ryzen 5800h rtx 3060 y parece que va bien. He probado Xenoblade chronicles 3 me va mejor en ryujinx con vulkan y fsr. Pokemon violeta y optopach traveler 2 me van mejor en OpenGL con fsr en yuzu.

Que configuraciones usáis por aquí?
alguien sabe como hacer funcionar correctamente el juego fast rmx?
muchas gracias
esemanu_87 escribió:Probando en un portátil ryzen 5800h rtx 3060 y parece que va bien. He probado Xenoblade chronicles 3 me va mejor en ryujinx con vulkan y fsr. Pokemon violeta y optopach traveler 2 me van mejor en OpenGL con fsr en yuzu.

Que configuraciones usáis por aquí?

Cada pc y cada juego es un mundo, configuraciones hay miles.
Busca en Youtube, suelen poner configuraciones para cada juego.
titorino escribió:alguien sabe como hacer funcionar correctamente el juego fast rmx?
muchas gracias



Buenas tardes, yo este lo puedo jugar perfectamente pero en Ryujinx, eso sí, tengo que poner la resolución nativa porque desde que lo subo de ahí se me vuelve injugable.
Decir que tengo un pc de gama media/baja. Ryzen 5 1500X, Gforce 1080 Ti y 16gb de Ram.

Aprovecho también para presentarme al resto, nunca había escrito por aquí pero me estoy metiendo mucho en el tema de emulación de Switch. Veo que aquí es un hilo para Yuzu y mi experiencia está resultando mejor con Ryujinx pero quería responder al compañero.
GordonFreeman escribió:
mingui escribió:
GordonFreeman escribió:¿Sabéis alguna forma "mágica" de mejorar el rendimiento de la emulación? por lo general el emulador me va bien (stuttering aparte, que no sé si es normal, pero el emulador parece tener un problema de framepacing que por mucho tiempo que pasa no solucionan), pero con algunos juegos me queda muy justo con mi viejo i7 4770K y me bajan los fps en determinadas situaciones, como con Super Mario Odyssey y Xenobalde Chronicle 3. Esto con Vulkan, con OpenGL es peor. Por cierto, algo que he observado es que las últimas versiones consumen una burrada de RAM, como 5 o 6 GB.

Mi hermano tenía un procesador como el tuyo y tenía un montón de problemas de rendimiento, ahora tiene un i5 10400f y es otra historia, todo perfecto.
Tanto en el i7 como ahora en el i5 monta una 1060 6gb.

Mi placa es LGA1150, ese procesador no es compatible, es decir, tendría que cambiar la placa, ya para eso cambiaría el PC entero, pero por el momento no me viene bien.


Yuzu para ir bien pide 6 nucleos por lo que e leido en reddit.

Yo acabo de pasar de un 4790 a un 12400f y es como la noche y el dia. El xeno3, de tener muchos problemas de rendimiento a ir fino fino.
@Javimetalrf muchas gracias ,en Ryujinx me va bien pero en open gl ,con vulkan se me cierra
1408 respuestas