[HILO OFICIAL] RGB-PI

@atg De lo que he podido probar, los favoritos ya funciona de maravilla y los bezeles para portatiles están muy guapos. Con el AdvMAME no me funciona ni teclado ni joystics.

Gracias por la nueva versión ;)
@repente Si hotkey+start me he colao, para salir de los scripts está programado que sea el botón 8 del mando depende cual tengas puede cambiar y no ser el select ser un gatillo o algo así, también puedes usar un teclado y salir con el escape.

@excitecube El AdvMame con los controles esta dando muchos problemas, el teclado está desactivado porque si se activa y no está conectado te saca del emulador, edita el archivo /share/system/.advmame/advmame.rc y ahí busca esto y pongo en auto:

device_joystick raw
device_keyboard none

Ya esta subida la imagen arreglada.
jarl, había dejado de recibir notificaciones de este hilo y hoy me da por entrar y me veo que ya hay nueva versión y todo!! Pues nada, este finde me pongo con ella XD
Buenas. Ante todo gran trabajo. Una duda. No se porqué en las portátiles me sale el juego, pero sin los bezel de la portatil.
Un saludo.
Edit.- Solucionado. era en el SU.
Venga, voy a cacharrear y a probar algunas cosas, si me lío a sacar fallos es por ayudar para mejorar el invento, ya lo sabes, a lo betatesting :)

Por cierto, este es el fallo a que nos referíamos en el Castlevania de Playstation después del prólogo (esa parte se ve perfecta), son unas bandas blancas que parpadean a saco. Sería un puntazo apuntarlo y echarle un ojo para otra release, quizás es algo sencillo de arreglar, no lo sé (creo que en el recalbox normal funciona bien, lo tengo que probar para confirmar).
El juego es una joya, estoy por comprar un cable para poder enchufar la play a los monitores sólo por este juego...

Imagen


Actualizo, feedback a saco:
@Atg, He probado las dos resoluciones, te enseño como se ven en mis dos, para que tengas un feedback.
El grande sí está ajustado con respecto a una megadrive original y el 240p test suite (es la única referencia que tengo).
El pequeño no te fijes en el ajuste horizontal porque ese estaba ajustado en base a un ajuste concreto del rgb-pi cuando estuve trasteando para usarlo para las portátiles, pero quizás te sirva como referencia de ajuste vertical ya que en esa no se ve achatada verticalmente :-? .
Una duda: EmulationStation arranca por defecto en Pal 50hz? o es ntsc 60hz?

- En ambos monitores se ve algo ovalada la imagen en 270 y verticalmente achatada en el 20" viéndose lineas rgb arriba, lo bueno es que ganamos bastante definición en todos los textos.
- En 240 la cosa mejora bastante en cuanto a ajuste general, el desplazamiento lateral hacia la izq. quizás sea porque el timing de la megadrive no sea una buena referencia en cuanfo a timing horizontal. Los laterales ya no están ovalados, lo malo que perdemos un poco de definición y los logos superiores se cortan, pero creo que merece la pena. El screen utility se ve mucho más pequeño en este modo (aunque luego se corrige, es raro, ahora me explico).
Yo me quedo con esta, ya la afinaré cambiando un pelín los hdmi timings.

Así es a 270:

Imagen

Imagen

Imagen

Así a 240:

Imagen

Imagen

Imagen

Y aquí va un bug que he encontrado, he hecho pruebas y es replicable por lo que lo tenemos cazado ;-)
- Con la imagen recién formateada, no funciona (al menos a mi, con el Nes30 por usb) el salir con hotkey+start el "centering test".
Además a 240 el screen utility se ve como más pequeño.
Pues bien, cargo una rom (el ninja gaiden de gameboy, no creo que influya cual pero ha sido esa con la que he hecho pruebas), salgo con hotkey+start y sale perfecto.
Después de eso, el screen utility se ve perfecto a 240 y ya funciona sin problema el salir con hotkey+start el "centering test".
Los editores individuales sigo sin poder salir con ningún boton del Nes30 (me da igual realmente, pero es porque tengas el dato).

Te pego una imagen de como se ve el screen utility después de ejecutar la rom, vamos, perfecto:

Imagen


Por último, he probado lo de los bezels en la gameboy. A mi personalmente no me mola, además está el hecho de lo de la imagen fija y el deterioro del fósforo, pero es un gusto totalmente personal. Lo bueno que como es opcional pues todos contentos.
Por cierto, he probado a cambiar manualmente el gb.cfg de retroarch para verlo como antes y va genial. Se hace rápido y sin problema así que perfecto! Puedo seguir usando el 9" :). Cuando haya una wiki o quizás en la faq, lo explicaría para los nuevos.
Una duda: ¿Tengo que poner 1920 y 224 en todas las portátiles o depende de cual varía esa resoulución?

Por último, corroboro que el selector de frecuencias va como la seda.
Otro día seguiré dandole caña y testeando, pero vamos, muy contento con el update, buen trabajo!!
@repente EDITO: Me parece que depende de la "version" del juego, yo lo estoy probando y se ven las franjas pero negras.
El juego es así tenia franjas solo que negras, hay que cambiar el color de fondo del emulador y ya está, aqui puedes verlo.
https://youtu.be/egkTac72EWU

El ES arranca dependiendo del timing, en 270 va a 50Hz y en 240 va a 60Hz. Lo que no hay forma de cambiar es que se muestra en 16/9 y nosotros lo embutimos en 4/3 asi que siempre se van a ver los logos achatados no hay nada que hacer.

El tema de que se ajuste la pantalla al salir de los juegos es porque se reestablece el framebuffer y la primera vez que entras está sin ajustar, hay que pulir cosas del codigo.

Las portatiles ponlas todas iguales, puedes jugar con el alto 224 o 240
Pillo sitio, amigos.

Esperando el cable para probarlo en Sony Trinitron de 25" recién trincada y mando clónico ps3 Shanwan.

También abogo por Retropie, más que nada por el Attract mode. Así que esperaré con gusto la migración [oki] , mientras disfruto del Recalbox.

¡Enhorabuena por el gran trabajo realizado!

[beer]
atg escribió:@repente Si hotkey+start me he colao, para salir de los scripts está programado que sea el botón 8 del mando depende cual tengas puede cambiar y no ser el select ser un gatillo o algo así, también puedes usar un teclado y salir con el escape.

@excitecube El AdvMame con los controles esta dando muchos problemas, el teclado está desactivado porque si se activa y no está conectado te saca del emulador, edita el archivo /share/system/.advmame/advmame.rc y ahí busca esto y pongo en auto:

device_joystick raw
device_keyboard none

Ya esta subida la imagen arreglada.


he puesto raw en lugar de auto y sigue sin funcionarme los controles.
He vuelto a bajar la imagen desde la web oficial y tampoco me funciona, que puedo hacer?
Atg, yo estoy probando la versión USA en ntsc a 60hz (en pal 50hz no tiene gracia).
¿Cuando dices de cambiar el fondo del emulador te refieres a cambiarlo tu en la próxima versión o es una acción que podemos hacer los usuarios con retroarch?

Si ES va a 50hz en 270, entonces el problema es de ajuste de mi monitor en esa frecuenta (Se pueden ajustar independientemente).
Lo de los logos aparte de achatados (eso es compresible) se veían cortados por arriba en 240.
No te precoupes, ajusto el monitor a 50hz y te confirmo.

Perfecto lo de las portátiles, probaré 224 y 240 a ver cual va mejor.
Gracias! :)
@jorge1414 una opción es cambiar device_keyboard y activarlo, entras en el juego y pulsas tab en teclado y te sale el menú de toda la vida de los MAME, y ahí configuras tú las teclas. Así es como lo hacía yo cuando lo estuve probando, el problema es que hay que hacerlo cada vez que pones un juego, porque no salva los cambios, no sé cómo será para que los guarde.
@darkcarmona Para que se guarden coge el archivo /tmp/advmame.rc donde estan los cambios hechos y copialo en / share/system/.advmame que es de donde los coge cada vez que arranca

Esto es asi porque si se guarda al salir algunos modelos de mandos solo funcionan la primera vez, y si se deja en raw funcionan siempre, son problemas que trae el advmame y hacemos los que se puede...

@Repente Juega a la PAL en español a 60Hz que en psx se puede sin problema.
Vale, le voy a dar un tiento. Gracias!
Ah! pensaba que al ser iso Pal tenía que ser sí o sí a 50hz, pues nada, selector a 60hz y arreglado :)
Gracias!
Muchachos, una pregunta de analfabeto: para actualizar a esta nueva alfa, ¿tengo que reformatear la tarjeta, o cómo hago? Es mi primera vez y estoy un poco nervioso.
Parte de las roms y configuración las conservaba en un USB sincronizado con el OS, lo cual por cierto me daba muchos problemas. ¿Debo hacer una instalación limpia en el USB también, o ejo el usb como está y el OS me conservará las preferencias? (por ejemplo, mandos y resoluciones).
Gracias!
darkcarmona escribió:@jorge1414 una opción es cambiar device_keyboard y activarlo, entras en el juego y pulsas tab en teclado y te sale el menú de toda la vida de los MAME, y ahí configuras tú las teclas. Así es como lo hacía yo cuando lo estuve probando, el problema es que hay que hacerlo cada vez que pones un juego, porque no salva los cambios, no sé cómo será para que los guarde.


Ok lo intentaré de ése modo, pero que se pone en lugar del none?, ¿yes? :-? , soy un petardo en esto de los archivos config [decaio]

Como activo el teclado? gracias!!
Perdón por si meto la pata, esta distribución de rgb-pi, se podría utilizar con una rasper 3 con el vga 666, y de este con un cable vga scart casero atacar a un tv normal.?????????
tuskador escribió:Muchachos, una pregunta de analfabeto: para actualizar a esta nueva alfa, ¿tengo que reformatear la tarjeta, o cómo hago? Es mi primera vez y estoy un poco nervioso.
Parte de las roms y configuración las conservaba en un USB sincronizado con el OS, lo cual por cierto me daba muchos problemas. ¿Debo hacer una instalación limpia en el USB también, o ejo el usb como está y el OS me conservará las preferencias? (por ejemplo, mandos y resoluciones).
Gracias!


Estoy igual de pez, me uno a la pregunta de tuskador.
atg escribió:@repente Si hotkey+start me he colao, para salir de los scripts está programado que sea el botón 8 del mando depende cual tengas puede cambiar y no ser el select ser un gatillo o algo así, también puedes usar un teclado y salir con el escape.

@excitecube El AdvMame con los controles esta dando muchos problemas, el teclado está desactivado porque si se activa y no está conectado te saca del emulador, edita el archivo /share/system/.advmame/advmame.rc y ahí busca esto y pongo en auto:

device_joystick raw
device_keyboard none

Ya esta subida la imagen arreglada.


Cómo se hace exactamente?, lo hago pero solo me reconoce la tecla 9 para poner creditos. Además, no consigo sacar el menú con la tecla tab, ni en MAME ni en AdvMAME.
excitecube escribió:
atg escribió:@repente Si hotkey+start me he colao, para salir de los scripts está programado que sea el botón 8 del mando depende cual tengas puede cambiar y no ser el select ser un gatillo o algo así, también puedes usar un teclado y salir con el escape.

@excitecube El AdvMame con los controles esta dando muchos problemas, el teclado está desactivado porque si se activa y no está conectado te saca del emulador, edita el archivo /share/system/.advmame/advmame.rc y ahí busca esto y pongo en auto:

device_joystick raw
device_keyboard none

Ya esta subida la imagen arreglada.


Cómo se hace exactamente?, lo hago pero solo me reconoce la tecla 9 para poner creditos. Además, no consigo sacar el menú con la tecla tab, ni en MAME ni en AdvMAME.


Estoy en tu misma situación, no he conseguido echar una partida en advmame, he cargado los juegos pero tambien sólo me reconoce 2 botones del teclado, ni mandos, ni nada, si alguien lo consigue que nos diga como por favor.
shiryu55 escribió:Perdón por si meto la pata, esta distribución de rgb-pi, se podría utilizar con una rasper 3 con el vga 666, y de este con un cable vga scart casero atacar a un tv normal.?????????


Esta contestado en el hilo, si que funciona, hay que modificar el config.txt de la siguiente manera:

Elimina la siguientes lineas::
dtparam=audio=on
dtoverlay=pwm-2chan,pin=18,func=2,pin2=19,func2=2
dtoverlay=rgb-pi
dpi_output_format=6

Pon la siguiente linea:
dtoverlay=vga666

Saludos.
Disculpar las molestias con el AdvmMAME, he hecho unos cambios y ya debería funcionar con todos los joysticks, el teclado está desactivado para que no sea necesario tenerlo conectado, podéis entrar al menú con select + X(psx), tenéis que volverlo a descargar.
gracias por contestar, esa configuración del config.txt, entonces es la valida para el vga 666.

Ahora bien, mirando con un poco mas de detenimiento en este hilo e querido entender, que solo la distribución de rgb- pi consigue tener la opción de multi resolución, y las demás distribuciones tienes que jugar con una resolución y luego adaptar mediante el menú del retroarch. o estoy equivocado del todo ??

En cuanto a lo del tema del cable casero como esta la cosa, es valido.??
@atg creo que C64 también tiene problemas con el joystick parece como si estuviera mapeado para otras funciones.
uso dual shock 3
atg escribió:Disculpar las molestias con el AdvmMAME, he hecho unos cambios y ya debería funcionar con todos los joysticks, el teclado está desactivado para que no sea necesario tenerlo conectado, podéis entrar al menú con select + X(psx), tenéis que volverlo a descargar.


Hay que gravar la imagen de nuevo entiendo no?
Una pregunta para @atg o para cualquiera que lo haya probado; ¿la auto-rotación de los controles direccionales en los juegos TATE (cuando se juega con el sistema en modo horizontal, es decir sin modificar nada relacionado con este aspecto en la SU) se hace efectiva por defecto o hay que activar/configurar algo?

Pregunto porque si pongo por ejemplo el Truxton II, ya sea en MAME o en FBA, siguen estando los controles configurados de la forma original en la que se jugaría con la pantalla puesta en vertical.

Gracias!
@torpider C64 necesitas teclado, el joystick que tenia no se si era suficiente para entrar en todos los juegos, a ver si algún usuario que fuese jugador o sepa bien como funciona el original nos puede echar una mano en el mapeado pero en principio yo creo que es obligatorio teclado.

@isopure Si, es necesario regrabar la SD porque algunos scripts también están modificados.

@R3dRuM Pues está activada por defecto, lo que puede pasar en tu caso es que por el mando que tienes (me imagino que tienes joystick) la asignación de los direccionales o los analógicos sea distinta a la general y a la que está programada, dime que mandos usas para investigar que pasa.
atg escribió:@R3dRuM Pues está activada por defecto, lo que puede pasar en tu caso es que por el mando que tienes (me imagino que tienes joystick) la asignación de los direccionales o los analógicos sea distinta a la general y a la que está programada, dime que mandos usas para investigar que pasa.

Solucionado. Uso un Mayflash F300, el problema al parecer es que tenía la palanquita de modo del joystick en D.Pad en lugar de analógico. Al cambiarlo hace la rotación de forma automática perfectamente.

Muchas gracias!
He enviado un mail a través de la web oficial para saber si aún sigue a la venta y la respuesta ha sido inmediata.
Voy a comprarme uno para hacer varias pruebas con mi maca y con un trinitron que tengo en mi habitación para jugar con Mame.

Me ancanta este cable y la idea que ha tenido el desarrollador.

Un saludo a todo@s!
Os quiero enseñar otro tema en el que estoy trasteando, hace tiempo que voy mirando carcasas para la Pi y no me termina de gustar ninguna así que me he puesto a diseñar mi carcasa ideal que recuerde a consolas iconicas del mundo de los videojuegos pero sin ser un clon de ninguna en concreto, aviso de que éste es el primer diseño que hago y tiene solo un día de trabajo, iré enseñando las mejoras y si os gusta subiré el diseño final para que os lo podáis descargar gratuitamente.

Imagen

Como veis puede recordar a varias consolas a la vez, tiene una ranura de inserción de tarjeta como la PCEngine pero de forma ovalada al final en lugar de recta, también tiene una hendidura que va del frontal a la parte de atras como la PSX, una tapa curva como Megadrive o un diseño cuadrado como la Dreamcast.

No tengáis en cuenta la calidad de impresión de este primer modelo, lo he hecho rápido para probar medidas.

Imagen

Imagen

Imagen
Hola,

He estado buscando sin éxito como cambiar el color de background por defecto del emulador de PSX libreto que es blanco y molesta parpadeando en juegos como Castlevania: SOTN.

Sabeis donde cambiarlo?

Muchas gracias!
Buenas,

¿Alguien ha conseguido que se guarden los high scores en FBA? En mame (2003) he conseguido que me los guarde sin problemas tras haber sustituido el fichero hiscore.dat de la carpeta /share/bios/mame2003/ por la versión antigua del mismo (http://www.mameworld.info/highscore/hiscoredat(old).zip), pero en FBA no encuentro manera de hacer que se guarden los highscores.

Por otro lado, ¿hay posibilidad de que también se monte la carpeta saves desde un dispositivo de almacenamiento externo al igual que ocurre con las carpetas roms y bios? Pregunto esto para evitar que se pierdan las partidas guardadas, las puntuaciones y las configuraciones de los juegos de neogeo (dip-switches, settings de unibios, etc) cada vez que se sustituye la imagen que haya instalada en la SD.

Gracias!

PD. Muy chulo el diseño de la carcasa atg.
Increible! [boing] [amor] [amor] [amor]

atg escribió:Os quiero enseñar otro tema en el que estoy trasteando, hace tiempo que voy mirando carcasas para la Pi y no me termina de gustar ninguna así que me he puesto a diseñar mi carcasa ideal que recuerde a consolas iconicas del mundo de los videojuegos pero sin ser un clon de ninguna en concreto, aviso de que éste es el primer diseño que hago y tiene solo un día de trabajo, iré enseñando las mejoras y si os gusta subiré el diseño final para que os lo podáis descargar gratuitamente.
...

Me gusta mucho la carcasa, más que nada por hacer una con identidad propia de RGB-pi y porque no podía decidirme por una de consola xD
una pregunta, cuando intento hacer scrapper ahora me dice DISK FULL podría ser algo de configuración? espacio tengo.
@qapitan Lo tengo pendiente de revisar lo del cambiar el color de fondo, pero hay otras versiones del SOTN como la PAL en que las franjas son negras y lo puedes jugar a a 60Hz

@R3dRuM A ver si va a ser un problema de permisos que el sistema no pueda escribir en el archivo necesario, le echare un ojo, el tema de montar la carpeta saves no es ningún problema lanzare una versión parcheada del USB Mount con eso.

@torpider Eso va a ser porque las guarda en la carpeta temporal de la SD o en alguna otra carpeta que no está en el USB, se puede buscar esta carpeta y añadirla de paso el USB Mount.

¿Nadie ha probado todavía de si se ha solucionado el tema de los controles en AdvMAME?
atg escribió:Disculpar las molestias con el AdvmMAME, he hecho unos cambios y ya debería funcionar con todos los joysticks, el teclado está desactivado para que no sea necesario tenerlo conectado, podéis entrar al menú con select + X(psx), tenéis que volverlo a descargar.


Muchas gracias @atg, ahora si que funciona [tadoramo] .

He detectado varios errores en AdvMAME, no sé si se podrán solucionar o son cosa del emulador:

-Con el juego Chelnov hay veces que parpadea parte de la pantalla dos o tres segundos y después ya se ve bien.
-Hay varios juegos, como el Legendary wings, que se baja el volumen solo.
-En el Shinobi, se deja de escuchar la musica y vuelve cuando quiere.

Hay varias cosas que me han gustado mucho de AdvMAME:

-La mejora de imput lag, si hay no se aprecia nada.
-El rescalado al rotar la pantalla a mejorado muchísimo.
-Los juegos cargan mucho más rapido, (un juego que tarda en cargar 4 segundos en MAME, con AdvMAME tarda 1 segundo).
-Soporta bastantes más juegos que MAME.

Por otra parte, he probado esta versión con el adaptador vga666 en la tele que te comenté que me parpadeaba constantemente (con el cable RGB-PI), tanto en el menú, como al cargar un juego. Ahora el menú no me parpadea nada, pero al cargar cualquier juego no para de parpadear.Crees que podría solucionarlo tocando los timings?

Que guapa que está la carcasa, con un diseño simple has podido reflejar lo que caracterizaba a cada consola.

Muchas gracias por tu trabajo y esfuerzo. [oki]
Acabo de probar el Symphony of the Night, pal españa, a 60hz, y sigue teniendo franjas parpadeantes.
Lo dejaremos para otra build no hay problema, sólo era por notificarlo.

Por cierto Atg, esa caja tiene muy buena pinta, me gusta la idea de hacer algo original combinando elementos de diferentes máquinas, luego trabajando un poco la impresión y pintando para dar uniformidad, puede quedar deluxe.
Hola a todos,

Soy uno de los nuevos afortunados en tener este maravilloso cable RGB-PI. Mis felicitaciones a atg por este fantastico proyecto y a todos los compañeros que con sus aportaciones diarias van ayudando a que este proyecto sea cada vez mejor :)

Tengo ya hace varios meses una raspberry con recalbox he estado trasteando con ella pero aun asi mis conocimientos sobre todo esto son muy limitados por lo que pido excusas por adelantado por si hago alguna pregunta muy elemental o si ya se a preguntado en el hilo. La verdad es que me estado leyendo las 119 paginas y madre mia esto es como prepararse una oposición [carcajad] y tengo un lio ahora en la cabeza muy serio [tomaaa]

De momento solo tengo un problema bastante serio, creo yo, y espero que tanto atg como algun compañero me pueda ayudar a resolverlo. Muchas gracias de antemano ;)

El problema que tengo es de imagen y que solo me habia pasado con una Nintendo 64 francesa preparada para RGB, es decir con mis otros sistemas, todos a 60 Hz; incluido una Neo Geo Aes japonesa nunca me habia pasado. El problema es que en la parte superior de la imagen me sale una banda de color (supongo que de color RGB ya que cambia depende del color con el que se superponga) y la unica forma de momento que he visto de solucionarlo parcialmente es utilizando el Screen utility / vertical positión y asi bajar la imagen 1 cm mas o menos para evitar que salga esta linea de color. Pero claro de esta forma tambien lo que provoco es, al bajar la imagen verticalmente, no ver un 1 cm de la parte inferior de la imagen. Y esta solución tampoco es muy buena porque hay sistemas dentro de RGB-Pi como por ejemplo PC-Engine que sale siempre la imagen a pantalla completa aunque lo haya bajado con el Screen utility.

No se si hay alguna solución para este problema, a mi, de momento y si es posible, se me habia ocurrido la idea de crear dentro del Screen utility un vertical zoom igual que si que esta el horizontal para poder bajar de arriba y de abajo y no perder información y que esto afectará a todos los sistemas por igual. A lo mejor esto tambien se puede hacer desde el individual editor pero me da un poco de miedo meterme en esa historia.

Os dejo algunas imagenes para que podasi ver con mas claridad mi problema. Una imagen de Mario de Snes donde si puedo bajar la linea vertical y otra imagen de un juego de PC-engine donde no puedo bajarla con el Screen utility.

Muchas gracias por vuestra ayuda y yo tambien intentare dentro de mis conocimientos elementales como usuario aportar mi experiencia personal en este fantastico proyecto.

Un saludo
atg escribió:¿Nadie ha probado todavía de si se ha solucionado el tema de los controles en AdvMAME?


Buenas, yo no he tenido ningún problema con los controles, probado hoy por primera vez AdvMAME con la ultima versión. Salvo que ya está hecho el cambio tan solicitado por el colega @darkcarmona de rotar los controles para poder jugar en horizontal a los juegos verticales... Me tocará modificar con en SU para jugar con la TV volcada.. jejeje

Por cierto ya me hice la lista de Roms verticales, si a alguien le interesa se la puedo pasar (en xml o txt). Me va a tocar pronto pillar el segundo cable!
Buenas,

Alguna opción para que automonte mi USB con todas las roms?

La verdad es que paso de copiar todas las roms y demás trabajo que he hecho cada vez que sale una beta nueva

Un saludo
primero dar la gracias a @atg por el tremendo trabajo, estoy muy agradecido,,,

Bueno he probado la nueva imagen y solo decir que recién instalada tengo un problema, he probado con varias sd y con todas me da el mismo, el problema es que cuando inicio el sistema solo me sale en la pantalla principal el menú rgb-pi config, no hay ningún emulador habilitado, voy a carpetas de roms y meto alguna para que me cree en el menú principal la entrada del emulador pero nada, sigue sin aparecer, en la anterior imagen aparecían los emuladores con alguna roms para probar pero aquí nada.

Como habilito los emuladores en el menú principal?
@8bits16bits

Tienes que reiniciar, después de añadir las ROMS a su correspondiente carpeta, para que las reconozca...
@Pek Copia en un pen formateado en fat 32 ,el la raiz del mismo estas dos carpetas:bios y roms
y dentro de ellas todo el tema,y luego en las rasp pi, la opcion de usb mount, y a funcionar....
isopure escribió:@Pek Copia en un pen formateado en fat 32 ,el la raiz del mismo estas dos carpetas:bios y roms
y dentro de ellas todo el tema,y luego en las rasp pi, la opcion de usb mount, y a funcionar....


Pero eso tengo que hacerlo cada vez que se inicia el sistema, y lo que yo quiero es que se automonte solo el pen usb, por eso quería saber si lo tienen contemplado o tengo que enzarzarme con el barrizal de Linux para dejarlo hecho por mi cuenta
ZarcoVal escribió:@8bits16bits

Tienes que reiniciar, después de añadir las ROMS a su correspondiente carpeta, para que las reconozca...

Si eso hago y nada, pongo las ROMs en sus carpetas correspondientes, reinicio y nada no me aparecen los emuladores.
8bits16bits escribió:
ZarcoVal escribió:@8bits16bits

Tienes que reiniciar, después de añadir las ROMS a su correspondiente carpeta, para que las reconozca...

Si eso hago y nada, pongo las ROMs en sus carpetas correspondientes, reinicio y nada no me aparecen los emuladores.

Cuando hayas metido las ROMs en sus carpetas correspondientes te te metes en el menú interfaz, le das hacía abajo hasta que veas la opción "actualizar lista de juegos", pulsas ahí y ya tienes las ROMs visibles
atg escribió:Os quiero enseñar otro tema en el que estoy trasteando, hace tiempo que voy mirando carcasas para la Pi y no me termina de gustar ninguna así que me he puesto a diseñar mi carcasa ideal que recuerde a consolas iconicas del mundo de los videojuegos pero sin ser un clon de ninguna en concreto, aviso de que éste es el primer diseño que hago y tiene solo un día de trabajo, iré enseñando las mejoras y si os gusta subiré el diseño final para que os lo podáis descargar gratuitamente.

Imagen

Como veis puede recordar a varias consolas a la vez, tiene una ranura de inserción de tarjeta como la PCEngine pero de forma ovalada al final en lugar de recta, también tiene una hendidura que va del frontal a la parte de atras como la PSX, una tapa curva como Megadrive o un diseño cuadrado como la Dreamcast.

No tengáis en cuenta la calidad de impresión de este primer modelo, lo he hecho rápido para probar medidas.

Imagen

Imagen

Imagen


A mí me gusta mucho ese modelo, me recuerda sobre todo a DC y PS, supongo que el color será decisivo a la hora de asemejarse más a un sistema o a otro.
Yo, personalmente, estoy probando carcasas de otras consolas que tengo por ahí (las consolas no funcionan) y de momento me gusta la de MS2. El problema de las carcasas muy pequeñas y/o ligeras (como la de metacrilato transpatrente que también he usado y todo el mundo tiene), es que a poco que le conectes un adaptador a la pi o cualquier cosa que cuelgue, se te cae todo el tinglado al suelo. a veces me dan ganas de meterle plomo a la carcasa o algo.
Es el único problema que yo le veo a la Pi, Nes mini etc... que de tan pequeñas que son les falta estabilidad; pegas un tirón al mando y todo va al suelo.
Si consigues que esa carcasa te quede de algún modo estabilizada a la mesa, habrás triunfado.

Por otra parte, he bajado el nuevo Os y lo quiero instalar. ¿Formateo la tarjeta o borro lo que hay y copio la imagen ahi tal cual?
EDIT: ya me acuerdo, estoy metiendo la img en la SD usando Etcher.
Segundo día de diseño de la carcasa, he ajustado algunas cosas desde el modelo anterior como son las ranuras para SD USB ethernet y es un poco mas alta, también he seguido añadiendo detalles de diseño mas molones como la cúpula con un biselado a 45º en un principio para pasar luego a curvado, falsos botones y una rejilla frontal de ventilación, también tiene unos anclajes para la Pi por dentro pero tengo que mejorarlos porque se han roto dos al quitar el relleno.

Imagen

Luego en la parte de la impresión he hecho cambios también he pasado de 0.4 a 0.2 en el ancho de capa y lo he colocado boca arriba en lugar de boca abajo como la ultima vez, con soportes y con el relleno de forma concentrica para que la cúpula quedase mejor, se gasta bastante material en relleno así pero el resultado...

Imagen

Imagen

Imagen

Imagen

Estoy muy contento con el resultado para esta hecho en dos días, le quedan por añadir algunas cosas como la salida del GPIO y del cable USB, mejores anclajes, ajustar un poco las ranuras traseras y quizás hacerle una tapa inferior con rejilla que podría tener un soporte para ventilador.

Me dejo cosas por contestar del hilo, en cuanto tenga tiempo las contesto.
Me mola bastante [oki]

Lo que comenta Tuskador es cierto, estoy por lastrar la base de la Nespi con plomos o algo.
Hacer una base para tu diseño sería un acierto, así se puede lastrar o poner gomitas antideslizantes del leroy merlin y queda más mono el conjunto.
Yo apostaría por el uso de insertos de 5mm, aunque entiendo que complica el montaje, pero bueno, como sugerencia para un modelo "pro".

Y si, el diseño impreso así es lo suyo, aunque se gasten soportes es lo de menos y queda mucho mejor la parte superior y te da más libertad para diseñar.
He probado la nueva imagen con advmame corregido, los controles funcionan correctamente excepto que no puedo salir del juego una vez iniciado, no me reconoce el hotkey+start para salir del juego y tengo que apagar la raspi bruscamente, no sé si és advmame tiene una configuracion diferente a la hora de salir del juego ó es que tiene un bug, ó tal vez haya hecho yo algo mal.
Yo lo descargue de la web por la noche, el día que se aviso que estaba corregido el advance mame y con el mando de PS3 no me van bien los controles, me salen start y select en los gatillos por decir algo.
2686 respuestas