Emulador de Mega Drive (GenPlus) con soporte para Wiimote y Classic.

Hasta el 40% de dto en la Semana del Portátil
1, 2, 3, 4
PaRaDoX escribió:A no ser que alguien sea valiente y se atreva a hacer con la nueva herramienta ¬¬

porq tanto odio? que es lo q temes?
Faelivrin escribió:Lopst eres un crack [tadoramo]

Otro problema es que el emulador no me guarda las partidas ni mediante SRAM ni STATE (realmente me interesa este ultimo), me dice que no encuentra la carpeta genplus/save en dev0/dev1 cuando esta creada, hace falta SDgecko para guardar o esta implementado guardar desde el frontal? El emu de SNES me guarda bien en STATE.


me temo que este solo graba en tarjetas de camecube y en sdgecko.

Es una putada, el ne Snes no va en pal60, este no me graba en mi tarjeta de camecube oficial de nintendo.

creo que todavia no tengo ningun emulador definitivo, aun así gracias a LoPsT por todo su trabajo.
enanogitano escribió:
me temo que este solo graba en tarjetas de camecube y en sdgecko.

Es una putada, el ne Snes no va en pal60, este no me graba en mi tarjeta de camecube oficial de nintendo.

creo que todavia no tengo ningun emulador definitivo, aun así gracias a LoPsT por todo su trabajo.


Lopst ha publicado esta madrugada una version del emu de SNES que fuerza PAL60 por lo que ya va a color a los que se les veia en blanco y negro. Esta en la pagina 20 del hilo, aunque te paso el enlace:

Descarga Emulador a 60Hz new.

No se si hay mirror asi que hay que tirar de gatitos [qmparto].

Sobre el hilo, pues el emu ya se me ha colgado una vez con el Sonic 1 y no guarda [snif], pero mientras se soluciona al menos puedo jugar algo.
Tambien se me ha quedado pillado el Sonic 1.

Hay una cosa que me ha llamado la atención. ¿La SD no tenía un límite de 8 letras cuando muestra los nombres de las roms?? Con este es el único que se ven enteros!! :S
Sasker escribió:
Si, los originales, A, B, C. que estaban en linea ascendente. He puesto fotos del mando de megadrive y del mando que sacaron luego con 6 botones...
Pero en la 'segunda epoca' de megadrive, cuando competia cara a cara con snes, en juegos de muchos botones, va a ser un lio usar ese mapeo...


Joder, yo no entiendo xq tanto quejarse x unos pocos de botones, acaso no les puedes dar a todos con el dedo o q? Asi se quitan las ganas de hacer nada.
lopst escribió:
Joder, yo no entiendo xq tanto quejarse x unos pocos de botones, acaso no les puedes dar a todos con el dedo o q? Asi se quitan las ganas de hacer nada.


lopst no hagas caso ha quedado perfecto [oki]
Muuuuuuuuuuuuuuchas gracias!!!!!! [tadoramo]
pos a mi se me colgo dos veces, una con el sonic2 por ponerle el mando clasic, que el sonic no me iba y otra en el aof por darle al + en el clasic, pero posiblemente fuese cosa mia, es la 1 vez que pruevo el hack del zelda. el emu esta de pm
por cierto el que prove era el pal60 por si tiene alguna relevancia
a mi alguna vez me pasa q al darle al menu del emulador mientras juego se keda medio pillado el emulador y al volver al juego se ve a media pantalla ( se ve el jego entero pero solo en media pantalla, como medio deformado) no se porque sera y si solo me ha pasado a mi

un par de veces se me ha quedado colgado con el mortal kombat (es una version hack del MK3, con los personajes del 1,2 y 3 pero en el pc funciona bien)
¿Pero eso qué es? ¿SMSplus o Genesis Plus? Parece que vienen las dos cosas mezcladas ahí dentro.


Sasker escribió:
lopst escribió:- Classic Controller:

Classic ..... GENESIS
---------------------
X .................. A
B .................. B
A .................. C
L .................. X
Y .................. Y
R .................. Z
+ ................ START
- ................. MODE
HOME ........... Menu del emulador

Que configuracion mas rara, no???

No deberia ser, por temas intuitivos:

Classic ..... GENESIS
---------------------
X .................. Y
Y .................. X
L .................. Z
B .................. A
A .................. B
R .................. C
+ ................ START
- ................. MODE
HOME ........... Menu del emulador

Teniendo en cuenta que el 90% de los juegos utilizan el botón C para que el personaje salte, no veo muy "intuitivo" que se salte con el R...

El B y el C de la MegaDrive siempre fueron los sucesores del B y el A de la NES, o el 1 y 2 de la SMS, siendo el A utilizado normalmente para acciones extra (magias, etc).

Pero estaría bien poder configurar los botones al gusto, para usar controles como el Hori Fighting Stick sin líos de botones.
el canal tiene el fondo negro no?
A no ser que alguien sea valiente y se atreva a hacer con la nueva herramienta ¬¬

Si te refieres al Wad packer 00000004 es que yo sepa no se puede usar para empaquetar dols o elfs.
oye sms no es emu de sega maseter system????
Sí, para mí que aquí ha habido una confusión...
No he probado ningún juego, ya que no sé exactamente para qué consola es el emulador.

Me dá que emula juegos de la Master System, Mega Drive y Genesis, aunque talvez esté equivocado. Recuerdo que el de PC hasta emulaba juegos de la GameGear, todo en uno.
El que emula Mega Drive, Master System y Game Gear... no te refieres al Kega Fusion?
Que nombre hay que darle a la carpeta de los roms y saves???
LoRD FeRKy escribió:oye sms no es emu de sega maseter system????


si, se ha ekivocado PaRaDoX al poner el nombre al canal. Tampoco pasa nada, somo humanos.

karakatua escribió:Que nombre hay que darle a la carpeta de los roms y saves???


Mirate el post principal (primer mensaje)
ah vale osea k si es el de megadrive pero el problema es k sta con el nombre del de master sistem ¿no?
okis ya jugue y lo vi
peeeeeerrrrdoooooooonnnnn!!!!! [borracho]
Dios, lo acabo de poner y estoy recordando mis viejos tiempos de Mega Drive, un millón de gracias!!!!!!

Solo una cosita, no consigo grabar states de juegos, he creado la carpeta /genplus/save (tambien he probado como saves) y cambio devica a SDCARD , SLOT A ó B y no funciona, sabéis si es que no está implementado o es que hago algo mal, gracias y salu2
danitxu escribió:Dios, lo acabo de poner y estoy recordando mis viejos tiempos de Mega Drive, un millón de gracias!!!!!!

Solo una cosita, no consigo grabar states de juegos, he creado la carpeta /genplus/save (tambien he probado como saves) y cambio devica a SDCARD , SLOT A ó B y no funciona, sabéis si es que no está implementado o es que hago algo mal, gracias y salu2

No está implementado el SAVE al frontal.
PaRaDoX escribió:No está implementado el SAVE al frontal.



Gracias por la respuesta ;)

El emulador está de PM, me estoy viciando como un loco :P
A mi con la versión pal60 en el canal , se me sigue viendo en rojo ¿Por que será? :(

Tengo que poner la consola en 50 herzios y luego ya puedo verlos 60 hzs, como ponga la consola a 60 , en rojo
titorino escribió:A mi con la versión pal60 en el canal , se me sigue viendo en rojo ¿Por que será? :(

Tengo que poner la consola en 50 herzios y luego ya puedo verlos 60 hzs, como ponga la consola a 60 , en rojo


¿Lo cargas directamente desde el hack o usas antes un loader?
¿No se puede cambiar la configuración de botones? Lo he intentado y no cambian.
Anoche intenté instalar el canal de megadrive y no habia manera. No me instala nada, solo me ejecuta el emulador a través del exploit del zelda pero nada más.

¿que hago mal? Pongo el title.wad y el bott.elf y con la tarjeta recien formateada y nada.
satanass pon el ultimo loader de zelda actualizando el save que tienes en la consola y el instalador en el raiz.
Juas, que pena que este emulador no anda muy fino. No es por criticar ni exigir, el emulador esta de puta madre, pero se queda bloqueado cada dos por tres.
Una pena. A ver si lo optimizan para poder disfrutar de este gran emu.
Por cierto, gracias por el curro.
por cierto una pregunta q se me acaba de ocurrir...

os acordais del mega 32x (el cacharro ese q se acoplaba a la megadrive)... sabeis si este emulador va con las roms del 32 x?

yo es q no tengo roms de esa
amiwiito escribió:por cierto una pregunta q se me acaba de ocurrir...

os acordais del mega 32x (el cacharro ese q se acoplaba a la megadrive)... sabeis si este emulador va con las roms del 32 x?

yo es q no tengo roms de esa


El 32x era simplemente una expansion de memoria que encima requeria su propia fuente de alimentacion.

Me acuerdo que luego sacaron algun juego que acoplabas 2 32x en la megadrive, una locura, y ademas el mega CD, aquello era un monstruo XD

No triumfo nada, creo que no habia ningun juego medio decente, y ademas muchos juegos de la MD estan mejor en la SNES aunque parezca imposible. (doom por ejemplo)
El 32x era simplemente una expansion de memoria que encima requeria su propia fuente de alimentacion.


De expansion de memoria nada, por si sola era una consola de 32 bits, simplemente se aprovechaba de la megadrive en tema de los puertos y el MegaCD y poco mas.

Caracteristicas de la 32x:

CPU: 2 x Hitachi SH2 a 23 Mhz/40 MIPS
Co-Procesador: Nueva VDP, 50.000 polígnos planos/s
RAM: 4 megabits extras
Paleta: 32.768 colores
Resolución: 320x224
Sonido: Estéreo digital PCM que se puede mezclar con el de Megadrive

¿A ti te parece esto un expansion de memoria?

Es una consola hecha y derecha pero incompleta, ya qu puertos de los mandos, y esas cosas se aprovechaba de la megadrive, ademas de que por eso necesita una fuente de alimentacion para ella sola.

Saludos.
Ya me molaria a mi poder jugar al virtua fighter de 32 X en mi wii....
TheFireRed escribió:
¿Lo cargas directamente desde el hack o usas antes un loader?


He instalado el canal , antes lo cargaba con el zelda y me iba bien .
SATANASSS escribió:Anoche intenté instalar el canal de megadrive y no habia manera. No me instala nada, solo me ejecuta el emulador a través del exploit del zelda pero nada más.

¿que hago mal? Pongo el title.wad y el bott.elf y con la tarjeta recien formateada y nada.



bott.elf????????? sera boot.elf

y estaras usando el elf del wad installer y no el el elf del genplus, no?
titorino escribió:
He instalado el canal , antes lo cargaba con el zelda y me iba bien .


Pues prueba a ejecutarlo directamente desde el Zelda, o con el MAG Loader a 50Hz desde el Zelda y después cargas el emulador.

A mí me funciona bien así. Si ejecutas un programa a 60Hz que no es compatible a 60Hz (de momento MAG Loader, y no sé si el Canal Homebrew), todos los programas que se ejecuten después tampoco funcionarán. Lo digo por experiencia propia.
no soy capaz a que me lea ninguna rom, he creado en la raiz de la sd genplus/roms pero no me los detecta
serneo escribió:Juas, que pena que este emulador no anda muy fino. No es por criticar ni exigir, el emulador esta de puta madre, pero se queda bloqueado cada dos por tres.
Una pena. A ver si lo optimizan para poder disfrutar de este gran emu.
Por cierto, gracias por el curro.

A mi tambien me va bastante chungo, es una pena. La version que va con el mando de gc me iba bien asi que habra que volver a ella y esperar a que mejoren este.
serneo escribió:Juas, que pena que este emulador no anda muy fino. No es por criticar ni exigir, el emulador esta de puta madre, pero se queda bloqueado cada dos por tres.
Una pena. A ver si lo optimizan para poder disfrutar de este gran emu.

A mí nunca se me ha colgado, y me va mejor que el de SNES en cuanto a compatibilidad y fidelidad con el sistema original, y además salen los títulos de los juegos completos. Aunque a lo mejor estoy usando una versión más vieja en la que no se haya estropeado algo...

Prueba a volver a formatear la SD, de todas formas.
A mi se me sigue viendo en blanco y negro el de 60, lo tengo que poner en 50 para verse en color. A alguien más le pasa?
Hay otra version del emulador que realmente funcione bien y se pueda guardar estado?
Gracias.
(mensaje borrado)
A ver si DRaGMaRe trae el canal para los que usan RGB, ya que pasan algo de ellos xD
Mi último aporte Canal GenPlus - Wiimote + Classic PAL60 RGB

Su nombre ya lo dice todo xD El canal de Megadrive con soporte para Wiimote como ya lo había... sólo que ahora también irá bien con los que usamos cable RGB.
ID: ASMS
Uso la misma ID que PaRaDoX por si alguno tiene su canal que pueda reemplazarlo directamente.

Un saludo.
DRaGMaRe escribió:Mi último aporte Canal SMSPlus - Wiimote + Classic PAL60 RGB

Su nombre ya lo dice todo xD El canal de Megadrive con soporte para Wiimote como ya lo había... sólo que ahora también irá bien con los que usamos cable RGB.
ID: ASMS
Uso la misma ID que PaRaDoX por si alguno tiene su canal que pueda reemplazarlo directamente.

Un saludo.


Pero el SMSPlus no es el nombre del emu de Master System? El de Mega Drive es el Genplus.
Es el de Megadrive. Cogí el nombre del primer post y como ponía SMSPlus pues le puse el mismo nombre...
Pero es el GenPlus.
DRaGMaRe escribió:Mi último aporte Canal GenPlus - Wiimote + Classic PAL60 RGB

Su nombre ya lo dice todo xD El canal de Megadrive con soporte para Wiimote como ya lo había... sólo que ahora también irá bien con los que usamos cable RGB.
ID: ASMS
Uso la misma ID que PaRaDoX por si alguno tiene su canal que pueda reemplazarlo directamente.

Un saludo.


Dragmare, a mí se me continúa viendo en rojo :/
BeaKManiak escribió:
DRaGMaRe escribió:Mi último aporte Canal GenPlus - Wiimote + Classic PAL60 RGB

Su nombre ya lo dice todo xD El canal de Megadrive con soporte para Wiimote como ya lo había... sólo que ahora también irá bien con los que usamos cable RGB.
ID: ASMS
Uso la misma ID que PaRaDoX por si alguno tiene su canal que pueda reemplazarlo directamente.

Un saludo.


Dragmare, a mí se me continúa viendo en rojo :/



Usas el cable RGB y tienes la Wii configurada a 60Hz 480i? Tu consola es PAL?
Si tenías el otro canal prueba a desinstalarlo primero, y luego instalar este. Yo acabo de volverlo a probar y se me ve con el color correcto.
Si tal puedo subir unos canales parcheados de otro modo

Prueba este a ver.. Canal GenPlus - Wiimote + Classic PAL60 RGB
DRaGMaRe escribió:Usas el cable RGB y tienes la Wii configurada a 60Hz 480i? Tu consola es PAL?
Si tenías el otro canal prueba a desinstalarlo primero, y luego instalar este. Yo acabo de volverlo a probar y se me ve con el color correcto.
Si tal puedo subir unos canales parcheados de otro modo

Prueba este a ver.. Canal GenPlus - Wiimote + Classic PAL60 RGB


Sí, tengo el cable RGB i la Wii PAL configurada a 480i. Antes había sobreescrito el canal, pero con desinstalarlo y reinstalarlo me ha hecho lo mismo (emulador en rojo). Con esta versión que has colgado nueva (desinstalando la antigua e instalando ésta) me da como resultado un CODE DUMP.
Me pasa lo mismo que a BeaKManiak , primero ne rojo , despues he desistalado la anteriror versión y he instalado la nueva , se qued automaticamente bloqueado y salen muchas letras [snif]

De todas formas gracias DRaGMaRe por tu ayuda [ginyo]
Esto me jode, porque a mi si me va bien y no a vosotros?
Por favor que más gente confirme si le funciona o no. Haré mas pruebas cuando pueda.

EDITO:

La prueba 1 es la que según no parece no funciona (a mi si) la 2 es nueva, a ver... porque me toi quedando sin ideas xD

Prueba 1 FAIL
Prueba 2 ?
Yo he descargado una versión que va con Wiimote y me va perfecta. Aunque no uso cable RGB, uso el cable A/V de serie.

Tengo que decir que este emulador es bestial. No he comprado ningún juego de la VC de sega, pero teniendo en cuenta que esto va a 60fps, estoy seguro que es mejor opción que los juegos empalados a 50hz y con franjas que nos pretendían vender.

Además, este emulador hace un resize casi perfecto o perfecto de la pantalla (el de snes en cambio hace bilinear, aunque desactives la interpolación) y el resultado final es brutalmente similar a una mega drive, sean juegos en 320x224 o en 256x224, el resultado es muy bueno.

Para mí este emulador debería ser el modelo a seguir por el resto.
193 respuestas
1, 2, 3, 4