Instalar Windows 7 en partición GPT

Ofertas en PcComponentes: Top Verano y PcCom Days
Esta tarde me he comprado un ASUS N56VM con Windows 7 Home Premium pre-instalado. He querido hacer una instalación limpia con un DVD de W7 HP de 64 bits. Inocente de mí formateé la partición donde estaba instalado el S.O. y me encontré con que no podía instalar Windows (partición GPT). Mirando por ahí encontré una forma de usar el diskpart para formatear la partición, pero después de seguir los pasos indicados sigo teniendo el mismo problema. En este mismo foro he encontrado un tutorial para convertir una partición GPT a NTFS, pero como no controlo muy bien el tema de los sistemas EFI tengo miedo de liarla todavía más. ¿Alguna idea?
Si formateas la partición desde la instalación de Windows7 debería instalar sin problemas, ¿lo has probado?
Perdón, solucioné el problema al día siguiente. El problema es que era imposible instalarlo desde ahí, la instalación estaba restringida. Esto es lo que hice, por si a alguien le puede servir:

- Dentro del gestor de particiones del instalador de Windows 7, pulsar Shift+F10
- Saltará la consola de comandos, introducir "diskpart"
- "list disk" por si tienes más de un disco duro. Si te sale un asterico al final, es que tienes el mismo problema que yo.
- "Select disk=0" En mi caso el disco es 0, pero puede ser 1,2,3,etc
- "clean" (Esto borrará todas las particiones de disco y su contenido)
- "exit"
- Refrescar la lista de particiones en la instalación de Windows. Desde ahí se puede continuar con normalidad.
Bueno, eso era lo que te iba a recomendar, pero veo que el Señor Google ha sido más rápido que yo. [+risas] Sólo una puntualización:
Las particiones GPT las puedes usar para iniciar Windows a partir del Windows Vista SP1 y en sus versiones de 64bits y sólo si tienes una BIOS-UEFI. Con una BIOS estándar no puedes iniciar Windows en ese tipo de partición, por eso no te dejaba ni instalarlo. ;)
increible amigo,,,,, me la pases varias semanas dandome topes y no sabia como, de hecho lleve mi lap al tecnico de mucha experiencia y ni el supo como,,,, leei tu post y me funciono a la perfeccion,, solo hay que mencionar, que hay q tener respaldado toda tu informacion ya que tienes q formaterar forzosamente,,,, muchas gracias por compartir tu experiencia,, saludos desde leon gto mexico...

quiero mencionar que el modelo de mi lap es una ASUS r500v, y creeo por el tamaño del HD q es de 750 , asus esta implementando este tipo de particion,, no se porque,,, y normalmente usos programas como autocad , 3d max, corel draw, y la raiz de todo este tema de instalar un win7 pro,,, es porque algunas aplicaciones de 3d max,,no me las dejaba instalar tampoco,,, me decia de un problema con el installer package scrip,,,, y por este sencillo error me vi en la necesidad de formatear y cambiar el estilo de particion... saludos..
Muchas Gracias Amigo por comprtir tu solucion te cuendo que yo habia instlado w8 y no me gusto para nada y decidi regresar a w7 pero me tope con el inconveniente que mi disco tenia particion GPT y buque hasta que encontre lo que nesesitava, Felicidades...

Saludos.
Kurdt89 escribió:Perdón, solucioné el problema al día siguiente. El problema es que era imposible instalarlo desde ahí, la instalación estaba restringida. Esto es lo que hice, por si a alguien le puede servir:

- Dentro del gestor de particiones del instalador de Windows 7, pulsar Shift+F10
- Saltará la consola de comandos, introducir "diskpart"
- "list disk" por si tienes más de un disco duro. Si te sale un asterico al final, es que tienes el mismo problema que yo.
- "Select disk=0" En mi caso el disco es 0, pero puede ser 1,2,3,etc
- "clean" (Esto borrará todas las particiones de disco y su contenido)
- "exit"
- Refrescar la lista de particiones en la instalación de Windows. Desde ahí se puede continuar con normalidad.


Grande !!!! gRacias !
Y a nadie le ha pasado que "bootea" el disco de instalacion de windows 7 ni de Ubuntu??
Solo me reconoce en la Bios un sistema alternativo de arranque al disco duro cuando le meto el Hiren's CD 9.3 y cuando intento arrancar desde el, se va al sistema operativo pre-instalado directamente.
Es verdad que estoy usando uno desatendido el "expertOS sp4", a lo mejor tenia que probar con uno original?
El de ubuntu esta sin manipular la imagen.
Que os parece? El equipo que tengo es un Asus X55A, y lo del UEFI, es un poco coñazo.
La semana pasada estuve lidiando con un problema similar en un portatil Asus X55A con W8 preinstalado. Conseguí instalar W7 64b desactivando el "Secure Boot" de la bios y activando en ella el "CSM" (UEFI Compatibility Support Module).
skarica escribió:La semana pasada estuve lidiando con un problema similar en un portatil Asus X55A con W8 preinstalado. Conseguí instalar W7 64b desactivando el "Secure Boot" de la bios y activando en ella el "CSM" (UEFI Compatibility Support Module).


Muchas gracias!!
Ya pude instalar el Win7 32b sin las historias del UEFI.
Impresiona lo sencillo que es y el tiempo que estado buscandolo. [+risas]
hola, perdonen que reabra el post, necesito ayuda, yo tengo una torre acer aspire M1935 con windows 8 preinstalado y me gustaria ponerle el windows 7,, cold7900 dices que lo conseguistes hacer y que es super sencillo, me podrias decir como lo conseguistes hacer,, yo es que consigo que me lea el dvd pero se me queda pillado al principio de la instalacion en la pantalla de carga de windows7 y de ahi no pasa, gracias
skarica escribió:La semana pasada estuve lidiando con un problema similar en un portatil Asus X55A con W8 preinstalado. Conseguí instalar W7 64b desactivando el "Secure Boot" de la bios y activando en ella el "CSM" (UEFI Compatibility Support Module).


Solamente seguí estas indicaciones, por eso me parecio super sencillo.
gracias por responder, entonces lo que hay que hacer es desactivar el Secure Boot y activar el UEFI de la bios, lo probare esta tarde a ver si hay suerte y lo consigo instalar,, muchas gracias. :p
Mil gracias por tu solucion, me sirvio hoy me trajeron una HP y cabal ese problema me comenzo a dar ya estaba yo mentando al dios del hardware y busque y encontre tu tema y me sirvio.

Gracias.
Muchas Gracias por la ayuda compis, siguiendo los pasos fue cocer y cantar, muy facil,, gracias ne nuevo
Kurdt89 escribió:Perdón, solucioné el problema al día siguiente. El problema es que era imposible instalarlo desde ahí, la instalación estaba restringida. Esto es lo que hice, por si a alguien le puede servir:

- Dentro del gestor de particiones del instalador de Windows 7, pulsar Shift+F10
- Saltará la consola de comandos, introducir "diskpart"
- "list disk" por si tienes más de un disco duro. Si te sale un asterico al final, es que tienes el mismo problema que yo.
- "Select disk=0" En mi caso el disco es 0, pero puede ser 1,2,3,etc
- "clean" (Esto borrará todas las particiones de disco y su contenido)
- "exit"
- Refrescar la lista de particiones en la instalación de Windows. Desde ahí se puede continuar con normalidad.

Hago eso con un portatil, pero ahora, cada vez que intento instalar windows 7 se queda permanentemente en "Expandiendo archivos de windows 0%" y no avanza. Tampoco me deja instalar otro SO y el recovery está borrado. Solo puedo entrar en la BIOS.

¿Se puede solucionar de alguna forma? Estoy muy preocupado. :( Porque como la haya liado es responsabilidad mia sobre este pc nuevo.
Y al hacer esto que mencionais, no te borra ese disco duro entero con lo que ello conlleva, me refiero a que si tambien te borra la parte de recuperacion a su estado de fabroca, es que el mio tiene varias particiones en ese disco y solo quiero borrar la particion donde quiero instalar el w7 ya que el 8 de fabrica me trae mucha basura y programas que me dan problemas que no me van. Parece que el este disco tengo varias particiones y en una de ellas esta como me parece a mi la de recuperacion del producto a su estado de fabrica. Gracias.
Up. ¿alguien sabe algo?
SAMSUNG - NP355E4C
con esto te ayuda a inicira con cd si eske no puedes usar la unidad de arranque de cd...
presionar F2 sigue estos pasos en boot.. en Secure boot ponle disable y en Os Mode Selection colocalo en UEFI and Legacy Os y te bootea del cd..
Conseguí instalar W7 64b desactivando el "Secure Boot" de la bios y activando en ella el "CSM" (UEFI Compatibility Support Module).
pasos de diskpart
Dentro del gestor de particiones del instalador de Windows 7 u 8, pulsar Shift+F10, es decir cuando te aparezaca la ventana de persolanizar elegir particones 1,2,3,4 en el disco duro se presiona Shift+F10,
- Saltará la consola de comandos de cmd, introducir "diskpart"
todo sin comillas
- "list disk" por si tienes más de un disco duro. Si te sale un asterico al final, es que tienes el mismo problema que yo.
- "Select disk=0" En mi caso el disco es 0, pero puede ser 1,2,3,etc
- "clean" (Esto borrará todas las particiones de disco y su contenido)
o dar "clear all"
- "exit"
y asi se borra todo y keda solo uno solo espera 20 segundos.
- Refrescar la lista de particiones en la instalación de Windows. Desde ahí se puede continuar con normalidad.

y ya puede instalar w8 o w7 sino es asi, te aparece solo una partiocion 8 y aparece error sigue los pasos

diskpart
rescan
list disk
select disk
create partition
primary
clear
exit
espera 15 a 30 segundos
luego actualizar o refrescar...
y seguir la instalacion

ami me funciono en samsung gpt de disco a rmb ke es ntfs.....
saludos

FUENTE

hilo_instalar-windows-7-en-particion-gpt_1833362

http://ingenieriaensistemasuat.wordpres ... traciones/
(mensaje borrado)
@Kurdt89 Excelente brother! He ganado tiempo y dinero! Gracias!
OYE X LOS KOMENTARIOS POSITIVOS KE TIENS VEO KE SI FUNCIONA,,, [boing]
HAC RATO EMPECE A FORMATEAR UNA KOMPU Y ME TIRO EL MISMO PROBLEMA KE A TI... [buuuaaaa] PRO AUN NO HE PROBADO HACR LOS PASOS KE DISTE,,, :-? LOS VOI A REALIZAR A VER KOMO M VA.. ,, GRACIAS X LA INFORMACION... (Y)


oye .. gracias x la informacion... x fin solucione mi problema... graciaz.. [360º]
wow muxas gracias definitivamente excelente solucion de hecho solo me registrado para dar las gracias !!!
Hola, soy nuevo, buscando este tema, encontre el foro. Veo que todos les ha resultado la solucion, pero para es una odisea aun. les comento, tengo una hp 2000 notebook con win8 enviada de EEUU. Decidi cambiar al win7 asi que me puso manos a la obra. o sorpresa no se puede. probe con el diskpàrt eliminando todas las particiones
le doy clean all y se demora demasiado (nose si le spaso a ustedes tambien) a si que cancelo y regreso al menu de seleccion de unidades de la instalacion de win7. con esa unica particion que me aparece la formateo y me resulta dos discos, bien. pero cuando instalo el win7 y reinicia para continuar, me sale un mensaje de bios que no encuentra unidad con so booteable o algo asi. asi que regreso al satup del bios y vuelvo activar la compatibilidad (desactivo uefi) y es algo redundante porque siempre que reinicia la instalacion de win7 tengo que entrar al setup para habilitar la compatibilidad.

intente tambien con activar la particion (lo hare mal, nose), de ser el caso de crear particiones yactivar (con diskpart) como se hace?

Ayuda lo antes posible.
Gracias.
Prueba a restaurar la configuración de la BIOS-UEFI a fábrica una vez hayas reiniciado por primera vez la instalación de Windows 7.
el win 8 que viene default es un dolor de hu.... Gracias
Juas, me viene de perlas ver este hilo levantado.

Estoy intentando instalar Windows 7 en un Toshiba Satellite L850-1RZ (portátil) que venía con Windows 8 de serie. El tema es que me gustaría conservar la partición de recuperación por si las moscas (no se si la garantía se la lleva por delante al tocar cosas de software y quiero conservar mi licencia de W8), pero el método Kurtd89 se cepilla todas las particiones.

He usado una copia de W7 64 bits, que se supone es compatible con UEFI, pero se queda atascada en "Starting Windows". He probado a desactivar los USBs, LAN y demás, pero sigue quedándose en la puñetera pantalla. ¿Tengo que desistir y acabar borrando todo :( ?
Comprueba que no tengas el SafeBoot o algo así activado en la BIOS-UEFI. Si no, intenta instalar Windows 7 con el modo de compatibilidad BIOS activado en la BIOS-UEFI.
Nada, al final he hecho eso y me he cepillado todas las particiones. Por lo que parece el instalador de Windows 7 es un poco puñetero con determinados componentes y le cuesta cargar en modo UEFI en determinadas máquinas.
Grandes tutoriales. Gracias
Yo quiero hacer lo que viene en el primer post con un Vaio recién comprado y ventilarme el W8 (no lo soporto) pero parece ser que anulas la garantía instalando el W7. ¿Alguna opción para poder usar el W7 y mantenga la garantía el equipo?.
No deberías perder la garantía por instalar otro sistema operativo en tu propio equipo.
Pues eso me ha dicho el vendedor. Que si instalo W7 pierdo la garantía, ¿algún sitio donde asegurme de esto para ver si meto el W7?
El formateo e instalación de otro sistema operativo en una maquina no debería suponer la anulación de garantía. Si estamos hablando de pirateo quizás puedas tener algún problema ya que es probable que eso no cumpla las condiciones de uso del producto, pero si tienes licencia legal o si usas un sistema operativo libre no deberías tener ningún problema. En cualquier caso, en estos links deberías tener todo lo que necesitas saber.

http://www.sony.es/support/es/warranty/general
http://www.sony.es/support/es/warranty
Su puta madre, tenía otra partición con datos... dspués de entrar en el disco, he entrado en la partición "select partition = 4", y le he dado a clean pensando que borraría la partición... xDDDD

A tomar por culo todo jajajaja (me río porque no era para tanto, si no ya me hubiese molestado en investigar más...) pero joder, estaba convencido [+risas] [+risas]

Gracias, eso sí, porque cuando he visto lo del GPT me he quedado a cuadros.
---
Muchas gracias por el aporte, muy importante, yo pude resolver el downgrade de windows 8 a windows 7.
Saludos!
Kurdt89 escribió:Perdón, solucioné el problema al día siguiente. El problema es que era imposible instalarlo desde ahí, la instalación estaba restringida. Esto es lo que hice, por si a alguien le puede servir:

- Dentro del gestor de particiones del instalador de Windows 7, pulsar Shift+F10
- Saltará la consola de comandos, introducir "diskpart"
- "list disk" por si tienes más de un disco duro. Si te sale un asterico al final, es que tienes el mismo problema que yo.
- "Select disk=0" En mi caso el disco es 0, pero puede ser 1,2,3,etc
- "clean" (Esto borrará todas las particiones de disco y su contenido)
- "exit"
- Refrescar la lista de particiones en la instalación de Windows. Desde ahí se puede continuar con normalidad.


MUCHAS GRACIAS.!!! XD XD XD XD XD
Muchas gracias por la info.
Hola, con respecto a la partición de recuperación del equipo:

En mi caso poseo un netbook que al no tener unidad lectora de DVD no viene con el susodicho disco de instalación, ¿y que pasa si se me estropea la partición de recuperación, como reinstalo el SO original si fuese necesario? Seguramente el fabricante tenga algún sistema previo pago, claro...

Para evitar tener que pasar por caja hice un volcado de la partición con Norton Ghost a un disco duro externo, y así evito perder la partición, el sistema operativo por el que ya pagué y, además, tengo una copia de seguridad por si acaso.

¿Como se hace?:
1- Arrancar el equipo normalmente.
2- Conectar el disco duro externo al equipo (es una obviedad, pero por si las moscas...).
3- Ejecutar Norton Ghost, que crea una imagen de la partición a un archivo que nosotros le indiquemos en el disco duro externo (hace un volcado de la partición).

Para recuperar la partición desde el disco duro externo hay dos casos:

Caso 1 - equipo con lector de DVD -
1- Crear cd de arranque desde Norton Ghost (en un equipo que funcione bien, off course).
2- Restaurar la partición desde el disco duro externo.
3- Reiniciar el equipo sin el cd de arranque y el solito debería autoarrancar desde la partición de arranque.

Caso 2 - Equipo que no tiene lector de dvd -
Aquí surge el problema de si el equipo puede o no arrancar desde un disco USB (mi netbook no lo permite).
Si arranca desde usb creamos un disco (memoria) usb de arranque para ejecutar Norton Ghost.
En Internet hay muchas apps para hacer esto. Yo recomiendo usar "yumi", aunque parece un poco lioso con un poco de paciencia se consigue dominarlo.
Luego ya solo hay que conectar el disco duro externo y restaurar la imagen de la partición.

Si no podemos utilizar una memoria usb solo queda intentar arrancar desde red, para lo que necesito otro equipo que actue como servidor.
Y en este punto es donde me he quedado y lo que me ha traido hasta este foro, si alguién tiene otra solución o un modo de hacerlo de manera más fácil bienvenido sea.

Espero haber sido de ayuda. Saludos.
Kurdt89 escribió:Perdón, solucioné el problema al día siguiente. El problema es que era imposible instalarlo desde ahí, la instalación estaba restringida. Esto es lo que hice, por si a alguien le puede servir:

- Dentro del gestor de particiones del instalador de Windows 7, pulsar Shift+F10
- Saltará la consola de comandos, introducir "diskpart"
- "list disk" por si tienes más de un disco duro. Si te sale un asterico al final, es que tienes el mismo problema que yo.
- "Select disk=0" En mi caso el disco es 0, pero puede ser 1,2,3,etc
- "clean" (Esto borrará todas las particiones de disco y su contenido)
- "exit"
- Refrescar la lista de particiones en la instalación de Windows. Desde ahí se puede continuar con normalidad.


Tengo una Lanix Neuron A Ya hice de todo incluyendo lo de este post y no funciona,
Mi problema es que al desactivar secure boot me desactiva el backligth de la pantalla y conectando una pantalla externa me permite instalar sin ningun problema pero mi pantalla del portatil sigue sin luz, una vez terminada la instalacion reactivo secure boot la luz regresa a la pantalla pero mi sistema operativo no funciona, ya instale windows 7 32 y 64 bits asi como nuevamente windows 8 a 64 bits y sucede lo mismo.
Cabe señalar que la decision de formatear fue porque el sistema se dañaba muy seguido la maquina dejaba de funcionar y solo estaba reparando de inicio.
Alguna sugerencia?
Muchas gracias, me ha servido de ayuda!!
Kurdt89 escribió:Perdón, solucioné el problema al día siguiente. El problema es que era imposible instalarlo desde ahí, la instalación estaba restringida. Esto es lo que hice, por si a alguien le puede servir:

- Dentro del gestor de particiones del instalador de Windows 7, pulsar Shift+F10
- Saltará la consola de comandos, introducir "diskpart"
- "list disk" por si tienes más de un disco duro. Si te sale un asterico al final, es que tienes el mismo problema que yo.
- "Select disk=0" En mi caso el disco es 0, pero puede ser 1,2,3,etc
- "clean" (Esto borrará todas las particiones de disco y su contenido)
- "exit"
- Refrescar la lista de particiones en la instalación de Windows. Desde ahí se puede continuar con normalidad.


Muchas gracias. Puesto en favoritos.
A ver, por favor, ya vale con el lameculos constante de este hilo. La solución que se propone Kurdt89 al principio de este hilo es válida pero sólo es una solución tipo receta que sirve para un conjunto determinado de casos. En la mayoría de las ocasiones es válida, pero NO ES LA MEJOR.

Como ya he dicho, Windows Vista a partir del Service Pack 1 en su versión de 64 bits puede instalarse e iniciarse en discos duros con particiones GPT y esto es válido hasta Windows 8.1 a día de hoy. Teniendo esto en cuenta, no es necesario cargarse todas las particiones, y con instalar un Windows de 64 bits vale.

Y añado, aquellas UEFIs que no tengan modo de compatibilidad con BIOS no pueden arrancar desde una partición que no sea GPT.
Hola! Quería agradecerte la explicación q diste, seuí todos tus pasos y pude hacerlo como vos. Muchas gracias! Saludos desde Salta-Argentina :)
Gracias me hiciste un gran favor... Dios te bendiga por compartir tu experiencia. Yo tenia el mismo problema gracias a ti lo solucioné.
Gracias amigo, me paso exactamente lo mismo que a vos, y gracias a tu experiencia problema solucionado e instalando w7...

saludos...
MIL GRACIAS ME HAS SALVADO!
¿No hay manera de solucionarlo sin borrar todo el disco duro? Que tengo otra particion donde esta mi respaldo.
Sí. Instalando un Windows de 64 bits arrancando la instalación en modo UEFI en lugar de "compatibilidad BIOS".

El problema es que muchas ISOs (especialmente las AiO o Todo en uno) no están bien hechas y tienen el sistema de arranque UEFI eliminado pudiendo sólo arrancar como BIOS. Lo mejor es que te busques y descargues una ISO original de Microsoft (sin tocar) con la versión de Windows que quieras instalar.
51 respuestas
1, 2