Hackintosh: qué, cómo y dónde

@M3GADRIV3 No hay nada 100% compatible salvo que uses hard de Apple como las wifi de iMac, el resto siempre tienes que afinar algo.

Perfecto no van ni tan siquiera los Mac no compatibles oficialmente que Apple deja sin dar soporte aunque sean compatibles no oficialmente.
apriliars3 escribió:@M3GADRIV3 No hay nada 100% compatible salvo que uses hard de Apple como las wifi de iMac, el resto siempre tienes que afinar algo.

Perfecto no van ni tan siquiera los Mac no compatibles oficialmente que Apple deja sin dar soporte aunque sean compatibles no oficialmente.


Llevo mas de diez años montando hackintosh y lo que te puedo decir es que si usas hardware compatible tienes cero problemas. Y esto no es opinión es un hecho lo creas o no. Que despues de su instalación se tenga que afinar alguna cosa no quita que no sea compatible y funcione en un 100%.
@apriliars3 algunos quereis ser más papistas que el papa.

Yo que he tenido hack por hardware y por software, te digo que un hack funciona igual que un mac original.
Jar-Jar escribió:@apriliars3 algunos quereis ser más papistas que el papa.

Yo que he tenido hack por hardware y por software, te digo que un hack funciona igual que un mac original.


Por nada es que Apple esta actualizando sus equipos con hardware propietario sea este CPU o en su defecto soldando sus partes para que sea dificil en un futuro instalar OSX en PCs. Para lo mas pronto posible y no muy lejos poder dejar atras los "listos" como nosotros que nos saltamos sus Macs a sobreprecio montando su OSX en la maquina que nos da la gana con piezas compatibles. Esto a Apple no le gusta porque por poco dinero tienes mucho mas y todavia aparece el "papa" de turno a decir que no son estables al 100% porque a el no le va bien. Sabra Dios que piezas usa o en donde tiene instalado la torta y luego pasa a soltar la perla.

Muchos tratan de instalar hackintosh en donde les sale del rabo y por eso pasa lo que pasa y despues pasan a soltar tonterias. Otros comienzan en esto hoy y quieren discutir con quienes llevamos en esto mucho, mucho tiempo.

Que esto no es oficial pues si, que no siempre instala todo y hay que buscarse la vida en ocasiones para dejarlo fino pues tambien, pero eso que dejando esto fino no funciona al 100% con piezas confirmadas compatibles eso, eso no es verdad.

Al Cesar lo que es del Cesar.
@Faxtron Después de toda la chapa que has metido, es para decir lo mismo que yo. [angelito] [beer] [beer] [beer]
Hola, sabeis por que puede ser que no se sincronice la app FOTOS con el iPhone, ha dejado de cargar fotos y no esta lleno iCloud.
Saludos
@Faxtron Tienes el hack con el dsdt o solo con kext?
apriliars3 escribió:@Faxtron Tienes el hack con el dsdt o solo con kext?

Kext
Pués yo he pasado a Mojave. Si, me doy cuenta que con mi anterior hack, dsdt, ssdt y 5 kexts ( Lilu, whatever green, la tarjeta de Red, ahci port y el fakesmc) iba como un puto tiro, ahora al pasar al actual, tengo unos 10 kexts, y como 15 parches en clover, cambiando cosas, pero...

Noto el pc menos ágil que el anterior, siendo infinitamente mejor.
Se queda como bloqueado cuando descomprimo ficheros y tarda mucho más que antes.
No me monta dos hds que tanto Windows como 3l anterior hack si lo hacía. Si recuerdo que en el último update que monté en el hack, esos dos discos se habían vuelto vagos a la hora de montarse, pero en Windows funcionan, están correctos de salud y no les pasa nada pero osx dice que naranjas de la china.

Miraré a ver qué más diferencias noto entre uno y otro, porque no es una creación mía, lo logré instalar por unas indicaciones de un forero..
Alguno anda con la Sapphire RX580 Nitro+ OC? Resulta que se queda colgado macOS Mojave y lo unico que se mueve es el cursor del raton, me pasa siempre que voy a opciones de wallpaper o tira de grafica como fotos.

Y algunos decian que iba nativa, vaya truño con la 1070Ti si no fuera por los Web drivers esto iba mucho mejor.
apriliars3 escribió:@M3GADRIV3 No hay nada 100% compatible salvo que uses hard de Apple como las wifi de iMac, el resto siempre tienes que afinar algo.

Perfecto no van ni tan siquiera los Mac no compatibles oficialmente que Apple deja sin dar soporte aunque sean compatibles no oficialmente.


Eso es lo que dicen los "gurus" de Apple. Si toda la patraña que sueltan fuese verdad no funcionarían las CPU's de intel nativas a excepción de X modelos que ellos utilizan y no es el caso, al igual que los chipsets.

La única diferéncia es su EFI propietaria, que la adaptas y poco más y quizá algun driver extra por algún hard como por ejemplo el puerto ethernet, o alguna wifi no soportada oficialmente.

En resument, el mismo OS reconoce los USB de Intel, chipsets, CPU y gráficas Intel. Qué mas necesitas? Las RX y Vega funcionan nativas.

(En tema de portátiles ya es difiere algo el asunto)

Respecto al tema de que acabarán capando al hackintosh, de momento sabiendo que todavía hay equipos sin el nuevo chip a la venta, te aseguras 6 años de soporte. Aparte, de momento ese chip es para la seguridad y poco más, por lo que es saltable, otra cosa es ya en un futuro que quieran implementar algo más o subirse a los SoCS ARM propietarios para sus equipos.

@jar-jar conseguiste hacer funcionar el equipo estable? Mojave parece que al fin es el nuevo snow leopard.
apriliars3 escribió:Alguno anda con la Sapphire RX580 Nitro+ OC? Resulta que se queda colgado macOS Mojave y lo unico que se mueve es el cursor del raton, me pasa siempre que voy a opciones de wallpaper o tira de grafica como fotos.

Y algunos decian que iba nativa, vaya truño con la 1070Ti si no fuera por los Web drivers esto iba mucho mejor.


Yo la tengo instalada desde hace 2 semanas y va perfecta, Le eh puesto hasta el heaven y sin problemas, nativa te reconoce con el HDMI, para usar el Displayport tienes que cambiar el SMBIOS a 14,2 o usar Lilu y WhateverGreen.kext

Mira a ver que algo tienes mal, yo con una 1080 ti, no iba ni la mitad de fluido que con la 580, cuando iban los web Drivers,

Yo uso Lilu y WhateverGreen.kext. (Mojave)

Edito que eh visto que la tuya es de 4GB la mia es esta de 8GB

https://www.amazon.es/Sapphire-RX-580-N ... Nitro++8gb
new30 escribió:
apriliars3 escribió:Alguno anda con la Sapphire RX580 Nitro+ OC? Resulta que se queda colgado macOS Mojave y lo unico que se mueve es el cursor del raton, me pasa siempre que voy a opciones de wallpaper o tira de grafica como fotos.

Y algunos decian que iba nativa, vaya truño con la 1070Ti si no fuera por los Web drivers esto iba mucho mejor.


Yo la tengo instalada desde hace 2 semanas y va perfecta, Le eh puesto hasta el heaven y sin problemas, nativa te reconoce con el HDMI, para usar el Displayport tienes que cambiar el SMBIOS a 14,2 o usar Lilu y WhateverGreen.kext

Mira a ver que algo tienes mal, yo con una 1080 ti, no iba ni la mitad de fluido que con la 580, cuando iban los web Drivers,

Yo uso Lilu y WhateverGreen.kext. (Mojave)

Edito que eh visto que la tuya es de 4GB la mia es esta de 8GB

https://www.amazon.es/Sapphire-RX-580-N ... Nitro++8gb


La mia es la misma de 8Gb

Imagen

Uso hdmi, va perfecta hasta que cambio es escritorio de Mojave de dinámico o cosas así. Uso MacPro6.1

Tampoco la he usado mucho ya que me tiro todo el día con Windows jugando.
Pues tiene que irte bien lo mismo algo mal configurado.
Yo uso la smbios 18,3
Intenta el uso de los kext si no los tienes instalados.
Le has puesto los hz de la pantalla correctamente?
Me imagino que si pero por si acaso

Yo al principio lo puse con hdmi y a 4k me lo limitaba a 50 hz el refresco de la pantalla y si notaba algo de retraso en el ratón.
Con displayport a 100 mhz y vuela.
new30 escribió:Pues tiene que irte bien lo mismo algo mal configurado.
Yo uso la smbios 18,3
Intenta el uso de los kext si no los tienes instalados.
Le has puesto los hz de la pantalla correctamente?
Me imagino que si pero por si acaso

Yo al principio lo puse con hdmi y a 4k me lo limitaba a 50 hz el refresco de la pantalla y si notaba algo de retraso en el ratón.
Con displayport a 100 mhz y vuela.


No soy el unico

https://www.tonymacx86.com/threads/sapp ... 459/page-3

Tu debes de tener igpu, mi Xeon no tiene. Seguiré probando con el SwapID.kext a ver si por lo menos no pasa aunque pierda rendimiento.
Si tengo igpu, aunque me acabo de dar cuenta que la tenia deshabilitada.
Y me iba bien.
En clover en la pestaña de gráficos tienes puesto algo?
Yo lo tengo todo deshabilitado hay.

Imagen
zagal escribió:@jar-jar conseguiste hacer funcionar el equipo estable? Mojave parece que al fin es el nuevo snow leopard.


Pues lo que se dice conseguir, conseguir, si, pero desde el último update de high sierra, hay dos discos que no me los monta (en windows perfecto y sin errores smart). Noto, o notaba el sistema algo perezoso a la hora de descomprimir ficheros.....

Por lo demás funcionando, pero tengo parches "on the fly" para aburrir....
new30 escribió:Si tengo igpu, aunque me acabo de dar cuenta que la tenia deshabilitada.
Y me iba bien.
En clover en la pestaña de gráficos tienes puesto algo?
Yo lo tengo todo deshabilitado hay.

Imagen


Que te dice el VideoProc???

https://www.winxdvd.com/hd-video-converter-deluxe/

Imagen

Tengo estos Kext, sin el SwapID.kext se me cuelga el programa (solo funciona el ratón) y con el Kext no va la aceleración gráfica (aunque yo lo noto igual).

Imagen
Nada, me pasa lo mismo que a ti, con la IGPU activada muy bien pero sin ella tengo los mismos problemas que tu.
Me imagino que ya sacaran algo.
es raro que yo sepa estaban soportadas por egpu estas tarjetas.

Habrá que leer más pero en el último comentario de la página 1 cambiando la bios a la pulse dicen que lo soporta.
Aunque me puedo equivocar.
https://forums.macrumors.com/threads/tu ... d.2101909/
@new30 las Sapphire RX 580 Nitro+ tienen dual bios? Investigare el tema pero parece que hay que cambiar el part number flasheando modificando en la rom original y cambiando los bytes para que pase el crc checksum. Sino a esperar a que de soporte Apple en alguna actualización a las eGPU (dicen que para Primavera?) o esperar que se pueda con algun fix parchear esto. Por lo visto yo lo tengo mas complicado, los que teneis igpu por lo menos podeis seguir tirando de Quicksync, h264 y hevc.
Buenas, he instalado una imagen de Mojave en un Thinkpad x240 con una SSD y 8 GB de RAM.

No termino de hacer funcionar los USB (aunque el usb para el raton por bluetooth me funciona) y el sonido tampoco.

Bajé los kext de tonymac de una página del x240 pero no me entero muy bien, ya que he seguido los pasos y sigo sin poder hacer nada... Alguien podría echarme un cable?

Muchas gracias!!!!
bitelmaniaco escribió:Buenas, he instalado una imagen de Mojave en un Thinkpad x240 con una SSD y 8 GB de RAM.

No termino de hacer funcionar los USB (aunque el usb para el raton por bluetooth me funciona) y el sonido tampoco.

Bajé los kext de tonymac de una página del x240 pero no me entero muy bien, ya que he seguido los pasos y sigo sin poder hacer nada... Alguien podría echarme un cable?

Muchas gracias!!!!


Prueba con esto

Mojave 10.14 USB Port Limit Patch
Mojave requires a patch to raise the USB port limit. If you want to be able to use all your USB ports and USB 3 speeds you will need this patch, Out of the USB port limit patches I’ve tested only one of them works for Mojave 10.14 Beta and here it is:

Open config.plist with Clover Configurator
Select Kernel and Kext Patches
Select the “+” at the button and input:
Name*: com.apple.driver.usb.AppleUSBXHCI
Find* [Hex]: 83FB0F0F 83030500 00
Replace* [Hex] : 83FB0F90 90909090 90
Comment: USB 10.14+ by PMHeart
MatchOS: 10.14.x
Save config.plist

Imagen

Si no te funciona pregunta a RehabMan en la guía del TP X240 porque a lo mejor lo tiene parcheado en el dsdt ya.

https://www.tonymacx86.com/threads/guid ... 40.245583/

https://www.tonymacx86.com/threads/guid ... xt.211311/
Imagen

Lo tenía ya así. El último es...

Siempre tengo que montar la EFI para hacer estas modificaciones, no?
@bitelmaniaco o ir probando con el pendrive, pero si, montar la EFI siempre.
@apriliars3 En principio con el DSDT modificado para mi equipo solucionaría los problemas que tengo?

He visto por el terminal que me da este error en los kext que he metido:

Kext with invalid signatured (-67062) allowed


El SIP lo tengo desactivado. No se me ocurre nada más.
A ver, tonymacx86, es la biblia de los hacks, de eso no hay duda.

Pero yo de vosotros, me pasaría por una web de un brasileño, que me recomendaron a mi, al pasar del 4970k al 8700k....

https://olarila.com/forum/
@Jar-Jar

Buenas! De ahí es la iso que me bajé. Es perfecta y me quedan algunos retoques por hacer. Por ejemplo:

- El teclado no me pilla la tecla de <> en su sitio, al lado de la Z, sino al lado del 1.
- El audio: sigo sin empaparme bien cómo hacer que funcione.
- Le metí el VirtualSMC.kext (creo que se llama) para que me pillara bien la batería y ahora tarda más en arrancar.
Pues mira, yo te cuento.

Siguiendo la guia de toynmacx86 y haciendo mil literalmente llamadas ñapas, arranqué una vez y no sé ni como lo hice, resultado cabreado y a la mierda todo.

Me lo recomendaron por aqui. Descargué la iso, la grabé, la metí en el pendrive.

Ordenador, arrancando, sonido, gráfica, absolutamente todo, no he probado si me funcionan todos los usb, pero tampoco me preocupa. El sistema arranca que se las pela..... encantado de la vida.

Para el sonido, lo que tienes que hacer es meter el kext del audio applehda.kext en la carpreta de los kexts.

Y por cierto, quieres un dsdt para tu equipo?? Habla con el administrador que te lo hace, tienes que mandarle lo que te crea la app olalira.
Ya tengo un dsdt desde la página de oralilla, SSDT, kexts, etc.

El caso es que hay algo que no termino de hacer bien. Por eso pregunto, aunque este hilo parece un poco muerto.

Seguiré intentando.
Yo que tengo el ordenador funcionando perfectamente, una pregunta.

dsdt?¿?¿. Esto que es?¿? el dsdt

Un saludo.
Sobre el tema de los drivers Pascal para Mojave como que aún nada, ¿no?

Estoy esperando a que salgan para hacer una instalación del sistema nuevo, que, como High Sierra me funciona todo pero la 1080 GTX no tengo aceleración y es una mierda.
bitelmaniaco escribió:Ya tengo un dsdt desde la página de oralilla, SSDT, kexts, etc.

El caso es que hay algo que no termino de hacer bien. Por eso pregunto, aunque este hilo parece un poco muerto.

Seguiré intentando.


En Oralilla hay un poco mas de movimiento, sino en insanelymac, tonymacx86,...

Hay grupo de Telegram si te interesa, aunque en el que estoy con Maldon tampoco hay mucho movimiento salvo cuando hay nuevo hack o problemas, somos cuatro gatos los que nos molestamos en instalar macOS en un pc y lo usa.

El problema de esto que como no tengas algo compatible que usa todo el mundo sueles morirte de asco porque en mi caso soy el unico con Xeon sin igpu y ni Maldon tiene remedio para la perdida de aceleracion grafica y cuelgues de Mojave a pesar de tener nativa la RX580 Nitro+ con Radeon framebuffer en vez del Orinoco framebuffer.
A ver si me podéis echar una mano.

He hecho una instalación de MacOs Sierra 10.12.6 en mi portátil. El caso es que estoy teniendo problemas con voodoops2controller.kext hay veces que funciona y otras que no. Es encender el ordenador y una lotería, porque no he sido capaz de encontrar por qué a veces funciona y otras no.

Ni que decir tiene de que lo he instalado siguiendo las instrucciones de https://github.com/RehabMan/OS-X-Voodoo ... to-Install

Hasta que no sea capaz de solucionarlo no puedo avanzar y por más que he buscado en Internet no he encontrado a nadie con problemas parecidos.
manugarrote escribió:A ver si me podéis echar una mano.

He hecho una instalación de MacOs Sierra 10.12.6 en mi portátil. El caso es que estoy teniendo problemas con voodoops2controller.kext hay veces que funciona y otras que no. Es encender el ordenador y una lotería, porque no he sido capaz de encontrar por qué a veces funciona y otras no.

Ni que decir tiene de que lo he instalado siguiendo las instrucciones de https://github.com/RehabMan/OS-X-Voodoo ... to-Install

Hasta que no sea capaz de solucionarlo no puedo avanzar y por más que he buscado en Internet no he encontrado a nadie con problemas parecidos.


En la carpeta de Extensiones debes quitar la applehda o algo asi, esa a veces crea conflicto y es por eso que a veces te va y otras no
Shiniori escribió:
manugarrote escribió:A ver si me podéis echar una mano.

He hecho una instalación de MacOs Sierra 10.12.6 en mi portátil. El caso es que estoy teniendo problemas con voodoops2controller.kext hay veces que funciona y otras que no. Es encender el ordenador y una lotería, porque no he sido capaz de encontrar por qué a veces funciona y otras no.

Ni que decir tiene de que lo he instalado siguiendo las instrucciones de https://github.com/RehabMan/OS-X-Voodoo ... to-Install

Hasta que no sea capaz de solucionarlo no puedo avanzar y por más que he buscado en Internet no he encontrado a nadie con problemas parecidos.


En la carpeta de Extensiones debes quitar la applehda o algo asi, esa a veces crea conflicto y es por eso que a veces te va y otras no

AppleHDAController o AppleHDA? Este último lo tuve que poner para tener audio de mi tarjeta Realtek.
Cunado dices la carpeta de Extensiones a qué te refieres exactamente? Porque puede ser la de Clover, /System/Library/Extensions/ o /Library/Extensions/

Gracias!!
manugarrote escribió:
Shiniori escribió:
manugarrote escribió:A ver si me podéis echar una mano.

He hecho una instalación de MacOs Sierra 10.12.6 en mi portátil. El caso es que estoy teniendo problemas con voodoops2controller.kext hay veces que funciona y otras que no. Es encender el ordenador y una lotería, porque no he sido capaz de encontrar por qué a veces funciona y otras no.

Ni que decir tiene de que lo he instalado siguiendo las instrucciones de https://github.com/RehabMan/OS-X-Voodoo ... to-Install

Hasta que no sea capaz de solucionarlo no puedo avanzar y por más que he buscado en Internet no he encontrado a nadie con problemas parecidos.


En la carpeta de Extensiones debes quitar la applehda o algo asi, esa a veces crea conflicto y es por eso que a veces te va y otras no

AppleHDAController o AppleHDA? Este último lo tuve que poner para tener audio de mi tarjeta Realtek.
Cunado dices la carpeta de Extensiones a qué te refieres exactamente? Porque puede ser la de Clover, /System/Library/Extensions/ o /Library/Extensions/

Gracias!!


La carpeta de Apple system-library-extensiones quitas el AppleHDA de ese modo, siempre te cargara el voodoohda
Shiniori escribió:La carpeta de Apple system-library-extensiones quitas el AppleHDA de ese modo, siempre te cargara el voodoohda

He borrado el AppleHDA, he probado a apagar/reiniciar varias veces y no ha habido problema, pero ha dejado de funcionar el sonido [sonrisa]

He instalado VoodooHDA, pero no va del todo fino...

En mi carpeta de Clover, tengo AppleALC y en el config.plist
<key>Audio</key>
      <dict>
         <key>Inject</key>
         <integer>3</integer>
      </dict>
Actualizado a 10.14.1 sin problema.
manugarrote escribió:
Shiniori escribió:La carpeta de Apple system-library-extensiones quitas el AppleHDA de ese modo, siempre te cargara el voodoohda

He borrado el AppleHDA, he probado a apagar/reiniciar varias veces y no ha habido problema, pero ha dejado de funcionar el sonido [sonrisa]

He instalado VoodooHDA, pero no va del todo fino...

En mi carpeta de Clover, tengo AppleALC y en el config.plist
<key>Audio</key>
      <dict>
         <key>Inject</key>
         <integer>3</integer>
      </dict>


Ostras tio tu tienes problemas con PS2 no con sonido error mio!!!! Pon el Applehda de nuevo. Lo del PS2 debes tenerlo puesto en la carpeta clover other
Shiniori escribió:Ostras tio tu tienes problemas con PS2 no con sonido error mio!!!! Pon el Applehda de nuevo. Lo del PS2 debes tenerlo puesto en la carpeta clover other

Pues te vas a reír, pero si el AppleHDA se han acabado los problemas con el teclado.

el voodoops2 pobré a hacer la instalación (borrando los kexts que podían dar problemas) y desde la Carpeta de Clover y tenía los mismos problemas.
para tener los kext actualizados aconsejo kext updater

kext updater mas info en insanelymac.com
@DJDM Ese está muy bien, que te lo deja en el escritorio...

He instalado VoodooHDA mediante un pkg que he encontrado pero sigo igual... Con un Thinkpad x240... No sé qué más hacer. El audio es lo último que me falta por configurar y no lo consigo.

Alguna mano amiga?

Gracias!!
bitelmaniaco escribió:@DJDM Ese está muy bien, que te lo deja en el escritorio...

He instalado VoodooHDA mediante un pkg que he encontrado pero sigo igual... Con un Thinkpad x240... No sé qué más hacer. El audio es lo último que me falta por configurar y no lo consigo.

Alguna mano amiga?

Gracias!!

Has probado a editar el archivo Info.plist y poner el DeviceID y el VendorID?
@manugarrote cómo puedo hacer eso? No es el config.plist, no?
bitelmaniaco escribió:@manugarrote cómo puedo hacer eso? No es el config.plist, no?

En el Readme, Common Issues: http://www.insanelymac.com/forum/topic/ ... -problems/
manugarrote escribió:
bitelmaniaco escribió:@manugarrote cómo puedo hacer eso? No es el config.plist, no?

En el Readme, Common Issues: http://www.insanelymac.com/forum/topic/ ... -problems/


Muchas gracias!! Esta tarde me pongo a ello!
bitelmaniaco escribió:Muchas gracias!! Esta tarde me pongo a ello!

Yo no he sido capaz de hacerlo funcionar. Sólo se escucha por los cascos y únicamente la música, las voces no.

En cambio, el Apple HDA, con el AppleACL y activado en la configuración del Clover va al pelo.
manugarrote escribió:
bitelmaniaco escribió:Muchas gracias!! Esta tarde me pongo a ello!

Yo no he sido capaz de hacerlo funcionar. Sólo se escucha por los cascos y únicamente la música, las voces no.

En cambio, el Apple HDA, con el AppleACL y activado en la configuración del Clover va al pelo.


Entonces me pongo mejor eso. Tienes otro tutorial para ello?
Cuando llegue a caso te lo escribo. Pero es básicamente copiar 2 kextx y modificar una cosilla del Clover.
@manugarrote

Sin prisa, estoy en la oficina y tengo el equipo en casa!

Muchas gracias!!!

EDITO: Al final lo he arreglado con el Kext Updater, sin tocar nada más me he bajado el VoodooHDA y lo he copiado en la partición del Clover. Aunque lo oigo muy bajo lo oigo.
7035 respuestas
1137, 138, 139, 140, 141