[Buscando soluciones] Conectando los mandos de SNES Mini al PC

1, 2, 3, 4
Yoshi's
EOLiano
7.800 mensajes
desde nov 2006
en Madrid
Editado 5 veces. Última: 17/10/2017 - 15:41:10 por Yoshi's.
Aunque hay un hilo oficial de SNES Mini, abro este hilo porque es un tema completamente aparte, que es el de conectar sus mandos al ordenador, para por ejemplo usarlos en un emulador de Super Nintendo.

Me he comprado el adaptador recomendado, el de MayFlash:

Imagen

Estoy totalmente desesperado porque nada más que conectar el mando completamente en reposo detecta varios botones pulsados:

Imagen

He probado con los dos mandos, y a ambos les pasa igual, y con 3 ordenadores, así que no parece que sea una cosa arbitraria.

Os invoco porque seguro que tenéis experiencia: @renzo_yugi @superfenix2020

De verdad que no me lo explico ni remotamente, porque no tiene lógica y parece que hay gente que le funciona sin más. Por si no fuera suficiente, no es mi único adaptador, también tengo uno inalámbrico:
https://www.amazon.es/Adaptador-mando-i ... 757&sr=8-2

Y el mismo resultado, tampoco funciona. Pero es que me aparecen pulsados exactamente los mismos botones.

Mil gracias a todos.

[ESTE PROBLEMA ESTÁ SOLUCIONADO - SEGUIMOS USANDO EL HILO PARA OTROS PROBLEMAS Y SUGERENCIAS]
superfenix2020
-Retro Gamer-
13.117 mensajes
desde sep 2011
Editado 1 vez. Última: 9/10/2017 - 19:58:17 por superfenix2020.
pues es muy raro, a mi me funciona bien. Igual es defectuoso el adaptador ese. Devuélvelo o cámbialo por otro.

A mi me funciona bien con Windows 10 y Windows 7 con mandos clásicos de Wii originales, y también con los de la SNES Mini.
También iba bien con los clónicos.

Si los mandos te funcionan bien en otros sitios, y has probado el adaptador en tres pcs distintos y sigue fallando, debe de ser cosa del adaptador.
Yoshi's
EOLiano
7.800 mensajes
desde nov 2006
en Madrid
Editado 8 veces. Última: 9/10/2017 - 20:10:22 por Yoshi's.
superfenix2020 escribió:Si los mandos te funcionan bien en otros sitios, y has probado el adaptador en tres pcs distintos y sigue fallando, debe de ser cosa del adaptador.


Pero es que tengo dos adaptadores Mayflash y no me funciona ninguno de ellos.

El normal:
https://www.amazon.es/gp/product/B0089O ... UTF8&psc=1

Y el inalámbrico:
https://www.amazon.es/Adaptador-mando-i ... 757&sr=8-2

En ambos me da el mismo fallo, los botones pulsados. Y a mí TODOS los mandos me van bien menos los de SNES Mini, me van bien los de NES Mini, los del SNES Club Nintendo (exceptuando L y R, cosa que es normal), los Hori Battle Pad con forma de GC, el clásico, el clásico Pro y hasta el nunchaku. Solo falla este.

A nivel mecánico lo achaco a una mayor longitud de cable que hace interpretar mal los pulsos eléctricos (ya advirtió algo Nintendo de la longitud del cable), pero conectados al Wiimote funcionan bien, ¿cómo puede ser que a los demás os funcionen bien?
superfenix2020
-Retro Gamer-
13.117 mensajes
desde sep 2011
Editado 3 veces. Última: 9/10/2017 - 22:31:57 por superfenix2020.
pues es muy raro. Acabo de volver a probar un mando de snes mini en el Wii Mayflash classic controller adapter USB PC y me funciona bien.

¿no será tu windows o algún problema de algún driver que te falte o del puerto USB que uses?

prueba a desinstalar drivers y cosas del USB y pruebalo en otro USB.

Yo uso windows 10 64bit, y sin problemas.

Que te falle un adaptador podría ser, pero dos distintos y lo mismo, eso ya no es casualidad.


edit: a mi me lo reconoce como "DUAL Box Wii" en los dispositivos de Windows.
renzo_yugi
Asesino de sueños
3.171 mensajes
desde dic 2010
en Madrid
@Yoshi's

Esta muy raro la verdad quizá algún problema de drivers como dice superfenix2020 más no se me ocurre
Yoshi's
EOLiano
7.800 mensajes
desde nov 2006
en Madrid
Editado 2 veces. Última: 10/10/2017 - 11:59:49 por Yoshi's.
El tema es que, como digo, he probado en 3 ordenadores, dos con Windows 10 de 64 bits, y uno con Windows 7 de 64 bits. En todos el mismo resultado, y sin instalar ningún driver por mi parte.

Habiendo probado con dos adaptadores, dos mandos y tres ordenadores, es matemáticamente imposible justificar el fallo de un solo elemento. Tiene que haber un fallo combinado de los dos adaptadores o los dos mandos.

Que fallen los dos adaptadores lo considero también imposible, la razón es que son dos adaptadores muy diferentes, uno inalámbrico y otro con cable, fabricados en diferentes años, por lo que ese punto queda prácticamente descartado.

La única conclusión posible es que fallan mis dos mandos de SNES Mini, la razón es que pueden haber sido fabricados de forma ligeramente diferente (o con un cable algo más largo) suficiente para funcionar con un Wiimote, pero para que no reconozca el Mayflash los niveles de voltaje correctos y me da valores imposibles.


Para poder seguir depurando el problema solo veo dos pasos:

1. @superfenix2020 si me hicieras el favor, ¿podrías probar tus mandos de SNES Club Nintendo en el adaptador de Mayflash? A mí me funcionan todos los botones, salvo el R/L, con esto nos alineamos completamente y descartamos totalmente que sean los adaptadores.

2. Si más gente del foro puede probarlo (SNES Mini y Mayflash), podemos ir viendo si a alguien más le da el mismo fallo que a mí. Si os funciona a todos, y el único que le falla es a mí, lo tengo relativamente más fácil, conseguir una SNES Mini nueva y devolver la mía a Amazon. Porfa, comentad en el hilo los que lo podáis probar, tanto si os funciona como si no.

Por otro lado, si alguien de Madrid es muy amable, podría acercarme a su zona con mi adaptador y mis mandos e ir probando combinaciones (vuestro adaptador con mi mando, mi adaptador con vuestro mando, etc.). Quedar en un bar con mi portátil, os invito a algo, y deshacer este entuerto en 10 minutos (tampoco se tarda más en hacer las pruebas).
amoremorte
MegaAdicto!!!
1.627 mensajes
desde jun 2013
en Valhalla
Puedes ser que quieras usar los "originales", pero has pensado en comprar los de aliexpress que son usb y valen menos de 3€ G.I. ?
Yoshi's
EOLiano
7.800 mensajes
desde nov 2006
en Madrid
Editado 2 veces. Última: 10/10/2017 - 13:12:36 por Yoshi's.
No exactamente, yo lo que quiero es usar mandos inalámbricos, ya que juego con un proyector a 4 metros del ordenador.

Con el MayFlash inalámbrico y los mandos de SNES Mini sería pura maravilla.

Además, me interesa un mando de calidad, no hace falta que sea oficial. Los 8bitdo no me hacen dar el salto porque tienen problemas con la batería y habría que comprarlos. Usar los de SNES Mini sería gratuito porque ya los tengo y el adaptador vale para todo tipo de mandos de Wii...
JrS-76
...
1.644 mensajes
desde ago 2002
Intenta probarlos con el driver de http://touchmote.net/, necesitaras un wiimote y bluetooth
Yoshi's
EOLiano
7.800 mensajes
desde nov 2006
en Madrid
Editado 1 vez. Última: 10/10/2017 - 14:45:10 por Yoshi's.
JrS-76 escribió:Intenta probarlos con el driver de http://touchmote.net/, necesitaras un wiimote y bluetooth


Gracias, por contestar, te comento.

Tanto con Touchmote como con la propia Wii U, mis mandos de SNES Mini van perfectamente. Mi interpretación es que el Wiimote recibe bien la señal del mando, la interpreta correctamente, y luego la pasa inalámbricamente sin mayor complicación a cualquier dispositivo, sea PC, o Wii.

Esta es justamente la razón por la que esto es tan complicado. Solo fallan cuando pongo juntos el MayFlash y el mando SNES Mini. Diría que es un mero tema de incompatibilidad (al final de al cabo es esperable, pues SNES no existía cuando Mayflash sacó el adaptador), sino fuera porque el resto de la gente del foro SÍ LE FUNCIONA, con los mismos mandos y los mismos adaptadores que yo.
1, 2, 3, 4