Ubuntu no reconoce ni teclado ni raton

Nuevas Hawkers con un 20% de dto.
Xaconi
4 8 15 16 23 42
1.657 mensajes
desde ago 2006
Buenas. Desde hace un rato que el ubuntu no me reconoce ni el teclado, ni el touchpad de mi portatil. Esto me mosquea ya que en ubuntu tengo un trabajo que en teoria tengo que entregar mañanaen la uni. He googleado y se plantean muchas soluciones, pero todas pasan por una combinacion de botones en el teclado. Lo dicho, a mi el teclado ahora mismo no me sirve de nada (mira si es grave que no me activa ni desactiva las mayusculas). Por lo tanto no puedo mirar el xconf ese. Si a alguien mas le ha pasado, o si teneis alguna idea de lo que puede ser, por favor posteadlo.
Desde ya muchas gracias.
amuchamu
MegaAdicto!!!
6.341 mensajes
desde jun 2004
¿En grub te va el teclado?
Xaconi
4 8 15 16 23 42
1.657 mensajes
desde ago 2006
Me va el teclado (perdon por no ponerlo) en el Grub, enm Windows 7 e incluso en la Live Session del Live CD de Ubuntu 9.04. Tanto teclado como raton (menos en grub claro). Acabo de probare conectar un raton USB y tampoco, ¿que puede ser?
amuchamu
MegaAdicto!!!
6.341 mensajes
desde jun 2004
Probablemente tengas algún problema con el xorg. ¿Has modificado algo recientemente? ¿Sabes si tienes activado el hotplugging? No uso ubuntu así que no sé cómo va el tema ahí, pero parece que lo tienes activado y mal configurado.

Puedes entrar en modo consola. Cuando estés en el menu de grub, pulsa la tecla 'e', te saldrá para editar la línea de arranque de tu kernel. Ahora tendrás que añadir al final de la línea el runlevel 3, que es el correspondiente a la consola (el 5 es el X11).

Es decir, cuando te sale grub eliges la línea con la que arrancas ubuntu, pulsas la tecla 'e', te saldrá algo así (es un ejemplo):
kernel /boot/vmlinux26 root=/dev/disk/by-uuid/blablabla tal vez más cosas ro

Tendrás que añadir un 3 al final, de modo que quede algo así:
kernel /boot/vmlinux26 root=/dev/disk/by-uuid/blablabla tal vez más cosas ro 3


El cambio es temporal.

Bueno, una vez que puedes modificarlo todo, habría que encontrar el problema y solucionarlo.

El xorg trae activado el hotplugging desde la versión 1.5 (para configurar al vuelo dispositivos sin que tengan escrita la configuración en el xorg.conf), en arch linux hay que instalar el paquete xf86-input-evdev (en ubuntu ni idea) o se da el problema que te pasa a ti, que te quedas sin teclado ni ratón.

Lo que puedes hacer, para ver si es eso, ahora que puedes entrar en la consola, añadir esto al xorg.conf para desactivar el hotplugging.

Section "ServerFlags"
    Option "AutoAddDevices" "False"
EndSection


Espero que te sirva de algo, suerte ;)
Chipi_vk
Adicto
136 mensajes
desde ago 2005
en Madrid, Vallecas
amuchamu escribió:.../...
Lo que puedes hacer, para ver si es eso, ahora que puedes entrar en la consola, añadir esto al xorg.conf para desactivar el hotplugging.

Section "ServerFlags"
    Option "AutoAddDevices" "False"
EndSection


Espero que te sirva de algo, suerte ;)
Muchas gracias amuchamu me ha venido al pelo :-D