Recreativa jamma con PC y placa Jamma/usb no funciona parcialmente

Buenas!!! qué tal?
Estoy terminando de poner a punto una recre original de los 80 a la cual he instalado un PC en su interior al cual he conectado una placa Jamma->USB. El PC lo tengo con Batocera.

Inicio el sistema y todo parece ir bien, de hecho, me reconoce dos mandos conectados "0H 3H Dual Arcade" y "1H 3H Dual Arcade" o algo similar a esto. Pero a la hora de iniciar un juego de MAME/NEO GEO (son los únicos sistemas que tengo), no inicia, vuelve al menú. En cuanto desconecto el USB de la placa Jamma->USB, los juegos inician sin problema.

No sé, no acabo de entender donde está el problema [triston] , opté por esta placa por aprovecha el cableado original que sé que funcionaba perfectamente, pero ya estoy planteándome poner una placa "arcade USB zero" que ya utilicé para una minirecre que hice y que no me ha dado ningún problema...

Esta es la placa Jamma->USB que tengo:
Imagen


Y esta la placa que pondré si no consigo solucionar el asunto:
Imagen




Gracias de antemano!!! [risita]
Debe ser cosa de Linux, a mi esa placa me funciona perfectamente con mame lanzándolo desde hyperspin en Win10.
Buenas,

en mi caso desconozco el motivo, pero por la vivencia con un mando X-Arcade, tambien podría estarse dando un conflicto de controles, ya que la mayoría de estas placas Jamma > USB interpretan el stick y controles como si fuesen un teclado,

https://wiki-batocera-org.translate.goo ... _tr_pto=sc

Imagino que aunque sólo por probar, podrías tratar de modificar un poco el apartado de controles en Batocera, en una primera búsqueda no he visto casi nada concreto. Ánimo.

https://forum-batocera-org.translate.go ... _tr_pto=sc
Unreal McCoy escribió:Buenas,

en mi caso desconozco el motivo, pero por la vivencia con un mando X-Arcade, tambien podría estarse dando un conflicto de controles, ya que la mayoría de estas placas Jamma > USB interpretan el stick y controles como si fuesen un teclado,

https://wiki-batocera-org.translate.goo ... _tr_pto=sc

Imagino que aunque sólo por probar, podrías tratar de modificar un poco el apartado de controles en Batocera, en una primera búsqueda no he visto casi nada concreto. Ánimo.

https://forum-batocera-org.translate.go ... _tr_pto=sc


Podría ser que entra conflicto con el teclado que tengo conectado siempre? [boing] Interesante, tengo que probar a iniciar sin el teclado...



shutupandsmile escribió:Debe ser cosa de Linux, a mi esa placa me funciona perfectamente con mame lanzándolo desde hyperspin en Win10.


Si no lo soluciono con las pistas que me dio el otro compañero, probaré conectando a un portátil con win10 a ver si descarto que la placa funcione perfectamente.



Muchas gracias a los dos!! [angelito]
Seguiré informado!
Mhitman escribió:
Podría ser que entra conflicto con el teclado que tengo conectado siempre? [boing] Interesante, tengo que probar a iniciar sin el teclado...
Muchas gracias a los dos!! [angelito]
Seguiré informado!


Esa era la idea principal pero por torpeza no lo precisé :p según recuerdo, desde hace muchos años y empleando diferentes sistemas (J-Pac,placa Jamma/USB, adaptador VGA-Scart, ect) muchas personas utilizan un teclado adjunto, a modo de apoyo. Ojalá puedas solucionarlo de la manera más sencilla. Suerte.
Perdón por la tardanza, pero le voy dedicando tiempo a la recre cuando puedo. Finalmente tras comerme la cabeza era una cuestión del cableado, el cual he revisado y encontré que en un punto tenía hecho un puente (no sé con que finalidad). El caso es que ya lo tengo funcionando "perfectamente". [risita]

Las comillas se deben a que ya puedo entrar en los juegos, jugar tanto con el jugador 1 como con el 2... todo funciona, menos un "detalle". Si en el player 1 pulso uno de los botones (el 2 si no me equivoco) se reinicia el juego, sale la notificación de batocera con el aviso "Reiniciando" y el juego se resetea.

Dónde se cambia esto? :-?

Gracias!!
5 respuestas