[HO][Plugin] PSVita Streaming USB [versión 1.3]

1, 2, 3
Este plugin utiliza el servicio UDCD (USB Device Controller Driver) del sistema operativo de la PSVita para transmitir el contenido de la pantalla simulando un dispositivo UVC (USB Video Class) como lo sería por ejemplo una Webcam o una capturadora de vídeo.

Cambios desde la versión v1.2:
  • Solucionado el soporte de aplicaciones del sistema gracias a u3shit
Cambios desde la versión v1.1:
  • Solucionado el soporte de 480x272
Cambios desde la versión v1.0:
  • Añadidos modos de vídeo 896x504 y 480x272
  • Añadido soporte para 30FPS
  • Añadida compatibilidad con el modo USB de VitaShell (a partir de su versión 1.95), aunque si activas el USB deberás reiniciar la Vita para que este plugin vuelva a funcionar
Si el video se ve mal, prueba de cambiar la configuración del reproductor para usar el formato de vídeo NV12 o usa otro reproductor (como PotPlayer u OBS). Si usas Windows 10 tal vez tengas que permitir el acceso de aplicaciones a la cámara en los ajustes de privacidad. En Linux recomiendo usar mpv (mpv tv:// --tv-device=/dev/videoX --tv-width=960 --tv-height=544) o mplayer (mplayer tv:// -tv driver=v4l2:device=/dev/videoX:width=960:height=544).

Lista de modos de vídeo soportados:
  • 960x544 @ 30 FPS y (menos de) 60 FPS
  • 896x504 @ 30 FPS y (casi) 60 FPS
  • 864x488 @ 30 FPS y 60 FPS
  • 480x272 @ 30 FPS y 60 FPS
Descarga:
Instalación:
  1. Copia udcd_uvc.skprx a la PSVita
  2. Añade udcd_uvc.skprx al config.txt de taiHEN (ur0:/tai/config.txt o ux0:/tai/config.txt):
    *KERNEL
    ur0:tai/udcd_uvc.skprx
  3. Reinicia la PSVita.
Solucionar ruido en el audio:
  • Desactiva la carga USB (Ajustes > Sistema)
Código fuente:

Nota: Recuerda que si cualquier cosa va mal (como por ejemplo que la PSVita no se inicia), siempre puedes pulsar L al arrancar para que no carguen los plugins.

Nota 2: No, no envía audio. Para eso usa un adaptador de mini-jack de 3.5mm.
Gracias!! :)


Sugiero, sin saber la dificultad que lleva, para los que no solemos instalar nada en el pc, de crear alguna app que se complemente con el plugin para capturar el video, así como el viejo remotejoy lite de psp.

[bye] [bye]
jotax escribió:Gracias!! :)


Sugiero, sin saber la dificultad que lleva, para los que no solemos instalar nada en el pc, de crear alguna app que se complemente con el plugin para capturar el video, así como el viejo remotejoy lite de psp.

[bye] [bye]


Precisamente la gracia de usar un estándar USB como lo es el USB Device Class es que cualquier aplicación que permita ver la Webcam (la misma que viene instalada con el Windows) también funcionará con la PSVita, aunque recomiendo la aplicación PotPlayer ya que permite configurar cosas como por ejemplo el buffering para disminuir el lag.
Llevaba tiempo pensando que porque no estaba este plugin posteado en eol. De lo mejor que he probado en ps vita. Muchas gracias @xerpi y fuerza para los próximos avances.
¿Se sabe si el error que lanza la transferencia vitashell usando este plugin está arreglado? Y otra cosa, ¿no seria posible como se hacia con vita2pc, de mediante el tittleid asignarle que juego queremos que haga streaming? Esto ultimo sulocionaria lo primero creo (Yo lo intente en la v5 y me crasheo la consola)

P.D. Invito a que lo usesis con el plugin de los mandos de xerpi o el minivitatv the flow, es una delicia.
vale, ya he conseguido cargar el plugin(v6) y verlo en el pc... no llegaba a saber si lo escribía mal en el config o que mi portátil no cumplía algún requisito de vídeo etc.

El caso es que no tenía instaladas algunas herramientas relacionadas con el windows... ni un software de webcam ni nada, taba pelado.

Ahora. He conseguido pasar el video con el recomendado potplayer(x64), pero me va a unos 44/45 frames, ¿es normal? pensaba que iba a 60, creí haber leído por ahí.

Debo tocar algo en la configuración del potplayer?


Edito:
Por cierto, existe algun tipo de conflicto al querer conectar la vita via usb con vitashell con el plugin activado.
¿será cosa de añadir un combo que lo deshabilite?
un tutorial de esto sería genial.
@xerpi
Hola, muchas gracias por el plugin, voy a probarlo ahora.

He visto que en redit está en la 1.1, creo que en bitbucket.org deberías poner la versión por la que vas para poder tener siempre la versión actualizada y no tener que buscarla.

Un saludo!
Nueva versión de vitashell que arregla el error que había al conectar este via usb con el plugin activado
He actualizado el post con la versión 1.1.
Bien :D
Gracias!

...y un UP

[bye]
xerpi escribió:Nota: Recuerda que si cualquier cosa va mal (como por ejemplo que la PSVita no se inicia), siempre puedes pulsar L al arrancar para que no carguen los plugins.



Que es justo lo que me ha pasado a mi y no me ha tocado otra que formatear la consola por que no había manera de salir del bucle ahora estoy en 3.68...
Hola qué tal. Soy bastante novato en esto. Mi portátil no me reconoce la PS Vita como dispositivo de captura de vídeo o webcam. Estoy en 3.68 con Vita fat y todos los plugins actualizados. He seguido todos los pasos pero no me la reconoce. Esta tarde voy a probar deshabilitando la webcam del portátil por si hubiera algún conflicto porque no se me ocurre qué puede ser.
J2MRaiden escribió:Hola qué tal. Soy bastante novato en esto. Mi portátil no me reconoce la PS Vita como dispositivo de captura de vídeo o webcam. Estoy en 3.68 con Vita fat y todos los plugins actualizados. He seguido todos los pasos pero no me la reconoce. Esta tarde voy a probar deshabilitando la webcam del portátil por si hubiera algún conflicto porque no se me ocurre qué puede ser.

En Windows 10 debes activarlo en ajustes de privacidad.
alguna manera de conectarlo a una raspi? ...es la mejor manera de transmitirlo a la tele


saludos
hellionz escribió:alguna manera de conectarlo a una raspi? ...es la mejor manera de transmitirlo a la tele


saludos


En Linux recomiendo mplayer: mplayer tv:// -tv driver=v4l2:device=/dev/videoX:width=960:height=544
xerpi escribió:
J2MRaiden escribió:Hola qué tal. Soy bastante novato en esto. Mi portátil no me reconoce la PS Vita como dispositivo de captura de vídeo o webcam. Estoy en 3.68 con Vita fat y todos los plugins actualizados. He seguido todos los pasos pero no me la reconoce. Esta tarde voy a probar deshabilitando la webcam del portátil por si hubiera algún conflicto porque no se me ocurre qué puede ser.

En Windows 10 debes activarlo en ajustes de privacidad.


Hola xerpi gracias por tu trabajazo! Aún no me reconoce la PSVita el ordenador portátil, sí en cambio el PC. En el portátil he comprobado que está activada la cámara en los ajustes de privacidad, he probado deshabilitando la webcam integrada y en OBS no me aparece ningún dispositivo de captura de imagen, ni tampoco en el administrador de dispositivos de Windows. En la Vita está instalado el plugin y antes de conectarla al portátil por USB activo el h-encore.

EDITO: Ya lo solucioné, tardó en reconocer un poco más de la cuenta pero sólo tenía que esperar como 5 minutos y lo reconoció perfectamente. El ansia. [+risas]

Enorme trabajazo @xerpi . Muchas gracias!
ChesaOne escribió:P.D. Invito a que lo usesis con el plugin de los mandos de xerpi o el minivitatv the flow, es una delicia.

No entiendo cómo vendría siendo esto para este plugin?! Soy muy tonto o sólo estoy perdido... Tú dices para jugar multijugador local o para controlarlo con un control desde el pc? :-?
¿Algo que podría hacer para mejorar el audio? He visto gente en Youtube a los que se les oye estupendo.

Así se me oye a mí: https://www.twitch.tv/videos/306156089

Y este es el cable que estoy usando:

Imagen


Edit: se me olvidó decir, la alimentacion por USB esta desactivada en las opciones de sistema de la Vita
Edit2: solucionado. Desde mi portátil, abrí el panel de control de realtek y le especifiqué que el dispositivo insertado era un micrófono analógico, a continuación en OBS, en las propiedades del dispositivo de captura de video (PS Vita) me fui abajo del todo, en Utilizar dispositivo de audio personalizado - Micrófono.

Ahora se oye genial! Os pondré un vídeo si quereis!
Muchas gracias Xerpi, este plugin es una pasada. Jugar Muramasa se volvió subitamente mas comodo con un dualshock 4 y una pantalla. Quizas como unica cosa que le falta es que apagase la pantalla cuando estuviese haciendo streaming.

Por lo demas perfecto, pareciera que estoy jugando con VSYNC aunque yo si estoy usando bluetooth para el audio.
bueno, he tenido un hueco para experimentar la experiencia del plugin junto a un DS3 y la verdad es que comodísimo, espero que pronto podamos disfrutar de esos 960x544 @ 60 FPS [angelito]
Me uno a los que te agradecen. Esto es increíble, muchas gracias! La pongo en el pc de mi habitación (20 pulgadas), audio por unos parlantes exteriores, usando ds4, y jugando Fifa 18. [beer]

PD: Hay una forma de que vaya fluido el stick análogo en juegos de psp (Adrenaline)? Es que muevo el personaje y como que se bloquea (se para), no sé si se entiende bien... Ej: En Silent Hill cuando vas corriendo se para el personaje luego de un 1 segundo aprox, como si se cortara la señal del control o algo así. Pls...
SerperiorOU escribió:Me uno a los que te agradecen. Esto es increíble, muchas gracias! La pongo en el pc de mi habitación (20 pulgadas), audio por unos parlantes exteriores, usando ds4, y jugando Fifa 18. [beer]

PD: Hay una forma de que vaya fluido el stick análogo en juegos de psp (Adrenaline)? Es que muevo el personaje y como que se bloquea (se para), no sé si se entiende bien... Ej: En Silent Hill cuando vas corriendo se para el personaje luego de un 1 segundo aprox, como si se cortara la señal del control o algo así. Pls...


Prueba con esta versión: https://www.reddit.com/r/vitahacks/comm ... it-android
xerpi escribió:Prueba con esta versión: https://www.reddit.com/r/vitahacks/comm ... it-android

Recién lo estoy probando y, me llevo la sorpresa de que al menos con DS4 el que vendría siendo R1 en Vita ahora pasó a ser R2. Ej: en Fifa que se corre con R en Vita, si usas DS4 corres con R2. Estoy confundido, creo. Gracias de todas formas!
@xerpi que excelente trabajo realizaste con este plugin, el nuevo modo que agregaste y aun no lo has hecho publico con estos cambios funciona de maravilla, ademas con un parche que hay en reddit para apagar la pantalla en las oled esto le da un plus increíble.
_Slash_ escribió:@xerpi que excelente trabajo realizaste con este plugin, el nuevo modo que agregaste y aun no lo has hecho publico con estos cambios funciona de maravilla, ademas con un parche que hay en reddit para apagar la pantalla en las oled esto le da un plus increíble.

pues ole!! ya sabemos que viene una actualización :D .... esperanding... :p :p
_Slash_ escribió:@xerpi que excelente trabajo realizaste con este plugin, el nuevo modo que agregaste y aun no lo has hecho publico con estos cambios funciona de maravilla, ademas con un parche que hay en reddit para apagar la pantalla en las oled esto le da un plus increíble.


Serías tan amable de dirigirme a la pagina donde esta apagar la pantalla oled y el nuevo modo del plugin?
@Arceles no guarde la pagina donde vi el parche, pero te lo dejo aquí en el post.

diff --git a/Makefile b/Makefile
index b9296bb..989e6f8 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@ OBJS   = main.o
LIBS   = -lSceSysmemForDriver_stub -lSceThreadmgrForDriver_stub \
   -lSceCpuForDriver_stub -lSceUdcdForDriver_stub \
   -lSceDisplayForDriver_stub -lSceIftuForDriver_stub \
-   -ltaihenForKernel_stub
+   -ltaihenForKernel_stub -lSceOledForDriver_stub

DEBUG ?= 0
ifeq ($(DEBUG), 1)
diff --git a/main.c b/main.c
index b757a4a..2a84276 100644
--- a/main.c
+++ b/main.c
@@ -74,6 +74,10 @@ static SceUID uvc_frame_buffer_uid;
static struct uvc_frame *uvc_frame_buffer_addr;
SceUID uvc_frame_req_evflag;

+int ksceOledGetBrightness();
+int ksceOledSetBrightness(unsigned int brightness);
+static unsigned int initial_brightness = 1;
+
static int usb_ep0_req_send(const void *data, unsigned int size)
{
   static SceUdcdDeviceRequest req;
@@ -382,6 +386,9 @@ static int uvc_udcd_attach(int usb_version, void *user_data)
{
   LOG("uvc_udcd_attach %d\n", usb_version);

+   initial_brightness = ksceOledGetBrightness();
+   ksceOledSetBrightness(0);
+
   ksceUdcdClearFIFO(&endpoints[2]);

   return 0;
@@ -391,6 +398,8 @@ static void uvc_udcd_detach(void *user_data)
{
   LOG("uvc_udcd_detach\n");

+   ksceOledSetBrightness(initial_brightness);
+
   uvc_handle_video_abort();
}

Saludos.
Hola a mi todos los juegos me van pero hay aplicaciones como grupos, PSN... que no me van. es normal. gracias
pregunta... sería posible que el audio también fuese por el usb para simplificar todo ?

@_Slash_ podrías compartir la versión compilada con el parche ese para apagar la pantalla ?
Se puede hacer captura de pantalla o solo de video?
jmal escribió:Se puede hacer captura de pantalla o solo de video?

Si te refieres a grabar como si fuese una capturadora, con OBS (es gratuito) puedes hacerlo.
SerperiorOU escribió:
jmal escribió:Se puede hacer captura de pantalla o solo de video?

Si te refieres a grabar como si fuese una capturadora, con OBS (es gratuito) puedes hacerlo.

Recomiendo PotPlayer si no quieres hacer streaming (solo ver la PSVita) y OBS para streamear.
holas, yo no doy con esta resolución 864x488 , orientadme porfis [ayay]

Imagen

uso el potplayer
@jotax por lo que veo @xerpi nada mas actualizo la información del post pero no dejo el enlace del plugin que incluyen esas resoluciones.
_Slash_ escribió:@jotax por lo que veo @xerpi nada mas actualizo la información del post pero no dejo el enlace del plugin que incluyen esas resoluciones.

El enlace es el mismo, siempre lo actualizo sobre el mismo link.
xerpi escribió:
_Slash_ escribió:@jotax por lo que veo @xerpi nada mas actualizo la información del post pero no dejo el enlace del plugin que incluyen esas resoluciones.

El enlace es el mismo, siempre lo actualizo sobre el mismo link.

y cual será el motivo por el que no me sale esa resolución? la version del que tengo instalado es la 1.1
jotax escribió:
xerpi escribió:
_Slash_ escribió:@jotax por lo que veo @xerpi nada mas actualizo la información del post pero no dejo el enlace del plugin que incluyen esas resoluciones.

El enlace es el mismo, siempre lo actualizo sobre el mismo link.

y cual será el motivo por el que no me sale esa resolución? la version del que tengo instalado es la 1.1


Copia y pega la salida del programa USBView para ver con mas detalla que pasa.
@jotax Esta información no es suficiente, necesito un dump de los descriptores USB, como este.
@jotax Hmm el formato es un poco raro y falta algo de información. ¿Estás usando este: https://docs.microsoft.com/en-us/window ... er/usbview USBVIew?
xerpi escribió:@jotax Hmm el formato es un poco raro y falta algo de información. ¿Estás usando este: https://docs.microsoft.com/en-us/window ... er/usbview USBVIew?

es que no he encontrado la opcion de dumpear los descriptores que dices en el usbView y he googleado para dar con un programa que haga eso.

Voy a revisar de nuevo el UsbView

No doy con el quid con el usbView xerpi

No soy un experto en estas cosas, solo sigo instrucciónes.
EDito
USBDeview es lo que estoy usando, ni me he fijado, perocedo a usar el que dices :/


ya :)

Device Descriptor:
bcdUSB: 0x0200
bDeviceClass: 0xEF
bDeviceSubClass: 0x02
bDeviceProtocol: 0x01
bMaxPacketSize0: 0x40 (64)
idVendor: 0x054C (Sony Corporation)
idProduct: 0x1337
bcdDevice: 0x0100
iManufacturer: 0x01
0x0409: "SONY"
iProduct: 0x02
0x0409: "PSVita"
iSerialNumber: 0x03
0x0409: "Vita UVC"
bNumConfigurations: 0x01

ConnectionStatus: DeviceConnected
Current Config Value: 0x01
Device Bus Speed: High
Device Address: 0x02
Open Pipes: 2

Endpoint Descriptor:
bEndpointAddress: 0x81 IN
Transfer Type: Interrupt
wMaxPacketSize: 0x0040 (64)
bInterval: 0x01

Endpoint Descriptor:
bEndpointAddress: 0x83 IN
Transfer Type: Bulk
wMaxPacketSize: 0x0200 (512)
bInterval: 0x00

Configuration Descriptor:
wTotalLength: 0x00E9
bNumInterfaces: 0x02
bConfigurationValue: 0x01
iConfiguration: 0x00
bmAttributes: 0x80 (Bus Powered )
MaxPower: 0xFA (500 Ma)

Unknown Descriptor:
bDescriptorType: 0x0B
bLength: 0x08
08 0B 00 02 0E 03 00 00

Interface Descriptor:
bInterfaceNumber: 0x00
bAlternateSetting: 0x00
bNumEndpoints: 0x01
bInterfaceClass: 0x0E
bInterfaceSubClass: 0x01
bInterfaceProtocol: 0x00
iInterface: 0x00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x0D
0D 24 01 10 01 1E 00 00 6C DC 02 01 01

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x08
08 24 02 01 00 02 00 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x09
09 24 03 02 01 01 00 01 00

Endpoint Descriptor:
bEndpointAddress: 0x81 IN
Transfer Type: Interrupt
wMaxPacketSize: 0x0040 (64)
bInterval: 0x01

Unknown Descriptor:
bDescriptorType: 0x25
bLength: 0x05
05 25 03 40 00

Interface Descriptor:
bInterfaceNumber: 0x01
bAlternateSetting: 0x00
bNumEndpoints: 0x01
bInterfaceClass: 0x0E
bInterfaceSubClass: 0x02
bInterfaceProtocol: 0x00
iInterface: 0x00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x0E
0E 24 01 01 95 00 83 00 02 00 00 00 01 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x1B
1B 24 04 01 03 4E 56 31 32 00 00 10 00 80 00 00
AA 00 38 9B 71 0C 01 00 00 00 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x22
22 24 05 01 00 C0 03 20 02 00 C0 34 0B 00 80 69
16 00 F4 0B 00 0A 8B 02 00 02 0A 8B 02 00 15 16
05 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x22
22 24 05 02 00 80 03 F8 01 00 A0 B0 09 00 40 61
13 00 56 0A 00 0A 8B 02 00 02 0A 8B 02 00 15 16
05 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x22
22 24 05 03 00 E0 01 10 01 00 30 CD 02 00 60 9A
05 00 FD 02 00 0A 8B 02 00 02 0A 8B 02 00 15 16
05 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x06
06 24 0D 00 00 00

Endpoint Descriptor:
bEndpointAddress: 0x83 IN
Transfer Type: Bulk
wMaxPacketSize: 0x0200 (512)
bInterval: 0x00
jotax escribió:
xerpi escribió:@jotax Hmm el formato es un poco raro y falta algo de información. ¿Estás usando este: https://docs.microsoft.com/en-us/window ... er/usbview USBVIew?

es que no he encontrado la opcion de dumpear los descriptores que dices en el usbView y he googleado para dar con un programa que haga eso.

Voy a revisar de nuevo el UsbView

No doy con el quid con el usbView xerpi

No soy un experto en estas cosas, solo sigo instrucciónes.
EDito
USBDeview es lo que estoy usando, ni me he fijado, perocedo a usar el que dices :/


ya :)

Device Descriptor:
bcdUSB: 0x0200
bDeviceClass: 0xEF
bDeviceSubClass: 0x02
bDeviceProtocol: 0x01
bMaxPacketSize0: 0x40 (64)
idVendor: 0x054C (Sony Corporation)
idProduct: 0x1337
bcdDevice: 0x0100
iManufacturer: 0x01
0x0409: "SONY"
iProduct: 0x02
0x0409: "PSVita"
iSerialNumber: 0x03
0x0409: "Vita UVC"
bNumConfigurations: 0x01

ConnectionStatus: DeviceConnected
Current Config Value: 0x01
Device Bus Speed: High
Device Address: 0x02
Open Pipes: 2

Endpoint Descriptor:
bEndpointAddress: 0x81 IN
Transfer Type: Interrupt
wMaxPacketSize: 0x0040 (64)
bInterval: 0x01

Endpoint Descriptor:
bEndpointAddress: 0x83 IN
Transfer Type: Bulk
wMaxPacketSize: 0x0200 (512)
bInterval: 0x00

Configuration Descriptor:
wTotalLength: 0x00E9
bNumInterfaces: 0x02
bConfigurationValue: 0x01
iConfiguration: 0x00
bmAttributes: 0x80 (Bus Powered )
MaxPower: 0xFA (500 Ma)

Unknown Descriptor:
bDescriptorType: 0x0B
bLength: 0x08
08 0B 00 02 0E 03 00 00

Interface Descriptor:
bInterfaceNumber: 0x00
bAlternateSetting: 0x00
bNumEndpoints: 0x01
bInterfaceClass: 0x0E
bInterfaceSubClass: 0x01
bInterfaceProtocol: 0x00
iInterface: 0x00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x0D
0D 24 01 10 01 1E 00 00 6C DC 02 01 01

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x08
08 24 02 01 00 02 00 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x09
09 24 03 02 01 01 00 01 00

Endpoint Descriptor:
bEndpointAddress: 0x81 IN
Transfer Type: Interrupt
wMaxPacketSize: 0x0040 (64)
bInterval: 0x01

Unknown Descriptor:
bDescriptorType: 0x25
bLength: 0x05
05 25 03 40 00

Interface Descriptor:
bInterfaceNumber: 0x01
bAlternateSetting: 0x00
bNumEndpoints: 0x01
bInterfaceClass: 0x0E
bInterfaceSubClass: 0x02
bInterfaceProtocol: 0x00
iInterface: 0x00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x0E
0E 24 01 01 95 00 83 00 02 00 00 00 01 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x1B
1B 24 04 01 03 4E 56 31 32 00 00 10 00 80 00 00
AA 00 38 9B 71 0C 01 00 00 00 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x22
22 24 05 01 00 C0 03 20 02 00 C0 34 0B 00 80 69
16 00 F4 0B 00 0A 8B 02 00 02 0A 8B 02 00 15 16
05 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x22
22 24 05 02 00 80 03 F8 01 00 A0 B0 09 00 40 61
13 00 56 0A 00 0A 8B 02 00 02 0A 8B 02 00 15 16
05 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x22
22 24 05 03 00 E0 01 10 01 00 30 CD 02 00 60 9A
05 00 FD 02 00 0A 8B 02 00 02 0A 8B 02 00 15 16
05 00

Unknown Descriptor:
bDescriptorType: 0x24
bLength: 0x06
06 24 0D 00 00 00

Endpoint Descriptor:
bEndpointAddress: 0x83 IN
Transfer Type: Bulk
wMaxPacketSize: 0x0200 (512)
bInterval: 0x00


Me sirve. Fíjate que debajo del todo solo hay 3 "Unknown Descriptor" con bLength igual 0x22. Estos descriptores dicen los modos de vídeo soportados y debería haber 4, por lo que estás usando una versión antigua del plugin. Vuelve a descargarla desde el mismo enlace.
xerpi escribió:
Me sirve. Fíjate que debajo del todo solo hay 3 "Unknown Descriptor" con bLength igual 0x22. Estos descriptores dicen los modos de vídeo soportados y debería haber 4, por lo que estás usando una versión antigua del plugin. Vuelve a descargarla desde el mismo enlace.

vaya, pues lo lamento, no estoy acostumbrado a dar la vara, quizás estoy haciendo algo mal pero... :(
Acabo de descargar ahora mismo y he reemplazado el plugin que era el mismo, mismo tamaño y tal y no me aparece dicha resolución 864x488

Imagen
jotax escribió:
xerpi escribió:
Me sirve. Fíjate que debajo del todo solo hay 3 "Unknown Descriptor" con bLength igual 0x22. Estos descriptores dicen los modos de vídeo soportados y debería haber 4, por lo que estás usando una versión antigua del plugin. Vuelve a descargarla desde el mismo enlace.

vaya, pues lo lamento, no estoy acostumbrado a dar la vara, quizás estoy haciendo algo mal pero... :(
Acabo de descargar ahora mismo y he reemplazado el plugin que era el mismo, mismo tamaño y tal y no me aparece dicha resolución 864x488

Imagen


A mi tampoco me aparece, justo acabo de bajarlo tambien e infortunadamente nada :( (por lo demas excelente plugin... es una gozada)
Arceles escribió:
jotax escribió:
xerpi escribió:
Me sirve. Fíjate que debajo del todo solo hay 3 "Unknown Descriptor" con bLength igual 0x22. Estos descriptores dicen los modos de vídeo soportados y debería haber 4, por lo que estás usando una versión antigua del plugin. Vuelve a descargarla desde el mismo enlace.

vaya, pues lo lamento, no estoy acostumbrado a dar la vara, quizás estoy haciendo algo mal pero... :(
Acabo de descargar ahora mismo y he reemplazado el plugin que era el mismo, mismo tamaño y tal y no me aparece dicha resolución 864x488

Imagen


A mi tampoco me aparece, justo acabo de bajarlo tambien e infortunadamente nada :( (por lo demas excelente plugin... es una gozada)

gracias por reportarlo, ya me siento algo mejor, estuve revisando de nuevo y nada.

Y si, es una genialidad este plugin.
Aunque no me queda claro si es compatible con la carga USB mientras se usa.
Saludos.
jotax escribió:
Arceles escribió:
jotax escribió:vaya, pues lo lamento, no estoy acostumbrado a dar la vara, quizás estoy haciendo algo mal pero... :(
Acabo de descargar ahora mismo y he reemplazado el plugin que era el mismo, mismo tamaño y tal y no me aparece dicha resolución 864x488

Imagen


A mi tampoco me aparece, justo acabo de bajarlo tambien e infortunadamente nada :( (por lo demas excelente plugin... es una gozada)

gracias por reportarlo, ya me siento algo mejor, estuve revisando de nuevo y nada.

Y si, es una genialidad este plugin.
Aunque no me queda claro si es compatible con la carga USB mientras se usa.
Saludos.


Tenéis razón, creo que al final no lo subí. Lo he vuelto a subir para asegurarme, descargadlo de nuevo.
xerpi escribió:
Tenéis razón, creo que al final no lo subí. Lo he vuelto a subir para asegurarme, descargadlo de nuevo.

ole!!, pues esta noche lo pruebo seguro [beer]

gracias!!
136 respuestas
1, 2, 3