GBARunner2 y Pokémon Esmeralda

Hola buenas. Ayer instalé el TwilightMenu++ en una DSi que tengo desde pequeño. Quería usar el GBARunner y vi lo del .bin, lo solucioné y todo eso y lograba abrir los juegos de GBA, pero al intentar abrir el Pokémon Esmeralda me salía la intro de GBA y después una pantalla blanca. Revisé la Wiki de GBARunner 2 (https://wiki.gbatemp.net/wiki/GBARunner2) y vi que Rubí y Zafiro se podían jugar, el Esmeralda no, por lo que busqué y encontré un hilo de GitHub que hablaba de panchear con la opción SRAM la ROM, lo cual hice sin resultado alguno. Además dice que necesito parchearlo para poder guardar la partida, pero no tengo ni idea de a qué parche se refiere. Si alguien sabe qué es, por favor que me deje la respuesta sobre el parche para guardar y de si se puede o no jugar esos juegos. Un saludo!
El esmeralda no funciona, se queda en pantalla blanca después del logo.
El rubí y zafiro si funcionan (no al 100%) pero hay que ponerles el parche sram con el programa gbata para que pueda guardar.
javitsu95 escribió:El esmeralda no funciona, se queda en pantalla blanca después del logo.
El rubí y zafiro si funcionan (no al 100%) pero hay que ponerles el parche sram con el programa gbata para que pueda guardar.

Como dije, el Zafiro/Rubí ya los parcheé con el programa. Al abrirlo con el GBARunner del propio menú, se queda en negro, pero si lo abro desde el Runner de la raíz si funciona. El problema es que NO deja guardar y en la lista de compatibilidad dice que sí.
raygum98 escribió:
javitsu95 escribió:El esmeralda no funciona, se queda en pantalla blanca después del logo.
El rubí y zafiro si funcionan (no al 100%) pero hay que ponerles el parche sram con el programa gbata para que pueda guardar.

Como dije, el Zafiro/Rubí ya los parcheé con el programa. Al abrirlo con el GBARunner del propio menú, se queda en negro, pero si lo abro desde el Runner de la raíz si funciona. El problema es que NO deja guardar y en la lista de compatibilidad dice que sí.

Tienes razón, lo he probado y tampoco funciona, pues debe ser algún bug o algo, a saber, gbarunner2 aún está muy verde... Yo no me fiaría mucho de la lista [+risas]
javitsu95 escribió:
raygum98 escribió:
javitsu95 escribió:El esmeralda no funciona, se queda en pantalla blanca después del logo.
El rubí y zafiro si funcionan (no al 100%) pero hay que ponerles el parche sram con el programa gbata para que pueda guardar.

Como dije, el Zafiro/Rubí ya los parcheé con el programa. Al abrirlo con el GBARunner del propio menú, se queda en negro, pero si lo abro desde el Runner de la raíz si funciona. El problema es que NO deja guardar y en la lista de compatibilidad dice que sí.

Tienes razón, lo he probado y tampoco funciona, pues debe ser algún bug o algo, a saber, gbarunner2 aún está muy verde... Yo no me fiaría mucho de la lista [+risas]

Estoy en el hilo oficial del creador del GBARunner y un usuario me ha hablado de usar la versión arm7, pero no entiendo de qué habla si ya dije que soy usuario de SD y no de R4. De todas formas solo toca esperar.
raygum98 escribió:
javitsu95 escribió:
raygum98 escribió:Como dije, el Zafiro/Rubí ya los parcheé con el programa. Al abrirlo con el GBARunner del propio menú, se queda en negro, pero si lo abro desde el Runner de la raíz si funciona. El problema es que NO deja guardar y en la lista de compatibilidad dice que sí.

Tienes razón, lo he probado y tampoco funciona, pues debe ser algún bug o algo, a saber, gbarunner2 aún está muy verde... Yo no me fiaría mucho de la lista [+risas]

Estoy en el hilo oficial del creador del GBARunner y un usuario me ha hablado de usar la versión arm7, pero no entiendo de qué habla si ya dije que soy usuario de SD y no de R4. De todas formas solo toca esperar.

La versión arm7 es la que usa GBArunner en twilight por defecto en SD, no sé por qué te ha dicho eso [+risas]
Dsi usa dos tipos de build que son la arm 7 y la arm9, son como dos motores que lleva y la 7 es la única (creo) que funciona en DSi por twilight.
Aquí lo puedes encontrar link
javitsu95 escribió:
raygum98 escribió:
javitsu95 escribió:Tienes razón, lo he probado y tampoco funciona, pues debe ser algún bug o algo, a saber, gbarunner2 aún está muy verde... Yo no me fiaría mucho de la lista [+risas]

Estoy en el hilo oficial del creador del GBARunner y un usuario me ha hablado de usar la versión arm7, pero no entiendo de qué habla si ya dije que soy usuario de SD y no de R4. De todas formas solo toca esperar.

La versión arm7 es la que usa GBArunner en twilight por defecto en SD, no sé por qué te ha dicho eso [+risas]
Dsi usa dos tipos de build que son la arm 7 y la arm9, son como dos motores que lleva y la 7 es la única (creo) que funciona en DSi por twilight.
Aquí lo puedes encontrar link

Por eso lo digo, se están comiendo la cabeza con tonterías cuando el propio problema es del programa.
@raygum98 Hola, perdón por el reflote pero por si no lo sabías, ya funciona Pokémon Esmeralda en la última versión (ahora se carga en la arm9 y no en la 7 que era la que no funcionaba).
Lo he probado y ahora sí inicia y guarda perfectamente [risita]
javitsu95 escribió:@raygum98 Hola, perdón por el reflote pero por si no lo sabías, ya funciona Pokémon Esmeralda en la última versión (ahora se carga en la arm9 y no en la 7 que era la que no funcionaba).
Lo he probado y ahora sí inicia y guarda perfectamente [risita]

Gracias por avisar. El arm9 se cargaba metiendo los archivos con tal nombre en la SD, verdad? Un saludo
raygum98 escribió:
javitsu95 escribió:@raygum98 Hola, perdón por el reflote pero por si no lo sabías, ya funciona Pokémon Esmeralda en la última versión (ahora se carga en la arm9 y no en la 7 que era la que no funcionaba).
Lo he probado y ahora sí inicia y guarda perfectamente [risita]

Gracias por avisar. El arm9 se cargaba metiendo los archivos con tal nombre en la SD, verdad? Un saludo

Creo que Twilight ya lo lleva incluido, yo al menos no tuve que descargar nada más solo el rar de la última versión. En los ajustes de Twilight verás las opciones activadas de arm9 y otras cosas.
9 respuestas