[Buscar post oficial de rodries] MPlayer CE v.0.6

1, 2, 3, 4, 514
Genial

Gracias por la noticia [oki]

Voy probarlo cualquier cosa lo comento.

Nos vemos [sonrisa]
Gracias por el aviso!!!
me baje la version del link de tehskeen pero supongo que es lo mismo, me funciono perfectamente y ahora si se lee el titulo completo de los archivos, saludos y gracias por la noticia
Entoncees, ¿este carga divx desde dvd? :o ya vi que habia un par de posts sobre eso, pero solo llegué a probar el primero, pero sin final feliz (ya no tengo la wii tan a mano ù.ú).

Si este carga divx, lo pruebo rápido ^^ Un saludoo!
Una pregunta este puede cargar cosas desde el USB como el Geexbox.

Un saludo y gracias por todo.

P.D.: Cual creéis que es mejor este o el Geexbox
The_Spike escribió:Entoncees, ¿este carga divx desde dvd? :o ya vi que habia un par de posts sobre eso, pero solo llegué a probar el primero, pero sin final feliz (ya no tengo la wii tan a mano ù.ú).

Si este carga divx, lo pruebo rápido ^^ Un saludoo!

Ese problema se resolvio hace mucho :D
Sigue el tutorial y lo instalaras en un momento. Esta version tiene unos arreglillos, la queria poner en el tutorial, pero primero queria probarla bien.
Pero vamos, para leer DVD de divx que es para lo que más se usa, funciona sin problema desde la primera que salio (pero la compilacion de Rodries tenia el famoso problema de los puntos blancos :))
lordchileno escribió:y también reproducción DVD-Vídeo

Eso quiere deci q podemos ver cualqueir peli en dvd? me refiero a dvds normales, esq probe con un backup de una peli en dvd con esta version q nos puso comepiedras y no fui capaz de q tirara... me refiero a la de este hilo: hilo_tutorial-como-ver-dvd-divx-en-tu-wii-con-sin-chip_1131157
_XavP_ escribió:
lordchileno escribió:y también reproducción DVD-Vídeo

Eso quiere deci q podemos ver cualqueir peli en dvd? me refiero a dvds normales, esq probe con un backup de una peli en dvd con esta version q nos puso comepiedras y no fui capaz de q tirara... me refiero a la de este hilo: hilo_tutorial-como-ver-dvd-divx-en-tu-wii-con-sin-chip_1131157

Ya está actualizado ese hilo, asi que lo puedes bajar de ahi, de la wiki, o de aqui mismo.
Un DVD-Video es un DVD de los que se compran en la tienda, con su menu, varios audios, subtitulos, todo eso. Si tu copia es de un DVD de ese tipo (es decir, con su menu, blablabla), entonces con la versión anterior no se podia, se puede con esta.
La version anterior lo que leia son DVD de datos, es decir, te grabas 5 o 6 peliculas en un DVD, o 10 capitulos de una serie, o musica, o lo que sea...
De cualquier manera, prueba esta versión y si no te va sigue otra vez los pasos del tutorial porque a lo mejor instalaste algo mal.
Muchisimas gracias comepiedras, con esto ya si q me doy totalmnete por satisfecho, pera mi tengo reproductor multimedia para todo ya en la wii jejejj

Esta tarde lo pruebo, aunq ahora no tengo niinguna peli en dvd a mano, tendre q esperar al finde, pero confio e q funcione.
Hay algun reproductor ya que cargue desde usb??
Saludos!!!
ganchix escribió:Hay algun reproductor ya que cargue desde usb??
Saludos!!!

Este mismo carga desde USB, pero no sirve cualquier disco duro y tiene que estar formateado a FAT.
Si quieres usar siemrpe por disco duro, lo mejor es el Geexbox, que, además, lee subtitulos externos, cosa que este aun no hace, este es el hilo oficial hilo_geexbox-reproductor-multimedia-dvd-usb-wiimote-bluetooth_1046657
La descarga está en la wiki de aplicaciones.
comepiedras escribió:
ganchix escribió:Hay algun reproductor ya que cargue desde usb??
Saludos!!!

Este mismo carga desde USB, pero no sirve cualquier disco duro y tiene que estar formateado a FAT.
Si quieres usar siemrpe por disco duro, lo mejor es el Geexbox, que, además, lee subtitulos externos, cosa que este aun no hace, este es el hilo oficial hilo_geexbox-reproductor-multimedia-dvd-usb-wiimote-bluetooth_1046657
La descarga está en la wiki de aplicaciones.

Ummm interesante gracias comepiedras, y si tengo dos particiones en el disco duro valdrá también no??
Un saludo
hay que tener algun cIOS instalado para que funcione en un 100% este reproductor????...

edito: perdon... es una pregunta
no sabía eso....lo estas afirmando o preguntando? :)
shin-gori escribió:hay que tener algun cIOS instalado para que funcione en un 100% este reproductor????...

edito: perdon... es una pregunta

Ni idea. Mira los ultimos cambios (de ahora mismo) del tutorial hilo_tutorial-como-ver-dvd-divx-en-tu-wii-con-sin-chip_1131157 y veras que he añadido una parte para saber si un dispositivo formateado a FAT funciona o no. Si no lo tienes formateado a FAT no lo pruebes, pues te puede corromper datos.
Si tienes dos particiones, una es FAT y la otra no... usa el Tester bajo tu responsabilidad o, mejor, simplemente prueba el disco con este Mplayer y nos comentas.
Si pruebas el tester y te funciona postealo en el tutorial por favor, pues aun nadie lo ha probado :)
shin-gori escribió:hay que tener algun cIOS instalado para que funcione en un 100% este reproductor????...

edito: perdon... es una pregunta

No, no es necesario.
Sigue mi tutorial y verás, según tu caso, que es lo que necesitas y que no.
gracias... vere en que puedo aportar en el tutorial tambien...
Cuatro cosas:
El icono de la aplicación no se me ve en el hc9, y a vosotros?
El archivo mplayerwii.conf no tenía q ir en la carpeta apps?
No me lee los dvd-video, ni originales ni "backups". Puede acceder a las carpetas audio_ts y video_ts, incluso abrir un archivo vob durante un segundo (code dump).
Supongo q se sabe ya, pero no lee dvd-rw
visjoner escribió:Cuatro cosas:
El icono de la aplicación no se me ve en el hc9, y a vosotros?
El archivo mplayerwii.conf no tenía q ir en la carpeta apps?
No me lee los dvd-video, ni originales ni "backups". Puede acceder a las carpetas audio_ts y video_ts, incluso abrir un archivo vob durante un segundo (code dump).
Supongo q se sabe ya, pero no lee dvd-rw


Tampoco me aparecía el icono, lo he cambiado por otro que tenia aquí yo y ya se ve.
Os lo dejo aquí por si os gusta: Imagen

Si el mplayerwii.config debe de ponerse en el raíz de la SD (al menos siempre ha sido así).

Rectifico:
Samba continua siendo como antes, hay que especificar al ruta de cada uno de los archivos, no se puede navegar.
Si que funciona samba, con navegador, dios que gustazo. Me ha funcionado con el formato ni usuario ni password y terminado en /, por si alguien tiene algún problema como yo lo tuve.
Gracias Rodries es un cambio que estaba esperando mucho, había probado de entra un directorio y a un archivo, al no funcionar el directorio (por el error), había deducido que seguiría como siempre.

... vamos por el camino de tener un media center muy completo.
lordchileno escribió:rodries ha lanzado una versión actualizada de su versión no oficial del port Mplayer,

Se supone que es mas o menos oficial ya que los últimos cambios ya están en http://code.google.com/p/mplayerwii/ de hecho la mejora del smb es la r19 que la he subido yo mismo, lo que pasa es que yo le pongo 7.4 para no liarme con mis experimentos.
Es decir es una compilación de la r19 del mplayer que está en google code.
Para el que le interese se puede subir el buffer del smb de 6144 a 7300 en el archivo smb_devoptab.c para ganar un poco mas de velocidad en samba, pero no mucha.

De todas formas ya estaba anunciado por comepiedras anteriormente.

Esos son ls cambios respeto a la 0.7 original:
- added dvd access from devoptab (from tipolosko) + read ahead cache (speed up
dvd) (from rodries)
- added mplayer cache to network (better streaming)
- added power off from wiimote button and from menu
- added HBC/channel detection and fixed channel exit crash
- clear content when a device is not found
- added samba file browsing
- Improved samba speed
- Increased network Mplayer cache (8M)

PD: Por cierto, con los cambios que he hecho ya si que se puede navegar usando samba
en el mplayerwii.conf añade una linea del tipo:
stream = smb://username:password@192.168.0.63/pelis/
asegurate de que acaba en /
#narfss
Samba continua siendo como antes, hay que especificar al ruta de cada uno de los archivos, no se puede navegar.


Pues decirte que sí se puede navegar por carpetas Samba, únicamente has de indicar una carpeta en vez de un archivo concreto, ej: (acabando en "/")

stream = smb://user:password@192.168.69.131/almacen/musica/
stream = smb://user:password@192.168.69.131/almacen/peliculas/

Acabo de probarlo, viéndome un capítulo de una serie completo y ahora tengo una pelicula en pruebas, y por ahora no se cuelga, eso sí, por USB ethernet (que sí le cuesta inicializar correctamente, hay que tenerlo desenchufado al arrancar HBC, y enchufarlo una vez este cargado mplayerwii, antes de elegir una carpeta Samba por ejemplo).

En cuanto al rendimiento, me da escasos parones (cabecera de la serie), cuando el bitrate parece superar la capacidad de del puerto USB, que siendo 1.0 es pobre, si este mejorara, seria cuasiperfecto para mí. El inicio de la reproducción es rápido y también parece que aguanta muy bien la sincronización de la voz y el vídeo.

Al salir con "Home" = Stop de una película/canción, a veces, tarda en volver y cuando lo hace, ya no muestra correctamente las carpetas, mostrándolas vacías. ¿Es esa tecla no, para detener una reproducción?

El problema de la inicialización usb ethernet ya existía antes y se lo comuniqué a rodries, que dijo no poder solucionar por no disponer de uno de estos adaptadores.

En fin, toca esperar a unas pocas más mejoras, y quizás el soporte soñado usb 2.0 hi-speed ...

edito: hola rodries, has posteado entretando, bueno, ya lees mis primeras impresionas, muy buenas, por cierto. :)
Gracias Rodries y Pecoso, he rectificado mi post para no sembrar confusión, es cierto funciona y muy bien ^^ salvo que mi punto de acceso wifi es algo viejo, y yo soy el menos indicado para decir que pasado un rato un vídeo se ha detenido (tal vez se me solucione con el posterior cambio en smb_devoptab.c, pero por ahora espero)
Más datos del problema de las carpetas vacías, que podría deberse a rutas demasiado largas y un posible desbordamiento del string que almacena la ruta, bueno relato lo acontecido:

Mi novia me vió navegar por las carpetas y me dijo: déjame a mi, que quiero escuchar una canción; total, que la pongo con el mando, eso sí, le digo, espérate a que termine la canción para cambiar, así lo hace, pero después de 5 o 6 canciones la Wii se bloqueó, arrojando este error:

Exception (DSI) occurred!

GPR00
GPR01
GPR02
...
GPR07

CODE DUMP:

...


Bueno, aquí sigo en el test ... ahora probando lo mismo por Wifi, a ver si da el mismo problema, luego pongo los resultados.

Más resultados: (no hay nada conectado ni a los usbs ni a los puertos de gamecube)

Por Wifi falló antes, a la tercera canción no saltó la excepción pero sí se trabó el audio, volvió para atrás pero ya no reproduce nada y las carpetas las muestra vacías ... luego quise volver al menú inicial para apagar la consola y ahora ya sí se me saltó el error de la excepción.

salu2!
narfss escribió:
visjoner escribió:Cuatro cosas:
El icono de la aplicación no se me ve en el hc9, y a vosotros?
El archivo mplayerwii.conf no tenía q ir en la carpeta apps?
No me lee los dvd-video, ni originales ni "backups". Puede acceder a las carpetas audio_ts y video_ts, incluso abrir un archivo vob durante un segundo (code dump).
Supongo q se sabe ya, pero no lee dvd-rw


Tampoco me aparecía el icono, lo he cambiado por otro que tenia aquí yo y ya se ve.
Os lo dejo aquí por si os gusta: Imagen

Si el mplayerwii.config debe de ponerse en el raíz de la SD (al menos siempre ha sido así).

Rectifico:
Samba continua siendo como antes, hay que especificar al ruta de cada uno de los archivos, no se puede navegar.
Si que funciona samba, con navegador, dios que gustazo. Me ha funcionado con el formato ni usuario ni password y terminado en /, por si alguien tiene algún problema como yo lo tuve.
Gracias Rodries es un cambio que estaba esperando mucho, había probado de entra un directorio y a un archivo, al no funcionar el directorio (por el error), había deducido que seguiría como siempre.

... vamos por el camino de tener un media center muy completo.



Corregido [poraki] usé tu icono, esta mucho mejor que el mio [beer]
Veo k no se ha corregido la carga de pelis de DVD [mamaaaaa] [buuuaaaa] [buuuaaaa] ,pues a los 10 segundo:code dump;
Video: .AVI
Resolucion:480*280
DVD: Verbatim -R
pinopop escribió:Veo k no se ha corregido la carga de pelis de DVD [mamaaaaa] [buuuaaaa] [buuuaaaa] ,pues a los 10 segundo:code dump;
Video: .AVI
Resolucion:480*280
DVD: Verbatim -R

Los DVD con peliculas funcionan perfectamente. Si por alguna razón no te funciona, será un problema de compatibilidad de la pelicula con el Mplayer. Ten en cuenta que estas versiones no son actualizaciones del Mplayer, sino modificaciones para mejorar algunas cosas, pero no se esta trabajando con la compatibilidad.
De todos modos, me extraña que tengas ese fallo, te recomendaria borrar todo y seguir mi tutorial paso por paso a ver si asi te funciona.

Ah! Otra cosa, si metes la pelicula en la SD se ve bien?
Lo acabo de probar y muy bien, sobre todo porque ahora ya me reconoce los nombres completos de los videos divx, lo ire usando para ver las cosillas a ver si tira sin problemas.
auu!!! que bien haber si ya no laes las estrellitas dichosas?? [360º] XD
Acabo de arreglar unos problemas con samba
Esta version es solo compilada por mi ya que me genera una depencia en un cambio que hay que hacer en libtinysmb, y hasta que no lo suban nadie podría compilarlo, por lo que todavía no lo he subido a google code.
Estos cambios optimizan un poquitin samba y se supone que arregla ciertos codedump de samba y la navegación por directorios que ha comentado Pecoso.
En cuanto deis el visto bueno subo el código y explico lo que hay que hacer en libtinysmb para compilarlo.
http://www.mediafire.com/?wohk10woyny
rodries escribió:Acabo de arreglar unos problemas con samba
Esta version es solo compilada por mi ya que me genera una depencia en un cambio que hay que hacer en libtinysmb, y hasta que no lo suban nadie podría compilarlo, por lo que todavía no lo he subido a google code.
Estos cambios optimizan un poquitin samba y se supone que arregla ciertos codedump de samba y la navegación por directorios que ha comentado Pecoso.
En cuanto deis el visto bueno subo el código y explico lo que hay que hacer en libtinysmb para compilarlo.
http://www.mediafire.com/?wohk10woyny


Madiquita ¿Para esto era todo aquel asunto que tenias con "la cosa nostra"?
con tipolosko XD
Po zi XD

Pero realmente me estoy dedicando a los devoptab, para que otros homebrew se puedan aprovechar.
Ahora estoy terminando el de samba, aunque me esperaré a publicarlo hasta que marcan añada la función samba que me hace falta que he dejado entuwii.
Este programa es un banco de pruebas muy bueno, mucha gente lo usa y le saca los fallos, luego veo los code dump y veo donde tengo los problemas :p
Por cierto, sabes si ya está arreglado el fallo de multihilo?
es que quiero hacer unos experimientos con caches en segundo plano y no quiero volverme loco por culpa de fallos que no hay quien dios encuentre ( excepto tu claro XD )
Como bien dices, son fallos que me los como yo (asi estoy de loco ya XD) y ni está resuelto, ni tiene visos de que se resuelva pronto XD

Afecta a los calculos con numeros flotantes, obviamente, pero si subes la prioridad del hilo en ejecucion de forma que no le interrumpa nadie hasta que el resultado esté bien guardado, no pasará nada. Ademas, dentro de que falle, no es un fallo continuo: depende de como se sincronice la cosa [+risas]. Antes era una cosa que se producia casi siempre, pero con el arreglo que hicieron, la cosa es mucho mas esquiva (sollo que no se como me las apaño que me toca los cojones cada dos por tres XD)

Ya sabes, si al final, todo es cosa de los jodios enanitos [+risas]
Yo tengo problemas con el MPlayer(todas las versiones que he probado),he seguido el tutorial para ver Divx en la Wii e instalado todo lo que pedia,cuando carga el Divx a los 10 segundos de reproduccion me da error DSI Exception Core Dump¿alguien sabe a que es debido?
Un saludo.
Psmaniaco escribió:Yo tengo problemas con el MPlayer(todas las versiones que he probado),he seguido el tutorial para ver Divx en la Wii e instalado todo lo que pedia,cuando carga el Divx a los 10 segundos de reproduccion me da error DSI Exception Core Dump¿alguien sabe a que es debido?
Un saludo.

Usa este último que he subido y dime los valores del code dump o sacale una foto donde se puedan leer.
Bien, rodries, testeando la nueva versión samba_fix:
#############################################################

1- vídeo testeado por SD, perfecto durante media hora, me cansé y lo paré.

2- mismo vídeo, por wifi + samba, parones continuos, a los 5 minutos lo paré.

3- mismo vídeo, por usb-ethernet + samba, sin parones practicamente, pero a los 15 minutos, sorpresa: la wii se congeló!!!

Imagen

Ahora, está mi novia escuchando música por usb-ethernet + samba, de momento bien, llevará como 6 canciones, por lo menos el problema de las rutas vacías parece haber desaparecido.

postdata: ¿no habría forma se solucionar el fallo de inicialización del usb-ethernet? es que funciona todo mucho mejor pero es un engorro arrancarlo: primero enchufado para que el HBC lo inicialice bien, luego desenchufarlo para arrancar mplayerwii y ya por fin enchufarlo otra vez...

:D
Hola rodries,
Estoy colaborando como probador para el hilo de utilidades de wii (Dol + Meta + Icono), y me encuentro con el problema que no puedo ver un DVD-VIDEO. Me lista el contenido pero al ejecutar un .vob me devuelve un error (code dump). Te lo adjunto para ver si puedes averiguar de que se trata. (tengo el dvdx puesto, no si será de ayuda).
Gracias de antemano.
Sabeis de que puede ser que el mplayer no me reconozca nada en el patch del lector de dvd y en el momento que le doy al boton A me sale el famoso exception dsi con la tabla de numeros y caracteres?? he probado varias versiones y en todas pasa igual, en cambio desde sd perfecto los mismos videos,saludos y gracias.
Espero que implementen el soporte para subtítulos pronto, sería a mi gusto de lo más completito
Canal MPlayerWii 0.7.4 build 2 (samba-fix):

Descarga: http://rapidshare.com/files/168428869/mplayer074b2.wad :cool: !

ID: MPWI

Recuerda instalarlo con el WAD Manager de Wanin.

Saludoz [hallow] !
wichoxp escribió:Canal MPlayerWii 0.7.4 build 2 (samba-fix):

Descarga: http://rapidshare.com/files/168428869/mplayer074b2.wad :cool: !

ID: MPWI

Recuerda instalarlo con el WAD Manager de Wanin.

Saludoz [hallow] !


Gracias por el canal, y por ponerlo en letra bien grande para que destaque entre tanto post "normal" :)
Gracias x el wad con el samba-fix,una cosa al instalarlo desde el wadmanager 1.3 me da error para concretar este (ret = -1029),tendre algo mal preparado para la instalacion del mplayer? saludos y gracias.
pabl1t0 escribió:Gracias x el wad con el samba-fix,una cosa al instalarlo desde el wadmanager 1.3 me da error para concretar este (ret = -1029),tendre algo mal preparado para la instalacion del mplayer? saludos y gracias.

El error que te muestra (ret = -1029) no corresponde al archivo wad.
Trata de instalarlo nuevamente o utiliza una SD bien formateada.
PD: también prueba instalarlo con otra versión del wad manager (1.0 por ejemplo).

Saludoz [360º] !
pabl1t0 escribió:Gracias x el wad con el samba-fix,una cosa al instalarlo desde el wadmanager 1.3 me da error para concretar este (ret = -1029),tendre algo mal preparado para la instalacion del mplayer? saludos y gracias.

¿Cual es tu version de Wii?
Gracias por contestar voy a formatear de nuevo la tarjeta y a buscar la version 1.0 del wad manager para probar a ver que pasa,la wii la tengo en 3.3e sin actualizacion tienda ni nada con el cios 36v7 de wanin,gracias y saludos.
¿Cual carga mejor mp4 desde USB, esta versión o el Geebox?
Esta carga de PM me encanta pero y todas esas web que hay dentro?? :-? bueno va mas rapido que lo noto yo [ayay] [amor]
He subido la ultima versión a code google (r20)
- Implemeta NTLM (gracias a Tantric)
- Mejorada la velocidad samba

Al implementar NTLM debe de arreglar los problemas de la gente que no le iba el samba en Vista o con Linux.
La velocidad maxima que he llegado a alcanzar son 660kb/s pero el wifi es inestable.

Versión compilada
http://www.mediafire.com/?qdxzxwgt0io
rodries escribió:He subido la ultima versión a code google (r20)
- Implemeta NTLM (gracias a Tantric)
- Mejorada la velocidad samba

Al implementar NTLM debe de arreglar los problemas de la gente que no le iba el samba en Vista o con Linux.
La velocidad maxima que he llegado a alcanzar son 660kb/s pero el wifi es inestable.

Versión compilada
http://www.mediafire.com/?qdxzxwgt0io


Gracias rodries!!! actualizaré el post
Excelente reproductor!!! .... Si no es mucha molestia, y para un futuro cercano... jeje, se podra implementar la lectura de discos USB formateados a NTFS?
Y respecto al samba (y es que no lo conozco, sorry)... hay que instalar algo en la PC para que funcione el streaming? :(
697 respuestas
1, 2, 3, 4, 514