AYUDA configracion 2 pistolas Aimtrak

1, 2
RonyxD
Novato
9 mensajes
desde nov 2017
Bueno, os comento mi problema, compre ya hace tiempo 2 aimtrak, y no llegar a configurarlas bien. Y despues de mucho tiempo me he puesto de nuevo a ello. Las configuro con el programa de aimtrak de ultimarc siguiendo la guia al dedillo, una como device 1 y otra como device 2. Hasta ahi perfecto, configuro el Mame como viene tambien en la guia de ultimarc, y tambien perfecto, tanto el player 1 como el player 2. Todo correcto.

El problema llega ya con model 2, model 3, los juegos nativos de PC House of dead 1, 2 y 3, emulador dolphin, etc. Tengo instalados troubleshooter como demulshooter, pero en todos esos emuladores y juegos ambas pistolas son el player 1, (va perfecto pero solo el player 1), mueven la misma mirilla y tal, no consigo que cada una sea para cada player. Mi sistema es windows 10, el silent hill arcade lo he intentado tambien pero al parecer el juego con es compatible con windows 10 y no me llega a arrancar, se queda en la pantalla gris donde pone coins 0 etc.

Bueno a ver si algun alma caritativa me ayuda a conseguir al fin poder usar ambas pistolas y poder disfrutar de estas aimtrak a dos player, he probado varias cosas que he ido leyendo por internet pero nada aun, gracias de antemano.
RonyxD
Novato
9 mensajes
desde nov 2017
Alguien que entienda que pueda echarme una mano please
M1ch3l
Habitual
35 mensajes
desde nov 2017
en Nintendo
Editado 7 veces. Última: 6/12/2017 - 12:40:00 por M1ch3l.
@RonyXD Me encantaria ayudarte pero es que yo tengo una pistola aimtrack funcionando pero solo tengo una.
Eso si, la tengo funcionando en todos los juegos ya sea model 2,3 taito typex , naomi pero tengo win 7 de S.O.

Lo que tengo problema y quizas tu me puedas dar algo de luz es en el recoil. Le compre una fuente de 36v y 3A que era la que recomendaban al principio; el tema es que me funciona bien pero cuando juego a un juego como el House of the dead 2 que hay que disparar continuamente no por ejemplo como time crisis que tiene sus pausas cuando te agachas o va corriendo la historia la pistola deja de hacer el recoil como si se "recalentara" o algo asi, me estuve informando por internet y puede ser que la fuente no aguente el estar disparando tan continuo. Visto eso me compre otra fuente esta vez de 36v y 5A y feliz de mi pensando que ya con esa me iria perfecta, el tema es que me pasa igual.
Tambien al paso de 1 minuto o asi , el recoil vuelve a funcionar pero eso digo lo de "recalentarse"
¿Que fuente tienes tu y si a ti no te pasa como a mi? Es que lei de gente que tiene de hasta 10A pero no voy a andar a comprar tantas fuente por lo menos mientras no este seguro, tampoco es que sean caras pero bueno.

Un saludo.

PD: En cuanto a tu pregunta ahora me he acordado que influye mucho el andar desenchufandolas por que creo que te cambia las ID, quizas tu problema tambien este por ahi, prueba a no desenchufarlas nunca y a ponerlas directamente en 2 puertos USB no lo hagas a traves de un concentrador USB

Otra cosa,¿ sabes que aparte de configurar la ID de cada pistola en el programa de aimtrack de ultimarc, tienes que hacerlo tambien en demulshooter, verdad? asignarle al player 1 y al player 2 en la pestaña de seleccion una de las pistolas a cada jugador.
Tambien en el emu de model 2 tienes que activar esta opcion en el .INI

UseRawinput=1

Te dejo un enlace a un chico que tenia problemas como tu y para model acabo reparando el error volviendo a poner una version nueva del emulador model 2.

https://forums.launchbox-app.com/topic/40267-2-aimtrak-lightguns-on-sega-model-2/

Y aqui tienes un pequeño tutorial:

https://gameroomsolutions.com/setup-dua ... 1-2-3mame/
RonyxD
Novato
9 mensajes
desde nov 2017
Consegui hacerlas funcionar perfectamente en model2, al fin jeje.

Ahora model3, consigo que el emulador me detecte ambas pistolas, cada una como player 1 y 2 respectivamente asi:

; Light guns (Lost World)
InputGunLeft = "NONE"
InputGunRight = "NONE"
InputGunUp = "NONE"
InputGunDown = "NONE"
InputGunX = "MOUSE2_XAXIS"
InputGunY = "MOUSE2_YAXIS"
InputTrigger = "MOUSE2_LEFT_BUTTON"
InputOffscreen = "MOUSE2_RIGHT_BUTTON"
InputAutoTrigger = 1
InputGunLeft2 = "NONE"
InputGunRight2 = "NONE"
InputGunUp2 = "NONE"
InputGunDown2 = "NONE"
InputGunX2 = "MOUSE3_XAXIS"
InputGunY2 = "MOUSE3_YAXIS"
InputTrigger2 = "MOUSE3_LEFT_BUTTON"
InputOffscreen2 = "MOUSE3_RIGHT_BUTTON"
InputAutoTrigger2 = 1

y en la ruta del juego asi para cargarlo: C:\Supermodel\Supermodel.exe lostwsga.zip -res=800,600 -input-system=rawinput

Hasta ahi bien, pero luego dentro del emulador entro al service mode con la tecla 6, y donde se calibran las armas, no puedo calibrarlas bien, solo las muevo en el cuadrante de arriba a la izquierda, es bastate raro, ambas pistolas disparan dentro del juego como player 1 y 2, y recargan bien etc. pero solo puedo disparar en un cuarto de pantalla :S

P.D: gracias, no las he desenchufado nunca siempre estan conectadas, y miro siempre que la id este bien en el programa de aimtrak. lo de demulshooter si lo tengo bien configurado. en todos los emus la primera pistola me va perfecta, incluyendo dolphin, pscx2, etc. el problema viene con la segunda arma.

P.D2: del recoil no puedo ayudarte lo siento, las compre sin el recoil porque no me va mucho jeje. nose ni como funciona.
M1ch3l
Habitual
35 mensajes
desde nov 2017
en Nintendo
Me alegro que lo consiguieses, tomo nota por si me pillo una segunda pistola.

Lo del recoil mola mucho que haga el placa placa cada vez que disparas, yo he visto gente que
consiguio la pistola original del time crisis y le meten la electronica dentro de la aimtrack y
el recoil hace que la pistola cada vez que dispares se mueva la parte de arriba igual que en la recreativa.
RonyxD
Novato
9 mensajes
desde nov 2017
Editado 1 vez. Última: 8/12/2017 - 18:20:22 por RonyxD.
Las cogí sin el retroceso en alguna sitios que acaba estropeándose pronto del uso. Tengo también dos EMS Top Gun III inalámbricas Que utilizo para la play Station dos y llevan retroceso. Pero sinceramente me acaba cansando cuando juegas bastante rato.

Siento no poder ayudarte con este tema, yo tampoco soy muy bueno con esto. Todo a base de tutoriales y En foros jeje
alex2005
MegaAdicto!!!
788 mensajes
desde jul 2012
en Murcia
Editado 1 vez. Última: 8/12/2017 - 18:34:48 por alex2005.
Me subo al carro, que seguramente en un futuro pille una segunda aimtrak.

Podrias si es posible comentar como lo has solucionado para model 2 y3?
por otro lado, hace unos dias instale windows 10 y no consegui hacer funcionar el model 2, siempre le ocurre un error al cargar una rom y solo puedo cerrarlo. Estaba usando la creators fall update, pero no hay manera, y me he vuelto temporalmente a windows 7.
has pasado por esto?

gracias!
RonyxD
Novato
9 mensajes
desde nov 2017
Editado 2 veces. Última: 11/12/2017 - 20:48:02 por RonyxD.
A mi me va perfecto el Model2 en windows 10. Merece la pena tener 2 para jugar a dobles jeje

En Model 2 pude jugar con ambas pistolas poniendo esto asi en la config:

UseRawInput=1 ;Read mouse through Rawinput, allowing 2 mice
RawDevP1=1 ;Assign specific RawInput devices to players. If you have more than 2 mice
RawDevP2=2 ;set which one is assigned to each player (0-based)

Activando el demulshooter, y calibrando las armas con el service mode.

En model 3 sigo teniendo problemas, pensaba que lo habia hecho pero aun estoy en ello.
RonyxD
Novato
9 mensajes
desde nov 2017
Bueno, vuelven los problemas, he formateado el pc para meterle windows 7, y poder jugar al silent hill arcade. He instalado de nuevo el software de aimtrak y configurado ambas pistolas como device 1 y device 2, como estaban vamos. Abro igual que antes el demul shooter activandolo antes en el simbolo de sistema: demulshooter.exe -target=model2 -rom=vcop2 -noresize, se, etc. y configuro el ini de EMULATOR como estaba:

[Input]
XInput=0 ;Enable support for Xbox360 compatible devices
EnableFF=0 ;Enable Force Feedback Effects
HoldGears=0 ;Set to 1 to return to Neutral in driving games when the gear shift key is released
UseRawInput=1 ;Read mouse through Rawinput, allowing 2 mice
RawDevP1=1 ;Assign specific RawInput devices to players. If you have more than 2 mice
RawDevP2=2 ;set which one is assigned to each player (0-based)

Pero al entrar a jugar al virtua cop 2 por ejemplo, solo se mueve y puedo calibrar la mirilla azul del jugador 2, la del jugador 1 ni se mueve ni hace nada el gatillo al disparar. La azul del player 2 todo perfecto, la del jugador 1 solo funciona perfectamente, la roja si pongo el UseRawInput en 1, pero claro entonces ya no funciona la del jugador 2, alguna ayudita? porque no entiendo nada jaja.

En el Supermodel, haciendo todo y configurando todo exactamente como estaba tambien antes, cuando ejecuto el lost world, la calibracion no puedo hacerla bien, los punteros no llegan a cubrir toda la pantalla, es como si estuvieran mal las coordenadas o algo, ahora ni poniendo la misma resolucion en el escritorio y el juego

Antes estaba en Windows 10 x64, ahora en windows 7 x64
coleguita
MegaAdicto!!!
502 mensajes
desde sep 2010
Yo tengo una pero cuál es el mejor emu para la pistola me refiero a títulos es decir que emulador le saca más provecho en mame no hay mucha cosa ... gracias?
1, 2