Actualizar BIOS con BDI

Tengo una Xbox con chip Aladdin la cual arranca directamente al dashboard UnleashX. Recientemente le he puesto un HDD mayor (500GB) pero solo me reconoce 123 o algo asi.

He intentado usar el XBPartioner 1.3, pero me salta este warning:
\2


La bios que tiene esta Xbox es la siguiente:
photo_2021-02-19_18-10-35.jpg


Usando BDI, que bios me recomendarias @hal9000 ?

Gracias de antemano
Que versión de xbox tienes?, desde el BDI se puede saber. En principio llevas una bios m8+16
En principio yo probaría con flashbios desde hdd y con la bios

3.2 Evox M8Plus16 Mod F sin animación, sin sonido

o esta otra

3.4 Evox M8Plus16 F
@hal9000 Gracias por responder tan rápido.
Es una v1.0.

No quiero cagarla otra vez como hice aqui, elegí la versión MOD :(:
hilo_flasheo-de-bios-erroneo-con-bdi_2407705

Tuve que comprar otro chip porque no habia forma de que arrancase.

Cruzaré los dedos esta vez. Ya te contaré.

Por cierto, gracias por el BDI!
Si es una 1.0 puedes usar variedad de bios, te recomiendo la 5003 f patched
Lo de mod on o mod no tiene misterio, simplemente se ha editado la bios para que no haga la intro, sin sonido, la gran X es azul y gris y el dvdcheck desmarcado (puede iniciar sin lector)
Los chips aladdin son recuperables con otro chip aladdin.
@hal9000 me da un poco de respeto, ya que ya jodí un chip por elegir la bios equivocada.
Podrías echarme una mano en el proceso?
Desde Flashbios busca bios para chip 1.0 y 256K (importante las dos cosas)

Line "Si desconoces la version de tu XBOX",2
      Line "usa el Xbox Version Detector",2
      Line "Una mala eleccion de Bios",2
      Line "puede romper tu ModChip",2
      Item "2.1 Evox M8Plus Mod F + G",@267
      Item "2.2 Evox M8Plus Mod F",@266
      Item "2.3 Evox M8Plus F + G",@241
      Item "2.4 Evox M8Plus F",@240
      Item "2.5 iND-BiOS 5003 Patched F + G",@278
      Item "2.6 iND-BiOS 5003 Patched F",@277
      Item "2.7 iND-BiOS 5003 BDI F + G",@288
      Item "2.8 iND-BiOS 5003 BDI F",@287
      Item "2.9 Xecuter 4981 Mod F + G",@231
      Item "2.10 Xecuter 4981 Mod F",@223
      Item "2.11 Xecuter 4981 F + G",@221
      Item "2.12 Xecuter 4981 F",@220
      Item "2.13 Xecuter 4983 F + G",@243
      Item "2.14 Xecuter 4983 F",@242
      Item "2.15 Xecuter 5035 F + G",@249
      Item "2.16 Xecuter 5035 F",@248
      Item "2.17 Xecuter 5035 Patched F + G",@281
      Item "2.18 Xecuter 5035 Patched F",@280

Si el hdd es de como mucho 1Tera puedes elegir Bios F (06) si tiene mas de 1Tera, entonces solo las F+G (67)
Si quieres bios son tocar, de esas puedes poner la 2.1 / 2.2 o mejor la 2.5 / 2.6
Yo personalmente recomiendo y uso la 2.7 / 2.8 aunque puede dar errores menores si se usa adaptador IDE a SATA, ya que es muy rápida de arranque y se puede dar de ostias con alguna combinación de adaptador+hdd. Si es el caso entonces usar la 2.5 / 2.6
Las 2.15 a 2.18 NO valen para los aladdines


Que chip estropeaste?, si es un aladdin advance si tiene arreglo, pero solo montado como lo muestro en la foto.

Imagen

Si lo montas boca abajo, no se puede acceder a la eeprom del chip en "caliente", es el que va en el zócalo.

Un vídeo de hace un millón de años.

Muchas gracias por las instrucciones tan detalladas @hal9000.

El chip que "jodí" era un Aladdin. Creo que lo soldé como muestras en la foto, pero bueno, ya está cambiado por uno en el que por lo menos arranca.

A ver si esta semana me pongo un rato y sigo tus notas y no la cago otra vez :D

Imagino, que actualizando la BIOS ya podré usar XBPartitioner para que me detecte el HDD (de 500 GB solo).

De nuevo, mil gracias. Ya postearé por aquí el resultado.
El flasheo son 10 segundos..... El aladdin que tienes roto, si lo que le paso es una mal flasheo tiene arreglo seguro. Te lo digo seguro ya que estoy harto de hacer pruebas raras editando bios, en eso que la he corrompido y todo a la mierda.
hal9000 escribió:El flasheo son 10 segundos..... El aladdin que tienes roto, si lo que le paso es una mal flasheo tiene arreglo seguro. Te lo digo seguro ya que estoy harto de hacer pruebas raras editando bios, en eso que la he corrompido y todo a la mierda.


El problema no es el tiempo del flasheo, es quitar los cables de la vieja xbox y enchufar la otra :D

Con respecto a lo de recuperar el chip mal flasheado, se necesita algún programador especial para el chip o se puede hacer directamente desde otra xbox? Conoces algún tutorial donde lo hagan? Quizás tu mismo has hecho uno :D
No hay tuto, lo primero es tener el AA montado con los chips hacía arriba, sino no se puede quitar la "eeprom" en caliente (en marcha).
Con la xbox con el AA funcional, ponerla en marcha normalmente. Se entiende que toda destapada, el lector y hdd fuera pero conectado.
Con mucho cuidado quitar la "eeprom" del AA, ojo que no se caiga y hagamos un corto. Introducir la "eeprom" del AA malo. Flashear y listo.
Si se saca el AA entero en marcha no funciona

AA = Aladdin Advance
eeprom = chip cuadrado que va en el zócalo (49LF020A). No confundir con la eeprom de la xbox

Nota:

Si tienes montado así el AA no vale

Imagen

Tiene que estar montado así, al menos en una de la XBOX

Imagen
@hal9000 Listo. Bios actualizada y HDD expandido.

Muchas gracias por la info y por las explicaciones :D
Hola a todos.
Aprovechando este hilo (actualización de Bios).
Comentaros que poseo una Xbox (creo que versión 1.6) a la que hace poco, he instalado un Hdd Sata de 400Gbps.

La partición F solo me muestra 137Gb (creo recordar), y por lo que he estado leyendo, tiene que ver con la versión de la Bios.

La Xbox no posee chip físico ni Tsop, únicamente SoftMod. Mi pregunta es:
¿Se puede actualizar la Bios de esta forma? ¿En caso contrario, existe alguna forma de ejecutar una Bios que permita utilizar toda la capacidad del Hdd?


Gracias anticipadas. Un saludo.
@lordofshadow
No creo que tengas exploit, creo mas bien que tienes chip o puede que tsop. Mira que versión de xbox tienes.
Hola hal9000.

Tengo exploit, ya que hace poco la adquirí y lo instalé.
Creo que queda claro que es por la Bios, ya que al ejecutar Xbpartitioner me indica que no se pueden crear particiones de mas tamaño, y que debería actualizar.

Con Chimp, aunque me da la opción de marcar la partición F con todo el tamaño restante, o distribuir el espacio entre las particiones F y G, y parece hacerlo bien, en cuanto ejecuto EvolutionX, la partición F alcanza los 130 Gb (o así).


Mi pregunta es, ¿es necesario Chip o Tsop para actualizar la Biosde la consola? ¿No existe otra forma de hacerlo, como ejecutar un Dashboard que permita cargar en caliente una bios almacenada en el Hdd?


Gracias. Un saludo.
Pues entonces te ha tocado el peor exploit que he conocido, ya que desde los tiempos del UXE (2005) ya usaban nkpatcher / phoenix bios loader metoo + bios m8, sin estos problemas.
Cuando ejecutas el Xbpartitioner te da la brasa sobre que no soporta LBA?

PD
Cambia de exploit, mírate el BDI [beer]
hal9000 escribió:Pues entonces te ha tocado el peor exploit que he conocido, ya que desde los tiempos del UXE (2005) ya usaban nkpatcher / phoenix bios loader metoo + bios m8, sin estos problemas.
Cuando ejecutas el Xbpartitioner te da la brasa sobre que no soporta LBA?

PD
Cambia de exploit, mírate el BDI [beer]


Cuando ejecutas el Xbpartitioner te da la brasa sobre que no soporta LBA?: exacto.

Cambia de exploit, mírate el BDI: ¿con este exploit se solucionaria el problema de tamaño?


Gracias por tu ayuda. Un saludo.
Hola Hal9000.
He descargado Borg-Disk, he instalado el Exploit, y Bingo! Ya me aparece el total de espacio restante en la partición F.

El problema residía en que, como comentabas, tenia un viejo instalador (Disco ZxbInstaller), que era de las primeras versiones que salieron cuando se encontró la vulnerabilidad, y el exploit estaba muy desfasado.
Guardaré el BDI como oro. Jejeje.



Ahora solo me resta pasar los programas y aplicaciones por Ftp.


Mil gracias!!!
Te debo una cervecita.... ;) ;)
HOLA A TODOS, tengo una duda hace no mucho un amigo mio se consiguió una xbox v1.6 que venia con un Aladdin XT PLUS 2 el quito el chip y la dejo solamente con softmod y un hd de 120 creo, el tema es que me regalo el chip y quiero ver si vale para una xbox 1.0 (que tiene muerto el tsop) el chip rulaba perfecto en la consola de mi amigo (v1.6) y lo instale en mi consola 1.0 al encenderla intenta iniciar 3 veces y luego queda en verde-rojo hay alguna forma de re flashear la bios del chip para que rule en mi 1.0? ya que vi que las bios de la 1.6 no van en 1.0 a 1.5. Desde ya gracias por adelantado pd:soy nuevo en el foro
Tienes el chip mal instalado, las bios de 1.6 van en todas las versiones anteriores, de hecho cuando compras un aladdin nuevo viene con una m8+16
CUIDADO!!!! al revés NO funciona. Si el chip tiene una bios para 1.0 a 1.5 y lo instalas en una v1.6, no funciona.
Gracias amigo @hal9000 por responder, lo probare repasar soldaduras, y ver que este todo bien, en el caso que logre hacer que funcione, que bios es la mejorcita para un hd de 500gb, y para mod 128mb? Cualquier bios me va x2, ind, evox. Saludos y Muchisimas Gracias.
Para una v1.0 lo suyo es TSOP, si tienes el mod de 128 y hdd gordo solo hay dos opciones la ind BIOS 5003 patch o la xecuter 5035
Ah perfecto amigo Gracias esa bios probare, pues al parecer mi tsop esta muerto por que sin chip ni nada la consola no me enciende hace lo de los 3 arranques quedando en verde-rojo existe alguna posibilidad de revivirlo?

Edit: Acabo de terminar de soldar bien el Aladdin y ya me encendio sin problemas (Que alivió) por ahora esta viva...
SantiXLDC escribió:Ah perfecto amigo Gracias esa bios probare, pues al parecer mi tsop esta muerto por que sin chip ni nada la consola no me enciende hace lo de los 3 arranques quedando en verde-rojo existe alguna posibilidad de revivirlo?

Edit: Acabo de terminar de soldar bien el Aladdin y ya me encendio sin problemas (Que alivió) por ahora esta viva...

Si, tiene remedio, lo que yo no estoy puesto en el tema. Deberías abrir un hilo sobre ese tema si quieres que te ayuden.
Si sigues solo con el aladdin, solo podrás usar la bios 5003 patch, ya que la 5035 es de 512k y no cabe.
Ah bueno amigo Muchas Gracias en algún momento lo abrire y gracias por su tiempo.

Edit: pues eh podido resucitar mi tsop Menos mal, al parecer habia algo de humedad en mi placa y le hice un lavado completo con tiner limpie bien la superficie que veia mas afectada y quedo bastante limpia al encender me arranco sin problemas, eso si la bios era la original la que estaba antes del malflasheo, Estoy super tranquilo que mi tsop este viva, pero igual si dejo bios original no puedo hacer mucho que digamos, que bios me recomiendan para tsop de 1MB para lo mismo de antes HD de 500 y mod 128mb? Gracias amigos.
24 respuestas