[PSP] Problema al instalar psptoolchain.

Ofertas en PcComponentes: Top Verano y PcCom Days
Mi problema es que el proceso de instalacion falla en un punto de esta.

He instalado los packetes requeridos antes de empezar con ella, tales como subv, automake1.9, doxygen, flex, paquetes lib-dev... Me descargo el repositorio completo del kit (SDK) y desde la terminal ejecuto /.psptoolchain.sh. Comienza todo correcto, resuelvo algun problema de librerias (MPFR, GMP) hasta que empieza a instalar el gcc-4.3.2. Todo correcto por el momento, cuando se me queda en un script.
El error es en .../scripts/002-gcc-4.3.2-stage1.sh ( : Failed. )

Utilizo Debian 4 Etch (stable).

Si alguien tiene idea de que puede estar pasando o le ha pasado me gustaria que lo postease. Thx.
El problema es de algunas referencias a mpfr al ejecutar un check-script.
libbackend.a(builtins.o): In function `fold_builtin_2':
../../gcc/builtins.c:10120: referencia a `mpfr_jn' sin definir
libbackend.a(builtins.o): In function `do_mpfr_lgamma_r':
../../gcc/builtins.c:13035: referencia a `mpfr_lgamma' sin definir
libbackend.a(builtins.o): In function `fold_builtin_2':
../../gcc/builtins.c:10126: referencia a `mpfr_yn' sin definir
../../gcc/builtins.c:10134: referencia a `mpfr_remainder' sin definir
libbackend.a(builtins.o): In function `do_mpfr_remquo':
../../gcc/builtins.c:12957: referencia a `mpfr_remquo' sin definir
libbackend.a(builtins.o): In function `fold_builtin_1':
../../gcc/builtins.c:9973: referencia a `mpfr_j0' sin definir
../../gcc/builtins.c:9979: referencia a `mpfr_j1' sin definir
../../gcc/builtins.c:9985: referencia a `mpfr_y0' sin definir
../../gcc/builtins.c:9991: referencia a `mpfr_y1' sin definir
collect2: ld returned 1 exit status
make[2]: *** [cc1-dummy] Error 1
make[2]: se sale del directorio `/home/fiso/trunk/psptoolchain/build/gcc-4.3.2/build-psp/gcc'
make[1]: *** [all-gcc] Error 2
make[1]: se sale del directorio `/home/fiso/trunk/psptoolchain/build/gcc-4.3.2/build-psp'
make: *** [all] Error 2
../scripts/002-gcc-4.3.2-stage1.sh: Failed.


Alguna info? Gracias.
No tengo mucha idea, pero esos fallos parecen el típico de que te falta incluir algún directorio extra donde esten los .h que definen todo eso.

Quizás tengas que instalar alguna dependencia :-S
Bien, retomo el tema despues de un tiempo apartado del desarrollo.
Empezaré desde el principio. Dices que puede faltar alguna dependencia.
A continuacion cito todas las dependencias a paquetes que había instalado y ya he reinstalado:

* automake1.9
* doxygen
* flex
* libncurses5-dev
* libreadline5-dev
* texinfo
* libusb-dev
* libgmp3-dev
* libmpfr-dev
* libreadline-dev


¿Creeis que falta alguna? Si sí, hacedmelo saber. Gracias.
3 respuestas