(HO) NSC_Builder. Eliminación de encriptación por titlerights en nsp y multi-content Builder.

Tr0Y
Yipi ka yei!!!
2.480 mensajes
desde jul 2006
en Midgar
@JulesRussel Efectivamente era tema de compatibilidad con 5.1.

He actualizado la emunand a 6.2 con ChoidujourNX y funciona perfecto con la opción que más me gusta, que es empaquetar juego+update en un xci.

Aprovechando el post, tengo una duda para futuras actualizaciones. Si por ejemplo mañana sale la actualización 1.2, ¿es posible actualizar sobre el paquete que tengo ahora de juego+actualizacion_1.1?, ¿o es necesario hacerlo con la primera versión del juego sin actualizar?

Muchísimas gracias por la ayuda.

Salu2.Tr0Y
JulesRussel
MegaAdicto!!!
4.950 mensajes
desde ene 2012
@Tr0Y Sí, usando el modo 4, "update mode".
igusi2000
tete
26.397 mensajes
desde ene 2005
en barcelona
Buenas no encuentro como se hace para probar de parxhear el super pang con masterkey5 ya que no consigo hacerlo funcionar ni en modo avion. Alguien me podria decir los pasos del programa para parchearlo
JulesRussel
MegaAdicto!!!
4.950 mensajes
desde ene 2012
@igusi2000
Sigues el proceso normal y le cambias la keygeneration cuando haga falta.
Imagen
igusi2000
tete
26.397 mensajes
desde ene 2005
en barcelona
@JulesRussel Vale gracias probare es que nonse muy bien como va el programa, luego miro
JulesRussel
MegaAdicto!!!
4.950 mensajes
desde ene 2012
Actualizado a v0.81 Beta
molondongo
Adicto
151 mensajes
desde sep 2006
en brunete
¿Que novedad lleva? el anterior funciona perfecto, no se que se podria mejorar..
jldc82
MegaAdicto!!!
1.321 mensajes
desde dic 2007
en Española
@molondongo tienes los cambios en la primera página.
JulesRussel
MegaAdicto!!!
4.950 mensajes
desde ene 2012
Editado 4 veces. Última: 6/03/2019 - 03:11:58 por JulesRussel.
Recordatorio. Si añadís la nueva masterkey7 el programa podrá parchear los juegos cuando empiecen a usar keygeneration8. Ya se puede conseguir de forma libre:
https://gbatemp.net/threads/switch-7-0- ... ad.532916/
Luego edito mi plantilla para reflejarlo.

Solucionado bug donde siempre se ignoraban los deltas en el nuevo "individual mode" de la bet2. Actualmente creo que podemos considerar así a las releases:

-Beta2: 0.81-d
https://github.com/julesontheroad/NSC_B ... 32bits.zip
https://github.com/julesontheroad/NSC_B ... 64bits.zip

-Stable: 0.80-c
https://github.com/julesontheroad/NSC_B ... 32bits.zip
https://github.com/julesontheroad/NSC_B ... 64bits.zip

@molondongo
  • Más velocidad y menos necesidad de espacio en disco en el splitter y la conversión individual.
  • Cambios en el update mode para que quite titlerights y parchee la base si es necesario.
  • Un modo para hacer bases de datos.
  • Mejoras en los modos info.
  • Un verificador de keys
  • Usa python para procesar directamente litas y entrads de usuario en ciertos puntos para resolver los errores con los caracteres especiales.
Eso a grandes rasgos.
satelman
Habitual
99 mensajes
desde mar 2014
Editado 3 veces. Última: 6/03/2019 - 02:00:20 por satelman.
JulesRussel escribió:Recordatorio. Si añadís la nueva masterkey7 el programa podrá parchear los juegos cuando empiecen a usar keygeneration8. Ya se puede conseguir de forma libre:
https://gbatemp.net/threads/switch-7-0- ... ad.532916/
Luego edito mi plantilla para reflejarlo.

Solucionado bug donde siempre se ignoraban los deltas en el nuevo "individual mode" de la bet2. Actualmente creo que podemos considerar así a las releases:

-Beta2: 0.81-c
https://github.com/julesontheroad/NSC_B ... x64_nk.zip
https://github.com/julesontheroad/NSC_B ... x86_nk.zip

-Stable: 0.80-c
https://github.com/julesontheroad/NSC_B ... 32bits.zip
https://github.com/julesontheroad/NSC_B ... 64bits.zip

@molondongo
  • Más velocidad y menos necesidad de espacio en disco en el splitter y la conversión individual.
  • Cambios en el update mode para que quite titlerights y parchee la base si es necesario.
  • Un modo para hacer bases de datos.
  • Mejoras en los modos info.
  • Un verificador de keys
  • Usa python para procesar directamente litas y entrads de usuario en ciertos puntos para resolver los errores con los caracteres especiales.
Eso a grandes rasgos.


Hola de nuevo, @JulesRussel:

Estoy probando tu última beta 2 de la versión 0.81-c (x64) y quiero obtener la información de FW con la opción 4, pero siempre me sale esto:

********************************************************
SHOW INFORMATION AND DATA ABOUT THE REQUIRED FIRMWARE
********************************************************
File "D:\NSCB_081c_x64\ztools\squirrel.exe", line 1
SyntaxError: Non-UTF-8 code starting with '\x90' in file D:\NSCB_081c_x64\ztools\squirrel.exe on line 1, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details

Y no muestra nada más. He probado varios .xci y lo mismo. Con la versión 0.80 beta no sucedía esto y tampoco con la versión 0.81-b, que acabo de probar. ¿Sabes qué puede estar pasando en la 0.81-c?