Dop-IOS v10

Sorteo Hawkers x EOL: iMac, iPad mini 2 y+
1, 2, 3, 4, 578
Mark R.
Falcon pawn!
4.962 mensajes
desde abr 2004
en Tarragona
Editado 22 veces. Última: 8/01/2012 - 11:33:08 por Mark R..
Descarga

NOTA: ESTE SOFTWARE PUEDE DAÑAR TU WII. ÚSALO BAJO TU RESPONSABILIDAD.
Dop-IOS ha sido probado satisfactoriamente en varias consolas. Aún así, no me hago responsable de los daños que pueda causar.
Se recomienda tener una copia de la NAND con BootMii.
IMPORTANTE: NO PARCHEAR IOS60 (o el IOS de tu menú de Wii) SI SE TIENE PRELOADER INSTALADO.


Dop-IOS es una modificación rápida del tona's shop installer. Permite descargar cualquier IOS, instalarlo y aplicarle el parche para tener de nuevo el bug trucha.

Este software le será muy útil a aquellos con modchip que quieren las novedades del menú 4.0 y quieren seguir jugando a juegos trucha desde el canal disco.
Pikmin 2 (y otros juegos nuevos como Punch Out) llevan la actualización 3.4. Si actualizas mediante disco o internet, se actualizan los IOS a sus nuevas versiones (con bug trucha corregido).

¿Cómo se usa?:
*Asegúrate de tener un IOS con bug trucha (cualquier cIOS vale)
*Actualiza a 3.4 o 4.0 (mediante disco)
*Ejecuta Dop-IOS
*Dopa IOS60 si ahora estás en 4.0, o IOS50 si estás en 3.4
*Dopa IOS36 (para Smash Bros. Brawl y otros juegos de Nintendo)
*Dopa IOS21 (para juegos third-party como No More Heroes o Dragon Ball Z Tenkaichi 3)

¡Ahora ya puedes jugar a Pikmin 2 sin que te pida actualizar! ¡Y además puedes jugar a tus juegos trucha en tu 3.4/4.0!


NOTA: Si actualizaste mediante el método Waninkoko, esto no funcionará y Pikmin 2 te seguirá pidiendo actualizar. Debes actualizar desde un disco de juego de Wii para conseguir las últimas versiones de los IOS.
Actualizar por internet ya no es viable, puesto que te subirá a la versión 4.2 y perderás acceso al software casero (a fecha de 29 de Septiembre de 2009).


Características
* Descarga cualquier IOS de los servidores de Nintendo
* Selecciona entre la versión antigua o la más moderna de cualquier IOS
* Aplica el bug trucha en cualquier IOS
* Aplica el parche ES_Identify en IOS36 (ideal para usuarios de Any Title Deleter y >3.4)
* Protección: no te permite instalar 'stubs'.
* Guarda los archivos en la SD para reutilizarlos posteriormente.
* Muestra tus IOS instalados.



Notas de la versión 9
* añadido selector de IOS a usar al inicio (ya no es necesario cIOS249)
* añadido selector de versión de IOS
* actualizado a todas las últimas versiones de IOS
Notas de la versión 10
* corregido selector de IOS a usar al inicio


Este texto se redactó en Febrero de 2010, la última versión del firmware de Wii era la 4.2.
Ten cuidado, una nueva versión del firmware podría convertir Dop-IOS en una aplicación más peligrosa.
toniteis
online
738 mensajes
desde abr 2008
en Vigo
Excelente aporte, asi nos evitaremos tus problemas [mad]

¿Se puede hacer offline?¿Poniendo los ios en la carpeta 000...1/... (no se si me explico)?
¿como se identifican los ios en el server de nintendo? o alguien hace el favor de poner los links

Yo de momento tengo todos los ios antiguos, actualice mediante wads el menu de sistema y el ios60, pero me interesa actualizar todos los ios para que no me pidan actualizar los juegos, pero quiero seguir jugando a mi manhunt2 uncensored (¿ios 21?)
poxolate3
MegaAdicto!!!
1.787 mensajes
desde mar 2008
Se te ha ocurrido esta aplicación gracias al brick que pudiste salvar XD
No hay mal que por bien no venga.
poxolate3
MegaAdicto!!!
1.787 mensajes
desde mar 2008
Se te ha ocurrido esta aplicación gracias al brick que pudiste salvar XD
No hay mal que por bien no venga.
Mark R.
Falcon pawn!
4.962 mensajes
desde abr 2004
en Tarragona
toniteis escribió:¿Se puede hacer offline?¿Poniendo los ios en la carpeta 000...1/... (no se si me explico)?
¿como se identifican los ios en el server de nintendo? o alguien hace el favor de poner los links

Yo de momento tengo todos los ios antiguos, actualice mediante wads el menu de sistema y el ios60, pero me interesa actualizar todos los ios para que no me pidan actualizar los juegos, pero quiero seguir jugando a mi manhunt2 uncensored (¿ios 21?)

Con esta aplicación no se puede hacer offline.
En un principio, tendrías que descargar con NUSD los dos IOS (o bien extraerlos de una ISO con actualización 3.4) y parchearlos con FreeTheBug. Eso es lo que hice, y ya ves lo que me pasó :( Supongo que algo hice mal. Si quieres pruébalo, si obtienes el mismo problema que yo es tan fácil como restaurar tu NAND con BootMii, o bien usar el mismo método que yo: ATD con cadena hexadecimal cambiada+Bannerbomb.
El Manhunt 2 supongo que debe ir por IOS21. En caso de que funcionase con otro sería cuestión de volver a compilar esta aplicación añadiendo ese IOS. Es muy simple, basta con cambiar dos cifras.
Había pensado de hacer una aplicación para TODOS los IOS antiguos. Pero de momento no estoy interesado en llenar de "mierda" la Wii. Contra más cosas originales haya, mejor. No es que vaya a pasar nada raro, desde luego, deben ser cosas mías :) Además siempre es bueno estar a la última actualización.
Con parchear el 36 y el 21, que son los que me interesaban sobra.

poxolate3 escribió:Se te ha ocurrido esta aplicación gracias al brick que pudiste salvar XD
No hay mal que por bien no venga.

Tendría que haber hecho esta aplicación desde el principio, y me hubiese ahorrado muchos problemas XD
civ
¿Qué joroba?
2.403 mensajes
desde may 2008
en Donde yo quiera
poxolate3 escribió:Se te ha ocurrido esta aplicación gracias al brick que pudiste salvar XD
No hay mal que por bien no venga.

¿Doble post?

¿Como?

poxolate3 escribió:Se te ha ocurrido esta aplicación gracias al brick que pudiste salvar XD
No hay mal que por bien no venga.
danny.ml
MegaAdicto!!!
1.594 mensajes
desde jun 2006
en México D.F.
Editado 1 vez. Última: 20/05/2009 - 06:40:46 por danny.ml.
Gracias por la info! Ya que yo tengo Modchip XD

Pregunta: Cual es el hilo/post donde esta tu problema y tu solución al brick? me interesa mucho saber como lo dañaste y como lo solucionaste.

Edit: Lo encontre XD ¿Creando una partición de actualización falsa?

Gracias! Saludos!
Mark R.
Falcon pawn!
4.962 mensajes
desde abr 2004
en Tarragona
danny.ml escribió:Gracias por la info! Ya que yo tengo Modchip XD

Pregunta: Cual es el hilo/post donde esta tu problema y tu solucion al brick? me interesa mucho saber como lo dañaste y como lo solucionaste.

Gracias! Saludos!

Si buscas entre mis últimos mensajes lo encontrarás.
danny.ml
MegaAdicto!!!
1.594 mensajes
desde jun 2006
en México D.F.
Ya recordé, es el post donde se te dañaron varios IOS.

Cambiando de tema, en el readme haces notar que podemos modificar el archivo "installer.c" para descargar y parchear otro IOS si así lo deseamos, tengo que compararlo con el source original de Tona, pero... que es lo que hay que modificar exactamente para descargar otro IOS? solamente con cambiar el numero del IOS? o hay otro dato más que modificar.

Comparándolo con la source de Tona he visto a simple vista estos cambios, pero se me puede haber ido algo.


ret = IOS_ReloadIOS(249); <<< Aquí me imagino que no hay que moverle, para que use el cIOS 249

ret = patchmii_install(1, 36, 0, 1, 36, 0, yes_or_no()); <<< aquí cambiar el número de la IOS a descargar cierto? bueno y con su respectivo dialogo de texto claro esta.

printf("\nAre you sure you want to install IOS36?\n");


De antemano muchas gracias! y me da gusto saber que has podido reparar tu Wii, la esperanza es lo ultimo en morir XD

Saludos!!!
Mark R.
Falcon pawn!
4.962 mensajes
desde abr 2004
en Tarragona
danny.ml escribió: ret = IOS_ReloadIOS(249); <<< Aquí me imagino que no hay que moverle, para que use el cIOS 249

ret = patchmii_install(1, 36, 0, 1, 36, 0, yes_or_no()); <<< aquí cambiar el número de la IOS a descargar cierto? bueno y con su respectivo dialogo de texto claro esta.

printf("\nAre you sure you want to install IOS36?\n");


De antemano muchas gracias! y me da gusto saber que has podido reparar tu Wii, la esperanza es lo ultimo en morir XD

Saludos!!!

Exactamente :)
Lo del cIOS no hay que tocarlo (a no ser que tengas IOS36 con bug trucha). Y luego es cuestión de cambiar esas dos cifras en la llamada a patchmii_install, si quieres puedes cambiar el último yes_or_no() por un 1 para que te ponga el parche automáticamente.
1, 2, 3, 4, 578