[HO] GoldLeaf (Antiguo Tinfoil) - Instalador de NSP desde Homebrew Launcher

Buenas a todos, estoy eliminando tickets de juegos que ya no tengo con la opción de delete common ticket, hasta ahí bien, ahora veo que tiene una opción llamada delete personalized ticket, y ahí dentro tengo 2 tickets, que son? puedo borrarlos?

Saludos!
Saludos a todos
Tengo un problema y antes de meter la pata os pregunto a ver si sabeis la respuesta.
Tengo Reinx 1.7, en mi Switch 4.1.0, hasta ahora habia instalado todos los .nsp sin problemas, pero ahora cuando intento instalar los último con Tinfoil 0.0.1, me da error y pone "is corrupt! You may have a bad dump, or fs_mitm may need to be removed. Error code: 0x00236e02.
Tendria que actualizar la consola a 6.0 o el tinfoil?
Gracias!
Instalando un juego, y luego su actualizacion... no deberia decirme que hay actualizacion disponible. ¿verdad? como se si la actualizacion esta activa y correctamente instalada????
@bastayadeswamp eso quiere decir que el update no es el más reciente aunque se instale bien por ejemplo puede ser que el update q instalaste sea versión 1.5 del juego pero ayer salió la 2.0 y aún no hay update para instalarlo de forma offline por eso te pide instalar una actualización, hay backup que se acaban de actualizar hace poco, saludos
bastayadeswamp escribió:Instalando un juego, y luego su actualizacion... no deberia decirme que hay actualizacion disponible. ¿verdad? como se si la actualizacion esta activa y correctamente instalada????


Cada firmware de Nintendo tiene un listado con la versión más reciente de todos los juegos lanzados hasta la fecha.
Al correr un juego, comprueba que la versión instalada es igual o superior que la que pone en el firmware. Si es menor, te aparece ese mensaje de actualización.
Vamos, que la comprobación no es contra los servidores de Nintendo para ver si es la última versión o no del juego, es contra el firm de tu consola.

Otra historia son los updates que piden actualizar a versiones más nuevas del firm, como el último del Mario Kart o del Mario Tennis que te piden satar a firms 6.0+. Esto te lo piden por pedir, porque realmente no necesitan ninguna librería nueva de estos firms. Para estos casos, Tinfoil.
Ok, lo pille. Muchas gracias.
Ahora parece que el cdnsp ha dejado de funcionar ... Buscaremos como bajarlo
Gracias
@Raugo He vuelto a intentar poniendo el nombre del archivo shi.nsp y de todas formas me marca el mismo error de antes. Pongo el error mas especifico:

OnSelected:165: URL size 1002cec7 is too large!
hay algun modo de poder borrar los tickets que tengamos una lista tocha (y lógicamente se congela la switch) de alguna manera???

ya me he pasado unos cuantos juegos y la verdad es que me gustaría ir limpiando un poco la base de datos sin tener que tirar de restaurar nand y hacer de nuevo todo el proceso.
yox escribió:Saludos a todos
Tengo un problema y antes de meter la pata os pregunto a ver si sabeis la respuesta.
Tengo Reinx 1.7, en mi Switch 4.1.0, hasta ahora habia instalado todos los .nsp sin problemas, pero ahora cuando intento instalar los último con Tinfoil 0.0.1, me da error y pone "is corrupt! You may have a bad dump, or fs_mitm may need to be removed. Error code: 0x00236e02.
Tendria que actualizar la consola a 6.0 o el tinfoil?
Gracias!

Buenas,

A mi me pasa algo similar, pero sobre todo en NSPs nuevos (Dragon ball, FF pocket edition), yo lo achacaba a que realmente esos juegos necesitan un firm superior... pero no se si me estoy saltando algo..

Saludos!
RolleR escribió:Buenas a todos, estoy eliminando tickets de juegos que ya no tengo con la opción de delete common ticket, hasta ahí bien, ahora veo que tiene una opción llamada delete personalized ticket, y ahí dentro tengo 2 tickets, que son? puedo borrarlos?

Saludos!


nadie?
Tirion escribió:
yox escribió:Saludos a todos
Tengo un problema y antes de meter la pata os pregunto a ver si sabeis la respuesta.
Tengo Reinx 1.7, en mi Switch 4.1.0, hasta ahora habia instalado todos los .nsp sin problemas, pero ahora cuando intento instalar los último con Tinfoil 0.0.1, me da error y pone "is corrupt! You may have a bad dump, or fs_mitm may need to be removed. Error code: 0x00236e02.
Tendria que actualizar la consola a 6.0 o el tinfoil?
Gracias!

Buenas,

A mi me pasa algo similar, pero sobre todo en NSPs nuevos (Dragon ball, FF pocket edition), yo lo achacaba a que realmente esos juegos necesitan un firm superior... pero no se si me estoy saltando algo..

Saludos!


¿Habéis probado con Tinfoil 0.2.1?
malvado24 escribió:
Tirion escribió:
yox escribió:Saludos a todos
Tengo un problema y antes de meter la pata os pregunto a ver si sabeis la respuesta.
Tengo Reinx 1.7, en mi Switch 4.1.0, hasta ahora habia instalado todos los .nsp sin problemas, pero ahora cuando intento instalar los último con Tinfoil 0.0.1, me da error y pone "is corrupt! You may have a bad dump, or fs_mitm may need to be removed. Error code: 0x00236e02.
Tendria que actualizar la consola a 6.0 o el tinfoil?
Gracias!

Buenas,

A mi me pasa algo similar, pero sobre todo en NSPs nuevos (Dragon ball, FF pocket edition), yo lo achacaba a que realmente esos juegos necesitan un firm superior... pero no se si me estoy saltando algo..

Saludos!


¿Habéis probado con Tinfoil 0.2.1?

Yo me bajé la ultima nightly de aquí,
https://bsnx.lavatech.top/tinfoil/
¿donde puedo encontrar esa 0.2.1? Entiendo por lo que dices que deberían funcionar los ultimos NSPs que han salido, no?
@Tirion A esa me refería, a mi m la marca como 0.2.1
Pero si estás ya probando con esta versión y no funciona, será por algún otro tema...
probado con la 0.2.1 en RajNX por si acaso y el mismo resultado con los nps que dice el compañero, creo que ya solo quedaria actulziar a 6.0
Estoy en 6.0 y ahora siempre me falla el tinfoil, me corre una sola vez pero como que se corrompe y a la próxima que quiero entrar me marca error de la Switch.

2345-0001.


EDIT: Me he fijado que me cambia la fecha a 1969 en ultima modificación del archivo.
Raugo escribió:Tinfoil es una aplicacion homebrew que permite instalar NSP directamente sin necesidad de usar layeredfs ni ninguna otra aplicacion ya que se carga desde homebrew launcher, de momento se encuentra en un estado bastante primitivo pero ya permite instalar los NSP aunque la interfaz sea un poco basica.

Source: https://github.com/Adubbz/Tinfoil
Aplicacion: https://gbatemp.net/attachments/tinfoil-zip.136098/

Fuente: https://gbatemp.net/threads/tinfoil-tit ... bz.511763/

Edito: Dejo aqui la ultima version que acabo de compilar:

https://mega.nz/#!IElDQADR!zMWV6uOR4kDq ... h7cNxVmG8Q

Es compatible con updates y no tiene el problema de borrar la BD al intentar instalar un dlc.

Saludos


Buenas, no entiendo bien que es lo que hay que instalar, dónde pone Source, la Aplicación o la última versión que acabas de compilar...(en este último caso sería poner el archivo .nro en la raíz y listo?).

Un saludo y gracias
Charlyiii escribió:
Raugo escribió:Tinfoil es una aplicacion homebrew que permite instalar NSP directamente sin necesidad de usar layeredfs ni ninguna otra aplicacion ya que se carga desde homebrew launcher, de momento se encuentra en un estado bastante primitivo pero ya permite instalar los NSP aunque la interfaz sea un poco basica.

Source: https://github.com/Adubbz/Tinfoil
Aplicacion: https://gbatemp.net/attachments/tinfoil-zip.136098/

Fuente: https://gbatemp.net/threads/tinfoil-tit ... bz.511763/

Edito: Dejo aqui la ultima version que acabo de compilar:

https://mega.nz/#!IElDQADR!zMWV6uOR4kDq ... h7cNxVmG8Q

Es compatible con updates y no tiene el problema de borrar la BD al intentar instalar un dlc.

Saludos


Buenas, no entiendo bien que es lo que hay que instalar, dónde pone Source, la Aplicación o la última versión que acabas de compilar...(en este último caso sería poner el archivo .nro en la raíz y listo?).

Un saludo y gracias

Con poner el .nro en la raiz y ejecutarlo desde un CFW es suficiente, en mi caso lo he probado con SX OS
Luego los nsps hay que meterlo en una ruta concreta de la SD, /tinfoil/nsp

Saludos
Tirion escribió:
Charlyiii escribió:
Raugo escribió:Tinfoil es una aplicacion homebrew que permite instalar NSP directamente sin necesidad de usar layeredfs ni ninguna otra aplicacion ya que se carga desde homebrew launcher, de momento se encuentra en un estado bastante primitivo pero ya permite instalar los NSP aunque la interfaz sea un poco basica.

Source: https://github.com/Adubbz/Tinfoil
Aplicacion: https://gbatemp.net/attachments/tinfoil-zip.136098/

Fuente: https://gbatemp.net/threads/tinfoil-tit ... bz.511763/

Edito: Dejo aqui la ultima version que acabo de compilar:

https://mega.nz/#!IElDQADR!zMWV6uOR4kDq ... h7cNxVmG8Q

Es compatible con updates y no tiene el problema de borrar la BD al intentar instalar un dlc.

Saludos


Buenas, no entiendo bien que es lo que hay que instalar, dónde pone Source, la Aplicación o la última versión que acabas de compilar...(en este último caso sería poner el archivo .nro en la raíz y listo?).

Un saludo y gracias

Con poner el .nro en la raiz y ejecutarlo desde un CFW es suficiente, en mi caso lo he probado con SX OS
Luego los nsps hay que meterlo en una ruta concreta de la SD, /tinfoil/nsp

Saludos


Muy claro, gracias!

Edito: Instalé la versión compilada de Raugo, es la versión 1.0. Al seleccionar el nsp para instalar no me da la opción de elegir donde lo quiero instalar, si memoria interna o SD, me lo instala directamente en la SD. Tengo entendido que podías elegir. Que hago mal? Es otra versión de Tinfoil la que hace esto?

Gracias de nuevo.
Es un no parar, ahora me sale un error 0x00234a02 con el Megaman11.
@Charlyiii Instalate la ultima build de este enlace
https://bsnx.lavatech.top/tinfoil/

Van por la 0.2.1, seguramente la que hay al inicio del post no tiene muchas de las features que hay ahora disponibles
Tirion escribió:@Charlyiii Instalate la ultima build de este enlace
https://bsnx.lavatech.top/tinfoil/

Van por la 0.2.1, seguramente la que hay al inicio del post no tiene muchas de las features que hay ahora disponibles


Gracias!!
Una duda! Entonces para los ultimos nsp solo es necesario actualizar el tinfoll o tambien es conveniente actualizar el reinx si se tiene de las primeras versiones?

Gracias

EDITO: he actualizado solo tinfoil y todo ok
Buenas! He actualizado Reinx a la versión 1.7... Pero ahora me encuentro con que no me lee mis copias de seguridad antiguas, solo las que instalé a tras la instalación de REinx. Pero si vuelvo a reinstalarlos tampoco puedo. Intuyo que quizás tenga algo que ver con tinfoil, ya que tengo la versión 0.0.1.

Como puedo actualizar la versión del tinfoil? Leí por aquí que metiera el archivo .nro en la raíz de la SD y lo ejecutara. Pero no encuentro forma de ejecutarlo.

gracias

PD: Me actualizó. Ya he podido actualizar Tinfoil, sin embargo sigue sin correr esos nsp, incluso volviendo a cargarlos desde el ordenador en la SD
regoland escribió:Una duda! Entonces para los ultimos nsp solo es necesario actualizar el tinfoll o tambien es conveniente actualizar el reinx si se tiene de las primeras versiones?

Gracias

EDITO: he actualizado solo tinfoil y todo ok


que firmaware tienes? porque yo no tengo forma de que tinfoil me instale los nsp nuevos
5.1 y el primer reinx q salio
ok gracias, yo tengo la 4.0.1 y no tengo forma de instalar esos nsp y he probado con reinx y con rajnx,
Buenas

Tengo el sx os 2.0 con el fw de 4.1.0 y estoy intentando instalar el nsp del dragón ball fighters pero no me deja, voy con la última versión de tinfoil. Alguien le pasa lo mismo?

Saludos
yox escribió:
regoland escribió:Una duda! Entonces para los ultimos nsp solo es necesario actualizar el tinfoll o tambien es conveniente actualizar el reinx si se tiene de las primeras versiones?

Gracias

EDITO: he actualizado solo tinfoil y todo ok


que firmaware tienes? porque yo no tengo forma de que tinfoil me instale los nsp nuevos


Pues yo estoy justo al revés. Tengo tinfoil 0.2.1 y Reinx 1.7 y sin problema cargo los últimos juegos, sin embargo es imposible cargar alguno anterior, me dice " ticket installation failed"

Cosas mas raras jajaj
A mí me sucede algo muy raro. Tengo la consola actualizada a 6.0 y tinfoil en la penúltima versión.
Resulta que hay juegos que puedo instalar perfectamente, en la tarjeta sd y funcionan sin problemas, en cambio hay otros que aunque cambie la instalación de la sd a la nand, le diga que evite comprobar el frimware o no,
no hay manera que funcionen. Siempre aparece el mensaje: failed to create placholder. En otros no me deja instalar en sd y solo me deja instalarlos en la nand, pero a pesar de eso al abrir el juego una vez instalado me salta un mensaje de error y no lo ejecuta.
Alguien sabe como funciona el nuevo metodo de instalacion por USB?
joker32 escribió:Buenas

Tengo el sx os 2.0 con el fw de 4.1.0 y estoy intentando instalar el nsp del dragón ball fighters pero no me deja, voy con la última versión de tinfoil. Alguien le pasa lo mismo?

Saludos

Si tienes Osx no necesitas tinfoil para instalar nsp lo haces desde el propio Osx....
SUGUSAPPLE escribió:
joker32 escribió:Buenas

Tengo el sx os 2.0 con el fw de 4.1.0 y estoy intentando instalar el nsp del dragón ball fighters pero no me deja, voy con la última versión de tinfoil. Alguien le pasa lo mismo?

Saludos

Si tienes Osx no necesitas tinfoil para instalar nsp lo haces desde el propio Osx....

Pero sx os no da la posibilidad de saltarse la petición de firmware como Tinfoil.
SUGUSAPPLE escribió:Buenas

Tengo el sx os 2.0 con el fw de 4.1.0 y estoy intentando instalar el nsp del dragón ball fighters pero no me deja, voy con la última versión de tinfoil. Alguien le pasa lo mismo?

Saludos


Yo lo estoy intentando igual igual desde 4.1.0, pero con RAJNX y el mismo problema., imposible. He probado el nsp y el xci convertido a nsp con identicos resultados. ¿Alguien sabe algo, no se puede intalar en estas versiones?
Chaky escribió:
SUGUSAPPLE escribió:Buenas

Tengo el sx os 2.0 con el fw de 4.1.0 y estoy intentando instalar el nsp del dragón ball fighters pero no me deja, voy con la última versión de tinfoil. Alguien le pasa lo mismo?

Saludos


Yo lo estoy intentando igual igual desde 4.1.0, pero con RAJNX y el mismo problema., imposible. He probado el nsp y el xci convertido a nsp con identicos resultados. ¿Alguien sabe algo, no se puede intalar en estas versiones?


Yo juego sin problemas usando el xci, pero yo estoy en versión de firmware 5.1.

Contanto que es un juego nuevo, podría ser que le problema es que requiere un firmware superior al que usais ?

Si instalais el nsp covertido o modificado, puede que le hayan quitado el requisito de firmware mínimo en el xml y no diga nada y simplemente no funcione porque haga uso de algo que no está en el 4.1.0.
@rugalb2k
Eso ya son varias cosas.
Yo estoy en 6.0 vía chaidojuir y no use jamás tinfoil para nsp la verdad....ahora cada uno lo que quiera
falque escribió:Buenas! He actualizado Reinx a la versión 1.7... Pero ahora me encuentro con que no me lee mis copias de seguridad antiguas, solo las que instalé a tras la instalación de REinx. Pero si vuelvo a reinstalarlos tampoco puedo. Intuyo que quizás tenga algo que ver con tinfoil, ya que tengo la versión 0.0.1.

Como puedo actualizar la versión del tinfoil? Leí por aquí que metiera el archivo .nro en la raíz de la SD y lo ejecutara. Pero no encuentro forma de ejecutarlo.

gracias

PD: Me actualizó. Ya he podido actualizar Tinfoil, sin embargo sigue sin correr esos nsp, incluso volviendo a cargarlos desde el ordenador en la SD



perdon por mi ignorancia, pero no puedo actualizar.
como lo hiciste? como ejecutaste el .nro?

editado.
que tonto soy, lo tenia que lanzar desde el hbmenu.
a mí no me van ahora, el hbmenu me dice que no se encuentran aplicaciones dentro de la SD. Sin embargo la carpeta Switch existe.
pero si le doy a un juego me sale que no se puede cargar
como va la instalacion online de NSP? sigue cascando?

me esperare entonces con los NSP grandes (actualizaciones) ...ya que en FAT32 la consola no me da ningun problema

Saludos
luzifers escribió:
Chaky escribió:
SUGUSAPPLE escribió:Buenas

Tengo el sx os 2.0 con el fw de 4.1.0 y estoy intentando instalar el nsp del dragón ball fighters pero no me deja, voy con la última versión de tinfoil. Alguien le pasa lo mismo?

Saludos


Yo lo estoy intentando igual igual desde 4.1.0, pero con RAJNX y el mismo problema., imposible. He probado el nsp y el xci convertido a nsp con identicos resultados. ¿Alguien sabe algo, no se puede intalar en estas versiones?


Yo juego sin problemas usando el xci, pero yo estoy en versión de firmware 5.1.

Contanto que es un juego nuevo, podría ser que le problema es que requiere un firmware superior al que usais ?

Si instalais el nsp covertido o modificado, puede que le hayan quitado el requisito de firmware mínimo en el xml y no diga nada y simplemente no funcione porque haga uso de algo que no está en el 4.1.0.


Me contesto a mi mismo, con la ultima del tinfoil ya el mismo error te da la respuesta. Te dice que posiblemente sea porque la version del nsp es mas actual y no puedas descifrarlo. Yo pensaba que en esos casos si instalaba pero en el menu aparecia en gris.
Tengo una duda chicos, tengo el xenoblade 2 original, si quiero ponerme el backup en la microsd, el save sigue siendo valido o tendría que hacer algo o empezar de nuevo?
@dawgun el save se guarda en un archivo aparte, asi que si haces un backup de tu original, si usas un XCI o si instalas....mientras no borres los datos del juego, ahi se quedara y se podra usar con cualquier formato (probado con XCI y NSP)

Saludos
@hellionz Muchisimas gracias! Me quedo mas tranquilo entonces

PD: Un tal s-arash en gbatemp dice que el desarrollo de tinfoil y el creador, Adubbz no va a continuarlo mas. ¿Sabéis algo del asunto?
@dawgun Sí, que le tocaron los cojones seriamente (con perdón) clonándole la aplicación, mezclándola con otro montón de cosas de homebrew sin dar mención a la procedencia y le tocó las narices descaradamente. Dijo hoy en discord que la comunidad era muy tóxica y que se tomaría un descanso.
Siempre tendreis deez del creador de nut, que aunque está en beta en algunas cosas como en el borrado de tickets es muy superior a tinfoil (en mi opinión). Ademá os permite crear un sevidor en el pc para instalar desde ahí los juegos.
Como ando liado y no quiero responder a mil preguntas sobre el funcionamiento no cree post, pero si alguno quiere crearlo:
https://github.com/blawar/nut/tree/master/dz
@JulesRussel Estoy enamorado de este programa. A ver si termina de arreglar la instalación de DLCs, que no termina de chutar, y que por favor le añada el nombre a los tickets que me voy a dejar los ojos buscando la correspondencia entre ticket id y el nombre del juego [carcajad]
@malvado24 Vuelve a bajar el .nro El nombre de los tickets sale en los juegos, en dlc y actualizaciones, en mi versión al menos no sale aún pero si tienes el juego instalado se ven fácil por el title id.
En los dlc no puede sacar el nombre ya que no está en el meta, en las actualizaciones no se porqué no lo hace. Los dlc podría asociarlos por la id si está el juego base instalado, la verdad.
Imagen
Y sí, por si alguien se lo pregunta aún tengo tickets. Esta es mi nand de pruebas XD
Tengo un par de dudas.
La instalacion de nsp por red como va?
Y la instalacion nsp por usb como funciona?
Gracias y saludos
@malvado24 Blake ya arregló lo de los dlc en deez, por lo que se comentaba en discord.
paxama escribió:Tengo un par de dudas.
La instalacion de nsp por red como va?
Y la instalacion nsp por usb como funciona?
Gracias y saludos

Me uno a tu pregunta compañero.
@JulesRussel Ahora sí. El tema de los nombres en los tickets es curioso, a falta de hacer más pruebas, sólo me los muestra cuando instalo los nsp desde el propio dz, no desde sx.
Una pregunta... ¿cómo se puede saber el titleid de un nsp?
Abriendo el nca con hactool te lo muestra, pero para sacar el nca del nsp necesito el titleid (al menos para pasarlo por nut)
@malvado24 En mi nuevo cleaner no have falta, lo lee del meta nca.
Lo añadí desde la versión 0.4. La última sería una pseudo 0.42 pero está aún sin publicar, puedes usar la 0.41 o bajarte el máster de GitHub.
1568 respuestas
15, 6, 7, 8, 932