[HO] Atmosphère CFW (Atmosphère 1.2.2 ) - Compatible con 13.1.0 y con emummc.

Baldman escribió:
davidDVD escribió:Parece que al final se han decidido por EL2 Emunand, en vez de la opción FS module [oki]

17 feb: There are two ways to do this -- do we want to virtualize NAND reads using EL2, or patch the FS module?

Probably the first one is preferable, but it'll also be a lot of work. A decision needs to be made here.

27 mar: We're doing EL2.


Una buena noticia!! Aunque quizás retrase un poco la salida por tener más trabajo de por medio...

me alegro pues de haber actualizado a 4 y poder pillar varios juegos, aparte de poder jugar al zelda con su actualizacion de juego. tampoco era plan de gastarse uno mas de 300 euros para tenerla guardada a la espera de que pudiera o no salir algo de scene
@SCORPION_XP Seguramente EL2 ya que es la modificación a mas bajo nivel por lo que a nivel de aplicaciones es transparente a ellas, solo el digamos "kernel" del sistema tendria la modificacion.

Saludos
Raugo escribió:@SCORPION_XP Seguramente EL2 ya que es la modificación a mas bajo nivel por lo que a nivel de aplicaciones es transparente a ellas, solo el digamos "kernel" del sistema tendria la modificacion.

Saludos


https://github.com/SciresM/Atmosphere-NX/issues/8


Entiendo que "EL2 driver" es a nivel de Kernel y se refiere a que en la TZ (TrustZone) puede llamar a ese driver en vez de al chip.

El FS module creo que es simplemente parchear el registro de arranque principal para redirigirlo y lo otro es prácticamente crearlo de 0.

Con la segunda opción (si se hace correctamente, claro) el riesgo de brick/update de la nand real sería nulo, porque se inutiliza totalmente la NAND, ya que directamente el Custom Kernel ni detectaría la NAND como componente... No?
Ains que ganas de que llegue ya :(
Me he comprado una switch que me ha venido en 3.0.0 y la verdad que la queria por jugar al mario odissey, pero ahora viendo esto no se si actualizarla a 3.01 o dejarla en 3.0...

Tan importante es la 3.0 frente a la 3.01???

Menudo dilema....

Saludos!!
Puking escribió:Ains que ganas de que llegue ya :(
Me he comprado una switch que me ha venido en 3.0.0 y la verdad que la queria por jugar al mario odissey, pero ahora viendo esto no se si actualizarla a 3.01 o dejarla en 3.0...

Tan importante es la 3.0 frente a la 3.01???

Menudo dilema....

Saludos!!


El dilema es que vas a tener que esperar a sabe dios cuando si subes a 3.0.1 . Si vas a usar el chip pues te da igual la versión de firmware que tengas. Ahora te digo que el chip puede ser muy caro y sale en primavera pero hace bastante que no dan señales de vida.
Normanito está baneado por "Troll"
Trentito escribió:El dilema es que vas a tener que esperar a sabe dios cuando si subes a 3.0.1 . Si vas a usar el chip pues te da igual la versión de firmware que tengas. Ahora te digo que el chip puede ser muy caro y sale en primavera pero hace bastante que no dan señales de vida.


Cuanto crees que va a costar mas o menos el chip, 150 euros?
Normanito escribió:
Trentito escribió:El dilema es que vas a tener que esperar a sabe dios cuando si subes a 3.0.1 . Si vas a usar el chip pues te da igual la versión de firmware que tengas. Ahora te digo que el chip puede ser muy caro y sale en primavera pero hace bastante que no dan señales de vida.


Cuanto crees que va a costar mas o menos el chip, 150 euros?


No sé decirte pero seguro que los 100€ no se lo quita nadie.
Normanito escribió:
Trentito escribió:El dilema es que vas a tener que esperar a sabe dios cuando si subes a 3.0.1 . Si vas a usar el chip pues te da igual la versión de firmware que tengas. Ahora te digo que el chip puede ser muy caro y sale en primavera pero hace bastante que no dan señales de vida.


Cuanto crees que va a costar mas o menos el chip, 150 euros?


El chip sin soldaduras igual cuesta eso (149.9€), y con soldadura unos 99.9€, evidentemente te lo estoy diciendo a lo loco, de momento los precios no se saben pero basandome en otros chips y encima que van a ser los primeros en lanzar algo de esto, seguramente inflen el precio ya que la empresa encargada de de vender estas cosas sabe que tienen los días contados (seguro que al poco vendrán los clones Chinos a mitad de precio y la scene por software) y necesitan ganar lo máximo posible en un corto peíodo de tiempo pero sin ser un precio desorbitado.

Saludos
Dudo mucho que valga tanto teniendo en cuenta que la scene les pisa los talones, ademas el xecuter coolrunner de 360 por ejemplo si no recuerdo mal salio por 20€, cierto es que había mas competencia pero vamos dudo mucho que valga mas de 70 u 80€.

Saludos
Normanito está baneado por "Troll"
Raugo escribió:Dudo mucho que valga tanto teniendo en cuenta que la scene les pisa los talones, ademas el xecuter coolrunner de 360 por ejemplo si no recuerdo mal salio por 20€, cierto es que había mas competencia pero vamos dudo mucho que valga mas de 70 u 80€.

Saludos


Una pregunta, el chip solo sirve para tener el cfw, y si es asi, si el chip es sin soldadura, se puede quitar despues de tener cfw?
@Normanito Aun no se sabe nada pero lo dudo, a menos que alguien haga publico el exploit del bootrom tendras que dejarlo puesto. Si se hace publico pues supongo que se podria usar el chip para instalar el exploit y luego quitarlo.

Saludos
Y no pensáis que en cuanto Nintendo saque el nuevo SoC liberarán el exploit, aunque el exploit afecte a otras plataformas, si ya han avisado de la vulnerabilidad, no creo que tarden mucho en soltarlo.

Saludos
Raugo escribió:Dudo mucho que valga tanto teniendo en cuenta que la scene les pisa los talones, ademas el xecuter coolrunner de 360 por ejemplo si no recuerdo mal salio por 20€, cierto es que había mas competencia pero vamos dudo mucho que valga mas de 70 u 80€.

Saludos

La 3ds esta mas que reventada y han sacado la stargate qie no tiene nada nuevo a 120€ de lanzamiento.

No veo descabellado que el chip de salida ronde los 120€
@CrusardGameamos Los de gateway/stargate siempre han sido bastante careros los de xecuter nunca han sacado un chip a un precio tan caro. Ademas ¿120€? Eran creo recordar 90$ unos 75-80€ al cambio.

PD: Para hablar del xecuter mejor aqui hilo_exploit-team-xecuter-para-todas-las-versiones-posible-modchip-anunciado_2268969 vamos a intentar no desviar mas el hilo.

Saludos
@CrusardGameamos Stargate 3DS valía de lanzamiento 80€, no se de donde sacáis esos precios?
Y ningún flashcard ha sido tan caro, el Gateway 3DS, el primero en aparecer, valió 65€ en su lanzamiento.
El modchip no creo que valga mas de esas cifras y si vale mas van a vender bien poco con el CFW a la vuelta de la esquina.

Salu2!
@egarrote Vender van a vender...

Porque lo que ellos venden (TX) es poder acceder al Bug ya estés en 5.0.0 o en el que sea... Y a partir de ahí instalar su CFW o lo que sea (no se sabe si están trabajando en uno propio; o puede que se lo tomen "prestado" a ReSwitched).
Trentito escribió:
Puking escribió:Ains que ganas de que llegue ya :(
Me he comprado una switch que me ha venido en 3.0.0 y la verdad que la queria por jugar al mario odissey, pero ahora viendo esto no se si actualizarla a 3.01 o dejarla en 3.0...

Tan importante es la 3.0 frente a la 3.01???

Menudo dilema....

Saludos!!


El dilema es que vas a tener que esperar a sabe dios cuando si subes a 3.0.1 . Si vas a usar el chip pues te da igual la versión de firmware que tengas. Ahora te digo que el chip puede ser muy caro y sale en primavera pero hace bastante que no dan señales de vida.

Vamos que lo mas recomendable es intentar tener paciencia no?
Según veo hasta 3.0 el cfw de aquí a verano puede que esté listo no?
El problema está desde 3.01 hasta el 4.1 que si que han confirmado que habrá pero que tardará bastante en llegar no?
Despues está el tema del chip, que con eso da igual la versión en la que estes, pero eso al ser hardware tendrá los inconvenientes de que costará una pasta y de que la garantía de la consola peligra...

Es así, verdad?
Saluudos!!!’
Puking escribió:
Trentito escribió:
Puking escribió:Ains que ganas de que llegue ya :(
Me he comprado una switch que me ha venido en 3.0.0 y la verdad que la queria por jugar al mario odissey, pero ahora viendo esto no se si actualizarla a 3.01 o dejarla en 3.0...

Tan importante es la 3.0 frente a la 3.01???

Menudo dilema....

Saludos!!


El dilema es que vas a tener que esperar a sabe dios cuando si subes a 3.0.1 . Si vas a usar el chip pues te da igual la versión de firmware que tengas. Ahora te digo que el chip puede ser muy caro y sale en primavera pero hace bastante que no dan señales de vida.

Vamos que lo mas recomendable es intentar tener paciencia no?
Según veo hasta 3.0 el cfw de aquí a verano puede que esté listo no?
El problema está desde 3.01 hasta el 4.1 que si que han confirmado que habrá pero que tardará bastante en llegar no?
Despues está el tema del chip, que con eso da igual la versión en la que estes, pero eso al ser hardware tendrá los inconvenientes de que costará una pasta y de que la garantía de la consola peligra...

Es así, verdad?
Saluudos!!!’


Si, quizás con suerte este para verano.
Si, esta gente ya se le conoce por poner precios altos a sus chip.
Con el chip olvídate de la garantía, por software supongo que se podrá hacer algo para que no se note.
egarrote escribió:@CrusardGameamos Stargate 3DS valía de lanzamiento 80€, no se de donde sacáis esos precios?
Y ningún flashcard ha sido tan caro, el Gateway 3DS, el primero en aparecer, valió 65€ en su lanzamiento.
El modchip no creo que valga mas de esas cifras y si vale mas van a vender bien poco con el CFW a la vuelta de la esquina.

Salu2!

Creo recordar haberla visto a ese precio en alguna tienda despues de su anuncio para recompra.

Suerte que yo consegui una gratis :)

Dejemos el tema que lo estamos desviando.
https://gbatemp.net/threads/atmosphere- ... es.499907/

CFW para verano en TODAS la versiones via fusée gelée?

Seria la p...
@GHETTOBLASTER Sí... Fusée gelée es Coldboot (lo que venderá Team Xecuter, pero gratis; para todos los que tengan FW <4.1.0).

P.d: Pues me imagino que ya han reportado a todos (Google, Tesla, Nvidia, etc) y lo van a liberar; yo ya lo aventure, "más pronto que tarde el Coldboot" jejeje... Notición sin lugar a dudas; CFW + Coldboot desde 1.0.0 hasta 4.1.0 para veranito (si todo va bien).

Dice que puede que salga algo un poco antes, para 1.0.0 vía Jamais Vu (TrustZoneHack).


Edito: Cuidao'... Pone All Firmwares... ¿Ha especificado si entra 5.X? Se sobreentiende que sí;
pero no sé, luego recalca que permanezcamos en 4.1.0 o menos... En fin, a esperar más datos.
Normanito está baneado por "Troll"
Trentito escribió:Si, quizás con suerte este para verano.
Si, esta gente ya se le conoce por poner precios altos a sus chip.
Con el chip olvídate de la garantía, por software supongo que se podrá hacer algo para que no se note.


¿La garantia se te quita al abrir la switch? Si es por el tema de que vean un chip dentro, ¿con el chip sin soldadura se arregla no?
TODAS LA VERSIONES

hablan incluso de versiones 5.0.X, solo depende que sea la revision antigua de la switch. :O :O

(recomiendan no pasar de 4.1 aun y todo, pero mas que nada por evitar posibles inconvenientes)

noticion, team xecuter no se va a comer nada a este paso.
Teniendo en cuenta que dicen que los que estén en 4.1 no actualicen imagino que con todas las versiones se refiere a que una vez instalado podemos actualizar, no creo que funcione en 5.0 directamente aunque quien sabe, habra que esperar a que den mas datos.

Saludos
Team Xecuter va a vender... Fusée gelée es íntegramente vía Software y Nintendo lo puede chapar chapando el Exploit de la TrustZone; tienes que ir de menos a más para llegar, es parcheable... Lo de Team Xecuter (aunque nada es seguro en esta vida) no lo es.

@Raugo ¿Crees que se referirá a que será Coldboot para todas menos para 5.X? Pero Fusée gelée es Coldboot... No nos puede dejar así XD
Super Noticia!!! , Dice que en todas las versiones con el hardware actual!!! Vamos que mientras tengamos las switch actuales y no las nuevas tendrá todo el mundo CFW [beer]
@davidDVD Lo dudo, el coldboot es indiferente de la version de firmware, por eso creo que mas bien es al contrario. Podremos tener el CFW en cualquier version pero para instalarlo habra que tener 4.1 o menos supongo.

Saludos
@Raugo Pero entonces la parte de que será menos conveniente... No sé, para mí se contradice lo del principio con la última parte.

En fin... Esa parte que sería la más importante a mi juicio, no lo aclaró del todo...

Edito: Podría ser... Que para <4.1.0 sea vía Software y para >5.X Hardware... No sé...
Eso de menos conveniente me huele muy raro (o soy yo que lo interpreto mal).


@Normanito Evidentemente; si abres la consola, pierdes la garantía... Para lo de
Xecuter es necesario abrir la consola (a priori, porque no han enseñado nada).
Que vamos a tener CFW este verano? Toma!!!!! [amor] No me muevo de 4.1.0 por absolutamente nada, que ganas!!!
Parece que la cosa esta bastante movidita en el discord. Al parecer alguien ha portado pegaswitch a 4.x

Saludos
Raugo escribió:Al parecer alguien ha portado pegaswitch a 4.x

Saludos


que regalamos esta noche?? [beer] [beer] [beer] [beer]
3 meses de espera para el cfw pufdfff un poco mala la noticia...
Algo mas de informacion:

SciresM - Today at 12:13 AM
It's in everyone's interest to dump their console's CAL0 partition (id == 27, in dump_bis.js). This contains all of your console's unique factory programming -- your client cert + privkey, your console's ticket RSA keys, etc etc.
And, in addition, to dump their keyblobs from their console's unique Boot0 partition (id == 0, in dump_bis.js).
If the absolute worst happens, and your console's nand gets destroyed or something
With a dump of those two partitions you can re-create your nand and get your console booting (and going online)
That's the minimum information you need. You'll likely want full backups
but those two combined are < 5 MB
And so there's no reason not to backup yours if you can.


Parece que extrayendo unos 5MB de información de nuestra nand podemos recrear una desde 0 Ademas segun parece Fusée Gelée funciona sin tener que instalar nada, segun Kate cualquier consola actual puede cargarlo recien sacada de la caja.

Saludos
Raugo escribió:Algo mas de informacion:

SciresM - Today at 12:13 AM
It's in everyone's interest to dump their console's CAL0 partition (id == 27, in dump_bis.js). This contains all of your console's unique factory programming -- your client cert + privkey, your console's ticket RSA keys, etc etc.
And, in addition, to dump their keyblobs from their console's unique Boot0 partition (id == 0, in dump_bis.js).
If the absolute worst happens, and your console's nand gets destroyed or something
With a dump of those two partitions you can re-create your nand and get your console booting (and going online)
That's the minimum information you need. You'll likely want full backups
but those two combined are < 5 MB
And so there's no reason not to backup yours if you can.


Parece que extrayendo unos 5MB de información de nuestra nand podemos recrear una desde 0 Ademas segun parece Fusée Gelée funciona sin tener que instalar nada, segun Kate cualquier consola actual puede cargarlo recien sacada de la caja.

Saludos



Se aproxima tutorial para hacer respaldo de esa info a que si jeje
¿Entonces los que estamos en 3.0.0 podemos actualizar a 4.1 para el Mario o el xeno?
Trentito escribió:¿Entonces los que estamos en 3.0.0 podemos actualizar a 4.1 para el Mario o el xeno?


Quedate en 3.0.0 siempre podrás actualizar a 4.1.0 pero volver hacia atrás no y cuanto más abajo mejor.
Trentito escribió:¿Entonces los que estamos en 3.0.0 podemos actualizar a 4.1 para el Mario o el xeno?

Para qué vas a subir a 4.1.0... En todo caso, sube a lo que te pida la Tarjeta de juego y ya está (3.0.1 para Mario y 3.0.2 para Xeno 2).


@Raugo Buenísima información [oki]

Me parece que voy a ir quitándome del medio la 2.1.0 y a quedarme sólo con la 4.1.0 :-|

P.d: Si me dicen que Fusée Gelée es válido para todas las Switch actuales, yendo directo al Bug al sacarla de la caja... Yo diría que la única desventaja de estar en >5.X sería el no tener TrustzoneHack... Pero siguen sin aclararlo.


Edito: Vale, según parece @ktemkin ha arrojado algo de luz al asunto del "menos conveniente" (en referencia a >5.X):

Kate Temkin on Discord:

the "somewhat less convenient" is an attempt to quantify the amount you should want a firmware 4.1.0 or lower We just wanted to make sure nobody was e.g. buying multiple switches so they could play the latest games on 5.0.x while holding onto a 4.1.0 because they thought a 4.1.0-or-lower was required. I wouldn't say you're in hard-mode territory, let alone hardmod territory if you're on latest. :)

No se hará más difícil, ni perderás funciones ni nada por el estilo ;)
Raugo escribió:Parece que la cosa esta bastante movidita en el discord. Al parecer alguien ha portado pegaswitch a 4.x

Saludos


fuente ? no lo he visto por GBA
Normanito está baneado por "Troll"
@davidDVD ¿Qué es trustzonehack?
Normanito escribió:@davidDVD ¿Qué es trustzonehack?

Una vulnerabilidad explotable que toma el control del supervisor de eventos del sistema, el encargado de evitar que hagamos cosas que no debamos, dicho asi rapido y mal.
Normanito está baneado por "Troll"
CrusardGameamos escribió:Una vulnerabilidad explotable que toma el control del supervisor de eventos del sistema, el encargado de evitar que hagamos cosas que no debamos, dicho asi rapido y mal.


Acabo de ver el hilo de Atmosphere, ¿por que dice david que no tener trustzonehack en menos de 5.0 es una desventaja si en el hilo pone que por trustzonehack habria que instalar otra vez el cfw cada vez que apagas la consola? Puede que igual lo haya entendido mal

Un saludo
Normanito escribió:
CrusardGameamos escribió:Una vulnerabilidad explotable que toma el control del supervisor de eventos del sistema, el encargado de evitar que hagamos cosas que no debamos, dicho asi rapido y mal.


Acabo de ver el hilo de Atmosphere, ¿por que dice david que no tener trustzonehack en menos de 5.0 es una desventaja si en el hilo pone que por trustzonehack habria que instalar otra vez el cfw cada vez que apagas la consola? Puede que igual lo haya entendido mal

Un saludo

Es un poco lio, tener acceso al kernel es tener acceso a la consola pero sin modificar nada ya que el trustzone lo detectaria, pero si eres capaz de modificar el trust zone no lo detectaria y por lo tanto podrias tener cfw permanente.

Esta explicado asi rapido y mal, pero creo que no va a ser necesario porque por lo que dicen saldra con coolboot, es decir, parchear el firmware en cada inicio de la consola.
Normanito escribió:Acabo de ver el hilo de Atmosphere, ¿por que dice david que no tener trustzonehack en menos de 5.0 es una desventaja si en el hilo pone que por trustzonehack habria que instalar otra vez el cfw cada vez que apagas la consola? Puede que igual lo haya entendido mal

Un saludo

Lo voy a tachar... Era una suposición porque no había información y tampoco la leí en el foro [+risas]

Si te fijas, abajo edité con la información auténtica; la ya corroborada [oki]

Kate Temkin on Discord:

the "somewhat less convenient" is an attempt to quantify the amount you should want a firmware 4.1.0 or lower We just wanted to make sure nobody was e.g. buying multiple switches so they could play the latest games on 5.0.x while holding onto a 4.1.0 because they thought a 4.1.0-or-lower was required. I wouldn't say you're in hard-mode territory, let alone hardmod territory if you're on latest. :)

La dejo de nuevo por si acaso...
Perdonad, entonces... ¿Da igual 3.0.0 que 4.1.0?
kie1313 escribió:Perdonad, entonces... ¿Da igual 3.0.0 que 4.1.0?

Siguen diciendo que no actualicemos.
kie1313 escribió:Perdonad, entonces... ¿Da igual 3.0.0 que 4.1.0?

Segun parece, da igual que estés en 1.0.0 hasta 5.0.1... El método va a ser el mismo.

Vamos, según dice la persona que descubrió fusée gelée... Ni es más difícil en 5.0.X ni hará falta hardmod.
Gracias.

Lo que me suponía.... No está claro [carcajad]
kie1313 escribió:Gracias.

Lo que me suponía.... No está claro [carcajad]

No... Está claro a mi parecer... Vamos para eso salió Kate Temkin a explicar la expresión que usó SciresM ayer, para aclarar que los que estéis en 5.0.X no tendréis problemas para usar fusée gelée (ni Hardmod, ni más difícil si estás en el último FW...) XD
davidDVD escribió:
kie1313 escribió:Perdonad, entonces... ¿Da igual 3.0.0 que 4.1.0?

Segun parece, da igual que estés en 1.0.0 hasta 5.0.1... El método va a ser el mismo.

Vamos, según dice la persona que descubrió fusée gelée... Ni es más difícil en 5.0.X ni hará falta hardmod.

Lo ultimo oficial que han dicho es que no actualicemos, lo de kate es algo que ha visto, pero eso no significa que lo vayan a lanzar el mismo dia que el cfw.
CrusardGameamos escribió:Lo ultimo oficial que han dicho es que no actualicemos, lo de kate es algo que ha visto, pero eso no significa que lo vayan a lanzar el mismo dia que el cfw.

Ya, yo no estoy diciendo que todo el mundo actualice a 5.0.1... Yo solo digo lo que ha dicho, que es posible
en 5.0.X y sin hardmod ni nada raro (aclaró lo que dijo SciresM con lo de "menos conveniente").

A partir de ahí, ya cada uno que haga lo que quiera [+risas]
10596 respuestas