[ACTUALIZADO 18/05/2019] Instalación de modchip interno (RCM-X86)

1, 2, 3, 4, 57
Han publicado la 0.9.7 con la que se puede cambiar de payload con pulsación larga de vol+

Entre que no mucho hacen la instalación de vol+ y que algunos chips tienen que cambiar el pinout creo que a parimtir de ahora ya no vale la pena actualizar para un uso básico.
@josete2k Gracias, acabo de verlo. Efectivamente, en mi caso me dejaré de preocupar ya y me quedaré en 0.9.6. Salu2
medievale escribió:@josete2k Gracias, acabo de verlo. Efectivamente, en mi caso me dejaré de preocupar ya y me quedaré en 0.9.6. Salu2



Una cosa sí que está mejor y es que ha depurado un poco el tema de backup/restauración de nand con hekate... Pero bueno, yo siendo usuario de sxos (y a sabiendas que sxos no precisa tampoco licencia para operar) tampoco le veo sentido salvo si se te rompe la conexión sd...y si se rompe la sd no hay forma de meter un backup de nand...
Buenas, vuelvo a consultar,que aun tengo dudas pero ya tengo el chip, solo no quiero cometer un error

por lo que he leido en el primer post, necesito tener la instalacion de 6 cables para que al encender la consola, entrar directamente a un CFW? si hiciera el de 4 cables tendria que hacer la modificacion del joycon y presionar botones cierto? el metodo que tu utilizaste para dual boot que es de 5 cables es para elegir al encender el cfw o sin cfw la consola? para mi entonces seria el de cables para que inicie en cfw, pues por todo lo que leido aqui y otros post, veo que el baneo llega si o si. Lo ultimo, viendo la foto de la instalacion, ese es el mejor lugar para ubicar el chip y todos los puntos a soldar estan sobre la placa, no es necesario sacarla completa y soldar por debajo?
No hay que soldar por debajo.

Con la instalación "media" y autorcm tienes exactamente lo que buscas. Te ahorras un cable (de los complicados) y si elndiayde mañana quieres dualboot desactivas autorcm y listo.

La única ventaja que tiene el modo "completo" es que es, en teoría menos detectable por Nintendo ya que la entrada en rcm es por hardware y no corrompiendo el boot0.
Hola. Esta instalación permitiría iniciar con firm normal para juego online con originales e inicio cfw para cargar homebrew?
MKB escribió:Hola. Esta instalación permitiría iniciar con firm normal para juego online con originales e inicio cfw para cargar homebrew?


La instalación dual boot de 6 cables si, trata de eso exactamente
Actualizado a 7.0.0 y la emunand no funciona... Esta noche probaré a restaurar 6.2.0.
Surfi89 escribió:
MKB escribió:Hola. Esta instalación permitiría iniciar con firm normal para juego online con originales e inicio cfw para cargar homebrew?


La instalación dual boot de 6 cables si, trata de eso exactamente


Gracias. No entiendo porque la gente usa dongles y emunand en la sd pudiendo hacer esto, cual es el inconveniente?

El que has puesto en el tuto ya no esta disponible, donde lo puedo conseguir?
@MKB Igualmente necesitas emunand, te ahorras el dongle.

Saludos
Raugo escribió:@MKB Igualmente necesitas emunand, te ahorras el dongle.

Saludos


Pero la segunda nand se almacena en el modchip en lugar de en la nand original o en la sd no?
@MKB La segunda nand se almacena en la SD tengas o no chip, el chip es solo un dongle pero soldado dentro no tiene ninguna facultad mas.

Saludos
Raugo escribió:@MKB La segunda nand se almacena en la SD tengas o no chip, el chip es solo un dongle pero soldado dentro no tiene ninguna facultad mas.

Saludos


oook gracias por la info, seria buena cosa que implementaran algo asi.
@Surfi89
Hola!!
Tu o @josete2k tuvisteis problemas para sacar algún tornillo?

Yo los mios de estrella tamaño 000 de arriba junto a la salida de aire y de abajo junto al usb, tela, estaban durísimo y he podido sacar todos menos el del lado derecho del usb mirando desde la parte de atrás de la switch.

El problema es que enseguida se ha perdido la forma de la cabeza del tornillo y no hay forma de sacarlo, a pesar de usar destornillado de ese tamaño....

¿Alguna idea? Sólo me falta ese para poder abrir la tapa..... lo tengo con una masa que endurece unido a un destonillador.... a ver si cuando endurezca consigo la fricción necesaria para terminar de sacarlo (le quedarán un par de vueltas...) pero vaya choff que no haya podido ni llegar a abrir la switch...
Pues yo la verdad los saque todos bien, sin tener que hacer un esfuerzo mayor ni nada, simplemente usar el destornillador correcto para cada tornillo y listo.

Tampoco tengo idea de como puedes sacarlo si te has comido la cabeza, en algun sitio lei que era posible sacar tornillos con la cabeza comida pero no recuerdo como.

Siento no ser de ayuda.. saludos y suerte!
@josete2k gracias por responder, usare entonces el de rcm de 4 cables, el que no usa el jig, aunque ahora quede con la duda, de usar la consola en modo dock, dices que salio una modificacion que ademas agrega un cable, para cuando se use el modo dock? quede medio perdido con eso.
hola buenos dias,estoy pre estañeando el chip para montarlo,no tuve tiempo tanto trabajar.veo que en el esquema hay 3 puntos para sacar los 3.3V. El mas corto, el de al lado del joycon y el de la nand. cual es preferible usar? muchas gracias.
@vitalus

Depende de tus habilidades de soldadura. El de la nand aunque está más lejos es más fácil y supone un riesgo menor.

Editado el 05/02/2019

@Surfi89 , finalmente lo he instalado, me ha dado más guerra los tornillos que te comenté que las soldaduras....

La única que me llevó más tiempo fué la de la masa que hay junto al USB, me encabezoné en querer soldar en ese punto y como muy bien dijo @josete2k en las masas necesitas mucha temperatura, yo trabajaba a 300 grados, así que el estaño se iba el solito hacia la zona metálica del tornillo del usb, por lo que al final soldé ahí.

Respecto al punto del joycon, a pesar de ser pequeño, con una buena lupa y luz se puede hacer sin problema, más miedo me daba el nuevo punto que evita que se quede en RCM la consola si la enciendes con vol + en el dock, ya que tenia muy cerca pequeños transistores o resistencias. Así que tanto ese punto como el del joycon los rodee con la cinta kapton que me comentaste para proteger del calor y evitar cargarmelos.

El punto del joycon se supone que hay que cablearlo usando el cable dorado más fino que viene con el chip, pero yo no fuí capaz de que se soldade, no se estañaba de ninguna manera, así que al final lo hice con un cable de los otros y sin problema, aunque el flex que hay a la altura de esa soldadura queda justito por la anchura del cable, pero conecta....

Así que ahora disfrutando del RCMX86 sin dongle y sin necesidad del iman en el joycon para entrar en RCM, una pasada.

Eso si, como os comenté, los tornillos PH 000 de los lados del usb y el de arriba junto a la salida del ventilador, me dieron muchos problemas ya que estaban muy duros y se les dehacía la cabeza enseguida, no se si es que están defectuosos... ya que con el resto de tornillos no he tenido ningún problema.

Por cierto, al volver a montar perdí el tornillo del lector de la sd..... al cogerlo con una pinza de precisión salió volando... y no lo he encontrado... aunque una vez montada la switch, parece no tener más importancia....

Buscaré a ver si venden tornillos de sustitución y así cambio también los 3 que me han dado problemas.

@Surfi89, animate a poner el cable que te falta, es mucho más comodo que el imán...

Saludos!!
Hola el domingo termine de instalar mi RCMX86 interno (ya pondre alguna foto.) Con la instalación como josetek2,(dual boot con el punto D4_6 cables.)en mi switch,dar las gracias a todos los que de alguna manera habéis colaborado en dar información en el hilo. Y comentar que no tuve ningún problema al desmontaje de la consola al usar los destornilladores correctos,ph2.0 y Y 0.0.
El único inconveniente que tuve fue que el cable de hilo de cobre no lo solde,costaba mucho y por miedo a quemar el pcb o levantar alguna pista desisti y solde un cable bueno awg,24. Ya que el punto joy con son muy pequeños.

Tengo una duda, si quisiera instalar sx os. Con el rcmx86 deberia comprar la licencia y meter el payload en la SD y me arrancaria sin problemas? De momento no me quiero liar con dual nand pero ya veremos mas adelante.

Estoy usando ahora atmosphere 0.8.3, también extraje las master key y t-sec keys de mi consola para poder convertir algunos xci a nsp y poder cargarlos bien.

Saludos.
vitalus escribió:Hola el domingo termine de instalar mi RCMX86 interno (ya pondre alguna foto.) Con la instalación como josetek2,(dual boot con el punto D4_6 cables.)en mi switch,dar las gracias a todos los que de alguna manera habéis colaborado en dar información en el hilo. Y comentar que no tuve ningún problema al desmontaje de la consola al usar los destornilladores correctos,ph2.0 y Y 0.0.
El único inconveniente que tuve fue que el cable de hilo de cobre no lo solde,costaba mucho y por miedo a quemar el pcb o levantar alguna pista desisti y solde un cable bueno awg,24. Ya que el punto joy con son muy pequeños.

Tengo una duda, si quisiera instalar sx os. Con el rcmx86 deberia comprar la licencia y meter el payload en la SD y me arrancaria sin problemas? De momento no me quiero liar con dual nand pero ya veremos mas adelante.

Estoy usando ahora atmosphere 0.8.3, también extraje las master key y t-sec keys de mi consola para poder convertir algunos xci a nsp y poder cargarlos bien.

Saludos.


A mi me pasó lo mismo con el hilo de cobre para el punto del joycon y al final lo tuve que hacer con un cable de los otros normales y sin problema.

Respecto a los tornillos, yo usé igual que tu los mismos destornilladores adecuados y solo tuve problemas con eses tornillos. Sospecho que pudede ser porque siguiendo la guía de ifixit, quité todos los tornillos y esos fueron los últimos, y puede que al hacer la carcasa algo de presión hacia afuera costase más sacarlos, es la única explicación que le doy a que estuviesen tan duros... no se...

Respecto a SXOS, si así es, tienes que bajarte el payload.bin de la web de xecuter y el boot.dat de la última versión de SX OS, y así carga sin problemas y ya podrias activar la licencia que compres.
Me llego este pequeñin, he leido bastante, pero siempre mi duda es con el famoso RCM, leyendo vi que ahora se puede agregar un cable extra para evitar un problema con el dock, tambien lei que si instalo todos los cables puedo acceder al rcm por hardware, mi intencion es encender la consola directo a un cfw, sin necesidad de combinacion de botones, no me interesa el online, tambien evitar problemas al ponerla en el dock, y evitar que se descargue completamente estando en rcm. desde ya gracias por la atencion.
Sanji_san escribió:Me llego este pequeñin, he leido bastante, pero siempre mi duda es con el famoso RCM, leyendo vi que ahora se puede agregar un cable extra para evitar un problema con el dock, tambien lei que si instalo todos los cables puedo acceder al rcm por hardware, mi intencion es encender la consola directo a un cfw, sin necesidad de combinacion de botones, no me interesa el online, tambien evitar problemas al ponerla en el dock, y evitar que se descargue completamente estando en rcm. desde ya gracias por la atencion.


Puedes poner todos los cables o hacer la instalación dual (sin el cable que va a VOL+) y activar autorcm.

Personalmente prefiero la segunda opción ya que si deseas arrancar OFW basta con desactivar autorcm.
@josete2k

Yo hice la misma instalación que tú con dualboot y el cable nuevo (RCM strap) desde la versión 0.96.

Lo tengo en versión 0.97 y encendiendo con vol + estando en el dock arranca en SXOS, así que genial.

Lo único es que he probado a conectarla al pc con un cable usb manteniendo el vol + presionado para que entre en RCM y tratar de inyectar un payload con pc, pero me pasa que el TegraRcmGUI detecta que la switch está en RCM pero al intentar inyectar un payload se queda pillado en inyecting payload y no hace nada, teniendo que apagarla con pulsación larga del power.

¿A ti te pasa lo mismo o como se comporta con la versión que tu tienes?
Yo puedo inyectar payload...

Aunque la vez que lo probé tenía autorcm activado.

Pero vamos, debería ir igual.

Con la consola apagada conectar el usb al pc manteniendo vol+.


Prueba la 0.9.8r3 porque han bloqueado la conexión usb una vez el chip se apaga en esa versión.
josete2k escribió:Yo puedo inyectar payload...

Aunque la vez que lo probé tenía autorcm activado.

Pero vamos, debería ir igual.

Con la consola apagada conectar el usb al pc manteniendo vol+.


Prueba la 0.9.8r3 porque han bloqueado la conexión usb una vez el chip se apaga en esa versión.


He probado a ponerle la 0.9.8r3 y se comporta exactamente igual.

Conectando el usb a la switch y manteniendo el vol + se queda la pantalla en negro y el tegrarcmgui detecta el modo rcm pero se queda pillado inyectando.

Arrancando con vol + ahora antes de cargar el payload por defecto da la opción de pulsar vol - y entrar en hekate y desde ahí la pongo en modo RCM, pasa lo mismo, se queda pillado al intentar inyectar por usb.

También lo he intentado usando un movil android y pasa lo mismo, y al desconectar el cable usb tanto en pc como en android se queda bloqueada en rcm y hay que apagar forzando con el power. En alguna ocasión el chip ha autoinyectado el payload de la sd al quitar el cable usb, pero las menos de las veces, lo más habitual es que se quede pillada.

No sé porque será.... todas mis pruebas son con cableado dualboot y sin autorcm....pero bueno, tampoco es un problema ya que puedo inyectar cualquier payload desde la sd.
El autoinyectado desde la sd o hekate ha de hacerlo siempre cuando quitas el cable USB porque el chip está programado para ello.

Mañana no porque tengo día de quirófanos pero nada más pueda lo pruebo yo por si fuera algo a reportar ya que lo ideal es que el chip no actúe mientras tengas un lanzador de payloads externo.
josete2k escribió:El autoinyectado desde la sd o hekate ha de hacerlo siempre cuando quitas el cable USB porque el chip está programado para ello.

Mañana no porque tengo día de quirófanos pero nada más pueda lo pruebo yo por si fuera algo a reportar ya que lo ideal es que el chip no actúe mientras tengas un lanzador de payloads externo.


Espero que no sea nada grave, animo compañero
@josete2k

Gracias por consultar el problema que te comenté en gbatemp, he visto que mattytrog ha respondido.

Creo que tiene razón, alguna soldadura se me ha quedado mal, porque al colocar el chip los cables del usb se llevaron algún que otro tirón.

Repasaré las soldaduras de usb y la de GND, ya que inyectar el payload lo hace sin problemas, pero he podido comprobar que el usb no va bien, me reconoce un usb con juegos el sxos pero a veces da errores de desconexión, por lo que sospecho que es una soldadura que aunque hace contacto a veces falla.

Imagino que es también el origen del problema de la inyección por usb.

Gracias.

Editado el 23/02/2019

@josete2k
Repasé las soldaduras, rehice algunas, y tienen continuidad perfecta, continua y comprobado en puntos de la placa con los pads del chip.

Sigue igual, reconoce el modo rcm tanto el pc como el movil android pero cuando inyecto se queda pillado. Además, cuando se queda pillado inyectando en RCM pero no hace nada, se queda pillado el RCM de forma que el chip ya no hace la autoinyección del payload si en RCM desconectas el USB.
Sin embargo, si entro en RCM con USB conectado pero no inyecto nada y desconecto el USB, inyecta automaticamente el payload de la sd, así que el chip funciona correctamente, excepto que por algún motivo no me permite inyectar en modo RCM a través del USB.

Respecto al puerto usb que me daba algún problema, ya se ha solucionado, no me ha vuelto a dar problemas cargando backups con sxos desde usb.

No se porque no me deja inyectar mediante usb estando en RCM, he probado en 0.9.6 y en la ultima 0.9.8r3.

Por lo demás 0 problemas.

¿Es normal que ahora cuando hago el reset al chip ya solo salga como unidad SWITCHBOOT? Ahora siempre me sale con ese nombre y ponga el UF2 que ponga me lo flashea sin problema.
La primera vez que lo instalé primero salia otro nombre de unidad, creo que INTERNAL y una vez flasheado el internal.uf2 ya salia el SWITCHBOOT para flashear el joycon.uf2
@luzifers No entiendo muy bien...

Hay que flashear con el bootloader (sólo la primera vez):

https://github.com/mattytrog/SWITCHBOOT ... JOYCON.uf2

Y luego meter la versión que quieras:

https://github.com/mattytrog/Simple-UF2 ... V099r1.UF2


Revisa por si acaso que tu chip tenga los pins correctos (en el chip) ya que hubo un cambio en uno de ellos al principio, concretamente el del joycon que pasó del cuarto pin (D3) al tercero (D2). Recuerdo que en D3 me inyectaba payload igual pero es posible que algunas funciones no fuesen las correctas.

Imagen

He estado haciendo perrerías con mi consola y puedo lanzar perfectamente payloads con tegraRCM_gui:

- conectando el cable al pc mientras pulso VOL+
- encendiendo normal, conectar el cable, apagar y encender de neuvo con power y VOL+ al mismo tiempo

de ambas formas, el programa detecta la consola en RCM y me lanza el payload sin problemas.
Hola @josete2k.

Gracias por responder.

Si que es una cosa rara. Repasé y arreglé todas las soldadutas y ahora todas tienen una continuidad perfecta. Chequeado en distintos puntos de la placa.

He repasado el esquema y es identico al que has posteado salvo el cable del vol + que no lo tengo instalado.

La he abierto para chequear y recolocar un poco los cables, ver que el chip está perfectamente aislado por todas partes y no puede hacer ningún corto.
La masa hace contacto perfecto, lo único es que al final la soldé encima de la cubierta metálica del usb en la parte superior, no se si eso puede tener algo que ver, pero lo raro es que el usb va perfecto para todo, actuarlizar el uf2, jugar a juegos en xci desde usb en SXOS, usar el dock, carga, todo... ,menos en modo RCM.

Lo curioso que antes de abrirla me la detectaba en modo RCM aunque luego tenia problemas inyectando, se qudaba pillada. Ahora una vez que la he vuelto a montar, ya no me reconoce el modo RCM el pc, me sale como dispositivo en error.

El caso es que con el uf2 que me pasó mattytrog que deshabilita el chip, funciona todo correctamente puedo inyectar sin problema, así que no se...

Lo único que se me ocurre es cambiar la masa y hacer como tu, que esté atornillada en un lateral del usb....

Editado:

He probado ahora el uf2 que deshabilita el chip y no me reconoce modo RCM por lo que no puedo inyectar.

Sospecho que será algo de la masa. Cuando tenga un rato la cambiaré a ver....
Actualizado con 0.9.9r4a

Los cambios son sustanciales. Uno de ellos es que permite extraer las keys de la consola, incluida la master key 07 que hace falta para descifrar los juegos que vengan en esa versión.
Yo estaba usando un trinket ( que visto lo visto, ...) son todos similares..
y en 6.x iba perfect, pero ahora al actualizar /(7.0) estoy probando a meterle los 5 ficheros que vienen para el trinket y no me arranca con ninguno.
no quiero tocarle la instalacion, porque segun he visto es valida asi...

en la micro sd que estais metiendo? para que arranque, porque me da pantalla negra, y no arranca..
.gracias
Supongo que tendrás que czsmbiar el payload principal.
molix escribió:Chicos, me acabo de comprar la swift y estoy planteandome el ponerle el chip. ¿Sabéis de alguien o algún sitio de confianza?. Soy de Valencia.

Hay un chico en Torrente, que se anuncia en milanuncios.
Yo le llevé la PS3 para un downgradeo y ahora la switch para la instalación del chip. Todo perfecto y rápido.
IMG_6220.jpg
IMG_6219.jpg

IMG_6214.jpg

consigo que me aparezcan estas pantallas ( hekate ) pero no carga nada
en la micro sd tengo esto:

[atmosfere]
[Nintendo]
[sept]
hbmenu.nro

que se me escapa¿


...
El contenido de la sd no es el correcto?
Que contenido debe de llevar aparte de la carpeta Nintendo ? He probado 1000 combinaciones y nada
Que no te reconoce la sd.
Buenas. Hace poco que me han instalado el chip.
Tengo una duda.
¿Se puede usar y es conveniente el autorcm? Más que nada para evitar usar el jig.
Si se usa autorcm, entiendo que al apagarla también se drenará la batería.
¿La forma de apagarla es igual que el chip? Es decir pulsando 20 segundos el botón power ¿o con la versión 0.84 de atmosphere ya se apaga bien? ¿Es indiferente dejarla en el dock?
Saludos.
Si te han instalado el chip como toca no tienes ni que usar el jig ni instalar autorcm.
Pues me han debido de hacer una cosa rara porque sin el jig no me arranca cuando pulso vol+ y power. Sin embargo si lo tengo en el dock con el jigg puesto lo puedo arrancar en CFW sin necesidad de sacarlo del dock.
@juans1369

La switch a mi me arranca en cfw sin sacarla del Dock.

Si necesitas un jig o autorcm para arrancar en cfw es porque no te han conectado el cable que va al joycon y hace que la consola entre automáticamente en rcm.

Yo no le veo encanto al chip interno si dependes del jig.

Preguntale a quien te instaló el chip si te puso el cable que va al joycon derecho, porque si es así esta fallando.
Ese punto de soldadura es el más complicado, a lo mejor por eso no te lo puso y te dijo que usarás el jig o autorcm.
luzifers escribió:@juans1369

La switch a mi me arranca en cfw sin sacarla del Dock.

Si necesitas un jig o autorcm para arrancar en cfw es porque no te han conectado el cable que va al joycon y hace que la consola entre automáticamente en rcm.

Yo no le veo encanto al chip interno si dependes del jig.

Preguntale a quien te instaló el chip si te puso el cable que va al joycon derecho, porque si es así esta fallando.
Ese punto de soldadura es el más complicado, a lo mejor por eso no te lo puso y te dijo que usarás el jig o autorcm.


Me imagino que no habrá puesto el cable del joycon.
En ese caso me decanto por el autorcm, para no depender del jig. Aunque voy a jugar casi siempre con la consola en el dock, por lo que podría dejar puesto siempre el jig. ¿O dejar el jig puesto daña el rail?
He leído en este hilo que al apagar la consola se drena algo la batería. Creo que un 2% en pocos días. ¿Hay alguna forma de apagarla y que no baje la batería o baje lo mínimo?
Saludos.
josete2k escribió:Que no te reconoce la sd.


asi es, parecia que encajaba bien, pero no..
pero ahora tengo otro problema, pantallazo negro, al darle a que me cargue el .bin,
si meto el de reinx, alterna pantallazos entre reinx->atmosphere y asi en bucle.
y si solo dejo el de atmosphere, pantallazo negro.

algo se me escapa del contenido minimo a contener en la micro sd...
A ver si alguien me saca de dudas.

Tengo el chip internamente con todos los straps puestos, es decir siempre me arranca en RCM.

Para actualizar la sysnand oficialmente a 7.01 (OFW) tengo que encender la consola apretando el reset y que el chip no actúe verdad? Es la única forma? Tengo que quemar los efuses sí o sí para poder utilizar el online no?

Si actualizo a 7.01 y no le doy al reset del chip, qué sucedería?
Si vas a usar el online no te recomiendo arrancar siempre en rcm.


Cambia el bootloader del chip por el de joycon_only y así pasarás a tener arranque dual.
Entonces hago El Paso 1 con el fichero de joycon_only y luego vuelvo a actualizar a la última versión del paso 2?

Y duda que tengo medio paranoica. Ayer puse la sd mal metida y al arrancar le di a arrancar con heckate sin querer. La consola claro, arrancó el ofw ya que no detectaba la sd.

Por suerte no estaba conectada a internet. La apaguetal como encendió y asenté bien la SD y ya volvió a arrancar con SX.

La duda es si al arrancar con ese payload “marca” la sysnand aunque no se haya hecho nada.

Tengo mi copia de la sysnand “virgen”, por lo que instalarla no es un problema, pero si no pasa nada me evito ese paso.
Gracias @josete2k Mañana cambio el método instalado en el chip y actualizo la sysnand a la 7.01
337 respuestas
1, 2, 3, 4, 57