[ACTUALIZADO 02/03/2022] Instalación de modchip interno (RCM-X86)

18, 9, 10, 11, 12
SUGUSAPPLE escribió:
DIABLO escribió:Buenas a todos de nuevo. Tengo este chip que es de un dongle, querría meterlo dentro de la consola y hacerle el arranque sin necesidad de tenerlo por separado. He leído y hay quien dice que lo ha hecho. Pero no me vienen marcados nada más que el punto de 3.3v y el gnd que corresponde a la bateria claro. El resto de puntos no sé en qué orden están. A ver si alguien sabe el orden de los puntos a soldar y si valdría claro, metiéndole los archivos que hay en el primer mensaje. Agradecido de antemano.
Imagen


Creo recordar,que un mensaje el compañero @julesrussel puso en su día el esquema de como soldar un sxos pro de forma interna como el rcmx86 ,creo recordar que es una forma de aprovecharlo cuando los capacitadores ( baterías) fallan,o bien por comodidad.
No encuentro el hilo, quizás @josete2k ,o el mismo @JulesRussel podrían echarnos una mano.

Editado: video del montaje del sxos soldado internamente

https://m.youtube.com/watch?v=77DWfGcStDQ

Esquema soldadura dongle sxos

https://m.imgur.com/a/JLUm4uV

No sé si tú dongle es un sxos o un rcmloader,supongo que las soldaduras serán parecidas. [oki]

Incluso puedes crear tu propio dongle.

hilo_tutorial-crea-tu-propio-dongle-portatil-para-cargar-payloads-it-is-easy_2287822

Muchas gracias, me los guardo por si acaso los volviera a necesitar.
Saludos.
o0SaN0o escribió:Estoy rayado con este chip. Solo me funciona el arranque con el punto d0 para arrancar la consola con power + vol+. Tengo la instalación con los 5 cables, cuando sueldo el punto d2 cable naranja no arranca. Si sueldo el cable naranja en d0 si que arranca y me coge el bootloader todo perfecto pero no me tecta el joycon derecho al introducirlo en el rail de la consola. El chip esta con el archivo RCMX86_INTERNAL_FUSEE_UF2_V3.

Que estoy haciendo mal?¿



El D0 es para poner un Led.

Imagen


Primero

https://github.com/mattytrog/FUSEE_SUIT ... RCMX86.uf2


Segundo

https://github.com/mattytrog/FUSEE_SUIT ... CM_X86.UF2


Que por cierto HOY justo se ha actualizado.

Por lo visto el autor ha perdido su cuenta de gbatemp así que las novedades están en el github.

https://github.com/mattytrog/FUSEE_SUITE
josete2k escribió:
o0SaN0o escribió:Estoy rayado con este chip. Solo me funciona el arranque con el punto d0 para arrancar la consola con power + vol+. Tengo la instalación con los 5 cables, cuando sueldo el punto d2 cable naranja no arranca. Si sueldo el cable naranja en d0 si que arranca y me coge el bootloader todo perfecto pero no me tecta el joycon derecho al introducirlo en el rail de la consola. El chip esta con el archivo RCMX86_INTERNAL_FUSEE_UF2_V3.

Que estoy haciendo mal?¿



El D0 es para poner un Led.

Imagen


Primero

https://github.com/mattytrog/FUSEE_SUIT ... RCMX86.uf2


Segundo

https://github.com/mattytrog/FUSEE_SUIT ... CM_X86.UF2


Que por cierto HOY justo se ha actualizado.

Por lo visto el autor ha perdido su cuenta de gbatemp así que las novedades están en el github.

https://github.com/mattytrog/FUSEE_SUITE


Ahora si que funciona, gracias
josete2k escribió:
o0SaN0o escribió:Estoy rayado con este chip. Solo me funciona el arranque con el punto d0 para arrancar la consola con power + vol+. Tengo la instalación con los 5 cables, cuando sueldo el punto d2 cable naranja no arranca. Si sueldo el cable naranja en d0 si que arranca y me coge el bootloader todo perfecto pero no me tecta el joycon derecho al introducirlo en el rail de la consola. El chip esta con el archivo RCMX86_INTERNAL_FUSEE_UF2_V3.

Que estoy haciendo mal?¿



El D0 es para poner un Led.

Imagen


Primero

https://github.com/mattytrog/FUSEE_SUIT ... RCMX86.uf2


Segundo

https://github.com/mattytrog/FUSEE_SUIT ... CM_X86.UF2


Que por cierto HOY justo se ha actualizado.

Por lo visto el autor ha perdido su cuenta de gbatemp así que las novedades están en el github.

https://github.com/mattytrog/FUSEE_SUITE


Josete muchas gracias, me ha quedado todo más claro. Si no me equivoco, y buscando hacer una instalación de 4 cables (que según lo último, sería 5 con el marrón para el tema del dock), tendría que tener la consola liberada de manera tradicional y activado el AutoRCM. Una vez tenga esto hecho y estabilizado, realizar este mod, ¿no?
Sí.

Yo lo tengo así en una de las dos switch que tengo. No soldé el cable naranja por pereza y tengo un jig por si alguna vez actualizo en stock y me quita el autorcm.
josete2k escribió:Sí.

Yo lo tengo así en una de las dos switch que tengo. No soldé el cable naranja por pereza y tengo un jig por si alguna vez actualizo en stock y me quita el autorcm.


Muchas gracias Josete, ¿y la soldadura de 3V es muy chunga? He visto que se hace en la pata de la resistencia, y es la que me echa para atrás para meterme con todo esto. He mirado hasta soldadores por Sevilla pero no es tarea fácil ya que no es algo que se promocione mucho.
@jaime9714 si sigues el primer mensaje verás que recomiendo soldar en un pad de la mmc, es muy difícil liarla.
josete2k escribió:@jaime9714 si sigues el primer mensaje verás que recomiendo soldar en un pad de la mmc, es muy difícil liarla.


¿Te refieres a este mensaje? Es que como luego dices "El hecho de usar puntos de 3.3v junto al core que vamos a instalar hacen que el chip se "apague" nada más hacer su faena, con lo que el consumo del mismo es prácticamente nulo" suponía que lo mejor era en el sitio original, en la pata de la resistencia por tema de batería.
Imagen
@jaime9714

Ese pad, sí.


Por cierto he actualizado un poco el primer mensaje...
josete2k escribió:@jaime9714

Ese pad, sí.


Por cierto he actualizado un poco el primer mensaje...

Esta tarde no iban los enlaces. Supongo será eso lo que has arreglado no?
Saludos.
josete2k escribió:@jaime9714

Ese pad, sí.


Por cierto he actualizado un poco el primer mensaje...


Eres el mejor muchas gracias por tu sabiduría.

Está pregunta ya es más para el público general: tengo un soldado TS100 pero siempre dudo en la temperatura que ajustar. ¿Para 1mm de estaño que temperatura recomendáis para no dañar?
jaime9714 escribió:
josete2k escribió:@jaime9714

Ese pad, sí.


Por cierto he actualizado un poco el primer mensaje...


Eres el mejor muchas gracias por tu sabiduría.

Está pregunta ya es más para el público general: tengo un soldado TS100 pero siempre dudo en la temperatura que ajustar. ¿Para 1mm de estaño que temperatura recomendáis para no dañar?

Depende de la temperatura de fusión del estaño y de los componentes que lleve, pero lo normal es que sea más de 200 grados que es lo más adecuado a la fusión del estaño en una proporción de 70sn y 30 de plomo, etc… Pero te digo una cosa, si vas a usar en la instalación un estaño de 1 mm. Te va a ser difícil, es demasiado grueso y te va a crear una bola de narices y como se pegue a otros componentes sobre todo en el punto 3,3v vas apañado para quitarlo. Y el soldador no sé cuál es pero la punta que no sea más gorda de 0,5 cm. Recomendación sería.
Saludos.
DIABLO escribió:
jaime9714 escribió:
josete2k escribió:@jaime9714

Ese pad, sí.


Por cierto he actualizado un poco el primer mensaje...


Eres el mejor muchas gracias por tu sabiduría.

Está pregunta ya es más para el público general: tengo un soldado TS100 pero siempre dudo en la temperatura que ajustar. ¿Para 1mm de estaño que temperatura recomendáis para no dañar?

Depende de la temperatura de fusión del estaño y de los componentes que lleve, pero lo normal es que sea más de 200 grados que es lo más adecuado a la fusión del estaño en una proporción de 70sn y 30 de plomo, etc… Pero te digo una cosa, si vas a usar en la instalación un estaño de 1 mm. Te va a ser difícil, es demasiado grueso y te va a crear una bola de narices y como se pegue a otros componentes sobre todo en el punto 3,3v vas apañado para quitarlo. Y el soldador no sé cuál es pero la punta que no sea más gorda de 0,5 cm. Recomendación sería.
Saludos.


¿300 grados sería óptimo? ¿Que estaño me recomiendas? Tengo que comprar estaño de calidad para esta faena y asi aprovecho.

Sobre el punto 3.3V voy a tirar por el recomendado por josete, en la emmc que luce más sencillo. El otro con la resistencia lo veo casi imposible.

La punta que tengo es la TS-B2, aunque tengo que limpiarla con la pasta esa rejuvenedora de puntas, que no la tengo lo fina que debiera. Aún así, me voy a pillar la TS-I para usarla en este caso. Veo que sabes mucho de soldar, ¿tienes algún vídeo clave tanto para mantenimiento como para soldaduras tan pequeñas? Yo aprendí con estos antiguos, que los recomiendo a todo el que quiera empezar a soldar (vídeo)
Imagen
jaime9714 escribió:
DIABLO escribió:
jaime9714 escribió:
Eres el mejor muchas gracias por tu sabiduría.

Está pregunta ya es más para el público general: tengo un soldado TS100 pero siempre dudo en la temperatura que ajustar. ¿Para 1mm de estaño que temperatura recomendáis para no dañar?

Depende de la temperatura de fusión del estaño y de los componentes que lleve, pero lo normal es que sea más de 200 grados que es lo más adecuado a la fusión del estaño en una proporción de 70sn y 30 de plomo, etc… Pero te digo una cosa, si vas a usar en la instalación un estaño de 1 mm. Te va a ser difícil, es demasiado grueso y te va a crear una bola de narices y como se pegue a otros componentes sobre todo en el punto 3,3v vas apañado para quitarlo. Y el soldador no sé cuál es pero la punta que no sea más gorda de 0,5 cm. Recomendación sería.
Saludos.


¿300 grados sería óptimo? ¿Que estaño me recomiendas? Tengo que comprar estaño de calidad para esta faena y asi aprovecho.

Sobre el punto 3.3V voy a tirar por el recomendado por josete, en la emmc que luce más sencillo. El otro con la resistencia lo veo casi imposible.

La punta que tengo es la TS-B2, aunque tengo que limpiarla con la pasta esa rejuvenedora de puntas, que no la tengo lo fina que debiera. Aún así, me voy a pillar la TS-I para usarla en este caso. Veo que sabes mucho de soldar, ¿tienes algún vídeo clave tanto para mantenimiento como para soldaduras tan pequeñas? Yo aprendí con estos antiguos, que los recomiendo a todo el que quiera empezar a soldar (vídeo)
Imagen

No se trata de ver un tutorial y ya saber soldar, jajaja, se trata de tener unos estudios de electrónica desde 1985, e ir innovando y actualizándose, tener una experiencia de tantos años, buen pulso, buenas herramientas (soldador de calidad, microscopio, estaño de calidad, flux en pasta que no sea conductor, pinzas profesionales y hasta destornilladores de precisión, pasta térmica de buena calidad). Conocimientos de electrónica si algo falla saber el por qué. Yo empecé con un soldador mucho más Gordo que el del vídeo que pones. Y ahora estoy con micro soldaduras y practicando todo lo que puedo con pistola de calor para los micros. Siempre estar a la última en todo y actualizando y nunca dejar de aprender. No todo es tan facil como coger un soldador, ver un vídeo y un plano y a la aventura. Te voy a enseñar fotos de los materiales que uso normalmente, pero eso no te servirá de mucho si no tienes una práctica continua y menos en microsoldaduras. No quiero decir que no lo puedas hacer y que no te salga bien, si no que la manera de hacerlo que te cuento es la correcta para que todo funcione perfectamente. O tú por ejemplo para arreglar una lavadora, una televisión, un secador de pelo, te vas a YouTube y a ver qué sale? Yo no, yo solo con ver el problema ya suelo saber donde falla. Si no de que existiríamos los electrónicos. Un bombero que no sepa de primeros auxilios, que no sepa cómo coger la manguera, que no lleve el uniforme reglamentario, no puede acudir a sofocar un incendio, si lo puede hacer, quizás lo consiga, pero a que precio? Se estaría jugando la vida. En fin que te ánimo a que lo hagas y espero te salga todo perfecto.

Imagen

Imagen

Imagen

Imagen

Estas son las herramientas que suelo utilizar, si eso te sirve de algo me alegraria, pero tengo muchísimas más, dependiendo de las necesidades.
Un saludo.
Que ventaja tiene hacer la instalación de 7 hilos con respecto a la de 6? no me queda claro.. con la de 6 tenemos la opción de arrancar como original o modificada, y con la de 7 no se puede?
000miguel escribió:Que ventaja tiene hacer la instalación de 7 hilos con respecto a la de 6? no me queda claro.. con la de 6 tenemos la opción de arrancar como original o modificada, y con la de 7 no se puede?

Con la de 6 cables necesitarás jig, con la de 7 no.
Saludos
No.

Con 7 cables es el chip el que pulsa vol+ y home
Con 6 cables sólo se pulsa home y has de pulsar tú vol+
Con 5 cables necesitas jig o autorcm
Por cierto, con las últimas versiones que subió matty también se arranca sin payload.bin con sólo meter hekate en la sd.
josete2k escribió:Por cierto, con las últimas versiones que subió matty también se arranca sin payload.bin con sólo meter hekate en la sd.


Más info y link please @josete2k
No hace falta... Es una función de hekate desde hace tiempo.

Simplemente leí que el archivo del chip busca primero payload.bin y luego busca sd:/bootloader/update.bin
Buenos dias

Acabo de recibir este chip RCM x86 , tengo de las primeras switch funcionando con jig y con dualboot, pero no me aclaro muy bien los puntos de soldadura, y antes de hacer algo mal, prefiero preguntar a ver si alguno ha instalado este chip o sabe mas claramente los puntos que debo soldar.

Muchas Gracias.

Imagen

Imagen

Imagen

Imagen
schuko1982 escribió:Buenos dias

Acabo de recibir este chip RCM x86 , tengo de las primeras switch funcionando con jig y con dualboot, pero no me aclaro muy bien los puntos de soldadura, y antes de hacer algo mal, prefiero preguntar a ver si alguno ha instalado este chip o sabe mas claramente los puntos que debo soldar.

Muchas Gracias.

Imagen

Imagen

Imagen

Imagen

Ten cuidado por que algunos de esos puntos son dificiles de soldar, sino sabes dejalo a alguien experto por que puedes provocar daños en la placa.
Un saludo.
Alguien tiene el pinout o diagrama de este? He buscado como loco y no encuentro nada.

ndice.jpg
Por curiosidad, si por lo que sea el chip a lo largo del tiempo llegara a romperse, se podría acceder al rcm mediante un jig?
¿Romperse?

Menudas preguntas...
josete2k escribió:¿Romperse?

Menudas preguntas...


Sí, romperse.
Te hablo desde la completa ignorancia xD.
@motorer Si el.chip esta bien instalado no se que % de ellos pueden fallar con el tiempo
Gracias por las respuestas, la verdad que me interesa muchísimo todo el tema de la scene, en cuanto tenga la switch que compre me pondré a ello, si me pongo muy pesado con las preguntas decídmelo [+risas] .

Muchas gracias!
motorer escribió:Gracias por las respuestas, la verdad que me interesa muchísimo todo el tema de la scene, en cuanto tenga la switch que compre me pondré a ello, si me pongo muy pesado con las preguntas decídmelo [+risas] .

Muchas gracias!

No deberia de fallar si esta bien soldado.
Un saludo.
Hola,

Yo ya tenia todo esto instalado con anterioridad. Quería actualizarlo para ponerlo en la ultima versión (9.2) pero al hacer el reset y que me aparezca la unidad SWITCHBOOT con los 3 archivos en el PC, si meto el ultimo "PART_1_FUSEE_RCMX86_INTERNAL-c40fc1c.uf2" el archivo se copia a la unidad pero no hace nada, se queda ahí y listo. ¿Qué me esta fallando?

*Edit: Nada, ya esta. En el github de matty pone que si no se reinicia solo que volvamos a hacer el doble click con el archivo metido y con eso se resetea y se flashea. Ahora la unidad se llama FUSEE, ya no se llama switchboot como antes.

Despues le he metido core del multiple press y listo.
579 respuestas
18, 9, 10, 11, 12