Problema con "libxml2" y SubVersion en Ubuntu 10.10

Código EOL25: 25% dto. para la nueva colección Hawkers SS16
AzagraMac
Loading...
7.220 mensajes
desde dic 2006
en /home/$user
Al ejecutar el "svn" para descargar algun repositorio, me da error de una libreria.

$ svn checkout svn://web_de_ejemplo
svn: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libneon-gnutls.so.27)
svn: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libneon-gnutls.so.27)


Y no doy con la solucion, logicamente, no me dejar descargar nada por subversion, he probado a reinstalar el paquete de subversion, pero nada.

PD: Ubuntu 10.10 64Bits
blackgem
Lord Of Librarians
6.631 mensajes
desde ene 2008
en Algún rincón enchufado
Prueba a reinstalar "libxml2", yo tengo la version "2.7.7.dfsg-4ubuntu0.1"

Uso Ubuntu 10.10 64bits.

Consulta la version que usas, en mi caso esa libreria la tengo de la seccion libs de los repositorios oficiales de Ubuntu.
AzagraMac
Loading...
7.220 mensajes
desde dic 2006
en /home/$user
nada, he probado a reinstalarla y sigue igual...

tengo la misma version:
$ dpkg -l | grep libxml2
ii  libxml2                               2.7.7.dfsg-4ubuntu0.1                             GNOME XML library
ii  libxml2-dbg                           2.7.7.dfsg-4ubuntu0.1                             Debugging symbols for the GNOME XML library
ii  libxml2-dev                           2.7.7.dfsg-4ubuntu0.1                             Development files for the GNOME XML library
ii  libxml2-doc                           2.7.7.dfsg-4ubuntu0.1                             Documentation for the GNOME XML library
ii  libxml2-utils                         2.7.7.dfsg-4ubuntu0.1                             XML utilities
ii  python-libxml2                        2.7.7.dfsg-4ubuntu0.1                             Python bindings for the GNOME XML library
Ferdy
/dev/annoying
4.370 mensajes
desde abr 2003
Mira a ver exactamente qué versión está instalando con algo como
dpkg -L libxml2 | grep '\.so'
. Y mira a ver qué versión quiere neon con algo como
ldd /usr/lib/libneon-gnutls.so.27
.

Si no sabes qué hacer con esa información, pégala e igual podemos echarte un cable.

- ferdy
AzagraMac
Loading...
7.220 mensajes
desde dic 2006
en /home/$user
Ferdy escribió:Mira a ver exactamente qué versión está instalando con algo como
dpkg -L libxml2 | grep '\.so'
. Y mira a ver qué versión quiere neon con algo como
ldd /usr/lib/libneon-gnutls.so.27
.

Si no sabes qué hacer con esa información, pégala e igual podemos echarte un cable.

- ferdy

Esto me da:
$ dpkg -L libxml2 | grep '\.so'
/usr/lib/libxml2.so.2.7.7
/usr/lib/libxml2.so.2


$ ldd /usr/lib/libneon-gnutls.so.27
/usr/lib/libneon-gnutls.so.27: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libneon-gnutls.so.27)
/usr/lib/libneon-gnutls.so.27: /usr/local/lib/libxml2.so.2: no version information available (required by /usr/lib/libneon-gnutls.so.27)
   linux-vdso.so.1 =>  (0x00007fff7f0f1000)
   libz.so.1 => /lib/libz.so.1 (0x00007fb998d88000)
   libgnutls.so.26 => /usr/lib/libgnutls.so.26 (0x00007fb998ae6000)
   libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007fb9988b1000)
   libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007fb9985ef000)
   libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007fb9983c9000)
   libcom_err.so.2 => /lib/libcom_err.so.2 (0x00007fb9981c4000)
   libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x00007fb997e77000)
   libc.so.6 => /lib/libc.so.6 (0x00007fb997af4000)
   libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0x00007fb9978e2000)
   libgcrypt.so.11 => /lib/libgcrypt.so.11 (0x00007fb99766a000)
   libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007fb997462000)
   libdl.so.2 => /lib/libdl.so.2 (0x00007fb99725d000)
   libkeyutils.so.1 => /lib/libkeyutils.so.1 (0x00007fb99705a000)
   libresolv.so.2 => /lib/libresolv.so.2 (0x00007fb996e41000)
   libpthread.so.0 => /lib/libpthread.so.0 (0x00007fb996c23000)
   /lib64/ld-linux-x86-64.so.2 (0x00007fb9991ee000)
   libm.so.6 => /lib/libm.so.6 (0x00007fb9969a0000)
   libgpg-error.so.0 => /lib/libgpg-error.so.0 (0x00007fb99679c000)


Muchas Gracias, como ves hasta hay tambien me da ese error... [mamaaaaa]
Ferdy
/dev/annoying
4.370 mensajes
desde abr 2003
Ahí lo tienes. El dev que empaquetó neon la ha cagado.

   libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x00007fb997e77000)


Puedes crear un enlace con ese nombre como "parche" temporal.

- ferdy