¿Cómo aumentar el búfer de la tarjeta de sonido o aumentar la latencia?

Para cuestiones informáticas generales: Software propietario, grabación, programas multimedia, etc.
Quintiliano
Cibercaballero
5.521 mensajes
desde mar 2006
en España

Hola

Como mi hilo anterior ha tenido un gran éxito XD hago una pregunta muy técnica que me gustaría aclarar.

Tengo un portátil Toshiba funcionando bajo Windows XP Home SP2, con 256+512 MB de RAM, 64 de los cuales asignados a la tarjeta de vídeo, y un procesador a 2,8Ghz.

Al hacer una grabación a la calidad máxima que da la tarjeta externa SB Connect (48Khz, 16 bits) en un fragmento de 46 minutos, me da unos 3 fallos, que consisten en que al digitalizar la señal se "come" una décima de segundo, como si le hubiera faltado tiempo para procesar la señal.

La tarjeta debe transferir unos 1600KB/S en este modo de grabación, pero esto no debería ser problema puesto que mi portátil tiene 3 puertos USB 2.0 y la tarjeta funciona incluso con USB 1.1 según el fabricante.

El disco duro tampoco debería ser el problema puesto que aunque no es muy grande (40 GB) tiene activado el modo DMA.

He leído que hay un parámetro que tiene que ver con este tipo de problemas, el buffer de la tarjeta de sonido. Pero no encuentro por ninguna parte cómo ajustarlo (para aumentarlo).

También he leído algo sobre que aumentar la latencia (no sé muy bien de qué) mejora el rendimiento de la tarjeta.

En la base de datos de Creative no he encontrado nada salvo un tutorial para limpiar el arranque del ordenador y afinar un poco el rendimiento de las tarjetas, pero no explica nada de esto del buffer, como si fuera algo de los tiempos del MS-DOS.

¿Alguien puede darme algo de luz al respecto?

Gracias ;)

Saludos

Quintiliano
Cibercaballero
5.521 mensajes
desde mar 2006
en España

Hola

Finalmente he logrado resolver el problemilla. No tenía que ver con el buffer.

Si alguien tiene algún problema similar a éste con esta misma tarjeta que reflote el hilo y le comentaré mi solución.

Saludos

Edguy
Metal Friend
3.702 mensajes
desde ene 2001
en No lo se ni yo

pues no he tenido nunca ese problema, pero me gustaria saber la solucion ya que siempre me gusta aprender cosas nuevas.

Un saludo.
Imagen
"Si, a pesar de ser retorcido y deformado, soy mas inteligente que tú, más inteligente que todos vosotros. Y algun día ¡Os lo demostraré! Algún dia tú con toda tu fuerza y tu encanto y tu buena apariencia, tú y todos vosotros me llamareis maestro"

Mi PC:


CPU: INTEL SANDY BRYDGE i2500K 3.3@4.5 GHz
Disipador: RL Custom Aqui el hilo
Placa Base:ASUS P8Z68-V PRO
Memoria: G.Skill Ripjaws X DDR3 1600@1866 PC3-12800 8GB 4x2GB CL7 Memoria DDR3
Disco(s) duro(s): SSD CRUCIAL M4 128 GB, WD Black SATA 3 maestro 500 GB, Seagate 500 GB 32 mb buffer, SAMSUNG 500 GB, WD Green 2 TB.
Lector(es) de CD/DVD/Grabadoras: Grabadora DVD LG 22x SATA
Gráfica: SAPPHIRE ATI RADEON HD 6850 TOXIC 1 GB DDR5
Sonido: Realtek @ ATI SB800 - High Definition Audio Controller
Ethernet: Realtek PCIe GBE Family Controller
Chasis: CORSAIR OBSIDIAN 750D
Ventiladores de chasis: 3 COOLER MASTER , 1 THERMALTAKE 12 CM AZUL, 1 COOLER MASTER SILENCE AZUL
Fuente de alimentación: Sharkoon Rush Power 600W (4x PCIe, modular)
Monitor: LG IPS236V 23" IPS LED, Asus VS228H LED 21.5" HDMI/DVI
Mouse: ROCCAT KONE PURE
Teclado: LOGITECH G110
Otros (scanner, impresora, controladoras SCSI, IDE, Raid...): ALTAVOCES LOGITECH X-530 5.1, AURICULARES INALAMBRICOS SENHEISER RS160, AURICULARES + MICROPHONE SENHEISER PC31, ALFOMBRILLA ROCCAT SENSE, HP PHOTOSMART 5520



Quintiliano
Cibercaballero
5.521 mensajes
desde mar 2006
en España

Edguy escribió:pues no he tenido nunca ese problema, pero me gustaria saber la solucion ya que siempre me gusta aprender cosas nuevas.

Un saludo.


Hola

¿Tienes una SB Connect?

¿Has grabado fragmentos de audio de 45 minutos o más seguidos a la máxima calidad? (16 bits/48Khz)

Dime si la usas con un portátil o un ordenador de sobremesa.

La solución en pocas palabras fue ésta:

1) Instalar todo el paquete de software propietario de Creative.

Sospecho que instalar solamente el controlador (ya que no me interesaban el resto de aplicaciones) pudo influir en que el dispositivo fallara.

2) Realizar un arranque limpio en Windows XP con los servicios y componentes básicos para trabajar con la tarjeta de sonido exclusivamente (para esto he seguido el tutorial de Microsoft de inicio limpio en Windows XP y el tutorial de Creative para mejorar el rendimiento de las tarjetas de sonido).

3) Poner el ordenador (portátil) en modo de alimentación total.

En la prueba de funcionamiento que hice ayer no he detectado ningún fallo en la grabación.

Saludos

Edguy
Metal Friend
3.702 mensajes
desde ene 2001
en No lo se ni yo

gracias, yo no la tengo pero un conocido si.
Evidentemente, el si ke instalo todas las aplicaciones de Creative ;)
Un saludo.
Imagen
"Si, a pesar de ser retorcido y deformado, soy mas inteligente que tú, más inteligente que todos vosotros. Y algun día ¡Os lo demostraré! Algún dia tú con toda tu fuerza y tu encanto y tu buena apariencia, tú y todos vosotros me llamareis maestro"

Mi PC:


CPU: INTEL SANDY BRYDGE i2500K 3.3@4.5 GHz
Disipador: RL Custom Aqui el hilo
Placa Base:ASUS P8Z68-V PRO
Memoria: G.Skill Ripjaws X DDR3 1600@1866 PC3-12800 8GB 4x2GB CL7 Memoria DDR3
Disco(s) duro(s): SSD CRUCIAL M4 128 GB, WD Black SATA 3 maestro 500 GB, Seagate 500 GB 32 mb buffer, SAMSUNG 500 GB, WD Green 2 TB.
Lector(es) de CD/DVD/Grabadoras: Grabadora DVD LG 22x SATA
Gráfica: SAPPHIRE ATI RADEON HD 6850 TOXIC 1 GB DDR5
Sonido: Realtek @ ATI SB800 - High Definition Audio Controller
Ethernet: Realtek PCIe GBE Family Controller
Chasis: CORSAIR OBSIDIAN 750D
Ventiladores de chasis: 3 COOLER MASTER , 1 THERMALTAKE 12 CM AZUL, 1 COOLER MASTER SILENCE AZUL
Fuente de alimentación: Sharkoon Rush Power 600W (4x PCIe, modular)
Monitor: LG IPS236V 23" IPS LED, Asus VS228H LED 21.5" HDMI/DVI
Mouse: ROCCAT KONE PURE
Teclado: LOGITECH G110
Otros (scanner, impresora, controladoras SCSI, IDE, Raid...): ALTAVOCES LOGITECH X-530 5.1, AURICULARES INALAMBRICOS SENHEISER RS160, AURICULARES + MICROPHONE SENHEISER PC31, ALFOMBRILLA ROCCAT SENSE, HP PHOTOSMART 5520



Quintiliano
Cibercaballero
5.521 mensajes
desde mar 2006
en España

Edguy escribió:gracias, yo no la tengo pero un conocido si.
Evidentemente, el si ke instalo todas las aplicaciones de Creative ;)
Un saludo.


Hola

Pues si tu amigo postea en EOL dile que se pase por este hilo, me interesaría mucho su opinión de esta tarjeta, para qué la ha usado y si le ha dado buen resultado.

Saludos


Volver a General

¿Quién está conectado?

Usuarios navegando por este foro: No hay usuarios registrados visitando el foro y 1 invitado